]> git.pld-linux.org Git - packages/wesnoth.git/blobdiff - wesnoth.spec
- s/png12/png
[packages/wesnoth.git] / wesnoth.spec
index 5ee7d391947c03d68a0b7a0e874c11d611bed8b5..c71ade6a926af65e0f9c588bb1611a83e48caa3c 100644 (file)
@@ -1,7 +1,7 @@
 # TODO
-# - rename language files sr@latin to sr@Latn and include them
 # - use desktop file included with project (consider which one are better)
-# - dont know what should I do with sr@latin man pages
+# - unpackaged language files
+# - fix lacales (seems broken)
 # Conditional build
 %bcond_without server  # without server
 %bcond_without tools   # without tools
@@ -11,36 +11,38 @@ Summary:    Strategy game with a fantasy theme
 Summary(hu.UTF-8):     Fantasy környezetben játszódó stratégiai játék
 Summary(pl.UTF-8):     Strategiczna gra z motywem fantasy
 Name:          wesnoth
-Version:       1.4.5
-Release:       1
+Version:       1.8
+Release:       0.1
 Epoch:         1
 License:       GPL v2+
 Group:         X11/Applications/Games/Strategy
-Source0:       http://www.wesnoth.org/files/%{name}-%{version}.tar.bz2
-# Source0-md5: 09b7b76d4a4eedf502f38df9d551d827
-Source1:       %{name}.desktop
-Source2:       %{name}_editor.desktop
-Source3:       %{name}d.init
-Patch0:                %{name}-Makefile.patch
-Patch1:                %{name}-locale_dir.patch
+Source0:       http://downloads.sourceforge.net/wesnoth/%{name}-%{version}.tar.bz2
+# Source0-md5: 07e4b97512e307c54dcfd86659a61e41
+Source1:       %{name}d.init
+Patch0:                %{name}-libpng.patch
+Patch1:                %{name}-desktop.patch
 URL:           http://www.wesnoth.org/
 BuildRequires: SDL-devel >= 1.2.7
 BuildRequires: SDL_image-devel >= 1.2
 BuildRequires: SDL_mixer-devel >= 1.2
 BuildRequires: SDL_net-devel >= 1.2
-BuildRequires: SDL_ttf-devel >= 2.0
-BuildRequires: autoconf >= 2.59
-BuildRequires: automake >= 1:1.9
+BuildRequires: SDL_ttf-devel >= 2.0.8
+BuildRequires: asciidoc
 BuildRequires: boost-devel >= 1.33
+BuildRequires: cmake >= 2.4
 %{?with_fribidi:BuildRequires: fribidi-devel}
 BuildRequires: gettext-devel
 BuildRequires: libpng-devel
 BuildRequires: libstdc++-devel
-BuildRequires: libtool >= 2:1.5
-BuildRequires: python-devel
-BuildRequires: rpm-pythonprov
+BuildRequires: libvorbis-devel
+BuildRequires: lua51-devel
+BuildRequires: pango-devel
+BuildRequires: pkgconfig
 BuildRequires: rpmbuild(macros) >= 1.268
-BuildRequires: zipios++-devel
+BuildRequires: sed >= 4.0
+BuildRequires: zlib-devel
+# sr@Latn vs. sr@latin
+Conflicts:     glibc-misc < 6:2.7
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -67,6 +69,7 @@ przenoszone z jednej scenerii do następnej kampanii.
 
 %package server
 Summary:       Network server for Wesnoth
+Summary(hu.UTF-8):     Hálózati szerver Wesnoth-hoz
 Summary(pl.UTF-8):     Sieciowy serwer dla Wesnoth
 Group:         X11/Applications/Games/Strategy
 Requires(post,preun):  /sbin/chkconfig
@@ -75,6 +78,8 @@ Requires(postun):     /usr/sbin/userdel
 Requires(pre): /usr/sbin/groupadd
 Requires(pre): /usr/sbin/useradd
 Requires:      rc-scripts >= 0.4.0.17
+# sr@Latn vs. sr@latin
+Conflicts:     glibc-misc < 6:2.7
 
 %description server
 Server for playing networked games of Wesnoth.
@@ -106,42 +111,57 @@ Edytor map i narzędzia do tłumaczeń.
 %patch0 -p1
 %patch1 -p1
 
+# don't install locales in %{_datadir}/%{name}
+%{__sed} -i 's,${DATADIR}/${LOCALEDIR},${LOCALEDIR},' CMakeLists.txt
+
+# link using libpng instead of libpng12
+%{__sed} -i 's,png12,png,' src/CMakeLists.txt
+
 %build
-%{__gettextize}
-%{__aclocal} -I m4
-%{__autoconf}
-%{__autoheader}
-%{__automake}
-%configure \
-       %{?with_server:--enable-server} \
-       %{?with_tools:--enable-editor} \
-       %{?with_tools:--enable-tools} \
-       --with%{!?with_fribidi:out}-fribidi \
-       --docdir=%{_docdir}/%{name}-%{version} \
-       --with-icondir=%{_pixmapsdir} \
-       --with-zipios
+install -d build
+cd build
+%cmake .. \
+       -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
+       -DCMAKE_INSTALL_PREFIX=%{_prefix} \
+       -DENABLE_STRICT_COMPILATION="off" \
+       -DBINDIR="%{_bindir}" \
+       -DMANDIR="%{_mandir}" \
+       -DLOCALEDIR="%{_datadir}/locale" \
+       %{!?with_server:-DENABLE_SERVER="off"} \
+       %{?with_server:-DENABLE_CAMPAIGN_SERVER="on"} \
+       %{!?with_tools:-DENABLE_EDITOR="off"} \
+       %{?with_tools:-DENABLE_TOOLS="on"} \
+       %{!?with_fribidi:-DENABLE_FRIBIDI="off"} \
+%if "%{_lib}" == "lib64"
+       -DLIB_SUFFIX=64
+%endif
+
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},/var/run/wesnothd,/etc/rc.d/init.d,%{_docdir}/%{name}-%{version}}
 
-%{__make} install \
+%{__make} -C build install \
        DESTDIR=$RPM_BUILD_ROOT
 
 # install additional docs
 install changelog README  $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
 gzip -9nf $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/{changelog,README}
 
-install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
-install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
-install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/wesnothd
+%if %{with server}
+install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/wesnothd
+%endif
 
-mv -f $RPM_BUILD_ROOT%{_datadir}/locale/{nb_NO,nb}
+mv -f $RPM_BUILD_ROOT%{_datadir}/locale/nb{_NO,}
+mv -f $RPM_BUILD_ROOT%{_datadir}/locale/fur{_IT,}
 
 # unsupported(?)
 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/ca_ES@valencia
 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/la
+rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/racv
+rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/en@shaw
+rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/sr@ijekavian
 rm -rf $RPM_BUILD_ROOT%{_mandir}/ca_ES@valencia
 
 # the same as manuals from %{_mandir}/man?
@@ -174,47 +194,50 @@ fi
 %attr(755,root,root) %{_bindir}/wesnoth
 %{_mandir}/man6/wesnoth.6*
 %lang(cs) %{_mandir}/cs/man6/wesnoth.6*
-%lang(da) %{_mandir}/da/man6/wesnoth.6*
 %lang(de) %{_mandir}/de/man6/wesnoth.6*
 %lang(es) %{_mandir}/es/man6/wesnoth.6*
+%lang(et) %{_mandir}/et/man6/wesnoth.6*
+%lang(fi) %{_mandir}/fi/man6/wesnoth.6*
 %lang(fr) %{_mandir}/fr/man6/wesnoth.6*
 %lang(gl) %{_mandir}/gl/man6/wesnoth.6*
 %lang(hu) %{_mandir}/hu/man6/wesnoth.6*
 %lang(it) %{_mandir}/it/man6/wesnoth.6*
 %lang(ja) %{_mandir}/ja/man6/wesnoth.6*
 %lang(lt) %{_mandir}/lt/man6/wesnoth.6*
-%lang(nl) %{_mandir}/nl/man6/wesnoth.6*
 %lang(pl) %{_mandir}/pl/man6/wesnoth.6*
+%lang(pt_BR) %{_mandir}/pt_BR/man6/wesnoth.6*
 %lang(sk) %{_mandir}/sk/man6/wesnoth.6*
 %lang(sr) %{_mandir}/sr/man6/wesnoth.6*
-%lang(sv) %{_mandir}/sv/man6/wesnoth.6*
+%lang(sr@latin) %{_mandir}/sr@latin/man6/wesnoth.6*
 %lang(tr) %{_mandir}/tr/man6/wesnoth.6*
 %lang(zh_CN) %{_mandir}/zh_CN/man6/wesnoth.6*
+%lang(zh_TW) %{_mandir}/zh_TW/man6/wesnoth.6*
 %{_datadir}/%{name}
-%{_desktopdir}/%{name}.desktop
-%{_pixmapsdir}/%{name}-icon.png
+%{_desktopdir}/*.desktop
+%{_pixmapsdir}/*-icon.png
 
 %if %{with server}
 %files server
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/campaignd
 %attr(755,root,root) %{_bindir}/wesnothd
 %attr(754,root,root) /etc/rc.d/init.d/wesnothd
 %{_mandir}/man6/wesnothd.6*
 %lang(cs) %{_mandir}/cs/man6/wesnothd.6*
-%lang(da) %{_mandir}/da/man6/wesnothd.6*
 %lang(de) %{_mandir}/de/man6/wesnothd.6*
 %lang(es) %{_mandir}/es/man6/wesnothd.6*
+%lang(et) %{_mandir}/et/man6/wesnothd.6*
+%lang(fi) %{_mandir}/fi/man6/wesnothd.6*
 %lang(fr) %{_mandir}/fr/man6/wesnothd.6*
-%lang(gl) %{_mandir}/gl/man6/wesnothd.6*
 %lang(hu) %{_mandir}/hu/man6/wesnothd.6*
 %lang(it) %{_mandir}/it/man6/wesnothd.6*
 %lang(ja) %{_mandir}/ja/man6/wesnothd.6*
 %lang(lt) %{_mandir}/lt/man6/wesnothd.6*
-%lang(nl) %{_mandir}/nl/man6/wesnothd.6*
 %lang(pl) %{_mandir}/pl/man6/wesnothd.6*
+%lang(pt_BR) %{_mandir}/pt_BR/man6/wesnothd.6*
 %lang(sk) %{_mandir}/sk/man6/wesnothd.6*
 %lang(sr) %{_mandir}/sr/man6/wesnothd.6*
-%lang(sv) %{_mandir}/sv/man6/wesnothd.6*
+%lang(sr@latin) %{_mandir}/sr@latin/man6/wesnothd.6*
 %lang(tr) %{_mandir}/tr/man6/wesnothd.6*
 %lang(zh_CN) %{_mandir}/zh_CN/man6/wesnothd.6*
 %attr(770,wesnothd,wesnothd) %dir /var/run/wesnothd
@@ -225,28 +248,4 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/cutter
 %attr(755,root,root) %{_bindir}/exploder
-%attr(755,root,root) %{_bindir}/wesnoth_editor
-%attr(755,root,root) %{_bindir}/wmlindent
-%attr(755,root,root) %{_bindir}/wmllint
-%attr(755,root,root) %{_bindir}/wmlscope
-%{_mandir}/man6/wesnoth_editor.6*
-%lang(cs) %{_mandir}/cs/man6/wesnoth_editor.6*
-%lang(da) %{_mandir}/da/man6/wesnoth_editor.6*
-%lang(de) %{_mandir}/de/man6/wesnoth_editor.6*
-%lang(es) %{_mandir}/es/man6/wesnoth_editor.6*
-%lang(fr) %{_mandir}/fr/man6/wesnoth_editor.6*
-%lang(gl) %{_mandir}/gl/man6/wesnoth_editor.6*
-%lang(hu) %{_mandir}/hu/man6/wesnoth_editor.6*
-%lang(it) %{_mandir}/it/man6/wesnoth_editor.6*
-%lang(ja) %{_mandir}/ja/man6/wesnoth_editor.6*
-%lang(lt) %{_mandir}/lt/man6/wesnoth_editor.6*
-%lang(nl) %{_mandir}/nl/man6/wesnoth_editor.6*
-%lang(pl) %{_mandir}/pl/man6/wesnoth_editor.6*
-%lang(sk) %{_mandir}/sk/man6/wesnoth_editor.6*
-%lang(sr) %{_mandir}/sr/man6/wesnoth_editor.6*
-%lang(sv) %{_mandir}/sv/man6/wesnoth_editor.6*
-%lang(tr) %{_mandir}/tr/man6/wesnoth_editor.6*
-%lang(zh_CN) %{_mandir}/zh_CN/man6/wesnoth_editor.6*
-%{_desktopdir}/%{name}_editor.desktop
-%{_pixmapsdir}/%{name}_editor-icon.png
 %endif
This page took 0.062908 seconds and 4 git commands to generate.