]> git.pld-linux.org Git - packages/wesnoth.git/blobdiff - wesnoth.spec
- down to 1.2.8 STABLE! (betas go to DEVEL, no matter what)
[packages/wesnoth.git] / wesnoth.spec
index 93c3ee1a8dda76a742d32658a8fd318a779de0f4..647a3491e42e508cf064bc66bff93b12d76a7c10 100644 (file)
@@ -1,19 +1,25 @@
+# TODO
+# - package rest of developement tools
+# - rename language files sr@latin to sr@Latn and include them
+# - use desktop file included with project (consider which one are better)
 #
 # Conditional build
 %bcond_without server  # without server
 %bcond_without tools   # without tools
 #
 Summary:       Strategy game with a fantasy theme
-Summary(pl):   Strategiczna gra z motywem fantasy
+Summary(pl.UTF-8):     Strategiczna gra z motywem fantasy
 Name:          wesnoth
-Version:       1.2
-Release:       2
+Version:       1.2.8
+Release:       1
+Epoch:         1
 License:       GPL v2+
 Group:         X11/Applications/Games/Strategy
-Source0:       http://www.wesnoth.org/files/%{name}-%{version}.tar.gz
-# Source0-md5: 722a459282abe6d04dbe228d031c088e
+Source0:       http://www.wesnoth.org/files/%{name}-%{version}.tar.bz2
+# Source0-md5: 99d17b23d2ea4dc3a008f5c69cd43789
 Source1:       %{name}.desktop
-Source2:       %{name}d.init
+Source2:       %{name}_editor.desktop
+Source3:       %{name}d.init
 Patch0:                %{name}-Makefile.patch
 Patch1:                %{name}-locale_dir.patch
 URL:           http://www.wesnoth.org/
@@ -22,11 +28,14 @@ BuildRequires:      SDL_image-devel >= 1.2
 BuildRequires: SDL_mixer-devel >= 1.2
 BuildRequires: SDL_net-devel >= 1.2
 BuildRequires: SDL_ttf-devel >= 2.0
-BuildRequires: autoconf >= 2.57
+BuildRequires: autoconf >= 2.59
 BuildRequires: automake >= 1:1.9
 BuildRequires: gettext-devel
+BuildRequires: libpng-devel
 BuildRequires: libstdc++-devel
 BuildRequires: libtool >= 2:1.5
+BuildRequires: python-devel
+BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.268
 BuildRequires: zipios++-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -38,41 +47,42 @@ disadvantages in different types of terrains and against different
 types of attacks. Units gain experience and advance levels, and are
 carried over from one scenario to the next campaign.
 
-%description -l pl
-Battle for Wesnoth jest strategiczn± gr± fantasy. Batalia o kontrolê
-nad wsiami przy pomocy ró¿nego rodzaju oddzia³ów, które maj± przewagê
-lub jej brak w odmiennym ukszta³towaniu terenu i przeciwko ró¿nym
-sposobom ataku. Oddzia³y zdobywaj± do¶wiadczenie i poziomy
-zaawansowania i s± przenoszone z jednej scenerii do nastêpnej
+%description -l pl.UTF-8
+Battle for Wesnoth jest strategiczną grą fantasy. Batalia o kontrolę
+nad wsiami przy pomocy różnego rodzaju oddziałów, które mają przewagę
+lub jej brak w odmiennym ukształtowaniu terenu i przeciwko różnym
+sposobom ataku. Oddziały zdobywają doświadczenie i poziomy
+zaawansowania i są przenoszone z jednej scenerii do następnej
 kampanii.
 
 %package server
 Summary:       Network server for Wesnoth
-Summary(pl):   Sieciowy serwer dla Wesnoth
+Summary(pl.UTF-8):     Sieciowy serwer dla Wesnoth
 Group:         X11/Applications/Games/Strategy
 Requires(post,preun):  /sbin/chkconfig
 Requires(postun):      /usr/sbin/groupdel
 Requires(postun):      /usr/sbin/userdel
 Requires(pre): /usr/sbin/groupadd
 Requires(pre): /usr/sbin/useradd
+Requires:      rc-scripts >= 0.4.0.17
 
 %description server
 Server for playing networked games of Wesnoth.
 
-%description server -l pl
+%description server -l pl.UTF-8
 Serwer do prowadzenia sieciowych gier Wesnoth.
 
 %package tools
 Summary:       Tools for Wesnoth
-Summary(pl):   Narzêdzia dla Wesnoth
+Summary(pl.UTF-8):     Narzędzia dla Wesnoth
 Group:         X11/Applications/Games/Strategy
 Requires:      %{name} = %{version}-%{release}
 
 %description tools
 Map editor and translations tools.
 
-%description tools -l pl
-Edytor map i narzêdzia do t³umaczeñ.
+%description tools -l pl.UTF-8
+Edytor map i narzędzia do tłumaczeń.
 
 %prep
 %setup -q
@@ -89,22 +99,28 @@ Edytor map i narz
        %{?with_server:--enable-server} \
        %{?with_tools:--enable-editor} \
        %{?with_tools:--enable-tools} \
+       --docdir=%{_docdir}/%{name}-%{version} \
+       --with-icondir=%{_pixmapsdir} \
        --with-zipios
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},/var/run/wesnothd,/etc/rc.d/init.d}
+install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},/var/run/wesnothd,/etc/rc.d/init.d,%{_docdir}/%{name}-%{version}}
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-install images/wesnoth-icon.png $RPM_BUILD_ROOT%{_pixmapsdir}
+# install additional docs
+install changelog README  $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
+gzip -9nf $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/{changelog,README}
+
 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
-install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/wesnothd
+install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
+install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/wesnothd
 
 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/{gl_ES,gl}
-mv -f $RPM_BUILD_ROOT%{_datadir}/locale/{nb_NO,nb} 
+mv -f $RPM_BUILD_ROOT%{_datadir}/locale/{nb_NO,nb}
 
 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/ca_ES@valencia
 
@@ -137,21 +153,22 @@ fi
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc changelog README MANUAL*
+%doc %{_docdir}/%{name}-%{version}
 %attr(755,root,root) %{_bindir}/wesnoth
-%attr(755,root,root) %{_bindir}/wmlxgettext
 %{_mandir}/man6/wesnoth.6*
 %lang(de) %{_mandir}/de/man6/wesnoth.6*
 %lang(cs) %{_mandir}/cs/man6/wesnoth.6*
 %lang(fr) %{_mandir}/fr/man6/wesnoth.6*
+%lang(it) %{_mandir}/it/man6/wesnoth.6*
 %lang(ja) %{_mandir}/ja/man6/wesnoth.6*
 %lang(nl) %{_mandir}/nl/man6/wesnoth.6*
 %lang(pt_BR) %{_mandir}/pt_BR/man6/wesnoth.6*
+%lang(ru) %{_mandir}/ru/man6/wesnoth.6*
 %lang(sk) %{_mandir}/sk/man6/wesnoth.6*
 %lang(sv) %{_mandir}/sv/man6/wesnoth.6*
 %{_datadir}/%{name}
 %{_desktopdir}/%{name}.desktop
-%{_pixmapsdir}/*
+#%{_pixmapsdir}/%{name}-icon.png
 
 %if %{with server}
 %files server
@@ -159,14 +176,16 @@ fi
 %attr(755,root,root) %{_bindir}/wesnothd
 %attr(754,root,root) /etc/rc.d/init.d/wesnothd
 %{_mandir}/man6/wesnothd.6*
-%lang(cs) %{_mandir}/cs/man6/wesnothd.6*
-%lang(de) %{_mandir}/de/man6/wesnothd.6*
-%lang(fr) %{_mandir}/fr/man6/wesnothd.6*
-%lang(ja) %{_mandir}/ja/man6/wesnothd.6*
-%lang(nl) %{_mandir}/nl/man6/wesnothd.6*
-%lang(pt_BR) %{_mandir}/pt_BR/man6/wesnothd.6*
-%lang(sk) %{_mandir}/sk/man6/wesnothd.6*
-%lang(sv) %{_mandir}/sv/man6/wesnothd.6*
+%lang(de) %{_mandir}/de/man6/wesnoth.6*
+%lang(cs) %{_mandir}/cs/man6/wesnoth.6*
+%lang(fr) %{_mandir}/fr/man6/wesnoth.6*
+%lang(it) %{_mandir}/it/man6/wesnoth.6*
+%lang(ja) %{_mandir}/ja/man6/wesnoth.6*
+%lang(nl) %{_mandir}/nl/man6/wesnoth.6*
+%lang(pt_BR) %{_mandir}/pt_BR/man6/wesnoth.6*
+%lang(ru) %{_mandir}/ru/man6/wesnoth.6*
+%lang(sk) %{_mandir}/sk/man6/wesnoth.6*
+%lang(sv) %{_mandir}/sv/man6/wesnoth.6*
 %attr(770,wesnothd,wesnothd) %dir /var/run/wesnothd
 %endif
 
@@ -184,6 +203,9 @@ fi
 %lang(ja) %{_mandir}/ja/man6/wesnoth_editor.6*
 %lang(nl) %{_mandir}/nl/man6/wesnoth_editor.6*
 %lang(pt_BR) %{_mandir}/pt_BR/man6/wesnoth_editor.6*
+%lang(ru) %{_mandir}/ru/man6/wesnoth_editor.6*
 %lang(sk) %{_mandir}/sk/man6/wesnoth_editor.6*
 %lang(sv) %{_mandir}/sv/man6/wesnoth_editor.6*
+%{_desktopdir}/%{name}_editor.desktop
+#%{_pixmapsdir}/%{name}_editor-icon.png
 %endif
This page took 0.039667 seconds and 4 git commands to generate.