]> git.pld-linux.org Git - packages/wesnoth.git/blobdiff - wesnoth.spec
- up to 1.16.0
[packages/wesnoth.git] / wesnoth.spec
index 8b80969dbc32e2c45d27f63c84af746638e0b96f..14dcce907014f70edc8ca853c1e8d78138d013d6 100644 (file)
@@ -4,43 +4,42 @@
 #
 # Conditional build
 %bcond_without server  # without server
-%bcond_without fribidi # without Bidirectional language support
 
 Summary:       Strategy game with a fantasy theme
 Summary(hu.UTF-8):     Fantasy környezetben játszódó stratégiai játék
 Summary(pl.UTF-8):     Gra strategiczna z motywem fantasy
 Name:          wesnoth
-Version:       1.14.16
+Version:       1.16.0
 Release:       1
 Epoch:         1
 License:       GPL v2+
 Group:         X11/Applications/Games/Strategy
 Source0:       http://downloads.sourceforge.net/wesnoth/%{name}-%{version}.tar.bz2
-# Source0-md5: 769733a55ab5742815e0acf8c51e13e4
+# Source0-md5: f07aebf91ef46e47312eb467e1426f06
 Source1:       %{name}d.init
 Source2:       %{name}.tmpfiles
 Source3:       %{name}.sysconfig
 Source4:       %{name}d.service
 URL:           http://www.wesnoth.org/
-BuildRequires: SDL2-devel >= 2.0.4
-BuildRequires: SDL2_image-devel >= 2.0.0
+BuildRequires: SDL2-devel >= 2.0.8
+BuildRequires: SDL2_image-devel >= 2.0.2
 BuildRequires: SDL2_mixer-devel >= 2.0.0
-BuildRequires: SDL2_ttf-devel >= 2.0.12
 BuildRequires: boost-devel >= 1.50.0
 BuildRequires: bzip2-devel
 BuildRequires: cairo-devel >= 1.10.0
 BuildRequires: cmake >= 2.8.5
 BuildRequires: dbus-devel
 BuildRequires: fontconfig-devel >= 2.4.1
-%{?with_fribidi:BuildRequires: fribidi-devel}
 BuildRequires: gettext-tools
 BuildRequires: libicu-devel
 BuildRequires: libpng-devel
-BuildRequires: libstdc++-devel
+BuildRequires: libstdc++-devel >= 6:4.7
 BuildRequires: libvorbis-devel
-BuildRequires: openssl-devel
+BuildRequires: openssl-devel >= 1.0
 BuildRequires: pango-devel >= 1:1.22.0
 BuildRequires: pkgconfig
+BuildRequires: readline-devel
+BuildRequires: rpm-build >= 4.6
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.605
 BuildRequires: sed >= 4.0
@@ -56,6 +55,7 @@ Requires:     %{name}-data = %{epoch}:%{version}
 Requires:      SDL2 >= 2.0.4
 Requires:      fontconfig >= 2.4.1
 Requires:      pango >= 1:1.22.8
+Obsoletes:     wesnoth-tools < 1:1.14
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -122,23 +122,21 @@ Ten pakiet zawiera pliki danych dla gry Wesnoth.
 %{__sed} -i 's,${DATADIR}/${LOCALEDIR},${LOCALEDIR},' CMakeLists.txt
 
 %{__sed} -i '1s,/usr/bin/env python3$,%{__python3},' \
-       data/tools/{GUI.pyw,about_cfg_to_wiki,addon_manager/__init__.py,addon_manager/html.py,campaign2wiki.py,extractbindings,hexometer.py,imgcheck,steam-changelog,terrain2wiki.py,unit_tree/TeamColorizer,unit_tree/__init__.py,unit_tree/animations.py,unit_tree/helpers.py,unit_tree/html_output.py,unit_tree/overview.py,unit_tree/wiki_output.py,wesnoth/campaignserver_client.py,wesnoth/libgithub.py,wesnoth/wescamp.py,wesnoth/wmliterator3.py,wesnoth/wmlparser3.py,wesnoth/wmltools3.py,wesnoth_addon_manager,wmlindent,wmllint,wmllint-1.4,wmlscope,wmlunits,wmlxgettext}
-%{__sed} -i '1s,/usr/bin/env python2$,%{__python},' \
-       data/tools/{expand-terrain-macros.py,journeylifter,rmtrans/rmtrans.py,scoutDefault.py,trackplacer,wesnoth/wmldata.py,wesnoth/wmlgrammar.py,wesnoth/wmliterator.py,wesnoth/wmlparser.py,wesnoth/wmlparser2.py,wesnoth/wmltools.py,wmlflip,wmlvalidator}
+       data/tools/{GUI.pyw,about_cfg_to_wiki,addon_manager/__init__.py,addon_manager/html.py,extractbindings,hexometer.py,imgcheck,steam-changelog,terrain2wiki.py,unit_tree/TeamColorizer,unit_tree/__init__.py,unit_tree/animations.py,unit_tree/helpers.py,unit_tree/html_output.py,unit_tree/overview.py,unit_tree/wiki_output.py,wesnoth/campaignserver_client.py,wesnoth/libgithub.py,wesnoth/wescamp.py,wesnoth/wmliterator3.py,wesnoth/wmlparser3.py,wesnoth/wmltools3.py,trackviewer.pyw,wesnoth_addon_manager,wmlflip,wmlindent,wmllint,wmllint-1.4,wmlscope,wmlunits,wmlxgettext,tmx_trackplacer,wesnoth/wmldata.py,wesnoth/trackplacer3/datatypes.py,wesnoth/wmlparser.py,expand-terrain-macros.py}
 
 %build
 install -d build
 cd build
-%cmake \
-       .. \
-       -DCMAKE_BUILD_TYPE="Release" \
-       -DENABLE_STRICT_COMPILATION="off" \
+# override *FLAGS to remove -DNDEBUG (wesnoth depends on asserts)
+CFLAGS="%{rpmcflags}"
+CXXFLAGS="%{rpmcxxflags}"
+%cmake .. \
+       -DENABLE_STRICT_COMPILATION=OFF \
        -DBINDIR="%{_bindir}" \
        -DMANDIR="%{_mandir}" \
        -DLOCALEDIR="%{_localedir}" \
-       %{!?with_server:-DENABLE_SERVER="off"} \
-       %{?with_server:-DENABLE_CAMPAIGN_SERVER="on"} \
-       %{!?with_fribidi:-DENABLE_FRIBIDI="off"}
+       %{!?with_server:-DENABLE_SERVER=OFF} \
+       %{?with_server:-DENABLE_CAMPAIGN_SERVER=ON}
 
 %{__make}
 
@@ -163,18 +161,19 @@ cp -p %{SOURCE4} $RPM_BUILD_ROOT%{systemdunitdir}/wesnothd.service
 # unify
 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{ca_ES@valencia,ca@valencia}
 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{nb_NO,nb}
-%{__mv} $RPM_BUILD_ROOT%{_localedir}/{fur_IT,fur}
 %{__mv} $RPM_BUILD_ROOT%{_mandir}/{ca_ES@valencia,ca@valencia}
 
 # unsupported(?)
-%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ang@latin
-%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/racv
+%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{ang@latin,grc,racv}
 %{__rm} -r $RPM_BUILD_ROOT%{_mandir}/sr@ijekavian
 %{__rm} -r $RPM_BUILD_ROOT%{_mandir}/sr@ijekavianlatin
 
 # the same as manuals from %{_mandir}/man?
 %{__rm} -r $RPM_BUILD_ROOT%{_mandir}/en_GB
 
+# remove HighContrast icon
+%{__rm} -r $RPM_BUILD_ROOT%{_iconsdir}/HighContrast/scalable/apps/wesnoth-icon.svg
+
 %find_lang %{name} --all-name
 
 %clean
@@ -213,26 +212,26 @@ fi
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-#%doc README changelog
+%doc README.md changelog.md
 %doc %{_docdir}/%{name}
 %attr(755,root,root) %{_bindir}/wesnoth
 %{_mandir}/man6/wesnoth.6*
 %lang(ca) %{_mandir}/ca/man6/wesnoth.6*
+%lang(cs) %{_mandir}/cs/man6/wesnoth.6*
 %lang(de) %{_mandir}/de/man6/wesnoth.6*
 %lang(es) %{_mandir}/es/man6/wesnoth.6*
 %lang(fr) %{_mandir}/fr/man6/wesnoth.6*
 %lang(hu) %{_mandir}/hu/man6/wesnoth.6*
 %lang(it) %{_mandir}/it/man6/wesnoth.6*
 %lang(ja) %{_mandir}/ja/man6/wesnoth.6*
-%lang(lt) %{_mandir}/lt/man6/wesnoth.6*
 %lang(pt_BR) %{_mandir}/pt_BR/man6/wesnoth.6*
 %lang(ru) %{_mandir}/ru/man6/wesnoth.6*
 %lang(tr) %{_mandir}/tr/man6/wesnoth.6*
 %lang(zh_CN) %{_mandir}/zh_CN/man6/wesnoth.6*
 %lang(zh_TW) %{_mandir}/zh_TW/man6/wesnoth.6*
-%{_desktopdir}/wesnoth.desktop
+%{_desktopdir}/org.wesnoth.Wesnoth.desktop
 %{_iconsdir}/hicolor/*x*/apps/wesnoth-icon.png
-%{_datadir}/metainfo/wesnoth.appdata.xml
+%{_datadir}/metainfo/org.wesnoth.Wesnoth.appdata.xml
 
 %if %{with server}
 %files server
@@ -247,25 +246,14 @@ fi
 %lang(cs) %{_mandir}/cs/man6/wesnothd.6*
 %lang(de) %{_mandir}/de/man6/wesnothd.6*
 %lang(es) %{_mandir}/es/man6/wesnothd.6*
-%lang(et) %{_mandir}/et/man6/wesnothd.6*
-%lang(fi) %{_mandir}/fi/man6/wesnothd.6*
 %lang(fr) %{_mandir}/fr/man6/wesnothd.6*
 %lang(gl) %{_mandir}/gl/man6/wesnothd.6*
 %lang(hu) %{_mandir}/hu/man6/wesnothd.6*
-%lang(id) %{_mandir}/id/man6/wesnothd.6*
 %lang(it) %{_mandir}/it/man6/wesnothd.6*
 %lang(ja) %{_mandir}/ja/man6/wesnothd.6*
-%lang(lt) %{_mandir}/lt/man6/wesnothd.6*
-%lang(pl) %{_mandir}/pl/man6/wesnothd.6*
-%lang(pt) %{_mandir}/pt/man6/wesnothd.6*
 %lang(pt_BR) %{_mandir}/pt_BR/man6/wesnothd.6*
 %lang(ru) %{_mandir}/ru/man6/wesnothd.6*
-%lang(sk) %{_mandir}/sk/man6/wesnothd.6*
-%lang(sr) %{_mandir}/sr/man6/wesnothd.6*
-%lang(sr@latin) %{_mandir}/sr@latin/man6/wesnothd.6*
 %lang(tr) %{_mandir}/tr/man6/wesnothd.6*
-%lang(uk) %{_mandir}/uk/man6/wesnothd.6*
-%lang(vi) %{_mandir}/vi/man6/wesnothd.6*
 %lang(zh_CN) %{_mandir}/zh_CN/man6/wesnothd.6*
 %lang(zh_TW) %{_mandir}/zh_TW/man6/wesnothd.6*
 %attr(770,wesnothd,wesnothd) %dir /var/run/wesnothd
This page took 0.069503 seconds and 4 git commands to generate.