]> git.pld-linux.org Git - packages/vlc.git/blobdiff - vlc.spec
- builds, -matroska-shared.patch dropped as links without it too; rel 1
[packages/vlc.git] / vlc.spec
index c11785b02f569f5490502ae1d4dffa0f3be9b663..4315005ba3eea54b095f9a8597f74c86f44b7740 100644 (file)
--- a/vlc.spec
+++ b/vlc.spec
@@ -1,10 +1,17 @@
 #
 # TODO:
-# - check the altivec patch 
+# - check the altivec patch
 # - add proper package descriptions/translations
-# - alsa doesn't build - "Unknown endian" message in config.log
+# - bcondize this damn spec! (it should be automated too)
+# - go through the configure --help and add all options with proper
+#   reqs and bconds
 #
 # Conditional build:
+%bcond_without aa      # build without aalib support
+%bcond_without caca    # build without caca support
+%bcond_without dv      # build without dv support
+%bcond_without lirc    # build without lirc support
+%bcond_without x264    # build without x264 support
 %bcond_without alsa    # don't build alsa plugin
 %bcond_without arts    # don't build arts plugin
 %bcond_without ggi     # don't build ggi plugin
 Summary:       VLC - a multimedia player and stream server
 Summary(pl):   VLC - odtwarzacz multimedialny oraz serwer strumieni
 Name:          vlc
-Version:       0.8.2
-Release:       0.5
+Version:       0.8.6
+Release:       1
 License:       GPL
 Group:         X11/Applications/Multimedia
-Source0:       http://download.videolan.org/pub/videolan/vlc/%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 0e56141a54055686c28e3de4dbed5990
+# use the bz2 src, its a 4mb difference
+Source0:       http://download.videolan.org/pub/videolan/vlc/%{version}/%{name}-%{version}.tar.bz2
+# Source0-md5: 77a275f3408c4c9feae451d4eae47f89
 Source1:       %{name}.desktop
 Patch0:                %{name}-altivec.patch
 Patch1:                %{name}-buildflags.patch
 Patch2:                %{name}-defaultfont.patch
 Patch3:                %{name}-live.patch
-Patch4:                %{name}-x8864.patch
+Patch4:                %{name}-pic-mmx.patch
+Patch5:                %{name}-real_codecs_path.patch
+Patch6:                %{name}-osdmenu_path.patch
+Patch7:                %{name}-gcc-hack.patch
 URL:           http://www.videolan.org/vlc/
 BuildRequires: OpenGL-devel
-BuildRequires: SDL-devel >= 1.2
+BuildRequires: SDL_image-devel >= 1.2
 BuildRequires: a52dec-libs-devel
-BuildRequires: aalib-devel
+%{?with_aa:BuildRequires:      aalib-devel}
 %{?with_alsa:BuildRequires:    alsa-lib-devel >= 0.9}
 %{?with_arts:BuildRequires:    artsc-devel}
 BuildRequires: autoconf
@@ -46,16 +57,17 @@ BuildRequires:      flac-devel
 BuildRequires: fribidi-devel
 BuildRequires: gettext-devel
 %{?with_hal:BuildRequires:     hal-devel >= 0.2.97}
-BuildRequires: libcaca-devel
-BuildRequires: libcdio-devel
+%{?with_dv:BuildRequires:      libavc1394-devel}
+%{?with_caca:BuildRequires:    libcaca-devel}
 BuildRequires: libcddb-devel
+BuildRequires: libcdio-devel
 BuildRequires: libdts-devel
-BuildRequires: libdv-devel
+%{?with_dv:BuildRequires:      libdv-devel}
 BuildRequires: libdvbpsi-devel
+BuildRequires: libdvdcss-devel
 BuildRequires: libdvdnav-devel
 BuildRequires: libdvdread-devel
-BuildRequires: libdvdcss-devel
-BuildRequires: libebml-devel >= 0.7.3
+BuildRequires: libebml-devel >= 0.7.6
 %{?with_ggi:BuildRequires:     libggi-devel}
 BuildRequires: libid3tag-devel
 BuildRequires: libmad-devel
@@ -63,38 +75,42 @@ BuildRequires:      libmatroska-devel >= 0.7.5
 BuildRequires: libmodplug-devel
 BuildRequires: libogg-devel
 BuildRequires: libpng-devel
+%{?with_dv:BuildRequires:      libraw1394-devel}
+BuildRequires: libsmbclient-devel
 BuildRequires: libtheora-devel
+BuildRequires: libtool
 BuildRequires: libvorbis-devel
+%{?with_x264:BuildRequires:    libx264-devel}
 BuildRequires: libxml2-devel
-BuildRequires: lirc-devel
+%{?with_lirc:BuildRequires:    lirc-devel}
 %{?with_live:BuildRequires:    live >= 2005.03.11}
-BuildRequires: mpeg2dec-devel
 %{?with_mozilla:BuildRequires: mozilla-devel}
+BuildRequires: mpeg2dec-devel >= 0.3.2
 BuildRequires: ncurses-devel
 %{?with_slp:BuildRequires:     openslp-devel}
 BuildRequires: pkgconfig
-%{?with_speex:BuildRequires:   speex-devel > 1.1.0}
+%{?with_speex:BuildRequires:   speex-devel > 1:1.1.0}
 %{?with_svgalib:BuildRequires: svgalib-devel}
 BuildRequires: vcdimager-devel
-BuildRequires: wxGTK2-devel >= 2.5.5
+BuildRequires: wxGTK2-unicode-devel >= 2.6.2-2
 BuildRequires: xosd-devel
 BuildRequires: xvid-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-VLC (initially VideoLAN Client) is a multimedia player for various 
+VLC (initially VideoLAN Client) is a multimedia player for various
 audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX, MP3, Ogg, ...)
-as well as DVDs, VCDs, and various streaming protocols. It can also 
-be used as a server to stream in unicast or multicast in IPv4 
-or IPv6 on a high-bandwidth network.
+as well as DVDs, VCDs, and various streaming protocols. It can also be
+used as a server to stream in unicast or multicast in IPv4 or IPv6 on
+a high-bandwidth network.
 
 %description -l pl
-VLC (wcze¶niej znany pod nazw± VideoLAN Client) jest odtwarzaczem 
-multimedialnym dla wielu formatów wideo i d¼wiêku (MPEG-1, MPEG-2, 
-MPEG-4, DivX, MP3, Ogg, ...), p³yt DVD, VCD oraz ró¿nych protoko³ów 
-strumieniowych. Mo¿e byæ wykorzystany jako serwer do wysy³ania 
-strumieni unicast lub multicast w protoko³ach IPv4 lub IPv6 
-w wysokoprzepustowych sieciach.
+VLC (wcze¶niej znany pod nazw± VideoLAN Client) jest odtwarzaczem
+multimedialnym dla wielu formatów wideo i d¼wiêku (MPEG-1, MPEG-2,
+MPEG-4, DivX, MP3, Ogg, ...), p³yt DVD, VCD oraz ró¿nych protoko³ów
+strumieniowych. Mo¿e byæ wykorzystany jako serwer do wysy³ania
+strumieni unicast lub multicast w protoko³ach IPv4 lub IPv6 w
+wysokoprzepustowych sieciach.
 
 %package devel
 Summary:       VLC header files
@@ -132,8 +148,8 @@ Obsoletes:  vlc-gtk
 X11 output plugin for VLC. Contains GUI image/icon resources.
 
 %description X11 -l pl
-Wtyczka wyj¶cia X11 dla klienta VLC. Zawiera zasoby interfejsu 
-GUI (obrazy/ikony).
+Wtyczka wyj¶cia X11 dla klienta VLC. Zawiera zasoby interfejsu GUI
+(obrazy/ikony).
 
 %package GGI
 Summary:       VLC - GGI output plugin
@@ -202,6 +218,9 @@ Wtyczka wyj
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
+%patch5 -p1
+%patch6 -p1
+%patch7 -p1
 
 %build
 cp -f /usr/share/automake/config.* .
@@ -213,14 +232,14 @@ CFLAGS="%{rpmcflags} -DALSA_PCM_OLD_HW_PARAMS_API"
 %ifarch ppc
        --disable-altivec \
 %endif
-       --enable-aa \
+       --%{?with_aa:en}%{!?with_aa:dis}able-aa \
        %{?with_alsa:--enable-alsa} \
        %{?with_arts:--enable-arts} \
        %{!?with_arts:--disable-arts} \
-       --enable-caca \
+       --%{?with_caca:en}%{!?with_caca:dis}able-caca \
        --enable-dsp \
        --enable-dummy \
-       --enable-dv \
+       --%{?with_dv:en}%{!?with_dv:dis}able-dv \
        --enable-dvb \
        --enable-dvbpsi \
        --with-dvdcss \
@@ -233,12 +252,10 @@ CFLAGS="%{rpmcflags} -DALSA_PCM_OLD_HW_PARAMS_API"
        --enable-fribidi \
        --enable-ffmpeg \
        --enable-flac \
-       %{?with_ggi:--enable-ggi} \
-       %{?with_ggi:--with-ggi} \
-       %{!?with_ggi:--disable-ggi} \
+       --%{?with_ggi:en}%{!?with_ggi:dis}able-ggi \
        %{!?with_speex:--disable-speex} \
        --disable-glide \
-       --enable-lirc \
+       --%{?with_lirc:en}%{!?with_lirc:dis}able-lirc \
        --enable-mad \
        --enable-mga \
        %{?with_mozilla:--enable-mozilla } \
@@ -247,22 +264,26 @@ CFLAGS="%{rpmcflags} -DALSA_PCM_OLD_HW_PARAMS_API"
        --with-livedotcom-tree=%{_libdir}/liveMedia \
        --enable-ncurses \
        --enable-pvr \
+       --enable-real \
+       --enable-realrtsp \
        --enable-sdl \
        --with-sdl=/usr \
        --enable-skins2 \
        %{?with_slp:--enable-slp} \
        %{!?with_slp:--disable-slp} \
+       --enable-smb \
        %{?with_svgalib:--enable-svgalib} \
        --enable-tarkin \
        --enable-theora \
        --enable-tremor \
        --enable-v4l\
        --enable-x11 \
+       %{!?with_x264:--disable-x264} \
        --enable-xosd \
        --enable-xvid \
        --enable-oss \
        --disable-testsuite \
-       --with-wx-config=wx-gtk2-ansi-config \
+       --with-wx-config=wx-gtk2-unicode-config \
        %{!?with_hal:--disable-hal} \
        --disable-optimizations # we use own RPM_OPT_FLAGS optimalizations
 
@@ -318,24 +339,16 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/vlc/stream_out
 %attr(755,root,root) %{_libdir}/vlc/audio_filter
 %attr(755,root,root) %{_libdir}/vlc/packetizer
-%attr(755,root,root) %{_libdir}/vlc/audio_output
 %attr(755,root,root) %{_libdir}/vlc/access_filter
 %attr(755,root,root) %{_libdir}/vlc/services_discovery
+%dir %{_libdir}/vlc/audio_output
 %exclude %{_libdir}/%{name}/audio_output/libaout_sdl_plugin.so
 %{?with_alsa:%exclude %{_libdir}/%{name}/audio_output/libalsa_plugin.so}
 %exclude %{_libdir}/%{name}/audio_output/libesd_plugin.so
+%attr(755,root,root) %{_libdir}/vlc/audio_output/*.so
 %dir %{_datadir}/%{name}
-%dir %{_datadir}/%{name}/http
-%dir %{_datadir}/%{name}/http/vlm
-%dir %{_datadir}/%{name}/http/admin
-%dir %{_datadir}/%{name}/skins2
-%dir %{_datadir}/%{name}/skins2/fonts
-%{_datadir}/%{name}/http/vlm/*.html
-%{_datadir}/%{name}/http/admin/*.html
-%{_datadir}/%{name}/http/admin/.access
-%{_datadir}/%{name}/http/style.css
-%{_datadir}/%{name}/http/*.html
-%{_datadir}/%{name}/ui.rc
+%{_datadir}/%{name}/http
+%{_datadir}/%{name}/osdmenu
 %{_mandir}/man1/vlc.1*
 
 %files devel
@@ -354,26 +367,25 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/svlc
 %attr(755,root,root) %{_bindir}/wxvlc
 %attr(755,root,root) %{_libdir}/vlc/gui/libskins2_plugin.so
-%attr(755,root,root) %{_libdir}/vlc/gui/libwxwindows_plugin.so
+%attr(755,root,root) %{_libdir}/vlc/gui/libwxwidgets_plugin.so
 %attr(755,root,root) %{_libdir}/vlc/access/libscreen_plugin.so
 %attr(755,root,root) %{_libdir}/vlc/video_output
 %{?with_ggi:%exclude %{_libdir}/%{name}/video_output/libggi_plugin.so}
 %exclude %{_libdir}/%{name}/video_output/libvout_sdl_plugin.so
 %exclude %{_libdir}/%{name}/video_output/libfb_plugin.so
 %attr(755,root,root) %{_libdir}/vlc/visualization/libxosd_plugin.so
-%{_datadir}/%{name}/skins2/default.vlt
-%{_datadir}/%{name}/skins2/fonts/FreeSans.ttf
-%{_datadir}/%{name}/skins2/skin.catalog
-%{_datadir}/%{name}/skins2/skin.dtd
+%{_datadir}/%{name}/skins2
 %{_datadir}/%{name}/vlc*.xpm
+%{_datadir}/%{name}/pda*.xpm
 %{_datadir}/%{name}/vlc*.png
-%{_desktopdir}/*
+%{_datadir}/%{name}/vlc*.ico
+%{_desktopdir}/*.desktop
 
 %if %{with ggi}
 %files GGI
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/%{name}/video_output/libggi_plugin.so
-%endif 
+%endif
 
 %files SDL
 %defattr(644,root,root,755)
This page took 0.046312 seconds and 4 git commands to generate.