]> git.pld-linux.org Git - packages/virt-viewer.git/blobdiff - virt-viewer.spec
upstream fix for build failure with recent meson versions
[packages/virt-viewer.git] / virt-viewer.spec
index bb4d20113f9be635e1feb1ad6ea852191465b9c9..4ab393cfd208703b378b85f6a69c94216adc76d5 100644 (file)
@@ -1,61 +1,59 @@
 #
 # Conditional build:
-%bcond_with    gtk2    # use GTK+ 2.x instead of GTK+ 3.x
 %bcond_without spice   # SPICE support
-%bcond_with    ovirt   # oVirt support [requiring libgovirt, depending on rest >= 1.7.13]
+%bcond_without ovirt   # oVirt support
 #
 Summary:       Virtual Machine Viewer
 Summary(pl.UTF-8):     Przeglądarka maszyny wirtualnej
 Name:          virt-viewer
-Version:       0.6.0
+Version:       11.0
 Release:       1
 License:       GPL v2+
 Group:         X11/Applications/Networking
-Source0:       https://fedorahosted.org/released/virt-viewer/%{name}-%{version}.tar.gz
-# Source0-md5: a3d7dd877105117e36185378ee1849ee
+Source0:       https://virt-manager.org/download/sources/virt-viewer/%{name}-%{version}.tar.xz
+# Source0-md5: 06b80228aaf10e614aeb8ffa4814b03a
+Patch0:                meson.patch
 URL:           http://virt-manager.org/
-BuildRequires: autoconf >= 2.50
-BuildRequires: automake
-BuildRequires: gettext-devel >= 0.14.1
-BuildRequires: glib2-devel >= 1:2.22.0
+BuildRequires: bash-completion-devel
+BuildRequires: cmake
+BuildRequires: gettext-tools >= 0.14.1
+BuildRequires: glib2-devel >= 1:2.40.0
+BuildRequires: gtk+3-devel >= 3.12
+BuildRequires: gtk3-vnc-devel >= 0.4.3
+BuildRequires: icoutils
 BuildRequires: intltool >= 0.35.0
-%{?with_ovirt:BuildRequires:   libgovirt-devel >= 0.3.0}
+%{?with_ovirt:BuildRequires:   libgovirt-devel >= 0.3.7}
 BuildRequires: libtool >= 2:2
-BuildRequires: libvirt-devel >= 0.10.0
+BuildRequires: libvirt-devel >= 1.2.8
+BuildRequires: libvirt-glib-devel >= 0.1.8
 BuildRequires: libxml2-devel >= 1:2.6.0
+BuildRequires: meson
+BuildRequires: ninja
 BuildRequires: perl-tools-pod
-BuildRequires: rpmbuild(macros) >= 1.596
+BuildRequires: pkgconfig
+%{?with_ovirt:BuildRequires:   rest-devel >= 0.8}
+BuildRequires: rpmbuild(macros) >= 2.000
 BuildRequires: sed >= 4.0
-BuildRequires: spice-protocol >= 0.10.1
-%if %{with gtk2}
-BuildRequires: gtk+2-devel >= 2:2.18.0
-BuildRequires: gtk-vnc-devel >= 0.4.3
-%{?with_spice:BuildRequires: spice-gtk2-devel >= 0.22}
-%else
-BuildRequires: gtk+3-devel >= 3.0.0
-BuildRequires: gtk3-vnc-devel >= 0.4.3
-%{?with_spice:BuildRequires: spice-gtk-devel >= 0.22}
-%endif
+%{?with_spice:BuildRequires:   spice-gtk-devel >= 0.35}
+BuildRequires: spice-protocol >= 0.12.7
+BuildRequires: vte-devel
 Requires(post,postun): gtk-update-icon-cache
 Requires(post,postun): shared-mime-info
-Requires:      glib2 >= 1:2.22.0
+Requires:      glib2 >= 1:2.40.0
+Requires:      gtk+3 >= 3.12
+Requires:      gtk3-vnc >= 0.4.3
 Requires:      hicolor-icon-theme
-Requires:      libvirt >= 0.10.0
+%{?with_ovirt:Requires:        libgovirt >= 0.3.3}
+Requires:      libvirt >= 1.2.8
+Requires:      libvirt-glib >= 0.1.8
 Requires:      libxml2 >= 1:2.6.0
-%if %{with gtk2}
-Requires:      gtk+2 >= 2:2.18.0
-Requires:      gtk-vnc >= 0.4.3
-%{?with_spice:Requires: spice-gtk2 >= 0.22}
-%else
-Requires:      gtk+3 >= 3.0.0
-Requires:      gtk3-vnc >= 0.4.3
-%{?with_spice:Requires: spice-gtk >= 0.22}
-%endif
-%{?with_ovirt:Requires:        libgovirt >= 0.3.0}
-Suggests:      openssh-clients
+%{?with_ovirt:Requires:        rest >= 0.8}
+%{?with_spice:Requires:        spice-gtk >= 0.35}
 Suggests:      gnome-keyring >= 0.4.9
+Suggests:      openssh-clients
+# let it obsolete withdrawn spice client from spice-space package
+%{?with_spice:Obsoletes:       spice-client}
 Obsoletes:     virt-viewer-plugin
-ExclusiveArch: %{ix86} %{x8664} ia64
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -70,31 +68,38 @@ Virtual Machine Viewer udostępnia klienta graficznej konsoli do
 SPICE-GTK do zapewnienia obrazu oraz libvirt do odczytu szczegółów
 serwera VNC/SPICE.
 
+%package -n bash-completion-virt-viewer
+Summary:       bash-completion for virt-viewer command
+Summary(pl.UTF-8):     bashowe uzupełnianie parametrów polecenia virt-viewer
+Group:         Applications/Shells
+Requires:      %{name} = %{version}-%{release}
+Requires:      bash-completion >= 2.0
+BuildArch:     noarch
+
+%description -n bash-completion-virt-viewer
+Bash-completion for virt-viewer command.
+
+%description -n bash-completion-virt-viewer -l pl.UTF-8
+Bashowe uzupełnianie parametrów polecenia virt-viewer.
+
 %prep
 %setup -q
-
-%{__sed} -i -e 's|PWD|shell pwd|g' icons/*/Makefile.am
+%patch0 -p1
 
 %build
-%{__libtoolize}
-%{__aclocal}
-%{__autoconf}
-%{__autoheader}
-%{__automake}
-%configure \
-       --disable-silent-rules \
-       --disable-update-mimedb \
-       %{__with_without spice spice-gtk} \
-       --with-gtk=%{?with_gtk2:2.0}%{!?with_gtk2:3.0} \
-       %{!?with_ovirt:--without-ovirt}
-
-%{__make}
+%meson \
+       %{!?with_ovirt:-Dovirt=disabled} \
+       %{?with_ovirt:-Dovirt=enabled} \
+       %{!?with_spice:-Dspice=disabled} \
+       %{?with_spice:-Dspice=enabled} \
+       build
+
+%ninja_build -C build
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT
+%ninja_install -C build
 
 %find_lang %{name}
 
@@ -111,14 +116,17 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc AUTHORS ChangeLog NEWS README
+%doc AUTHORS NEWS README.md
 %attr(755,root,root) %{_bindir}/virt-viewer
 %attr(755,root,root) %{_bindir}/remote-viewer
-%dir %{_datadir}/%{name}
-%dir %{_datadir}/%{name}/ui
-%{_datadir}/%{name}/ui/*.xml
+%{_datadir}/metainfo/remote-viewer.appdata.xml
 %{_datadir}/mime/packages/virt-viewer-mime.xml
 %{_desktopdir}/remote-viewer.desktop
 %{_iconsdir}/hicolor/*/apps/virt-viewer.png
+%{_iconsdir}/hicolor/scalable/apps/virt-viewer.svg
 %{_mandir}/man1/virt-viewer.1*
 %{_mandir}/man1/remote-viewer.1*
+
+%files -n bash-completion-virt-viewer
+%defattr(644,root,root,755)
+%{bash_compdir}/virt-viewer
This page took 0.170463 seconds and 4 git commands to generate.