]> git.pld-linux.org Git - packages/vim.git/blobdiff - vim.spec
- updated to 7.1.100
[packages/vim.git] / vim.spec
index aea9e1dc91b78aa1bcdb2a866bd78367269008a5..6ef1f0dec604b524af2989620d25b9c29d17f3c0 100644 (file)
--- a/vim.spec
+++ b/vim.spec
@@ -1,7 +1,8 @@
 # TODO:
 # - merge with AC-branch
 # - some nice icon
-# - bonobo patches need update
+# - create vim-full (better name, anybody?) or/and other packages
+#   for scripting languages support
 #
 # Conditional build:
 %bcond_without static          # don't build static version
 %bcond_without motif           # don't build Motif-based gvim
 %bcond_without gtk             # don't build GTK+-based gvim support
 %bcond_without gnome           # don't build GNOME-based gvim support
-%bcond_without perl            # without Perl interp
-%bcond_without python          # with Python interp
-%bcond_without ruby            # with Ruby interp
-%bcond_without tcl             # with Tcl interp
-%bcond_with    bonobo          # with bonobo component (breaks other things)
+%bcond_with    perl            # with Perl interp
+%bcond_with    python          # with Python interp
+%bcond_with    ruby            # with Ruby interp
+%bcond_with    tcl             # with Tcl interp
 %bcond_without selinux         # without selinux support
 %bcond_without home_etc        # without home_etc support
 #
 %define                _ver            7.1
-%define                _patchlevel     035
+%define                _patchlevel     100
 %define                _rel            1
 
 # cflags get changed while configuring
@@ -85,10 +85,7 @@ Patch20:     %{name}-tutor-lessdeps.patch
 Patch21:       %{name}-nagios.patch
 Patch22:       %{name}-filetypes.patch
 Patch23:       %{name}-man_installation.patch
-Patch100:      %{name}-bonobo-20050909.patch
-Patch101:      %{name}-bonobo.patch
 Patch102:      %{name}-gtkfilechooser.patch
-Patch103:      %{name}-gtkfilechooser-bonobo.patch
 Patch104:      %{name}-home_etc.patch
 Patch105:      %{name}-selinux.patch
 Patch106:      %{name}-autopaste.patch
@@ -110,12 +107,6 @@ BuildRequires:     ncurses-devel
 %{?with_tcl:BuildRequires:     tcl-devel}
 %{?with_athena:BuildRequires:  xorg-lib-libXaw-devel}
 Obsoletes:     kvim
-%if %{with bonobo}
-BuildRequires: ORBit2-devel
-BuildRequires: libbonoboui-devel >= 2.2.0
-BuildRequires: libgnomeui-devel >= 2.2.0.1
-BuildRequires: nautilus-devel >= 2.2.0
-%endif
 BuildRequires: rpmbuild(macros) >= 1.351
 %if %{with static}
 BuildRequires: acl-static
@@ -317,6 +308,7 @@ Group:              Applications/Editors/Vim
 # mktemp is for vimtutor
 Requires:      mktemp
 Requires:      vi-editor
+Obsoletes:     gvim-bonobo
 Obsoletes:     vim-common
 
 %description rt
@@ -506,24 +498,6 @@ GNOME, что позволяет запускать VIM как приложен
 дозволяє запускати VIM як прикладну програму X Window System - з
 повністю графічним інтерфейсом та підтримкою миші.
 
-%package -n gvim-bonobo
-Summary:       Vim for X Window built as bonobo component
-Summary(pl.UTF-8):     Vim dla X Window zbudowany jako element bonobo
-Group:         Applications/Editors/Vim
-Requires:      %{name}-rt = %{epoch}:%{version}-%{release}
-Requires:      iconv
-Provides:      gvim
-Provides:      vi-editor
-Obsoletes:     vim-X11
-
-%description -n gvim-bonobo
-The classic Unix text editor now also under X Window System! This
-version is build as bonobo component.
-
-%description -n gvim-bonobo -l pl.UTF-8
-Wersja edytora Vim pracująca w środowisku X Window, zbudowana jako
-element bonobo.
-
 %prep
 %setup -q -n %{name}71 -b1 -b2
 
@@ -555,14 +529,6 @@ element bonobo.
 %patch22 -p1
 %patch23 -p1
 
-# bonobo
-%if %{with bonobo}
-%patch100 -p1
-%patch101 -p1
-%patch102 -p1
-%patch103 -p1
-%endif
-
 # home etc
 %{?with_home_etc:%patch104 -p1}
 
@@ -590,33 +556,6 @@ cp -f configure auto
 
 install -d bin
 
-%if %{with bonobo}
-%{__make} distclean
-%configure \
-       --with-features=huge \
-       --enable-gui=gnome2 \
-       --enable-bonobo \
-       --enable-gtk2-check \
-       --enable-gnome-check \
-       --with-x \
-       %{!?with_perl:--disable-perlinterp} \
-       %{?with_perl:--enable-perlinterp} \
-       %{!?with_python:--disable-pythoninterp} \
-       %{?with_python:--enable-pythoninterp} \
-       %{!?with_ruby:--disable-rubyinterp} \
-       %{?with_ruby:--enable-rubyinterp} \
-       %{!?with_tcl:--disable-tclinterp} \
-       %{?with_tcl:--enable-tclinterp} \
-       --disable-gpm \
-       --enable-cscope \
-       --enable-nls \
-       --with-modifiedby="PLD Linux Distribution" \
-       --with-compiledby="PLD Linux Distribution"
-
-%{__make} vim-component vim-factory Vim_Control.server
-mv vim-component vim-factory Vim_Control.server bin/
-%endif
-
 %if %{with static}
 %{__make} distclean
 LDFLAGS="%{rpmldflags} -static"
@@ -630,7 +569,6 @@ LDFLAGS="%{rpmldflags} -static"
        --disable-cscope \
        --disable-gpm \
        --disable-multibyte \
-       %{?with_bonobo:--disable-bonobo} \
        --with-features=small \
        --with-tlib="ncurses -ltinfo" \
        --disable-nls \
@@ -655,7 +593,6 @@ LDFLAGS="%{rpmldflags}"
        %{?with_ruby:--enable-rubyinterp} \
        %{!?with_tcl:--disable-tclinterp} \
        %{?with_tcl:--enable-tclinterp} \
-       %{?with_bonobo:--disable-bonobo} \
        --enable-cscope \
        --enable-gpm \
        --with-features=huge \
@@ -683,7 +620,6 @@ mv -f vim bin/vim.ncurses
        %{?with_ruby:--enable-rubyinterp} \
        %{!?with_tcl:--disable-tclinterp} \
        %{?with_tcl:--enable-tclinterp} \
-       %{?with_bonobo:--disable-bonobo} \
        --enable-cscope \
        --enable-fontset \
        --disable-gpm \
@@ -712,7 +648,6 @@ mv -f vim bin/gvim.athena
        %{?with_ruby:--enable-rubyinterp} \
        %{!?with_tcl:--disable-tclinterp} \
        %{?with_tcl:--enable-tclinterp} \
-       %{?with_bonobo:--disable-bonobo} \
        --enable-multibyte \
        --enable-cscope \
        --enable-fontset \
@@ -742,7 +677,6 @@ mv -f vim bin/gvim.motif
        %{?with_ruby:--enable-rubyinterp} \
        %{!?with_tcl:--disable-tclinterp} \
        %{?with_tcl:--enable-tclinterp} \
-       %{?with_bonobo:--disable-bonobo} \
        --disable-gpm \
        --enable-cscope \
        --with-tlib="ncurses -ltinfo" \
@@ -759,7 +693,6 @@ mv -f vim bin/gvim.gtk
 %configure \
        --with-features=huge \
        --enable-gui=gnome2 \
-       %{?with_bonobo:--disable-bonobo} \
        --enable-gtk2-check \
        --enable-gnome-check \
        --with-x \
@@ -863,13 +796,6 @@ install runtime/vim16x16.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/16x16/apps/vim.
 install runtime/vim32x32.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/32x32/apps/vim.png
 install runtime/vim48x48.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/48x48/apps/vim.png
 
-# Bonobo
-%if %{with bonobo}
-install -d $RPM_BUILD_ROOT%{_libdir}/bonobo/servers
-install src/bin/Vim_Control.server $RPM_BUILD_ROOT%{_libdir}/bonobo/servers
-install src/bin/vim-{component,factory} $RPM_BUILD_ROOT%{_bindir}
-%endif
-
 bzip2 -dc %{SOURCE3} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
 
 unzip -qd $RPM_BUILD_ROOT%{_datadir}/vim/v*/doc %{SOURCE4}
@@ -921,25 +847,25 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/rvim
 %attr(755,root,root) %{_bindir}/vim
 %attr(755,root,root) %{_bindir}/vimdiff
-%{_mandir}/man1/eview.1*
+#%{_mandir}/man1/eview.1*
 %{_mandir}/man1/evim.1*
 %{_mandir}/man1/rvim.1*
 %{_mandir}/man1/vimdiff.1*
 %lang(fi) %{_mandir}/fi/man1/rvim.1*
-%lang(fr) %{_mandir}/fr/man1/eview.1*
+#%lang(fr) %{_mandir}/fr/man1/eview.1*
 %lang(fr) %{_mandir}/fr/man1/evim.1*
 %lang(fr) %{_mandir}/fr/man1/rvim.1*
 %lang(fr) %{_mandir}/fr/man1/vimdiff.1*
 %lang(id) %{_mandir}/id/man1/rvim.1*
-%lang(it) %{_mandir}/it/man1/eview.1*
+#%lang(it) %{_mandir}/it/man1/eview.1*
 %lang(it) %{_mandir}/it/man1/evim.1*
 %lang(it) %{_mandir}/it/man1/rvim.1*
 %lang(it) %{_mandir}/it/man1/vimdiff.1*
-%lang(pl) %{_mandir}/pl/man1/eview.1*
+#%lang(pl) %{_mandir}/pl/man1/eview.1*
 %lang(pl) %{_mandir}/pl/man1/evim.1*
 %lang(pl) %{_mandir}/pl/man1/rvim.1*
 %lang(pl) %{_mandir}/pl/man1/vimdiff.1*
-%lang(ru) %{_mandir}/ru/man1/eview.1*
+#%lang(ru) %{_mandir}/ru/man1/eview.1*
 %lang(ru) %{_mandir}/ru/man1/evim.1*
 %lang(ru) %{_mandir}/ru/man1/rvim.1*
 %lang(ru) %{_mandir}/ru/man1/vimdiff.1*
@@ -1153,11 +1079,3 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/gvim.gnome
 %{_desktopdir}/gvim-gnome.desktop
 %endif
-
-%if %{with bonobo}
-%files -n gvim-bonobo
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/vim-component
-%attr(755,root,root) %{_bindir}/vim-factory
-%{_libdir}/bonobo/servers/*
-%endif
This page took 0.045272 seconds and 4 git commands to generate.