]> git.pld-linux.org Git - packages/uboot.git/blobdiff - uboot.spec
up to 2022.01
[packages/uboot.git] / uboot.spec
index a7f47f17a795a5eea1a14ab9b12d6b576a9b2790..6b181feb341a0542934c645af4a4d039e5a51b61 100644 (file)
@@ -1,29 +1,49 @@
 Summary:       Das U-Boot -- the Universal Boot Loader
 Summary(pl.UTF-8):     Das U-Boot - uniwersalny bootloader
 Name:          uboot
-Version:       2020.10
+Version:       2022.01
 Release:       1
 License:       GPL v2
 Group:         Applications/System
 Source0:       https://ftp.denx.de/pub/u-boot/u-boot-%{version}.tar.bz2
-# Source0-md5: 14656f08aa73a8dbbde2424fe78bbe3b
+# Source0-md5: 49ba74a214d14c6340c8067bc1ed5fa0
+Source1:       https://github.com/hardkernel/u-boot/archive/travis/odroidc4-189/odroid-189.tar.gz
+# Source1-md5: dd117b6180ad5c9abb3303b31e57e7b4
 Patch0:                rpi-Enable-using-the-DT-provided-by-the-Raspberry-Pi.patch
+Patch1:                %{name}-pbp_usb_hang.patch
+Patch2:                rk3399-emmc.patch
+Patch3:                hardkernel-uboot-gcc5.patch
+Patch4:                hardkernel-uboot-werror.patch
+Patch5:                hardkernel-uboot-arm_cross.patch
+Patch6:                hardkernel-uboot-no_stdint.patch
+Patch7:                hardkernel-uboot-x86_64_bin.patch
+Patch8:                hardkernel-uboot-acs.patch
+Patch9:                hardkernel-uboot-uboot_payload.patch
 URL:           https://www.denx.de/wiki/U-Boot
+BuildRequires: bison
+BuildRequires: dtc
+BuildRequires: flex
+BuildRequires: openssl-devel
+BuildRequires: rpmbuild(macros) >= 2.007
 %ifarch aarch64
 BuildRequires: arm-trusted-firmware-armv8
+BuildRequires: box64
+BuildRequires: crossarm-gcc
+BuildRequires: qemu-user
+BuildConflicts:        libfdt-devel
 %endif
-BuildRequires: bison
-BuildRequires: flex
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                common_configs  tools-only
 
-%ifarch %{arm}
+%ifarch %{armv6}
 %define                arch_configs    rpi_0_w rpi_2
-%else
-%ifarch aarch64
-%define                arch_configs    pinebook-pro-rk3399
 %endif
+%ifarch %{armv7}
+%define                arch_configs    rpi_2
+%endif
+%ifarch aarch64
+%define                arch_configs    odroid-n2 pinebook-pro-rk3399
 %endif
 
 %define                configs %{common_configs} %{?arch_configs}
@@ -42,27 +62,50 @@ Das U-Boot (Universal Bootloader lub "łódź podwodna" po niemiecku) to
 bootloader dla wielu różnych architektur komputerów, w tym PPC, ARM,
 AVR32, MIPS, x86, 68k, Nios i MicroBlaze.
 
+%package image-odroid-n2
+Summary:       U-Boot firmware images for Odroid N2/N2+
+Summary(pl.UTF-8):     Obrazy firmware'u U-Boot dla urządzeń Odroid N2/N2+
+Group:         Applications/System
+
+%description image-odroid-n2
+U-Boot firmware images for Odroid N2/N2+.
+
+%description image-odroid-n2 -l pl.UTF-8
+Obrazy firmware'u U-Boot dla urządzeń Odroid N2/N2+.
+
 %package image-pinebook-pro
 Summary:       U-Boot firmware images for Pinebook Pro
+Summary(pl.UTF-8):     Obrazy firmware'u U-Boot dla urządzeń Pinebook Pro
 Group:         Applications/System
 
 %description image-pinebook-pro
 U-Boot firmware images for Pinebook Pro.
 
+%description image-pinebook-pro -l pl.UTF-8
+Obrazy firmware'u U-Boot dla urządzeń Pinebook Pro.
+
 %package image-raspberry-pi-2
 Summary:       U-Boot firmware image for Raspberry Pi 2
+Summary(pl.UTF-8):     Obrazy firmware'u U-Boot dla urządzeń Raspberry Pi 2
 Group:         Applications/System
 
 %description image-raspberry-pi-2
 U-Boot firmware image for Raspberry Pi 2.
 
+%description image-raspberry-pi-2 -l pl.UTF-8
+Obrazy firmware'u U-Boot dla urządzeń Raspberry Pi 2.
+
 %package image-raspberry-pi-zero
 Summary:       U-Boot firmware image for Raspberry Pi Zero
+Summary(pl.UTF-8):     Obrazy firmware'u U-Boot dla urządzeń Raspberry Pi Zero
 Group:         Applications/System
 
 %description image-raspberry-pi-zero
 U-Boot firmware image for Raspberry Pi Zero.
 
+%description image-raspberry-pi-zero -l pl.UTF-8
+Obrazy firmware'u U-Boot dla urządzeń Raspberry Pi Zero.
+
 %package mkimage
 Summary:       Generate kernel image for U-Boot
 Summary(pl.UTF-8):     Generowanie obrazu jądra dla U-Boota
@@ -93,7 +136,25 @@ czasie utworzenia, sumach kontrolnych CRC32 itp.
 
 %prep
 %setup -q -n u-boot-%{version}
+%ifarch %{arm} aarch64
 %patch0 -p1
+%endif
+%ifarch aarch64
+%patch1 -p1
+%patch2 -p1
+install -d build/hardkernel-uboot-odroid
+tar xf %{SOURCE1} -C build/hardkernel-uboot-odroid
+mv build/hardkernel-uboot-odroid/u-boot*/* build/hardkernel-uboot-odroid
+cd build/hardkernel-uboot-odroid
+%patch3 -p1
+%patch4 -p1
+%patch5 -p1
+%patch6 -p1
+%patch7 -p1
+%patch8 -p1
+%patch9 -p1
+cd ../..
+%endif
 
 %build
 for config in %configs; do
@@ -102,6 +163,7 @@ for config in %configs; do
                cp -p /usr/share/arm-trusted-firmware/rk3399/* build/$config
        fi
        %{__make} ${config}_defconfig \
+               CC="%{__cc}" \
                HOSTCC="%{__cc}" \
                STRIP=: \
                HOSTCFLAGS="%{rpmcflags}" \
@@ -110,6 +172,7 @@ for config in %configs; do
                O=build/$config
        %{__make} \
                $(test "$config" = "tools-only" && echo tools-only) \
+               CC="%{__cc}" \
                HOSTCC="%{__cc}" \
                STRIP=: \
                HOSTCFLAGS="%{rpmcflags}" \
@@ -117,10 +180,23 @@ for config in %configs; do
                V=1 \
                O=build/$config
 done
+%ifarch aarch64
+cd build/hardkernel-uboot-odroid
+%{__make} odroidn2_defconfig \
+       V=1
+%{__make} \
+       CROSS_COMPILE= \
+       ARM_CROSS_COMPILE=arm-linux-gnueabi- \
+       UBOOT_PAYLOAD=$(pwd)/../odroid-n2/u-boot.bin \
+       X86_64_DYNAMIC_WRAPPER=/usr/bin/box64 \
+       X86_64_STATIC_WRAPPER=/usr/bin/qemu-x86_64 \
+       V=1
+cd ../..
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_bindir}
+install -d $RPM_BUILD_ROOT{%{_bindir},%{imagedir}}
 
 for config in %configs; do
        if [ "$config" = "tools-only" ]; then
@@ -128,6 +204,9 @@ for config in %configs; do
        elif echo ' %rk3399_configs ' | grep -q " $config "; then
                install -d $RPM_BUILD_ROOT%{imagedir}/$config
                cp -p build/$config/{idbloader.img,u-boot.itb} $RPM_BUILD_ROOT%{imagedir}/$config
+       elif [ $config = "odroid-n2" ]; then
+               install -d $RPM_BUILD_ROOT%{imagedir}/$config
+               cp -p build/hardkernel-uboot-odroid/sd_fuse/u-boot.bin $RPM_BUILD_ROOT%{imagedir}/$config
        else
                install -d $RPM_BUILD_ROOT%{imagedir}/$config
                cp -p build/$config/u-boot.bin $RPM_BUILD_ROOT%{imagedir}/$config
@@ -143,16 +222,22 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{imagedir}
 
 %ifarch aarch64
+%files image-odroid-n2
+%defattr(644,root,root,755)
+%{imagedir}/odroid-n2
+
 %files image-pinebook-pro
 %defattr(644,root,root,755)
 %{imagedir}/pinebook-pro-rk3399
 %endif
 
-%ifarch %{arm}
+%ifarch %{armv6} %{armv7}
 %files image-raspberry-pi-2
 %defattr(644,root,root,755)
 %{imagedir}/rpi_2
+%endif
 
+%ifarch %{armv6}
 %files image-raspberry-pi-zero
 %defattr(644,root,root,755)
 %{imagedir}/rpi_0_w
This page took 0.047322 seconds and 4 git commands to generate.