]> git.pld-linux.org Git - packages/tla.git/blobdiff - tla.spec
- rel 3; fix docs build
[packages/tla.git] / tla.spec
index 05018e3ed63c3d32737ab632be021be0ebfe5e3a..a2ba7d32f0b4dfab02cb26396d3ebfbbc096e242 100644 (file)
--- a/tla.spec
+++ b/tla.spec
@@ -1,65 +1,84 @@
-Name:          tla
 Summary:       tla arch - revision control system
-Summary(pl):   tla arch - systeme kontroli wersji
-Version:       1.1pre7
-Release:       2
+Summary(pl):   tla arch - system kontroli wersji
+Name:          tla
+Version:       1.3.3
+Release:       3
+Epoch:         1
 License:       GPL v2
 Group:         Development/Version Control
-URL:           http://regexps.srparish.net/www/
-Source0:       http://ftp.gnu.org/gnu/gnu-arch/%{name}-%{version}.tar.gz
-# Source0-md5: 98542bdbcaf2e6146f41ba90a7643fc0
+Source0:       ftp://ftp.gnu.org/pub/gnu/gnu-arch/%{name}-%{version}.tar.gz
+# Source0-md5: 61d5dea41e071f78a8319401ee07ab0b
+Patch0:                %{name}-neon.patch
+URL:           http://www.gnu.org/software/gnu-arch/
+Requires:      diffutils
+Requires:      patch
+Requires:      tar
+BuildRequires: findutils
+BuildRequires: neon-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-tla arch is a revision control system: a program that lets
-programmers archive a history of changes made to the software they
-maintain and that, more importantly, helps programmers to coordinate,
-synchronize, and combine multiple lines of development for a single
-project.
+tla arch is a revision control system: a program that lets programmers
+archive a history of changes made to the software they maintain and
+that, more importantly, helps programmers to coordinate, synchronize,
+and combine multiple lines of development for a single project.
 
 arch version tla is a C version of the reference arch concepts.
 
+%description -l pl
+tla arch jest systemem kontroli wersji - programem, który pozwala
+programistom archiwizowaæ historiê zmian wykonanych w rozwijanym przez
+nich oprogramowaniu oraz, co wa¿niejsze, pomaga programistom
+koordynowaæ, synchronizowaæ i ³±czyæ wiele linii kodu podczas rozwoju
+projektu.
+
+arch w wersji tla to wersja w C wzorcowych idei arch.
+
 %prep
 %setup -q
-
-## using: rpmbuild -ba --target=i686-redhat-linux tls-1.0.6.spec
+%patch0 -p1
 
 %build
-cd %{_builddir}/%{name}-%{version}/src
+rm -rf src/tla/libneon
+ln -s /usr/include/neon src/tla/libneon
+cd src
 mkdir =build
 cd =build
-## imitate what an rpm macro would export
-export CFLAGS="${RPM_OPT_FLAGS}" CXXFLAGS="${RPM_OPT_FLAGS}" FFLAGS="${RPM_OPT_FLAGS}";
-../configure --prefix=%{_prefix} --destdir=%{buildroot}
-%{__make}
-# ok, I tested already
-%{__make} test
 
+CFLAGS="%{rpmcflags}"
+CXXFLAGS="%{rpmcflags}"
+FFLAGS="%{rpmcflags}"
+export CFLAGS CXXFLAGS FFLAGS
+
+# custom configure script
+../configure \
+       --prefix=%{_prefix} \
+       --destdir=$RPM_BUILD_ROOT \
+       --with-ssh-is-openssh=1 \
+       --with-cc="%{__cc}"
+%{__make} -j1
+
+# ok, I tested already
+%{__make} -j1 test
 
 %install
 rm -rf $RPM_BUILD_ROOT
-rm -rf %{buildroot}
-cd %{_builddir}/%{name}-%{version}/src/=build
-%{__make} install
-## move some docs to a place the rpm doc macro likes
-cd %{_builddir}/%{name}-%{version}
-cp src/tla/=THANKS =THANKS
-cp --recursive src/docs-tla/html html
-cp --recursive src/docs-tla/ps ps
-cp --recursive src/docs-tla/texi texi
 
-# CLEANUP UNKNOWN USAGE DIRS
-rm -rf %{buildroot}%{_libdir}
-rm -rf %{buildroot}%{_prefix}/src
+%{__make} -j1 -C src/=build install
 
+rm -rf html
+cp -a src/docs-tla html
+find html -type f ! -name "*.html" -exec rm -rf "{}" ";"
+find html -type d -name ".arch-ids" -exec rm -rf "{}" ";" || :
+find html -type d -name "{arch}" -exec rm -rf "{}" ";" || :
+
+rm -rf $RPM_BUILD_ROOT%{_libdir}
+rm -rf $RPM_BUILD_ROOT%{_prefix}/src
 
 %clean
-rm -rf %{buildroot}
+rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc COPYING =INSTALL =RELEASE-ID html ps texi
+%doc html
 %attr(755,root,root) %{_bindir}/*
-#{_includedir}
-#{_libdir}
-#{_libexecdir}
This page took 0.181523 seconds and 4 git commands to generate.