]> git.pld-linux.org Git - packages/tla.git/blobdiff - tla.spec
- 1.3 pre2
[packages/tla.git] / tla.spec
index 36d976ce5994f0ee480d7a5c02e81ed2200f5ad7..0938c9972354c77862437667ab3ea71cf34bc619 100644 (file)
--- a/tla.spec
+++ b/tla.spec
@@ -1,65 +1,82 @@
-Name:          tla
 Summary:       tla arch - revision control system
-Summary(pl):   tla arch - systeme kontroli wersji
-Version:       1.1pre5
-Release:       1
+Summary(pl):   tla arch - system kontroli wersji
+Name:          tla
+Version:       1.3
+%define        pre     pre2
+Release:       0.%{pre}.1
+Epoch:         1
 License:       GPL v2
 Group:         Development/Version Control
-URL:           http://regexps.srparish.net/www/
-Source0:       http://regexps.srparish.net/src/%{name}/%{name}-%{version}.tar.gz
-# Source0-md5: 16512739150bdb81764a9d2fffb6a423
+Source0:       http://www.seyza.com/releases/%{name}-%{version}%{pre}.tar.gz
+# Source0-md5: 1ea98d553f376b36da43f782cd08fd51
+# http://people.debian.org/~asuffield/daily/tla/lord/
+Patch0:                %{name}-neon.patch
+URL:           http://www.gnu.org/software/gnu-arch/
+Requires:      diffutils
+Requires:      patch
+Requires:      tar
+BuildRequires: neon-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-tla arch is a revision control system: a program that lets
-programmers archive a history of changes made to the software they
-maintain and that, more importantly, helps programmers to coordinate,
-synchronize, and combine multiple lines of development for a single
-project.
+tla arch is a revision control system: a program that lets programmers
+archive a history of changes made to the software they maintain and
+that, more importantly, helps programmers to coordinate, synchronize,
+and combine multiple lines of development for a single project.
 
 arch version tla is a C version of the reference arch concepts.
 
-%prep
-%setup -q
+%description -l pl
+tla arch jest systemem kontroli wersji - programem, który pozwala
+programistom archiwizowaæ historiê zmian wykonanych w rozwijanym przez
+nich oprogramowaniu oraz, co wa¿niejsze, pomaga programistom
+koordynowaæ, synchronizowaæ i ³±czyæ wiele linii kodu podczas rozwoju
+projektu.
 
-## using: rpmbuild -ba --target=i686-redhat-linux tls-1.0.6.spec
+arch w wersji tla to wersja w C wzorcowych idei arch.
+
+%prep
+%setup -q -n %{name}-%{version}%{pre}
+%patch0 -p1
 
 %build
-cd %{_builddir}/%{name}-%{version}/src
+rm -rf src/tla/libneon
+ln -s /usr/include/neon src/tla/libneon
+cd src
 mkdir =build
 cd =build
-## imitate what an rpm macro would export
-export CFLAGS="${RPM_OPT_FLAGS}" CXXFLAGS="${RPM_OPT_FLAGS}" FFLAGS="${RPM_OPT_FLAGS}";
-../configure --prefix=%{_prefix} --destdir=%{buildroot}
-%{__make}
-# ok, I tested already
-%{__make} test
 
+CFLAGS="%{rpmcflags}"
+CXXFLAGS="%{rpmcflags}"
+FFLAGS="%{rpmcflags}"
+export CFLAGS CXXFLAGS FFLAGS
+
+# custom configure script
+../configure \
+       --prefix=%{_prefix} \
+       --destdir=$RPM_BUILD_ROOT \
+       --with-ssh-is-openssh=1 \
+       --with-cc="%{__cc}"
+%{__make} -j1
+
+# ok, I tested already
+%{__make} -j1 test
 
 %install
 rm -rf $RPM_BUILD_ROOT
-rm -rf %{buildroot}
-cd %{_builddir}/%{name}-%{version}/src/=build
-%{__make} install
-## move some docs to a place the rpm doc macro likes
-cd %{_builddir}/%{name}-%{version}
-cp src/tla/=THANKS =THANKS
-cp --recursive src/docs-tla/html html
-cp --recursive src/docs-tla/ps ps
-cp --recursive src/docs-tla/texi texi
 
-# CLEANUP UNKNOWN USAGE DIRS
-rm -rf %{buildroot}%{_libdir}
-rm -rf %{buildroot}%{_prefix}/src
+%{__make} -j1 -C src/=build install
 
+cp --recursive src/docs-tla/html html
+
+rm -rf html/.arch-ids
+rm -rf $RPM_BUILD_ROOT%{_libdir}
+rm -rf $RPM_BUILD_ROOT%{_prefix}/src
 
 %clean
-rm -rf %{buildroot}
+rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc COPYING =INSTALL =RELEASE-ID html ps texi
-%attr(755,root,root) %{_bindir}
-#{_includedir}
-#{_libdir}
-#{_libexecdir}
+%doc html
+%attr(755,root,root) %{_bindir}/*
This page took 0.050208 seconds and 4 git commands to generate.