]> git.pld-linux.org Git - packages/thrift.git/blobdiff - thrift.spec
Fixed typo in nodejs and lua bconds.
[packages/thrift.git] / thrift.spec
index 2cd30873b51c6de812b4a7c247fc6b5c7ecb565a..9eb7ba0022b29d603d20f6122f6d2d3fc1e61c8a 100644 (file)
 #
 # language options
 %bcond_without cpp             # build the C++ library
-%bcond_without qt4             # build the Qt library
+%bcond_with    qt4             # build the Qt4 library
+%bcond_with    qt5             # build the Qt5 library
 %bcond_without c_glib          # build the C (GLib) library
-%bcond_without csharp          # build the C# library
+%bcond_with    csharp          # build the C# library
 %bcond_with    java            # build the Java library
 %bcond_with    erlang          # build the Erlang library
 %bcond_with    nodejs          # build nodejs library
 %bcond_with    lua             # build Lua library
 %bcond_without python          # build the Python library
-%bcond_without perl            # build the Perl library
-%bcond_without php             # build the PHP library
+%bcond_with    perl            # build the Perl library
+%bcond_with    php             # build the PHP library
 %bcond_with    php_extension   # build the PHP_EXTENSION library
 %bcond_with    ruby            # build the Ruby library
 %bcond_with    haskell         # build the Haskell library
-%bcond_without go              # build the Go library
+%bcond_with    go              # build the Go library
 %bcond_with    d               # build the D library
 
+%if %{with perl}
+%define                pdir    Thrift
+%endif
+
 %if 0%{!?php_name:1}
 %define                php_name        php55
 %endif
 Summary:       Framework for scalable cross-language services development
 Summary(pl.UTF-8):     Szkielet budowania skalowalnych usług dla różnych języków programowania
 Name:          thrift
-Version:       0.9.2
-Release:       0.4
+Version:       0.9.3
+Release:       2.2
 License:       Apache v2.0
 Group:         Development/Libraries
 Source0:       http://www.apache.org/dist/thrift/%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 89f63cc4d0100912f4a1f8a9dee63678
+# Source0-md5: 88d667a8ae870d5adeca8cb7d6795442
 Patch0:                %{name}-Werror_strlcpy_fix.patch
 Patch1:                %{name}-cpp_link_fix.patch
 URL:           http://thrift.apache.org/
@@ -227,12 +232,14 @@ Interfejs thrift dla Perla.
        PERL_PREFIX=%{perl_vendorlib} \
        %{__with_without cpp} \
        %{__with_without qt4} \
+       %{__with_without qt5} \
        %{__with_without c_glib} \
        %{__with_without csharp} \
        %{__with_without java} \
        %{__with_without erlang} \
+       %{__with_without nodejs} \
        %{__with_without python} \
-       %{__with_without bcond_without} \
+       %{__with_without lua} \
        %{__with_without perl} \
        %{__with_without php} \
        %{__with_without php_extension} \
@@ -284,6 +291,9 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with qt4}
 %{_libdir}/libthriftqt-%{version}.so
 %endif
+%if %{with qt5}
+%{_libdir}/libthriftqt5-%{version}.so
+%endif
 %if %{with c_glib}
 %{_libdir}/libthrift_c_glib.so.*
 %endif
@@ -305,6 +315,11 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/libthriftqt.la
 %{_pkgconfigdir}/thrift-qt.pc
 %endif
+%if %{with qt5}
+%{_libdir}/libthriftqt5.so
+%{_libdir}/libthriftqt5.la
+%{_pkgconfigdir}/thrift-qt5.pc
+%endif
 %if %{with c_glib}
 %{_libdir}/libthrift_c_glib.so
 %{_libdir}/libthrift_c_glib.la
@@ -319,6 +334,9 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with qt4}
 %{_libdir}/libthriftqt.a
 %endif
+%if %{with qt5}
+%{_libdir}/libthriftqt5.a
+%endif
 %if %{with c_glib}
 %{_libdir}/libthrift_c_glib.a
 %endif
This page took 0.093349 seconds and 4 git commands to generate.