]> git.pld-linux.org Git - packages/tesseract.git/blobdiff - tesseract.spec
- rebuild with icu 58.2
[packages/tesseract.git] / tesseract.spec
index 8f6165c090918adbbd233506b5f3ea677e1d7db1..bb83ff3da95909ec51b4f4ac48b40892ae79d49c 100644 (file)
@@ -1,22 +1,32 @@
 # TODO:
 # - warnings at compile stage about pointer size on amd64 - needs check
+#
+# Conditional build:
+%bcond_without openmp  # OpenMP support
+%bcond_with    opencl  # OpenCL support
+#
 Summary:       Tesseract Open Source OCR Engine
 Summary(pl.UTF-8):     Tesseract - silnik OCR o otwartych źródłach
 Name:          tesseract
-Version:       3.01
-Release:       1
+Version:       3.04.01
+Release:       3
 License:       Apache v2.0
 Group:         Applications/Graphics
-#Source0Download: http://code.google.com/p/tesseract-ocr/downloads/list
-Source0:       http://tesseract-ocr.googlecode.com/files/%{name}-%{version}.tar.gz
-# Source0-md5: 1ba496e51a42358fb9d3ffe781b2d20a
-URL:           http://code.google.com/p/tesseract-ocr/
+Source0:       https://github.com/tesseract-ocr/tesseract/archive/%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: 645a21effcf2825a3473849d72a7fd90
+Patch0:                %{name}-opencl.patch
+URL:           https://github.com/tesseract-ocr/
+%{?with_opencl:BuildRequires:  OpenCL-devel}
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
-BuildRequires: leptonlib-devel
-BuildRequires: libstdc++-devel
+BuildRequires: cairo-devel
+BuildRequires: leptonlib-devel >= 1.71
+%{?with_openmp:BuildRequires:  libgomp-devel}
+BuildRequires: libicu-devel
+BuildRequires: libstdc++-devel >= 6:4.7
 BuildRequires: libtiff-devel
-BuildRequires: libtool
+BuildRequires: libtool >= 2:2
+BuildRequires: pango-devel
 Suggests:      tesseract-data >= 3
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -30,6 +40,18 @@ Silnik OCR o komercyjnej jakości oryginalnie stworzony przez HP w
 latach 1985-1995. W 1995 roku był jednym z 3 najlepszych wg UNLV.
 Źródła zostały uwolnione przez HP i UNLV w 2005 roku.
 
+%package training
+Summary:       Tesseract training tools
+Summary(pl.UTF-8):     Narzędzia treningowe Tesseracta
+Group:          Applications/Graphics
+Requires:      %{name} = %{version}
+
+%description training
+This package contains the Tesseract training tools.
+
+%description training -l pl.UTF-8
+Ten pakiet zawiera programy do trenowania Tesseracta.
+
 %package devel
 Summary:       Header files for Tesseract libraries
 Summary(pl.UTF-8):     Pliki nagłówkowe bibliotek Tesseracta
@@ -37,7 +59,6 @@ Group:          Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 Requires:      leptonlib-devel
 Requires:      libstdc++-devel
-Requires:      libtiff-devel
 
 %description devel
 This package contains the development header files necessary to
@@ -61,6 +82,7 @@ Statyczne biblioteki Tesseracta.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 %{__libtoolize}
@@ -68,8 +90,11 @@ Statyczne biblioteki Tesseracta.
 %{__autoconf}
 %{__autoheader}
 %{__automake}
-%configure
+%configure \
+       %{?with_opencl:--enable-opencl} \
+       %{!?with_openmp:--disable-openmp}
 %{__make}
+%{__make} training
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -77,37 +102,53 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+%{__make} training-install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libtesseract.la
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post   -p /sbin/ldconfig
+%postun -p /sbin/ldconfig
+
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS COPYING ChangeLog README ReleaseNotes
+%doc AUTHORS COPYING ChangeLog README.md ReleaseNotes
+%attr(755,root,root) %{_bindir}/tesseract
+%attr(755,root,root) %{_libdir}/libtesseract.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libtesseract.so.3
+%{_datadir}/tessdata
+%{_mandir}/man1/tesseract.1*
+
+%files training
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/ambiguous_words
+%attr(755,root,root) %{_bindir}/classifier_tester
 %attr(755,root,root) %{_bindir}/cntraining
 %attr(755,root,root) %{_bindir}/combine_tessdata
+%attr(755,root,root) %{_bindir}/dawg2wordlist
 %attr(755,root,root) %{_bindir}/mftraining
-%attr(755,root,root) %{_bindir}/tesseract
+%attr(755,root,root) %{_bindir}/set_unicharset_properties
+%attr(755,root,root) %{_bindir}/shapeclustering
+%attr(755,root,root) %{_bindir}/text2image
 %attr(755,root,root) %{_bindir}/unicharset_extractor
 %attr(755,root,root) %{_bindir}/wordlist2dawg
-%attr(755,root,root) %{_libdir}/libtesseract.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libtesseract.so.3
-%dir %{_datadir}/tessdata
-%dir %{_datadir}/tessdata/configs
-%{_datadir}/tessdata/configs/*
-%dir %{_datadir}/tessdata/tessconfigs
-%{_datadir}/tessdata/tessconfigs/*
+%{_mandir}/man1/ambiguous_words.1*
 %{_mandir}/man1/cntraining.1*
 %{_mandir}/man1/combine_tessdata.1*
+%{_mandir}/man1/dawg2wordlist.1*
 %{_mandir}/man1/mftraining.1*
-%{_mandir}/man1/tesseract.1*
+%{_mandir}/man1/shapeclustering.1*
 %{_mandir}/man1/unicharset_extractor.1*
 %{_mandir}/man1/wordlist2dawg.1*
 
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libtesseract.so
-%{_libdir}/libtesseract.la
 %{_includedir}/%{name}
+%{_pkgconfigdir}/tesseract.pc
 %{_mandir}/man5/unicharambigs.5*
 %{_mandir}/man5/unicharset.5*
 
This page took 0.044279 seconds and 4 git commands to generate.