]> git.pld-linux.org Git - packages/template-glib.git/blobdiff - template-glib.spec
- updated to 3.36.0
[packages/template-glib.git] / template-glib.spec
index 62f24b6e283f8bb3c8e7ed9642b8aa0162678a12..666acc6ca15661a34879a1c65976ba1e256da48d 100644 (file)
@@ -1,19 +1,30 @@
+#
+# Conditional build:
+%bcond_without apidocs         # API documentation
+%bcond_without static_libs     # static library
+
 Summary:       template-glib - generate text based on a template and user defined state
+Summary(pl.UTF-8):     template-glib - generowanie tekstu w oparciu o szablon i stan przekazany przez użytkownika
 Name:          template-glib
-Version:       3.28.0
+Version:       3.36.0
 Release:       1
 License:       LGPL v2.1+
 Group:         Libraries
-Source0:       http://ftp.gnome.org/pub/GNOME/sources/template-glib/3.28/%{name}-%{version}.tar.xz
-# Source0-md5: bae97336986704ba4f3b4921bd3cd5b3
+Source0:       https://download.gnome.org/sources/template-glib/3.36/%{name}-%{version}.tar.xz
+# Source0-md5: 809740d6b4834f0ffe9d42e0f4815a79
+URL:           https://gitlab.gnome.org/GNOME/template-glib
+BuildRequires: bison
 BuildRequires: docbook-dtd412-xml
 BuildRequires: gettext-tools >= 0.18
+BuildRequires: flex
 BuildRequires: glib2-devel >= 1:2.44.0
 BuildRequires: gobject-introspection-devel >= 0.9.5
-BuildRequires: gtk-doc >= 1.20
-BuildRequires: meson >= 0.40.1
+%{?with_apidocs:BuildRequires: gtk-doc >= 1.20}
+BuildRequires: meson >= 0.51.0
+BuildRequires: ninja >= 1.5
 BuildRequires: pkgconfig
-BuildRequires: rpmbuild(macros) >= 1.726
+BuildRequires: rpm-build >= 4.6
+BuildRequires: rpmbuild(macros) >= 1.736
 BuildRequires: vala
 Requires:      glib2 >= 1:2.44.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -25,8 +36,16 @@ runtime, so it is safe to use from any GObject-Introspectable
 language.
 
 Template-GLib allows you to access properties on GObjects as well as
-call simple methods via GObject-Introspection. See our examples for
-how to call methods.
+call simple methods via GObject-Introspection.
+
+%description -l pl.UTF-8
+Template-GLib to biblioteka pomagająca generować tekst w oparciu o
+szablon oraz stan przekazany przez użytkownika. Nie wykorzystuje
+bibliotek językowych, więc bezpiecznie można jej używać z dowolnego
+języka obsługującego GObject-Introspection.
+
+Template-GLib pozwala na dostęp do właściwości obiektów GObject, a
+także wywoływanie prostych metod poprzez GObject-Introspection.
 
 %package devel
 Summary:       Header files for the template-glib library
@@ -34,6 +53,7 @@ Summary(pl.UTF-8):    Pliki nagłówkowe biblioteki template-glib
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 Requires:      glib2-devel >= 1:2.44.0
+Requires:      gobject-introspection-devel >= 0.9.5
 
 %description devel
 Header files for the template-glib library.
@@ -41,14 +61,24 @@ Header files for the template-glib library.
 %description devel -l pl.UTF-8
 Pliki nagłówkowe biblioteki template-glib.
 
+%package static
+Summary:       Static template-glib library
+Summary(pl.UTF-8):     Biblioteka statyczna template-glib
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{version}-%{release}
+
+%description static
+Static template-glib library.
+
+%description static -l pl.UTF-8
+Biblioteka statyczna template-glib.
+
 %package apidocs
 Summary:       template-glib API documentation
 Summary(pl.UTF-8):     Dokumentacja API template-glib
 Group:         Documentation
 Requires:      gtk-doc-common
-%if "%{_rpmversion}" >= "5"
 BuildArch:     noarch
-%endif
 
 %description apidocs
 Template-glib API documentation.
@@ -62,9 +92,7 @@ Summary(pl.UTF-8):    API template-glib dla języka Vala
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{version}-%{release}
 Requires:      vala >= 2:0.18.0
-%if "%{_rpmversion}" >= "5"
 BuildArch:     noarch
-%endif
 
 %description -n vala-template-glib
 Template-glib API for Vala language.
@@ -77,15 +105,15 @@ API template-glib dla języka Vala.
 
 %build
 %meson build \
-       -Dintrospection=true \
-       -Denable_gtk_doc=true
+       %{!?with_static_libs:--default-library=shared} \
+       %{?with_apidocs:-Dgtk_doc=true}
 
-%meson_build -C build
+%ninja_build -C build
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%meson_install -C build
+%ninja_install -C build
 
 %find_lang %{name} --with-gnome
 
@@ -97,7 +125,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc NEWS README.md
+%doc AUTHORS NEWS README.md
 %attr(755,root,root) %{_libdir}/libtemplate_glib-1.0.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libtemplate_glib-1.0.so.0
 %{_libdir}/girepository-1.0/Template-1.0.typelib
@@ -109,9 +137,17 @@ rm -rf $RPM_BUILD_ROOT
 %{_includedir}/template-glib-1.0
 %{_pkgconfigdir}/template-glib-1.0.pc
 
+%if %{with static_libs}
+%files static
+%defattr(644,root,root,755)
+%{_libdir}/libtemplate_glib-1.0.a
+%endif
+
+%if %{with apidocs}
 %files apidocs
 %defattr(644,root,root,755)
 %{_gtkdocdir}/template-glib
+%endif
 
 %files -n vala-template-glib
 %defattr(644,root,root,755)
This page took 0.078392 seconds and 4 git commands to generate.