]> git.pld-linux.org Git - packages/talloc.git/blobdiff - talloc.spec
- versioned Obsoletes
[packages/talloc.git] / talloc.spec
index 7822f29cafc66bb31cdfe5384fb63a96ec7d65bb..56231c47e3b60e678484cae341dc5d1989e59635 100644 (file)
@@ -1,21 +1,27 @@
 Summary:       The talloc library - a hierarchical pool based memory system
 Summary(pl.UTF-8):     Biblioteka talloc - system przydzielania pamięci oparty na hierarchicznej puli
-Name:          libtalloc
-Version:       2.0.6
+Name:          talloc
+Version:       2.3.2
 Release:       1
 Epoch:         2
 License:       LGPL v3+
 Group:         Libraries
-Source0:       http://samba.org/ftp/talloc/talloc-%{version}.tar.gz
-# Source0-md5: bd1be34297e89b27a394b49d5182550e
-URL:           http://talloc.samba.org/
+Source0:       https://download.samba.org/pub/talloc/%{name}-%{version}.tar.gz
+# Source0-md5: 3376a86bdf9dd4abc6b8d8d645390902
+URL:           https://talloc.samba.org/
 BuildRequires: docbook-dtd42-xml
 BuildRequires: docbook-style-xsl
+BuildRequires: libbsd-devel
 BuildRequires: libxslt-progs
-BuildRequires: python >= 1:2.4.2
-BuildRequires: python-devel >= 1:2.4.2
-BuildRequires: python-modules
+BuildRequires: python3 >= 1:3.2
+BuildRequires: python3-devel >= 1:3.2
+BuildRequires: python3-modules >= 1:3.2
 BuildRequires: rpm-pythonprov
+Provides:      libtalloc = 2:%{version}-%{release}
+Obsoletes:     libtalloc < 2:2.0.7-2
+# talloc 2.2+ dropped python2 support
+Obsoletes:     python-talloc < 2:2.2
+Obsoletes:     python-talloc-devel < 2:2.2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -31,7 +37,9 @@ Summary:      Development files for the talloc library
 Summary(pl.UTF-8):     Pliki programistyczne biblioteki talloc
 Group:         Development/Libraries
 Requires:      %{name} = %{epoch}:%{version}-%{release}
-Obsoletes:     libtalloc-static
+Provides:      libtalloc-devel = 2:%{version}-%{release}
+Obsoletes:     libtalloc-devel < 2:2.0.7-2
+Obsoletes:     libtalloc-static < 2:2.0.5
 
 %description devel
 Development files needed to create programs that link against the
@@ -41,44 +49,46 @@ talloc library.
 Pliki programistyczne potrzebne do tworzenia programów używających
 biblioteki talloc.
 
-%package -n python-talloc
-Summary:       Python binding for talloc library
-Summary(pl.UTF-8):     Wiązanie Pythona do biblioteki talloc
+%package -n python3-talloc
+Summary:       Python binding for talloc library
+Summary(pl.UTF-8):     Wiązanie Pythona do biblioteki talloc
 Group:         Libraries/Python
 Requires:      %{name} = %{epoch}:%{version}-%{release}
-Requires:      python-libs >= 1:2.4.2
+Requires:      python3-libs >= 1:3.2
 
-%description -n python-talloc
-Python binding for talloc library.
+%description -n python3-talloc
+Python binding for talloc library.
 
-%description -n python-talloc -l pl.UTF-8
-Wiązanie Pythona do biblioteki talloc.
+%description -n python3-talloc -l pl.UTF-8
+Wiązanie Pythona do biblioteki talloc.
 
-%package -n python-talloc-devel
-Summary:       Development files for pytalloc-util library
-Summary(pl.UTF-8):     Pliki programistyczne biblioteki pytalloc-util
+%package -n python3-talloc-devel
+Summary:       Development files for Python 3 pytalloc-util library
+Summary(pl.UTF-8):     Pliki programistyczne biblioteki pytalloc-util dla Pythona 3
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{epoch}:%{version}-%{release}
-Requires:      python-devel >= 1:2.4.2
-Requires:      python-talloc = %{epoch}:%{version}-%{release}
+Requires:      python3-devel >= 1:3.2
+Requires:      python3-talloc = %{epoch}:%{version}-%{release}
 
-%description -n python-talloc-devel
-Development files for pytalloc-util library.
+%description -n python3-talloc-devel
+Development files for Python 3 pytalloc-util library.
 
-%description -n python-talloc-devel -l pl.UTF-8
-Pliki programistyczne biblioteki pytalloc-util.
+%description -n python3-talloc-devel -l pl.UTF-8
+Pliki programistyczne biblioteki pytalloc-util dla Pythona 3.
 
 %prep
-%setup -q -n talloc-%{version}
+%setup -q
 
 %build
-# note: configure in fact is waf call
+# threading breaks waf
+export JOBS=1
+
 CC="%{__cc}" \
 CFLAGS="%{rpmcflags}" \
-PYTHONDIR=%{py_sitedir} \
-./configure \
+%{__python3} buildtools/bin/waf configure \
        --prefix=%{_prefix} \
-       --libdir=%{_libdir}
+       --libdir=%{_libdir} \
+       --disable-rpath
 
 %{__make} \
        V=1
@@ -95,10 +105,13 @@ rm -rf $RPM_BUILD_ROOT
 %post  -p /sbin/ldconfig
 %postun        -p /sbin/ldconfig
 
-%triggerpostun -p /sbin/postshell -- %{name} < 2:2.0.1-5
+%triggerpostun -p /sbin/postshell -- libtalloc < 2:2.0.1-5
 -rm -f %{_libdir}/libtalloc.so.2
 /sbin/ldconfig
 
+%post  -n python3-talloc -p /sbin/ldconfig
+%postun        -n python3-talloc -p /sbin/ldconfig
+
 %files
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libtalloc.so.*.*.*
@@ -112,14 +125,14 @@ rm -rf $RPM_BUILD_ROOT
 %{_pkgconfigdir}/talloc.pc
 %{_mandir}/man3/talloc.3*
 
-%files -n python-talloc
+%files -n python3-talloc
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libpytalloc-util.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libpytalloc-util.so.2
-%attr(755,root,root) %{py_sitedir}/talloc.so
+%attr(755,root,root) %{_libdir}/libpytalloc-util.cpython-3*.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libpytalloc-util.cpython-3*.so.2
+%attr(755,root,root) %{py3_sitedir}/talloc.cpython-3*.so
 
-%files -n python-talloc-devel
+%files -n python3-talloc-devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libpytalloc-util.so
+%attr(755,root,root) %{_libdir}/libpytalloc-util.cpython-3*.so
 %{_includedir}/pytalloc.h
-%{_pkgconfigdir}/pytalloc-util.pc
+%{_pkgconfigdir}/pytalloc-util.cpython-3*.pc
This page took 0.076068 seconds and 4 git commands to generate.