]> git.pld-linux.org Git - packages/systemd.git/blobdiff - systemd.spec
- /lib/systemd and /usr/lib/tmpfiles.d moved to filesystem
[packages/systemd.git] / systemd.spec
index fc3bed0bc307bba3cc0f54c4ca936c3f0a06a92d..f1b876a204402c8f2200478cf28b48ce762b239d 100644 (file)
@@ -24,11 +24,12 @@ Summary:    A System and Service Manager
 Summary(pl.UTF-8):     systemd - zarządca systemu i usług dla Linuksa
 Name:          systemd
 Version:       37
-Release:       0.6
+Release:       0.7
 License:       GPL v2+
 Group:         Base
 Source0:       http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.bz2
 # Source0-md5: 1435f23be79c8c38d1121c6b150510f3
+Source1:       systemd-sysv-convert
 Patch0:                target-pld.patch
 URL:           http://www.freedesktop.org/wiki/Software/systemd
 %{?with_audit:BuildRequires:   audit-libs-devel}
@@ -61,7 +62,7 @@ Requires:     agetty
 Requires:      dbus >= 1.3.2
 Requires:      dbus-systemd
 # python modules required by systemd-analyze
-Requires:      filesystem >= 3.0-43
+Requires:      filesystem >= 4.0
 Requires:      python-dbus
 Requires:      python-modules
 Requires:      rc-scripts
@@ -180,7 +181,7 @@ rm -rf $RPM_BUILD_ROOT
 
 for lib in libsystemd-daemon libsystemd-login; do
        %{__mv} $RPM_BUILD_ROOT{%{_libdir}/$lib.so.*,/%{_lib}}
-       ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/$lib.so.*) $RPM_BUILD_ROOT%{_libdir}/$lib.so
+       ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/$lib.so.*.*.*) $RPM_BUILD_ROOT%{_libdir}/$lib.so
 done
 
 # Create SysV compatibility symlinks. systemctl/systemd are smart
@@ -201,9 +202,10 @@ ln -s ../modules $RPM_BUILD_ROOT%{_sysconfdir}/modules-load.d/modules.conf
 # them.
 %{__rm} -r $RPM_BUILD_ROOT%{_sysconfdir}/systemd/system/*.target.wants
 
-# do not cover /media (system-specific removable mountpoints)
+# do not cover /media (system-specific removable mountpoints) for now
+# needs %post code to convert existing /media structure to tmpfiles
 %{__rm} -f $RPM_BUILD_ROOT/lib/systemd/local-fs.target.wants/media.mount
-# do not cover /var/run (packages need rpm-provided subdirectories)
+# do not cover /var/run until packages need rpm-provided-only subdirectories
 %{__rm} -f $RPM_BUILD_ROOT/lib/systemd/local-fs.target.wants/var-run.mount
 
 # Make sure these directories are properly owned
@@ -212,6 +214,13 @@ install -d $RPM_BUILD_ROOT/lib/systemd/system/{basic,dbus,default,halt,kexec,pow
 # Create new-style configuration files so that we can ghost-own them
 touch $RPM_BUILD_ROOT%{_sysconfdir}/{hostname,locale.conf,machine-id,machine-info,os-release,timezone,vconsole.conf}
 
+# Install SysV conversion tool for systemd
+install -m 0755 %{SOURCE1} $RPM_BUILD_ROOT/%{_bindir}/
+
+install -d $RPM_BUILD_ROOT/var/log
+> $RPM_BUILD_ROOT/var/log/btmp
+> $RPM_BUILD_ROOT/var/log/wtmp
+
 %if %{without gtk}
 # to shut up check-files
 rm -f $RPM_BUILD_ROOT%{_bindir}/systemadm
@@ -296,6 +305,7 @@ fi
 %attr(755,root,root) %{_bindir}/systemd-analyze
 %attr(755,root,root) %{_bindir}/systemd-cgls
 %attr(755,root,root) %{_bindir}/systemd-nspawn
+%attr(755,root,root) %{_bindir}/systemd-sysv-convert
 %attr(755,root,root) %{_bindir}/systemd-stdio-bridge
 %attr(755,root,root) /sbin/halt
 %attr(755,root,root) /sbin/init
@@ -314,7 +324,7 @@ fi
 /lib/udev/rules.d/73-seat-late.rules
 %dir %{_libexecdir}/systemd
 %{_libexecdir}/systemd/user
-%config(noreplace,missingok) %verify(not md5 mtime size) %{_libexecdir}/tmpfiles.d/*.conf
+%config(noreplace,missingok) %{_libexecdir}/tmpfiles.d/*.conf
 %{_datadir}/dbus-1/interfaces/org.freedesktop.hostname1.xml
 %{_datadir}/dbus-1/interfaces/org.freedesktop.locale1.xml
 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.*.xml
@@ -356,19 +366,7 @@ fi
 %{_mandir}/man5/modules-load.d.5*
 %{_mandir}/man5/os-release.5*
 %{_mandir}/man5/sysctl.d.5*
-%{_mandir}/man5/systemd.automount.5*
-%{_mandir}/man5/systemd.conf.5*
-%{_mandir}/man5/systemd.device.5*
-%{_mandir}/man5/systemd.exec.5*
-%{_mandir}/man5/systemd.mount.5*
-%{_mandir}/man5/systemd.path.5*
-%{_mandir}/man5/systemd.service.5*
-%{_mandir}/man5/systemd.snapshot.5*
-%{_mandir}/man5/systemd.socket.5*
-%{_mandir}/man5/systemd.swap.5*
-%{_mandir}/man5/systemd.target.5*
-%{_mandir}/man5/systemd.timer.5*
-%{_mandir}/man5/systemd.unit.5*
+%{_mandir}/man5/systemd.*.5*
 %{_mandir}/man5/systemd-logind.conf.5*
 %{_mandir}/man5/timezone.5*
 %{_mandir}/man5/vconsole.conf.5*
@@ -382,6 +380,8 @@ fi
 %{_mandir}/man8/runlevel.8*
 %{_mandir}/man8/shutdown.8*
 %{_mandir}/man8/telinit.8*
+%attr(640,root,root) %ghost /var/log/btmp
+%attr(664,root,utmp) %ghost /var/log/wtmp
 
 %if %{with pam}
 %attr(755,root,root) /%{_lib}/security/pam_systemd.so
@@ -404,16 +404,13 @@ fi
 %dir %{_sysconfdir}/systemd
 %dir %{_sysconfdir}/systemd/system
 %dir %{_sysconfdir}/tmpfiles.d
-%dir /lib/systemd
-%config(noreplace,missingok) %verify(not md5 mtime size) /lib/systemd/system
 %dir %{_libexecdir}/binfmt.d
 %dir %{_libexecdir}/modules-load.d
 %dir %{_libexecdir}/sysctl.d
-%dir %{_libexecdir}/tmpfiles.d
 %attr(755,root,root) /bin/systemctl
 %attr(755,root,root) /bin/systemd-tmpfiles
-%{_mandir}/man5/tmpfiles.d.5*
 %{_mandir}/man1/systemctl.1*
+%{_mandir}/man5/tmpfiles.d.5*
 %{_mandir}/man8/systemd-tmpfiles.8*
 %{_npkgconfigdir}/systemd.pc
 
@@ -432,7 +429,7 @@ fi
 %files devel
 %defattr(644,root,root,755)
 %{_includedir}/systemd
-%{_libdir}/libsystemd-daemon.so
-%{_libdir}/libsystemd-login.so
+%attr(755,root,root) %{_libdir}/libsystemd-daemon.so
+%attr(755,root,root) %{_libdir}/libsystemd-login.so
 %{_pkgconfigdir}/libsystemd-daemon.pc
 %{_pkgconfigdir}/libsystemd-login.pc
This page took 0.833198 seconds and 4 git commands to generate.