]> git.pld-linux.org Git - packages/systemd.git/blobdiff - systemd.spec
- if there are no submounts, try get over with it without tmpdir
[packages/systemd.git] / systemd.spec
index 8c5733f939ab251cc7263f3ea7058738eabaa855..8525e06e75f8f0a19de58e10b6695094a9e44122 100644 (file)
@@ -7,9 +7,8 @@
 # Conditional build:
 %bcond_without audit           # without audit support
 %bcond_without cryptsetup      # without cryptsetup support
-%bcond_without gtk             # build gtk tools
 %bcond_without pam             # PAM authentication support
-%bcond_with    plymouth        # plymouth support
+%bcond_without plymouth        # do not install plymouth units
 %bcond_without selinux         # without SELinux support
 %bcond_without tcpd            # libwrap (tcp_wrappers) support
 
@@ -17,7 +16,7 @@ Summary:      A System and Service Manager
 Summary(pl.UTF-8):     systemd - zarządca systemu i usług dla Linuksa
 Name:          systemd
 Version:       44
-Release:       1
+Release:       8
 License:       GPL v2+
 Group:         Base
 Source0:       http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.xz
@@ -31,12 +30,15 @@ Source10:   pld-storage-init-late.service
 Source11:      pld-storage-init.service
 Source12:      pld-wait-storage.service
 Source13:      pld-storage-init.sh
+Source14:      pld-clean-tmp.service
+Source15:      pld-clean-tmp.sh
 Patch0:                target-pld.patch
 Patch1:                config-pld.patch
 Patch2:                shut-sysv-up.patch
 Patch3:                pld-sysv-network.patch
 Patch4:                tmpfiles-not-fatal.patch
 Patch5:                CVE-2012-1174.patch
+Patch6:                dont-trash-X-sessions.patch
 URL:           http://www.freedesktop.org/wiki/Software/systemd
 BuildRequires: acl-devel
 %{?with_audit:BuildRequires:   audit-libs-devel}
@@ -59,15 +61,7 @@ BuildRequires:       m4
 BuildRequires: pkgconfig >= 0.9.0
 BuildRequires: rpmbuild(macros) >= 1.627
 BuildRequires: udev-devel >= 1:172
-# not required for building from release (which contains *.c for *.vala)
-#BuildRequires:        vala >= 0.10.0
 BuildRequires: xz-devel
-%if %{with gtk}
-BuildRequires: glib2-devel >= 1:2.26.1
-BuildRequires: gtk+2-devel >= 2:2.24.0
-BuildRequires: libgee-devel
-BuildRequires: libnotify-devel >= 0.7.0
-%endif
 Requires:      %{name}-libs = %{version}-%{release}
 Requires:      %{name}-units = %{version}-%{release}
 Requires:      /etc/os-release
@@ -75,19 +69,17 @@ Requires:   SysVinit-tools
 Requires:      agetty
 Requires:      dbus >= 1.4.16-6
 Requires:      filesystem >= 4.0-2
-Requires:      rc-scripts >= 0.4.5.1-7
+Requires:      libutempter
+Requires:      rc-scripts >= 0.4.5.3-7
 Requires:      setup >= 2.8.0-2
 Requires:      udev-core >= 1:175-5
 Requires:      udev-libs >= 1:172
 Requires:      virtual(module-tools)
+Suggests:      %{name}-no-compat-tmpfiles
 Suggests:      ConsoleKit
 Suggests:      fsck >= 2.20
 Suggests:      kmod >= 5
 Suggests:      nss_myhostname
-# python modules required by systemd-analyze
-Suggests:      %{name}-no-compat-tmpfiles
-Suggests:      python-dbus
-Suggests:      python-modules
 Suggests:      service(klogd)
 Suggests:      service(syslog)
 Provides:      udev-acl
@@ -168,6 +160,7 @@ Summary:    Plymouth support units for systemd
 Summary(pl.UTF-8):     Jednostki wspierające Plymouth dla systemd
 Group:         Base
 Requires:      %{name}-units = %{version}-%{release}
+Requires:      plymouth
 
 %description plymouth
 Plymouth (graphical boot) support units for systemd.
@@ -175,18 +168,19 @@ Plymouth (graphical boot) support units for systemd.
 %description plymouth -l pl.UTF-8
 Jednostki wspierające Plymouth (graficzny start systemu) dla systemd.
 
-%package gtk
-Summary:       Graphical frontend for systemd
-Summary(pl.UTF-8):     Graficzny interfejs do systemd
+%package analyze
+Summary:       Tool for processing systemd profiling information
 Group:         Base
 Requires:      %{name} = %{version}-%{release}
-Requires:      polkit
+Requires:      python-dbus
+Requires:      python-modules
+Requires:      python-pycairo
+Conflicts:     %{name} < 44-3
 
-%description gtk
-Graphical front-end for systemd.
-
-%description gtk -l pl.UTF-8
-Graficzny interfejs do systemd.
+%description analyze
+'systemd-analyze blame' lists which systemd unit needed how much time
+to finish initialization at boot. 'systemd-analyze plot' renders an
+SVG visualizing the parallel start of units at boot.
 
 %package libs
 Summary:       Shared systemd libraries
@@ -320,6 +314,7 @@ Force update of packages that provide tmpfiles.d configuration
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
+%patch6 -p1
 cp -p %{SOURCE2} src/systemd_booted.c
 
 %build
@@ -330,7 +325,7 @@ cp -p %{SOURCE2} src/systemd_booted.c
 %configure \
        %{__enable_disable audit} \
        %{__enable_disable cryptsetup libcryptsetup} \
-       %{__enable_disable gtk} \
+       --disable-gtk \
        %{__enable_disable pam} \
        %{__enable_disable plymouth} \
        %{__enable_disable selinux} \
@@ -347,11 +342,12 @@ cp -p %{SOURCE2} src/systemd_booted.c
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT/var/lib/%{name}/coredump
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-./libtool --mode=install install -m755 systemd_booted $RPM_BUILD_ROOT/bin/systemd_booted
+./libtool --mode=install install -p -m755 systemd_booted $RPM_BUILD_ROOT/bin/systemd_booted
 
 # Main binary has been moved, but we don't want to break existing installs
 ln -s ../lib/systemd/systemd $RPM_BUILD_ROOT/bin/systemd
@@ -378,20 +374,26 @@ ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/netfs.service
 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/random.service
 
 # add static (non-NetworkManager) networking
-install %{SOURCE3} $RPM_BUILD_ROOT%{systemdunitdir}/network.service
+cp -p %{SOURCE3} $RPM_BUILD_ROOT%{systemdunitdir}/network.service
 
 # install compatibility tmpfiles configs
-install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-media.conf
-install %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
+cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-media.conf
+cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
 
 # Install and enable storage subsystems support services (RAID, LVM, etc.)
-install %{SOURCE10} $RPM_BUILD_ROOT%{systemdunitdir}/pld-storage-init-late.service
-install %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}/pld-storage-init.service
-install %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/pld-wait-storage.service
-install %{SOURCE13} $RPM_BUILD_ROOT/lib/systemd/pld-storage-init
+cp -p %{SOURCE10} $RPM_BUILD_ROOT%{systemdunitdir}/pld-storage-init-late.service
+cp -p %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}/pld-storage-init.service
+cp -p %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/pld-wait-storage.service
+cp -p %{SOURCE14} $RPM_BUILD_ROOT%{systemdunitdir}/pld-clean-tmp.service
+install -p %{SOURCE13} $RPM_BUILD_ROOT/lib/systemd/pld-storage-init
+install -p %{SOURCE15} $RPM_BUILD_ROOT/lib/systemd/pld-clean-tmp
+
+ln -s ../pld-storage-init-late.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants
+ln -s ../pld-storage-init.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants
+ln -s ../pld-clean-tmp.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants
 
-ln -s ../pld-storage-init-late.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants/pld-storage-init-late.service
-ln -s ../pld-storage-init.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants/pld-storage-init.service
+# handled by rc-local sysv service, no need for generator
+%{__rm} $RPM_BUILD_ROOT/lib/systemd/system-generators/systemd-rc-local-generator
 
 # Make sure these directories are properly owned:
 #      - halt,kexec,poweroff,reboot: generic ones used by ConsoleKit-systemd,
@@ -409,9 +411,7 @@ install -d $RPM_BUILD_ROOT/var/log
 :> $RPM_BUILD_ROOT/var/log/btmp
 :> $RPM_BUILD_ROOT/var/log/wtmp
 
-%if %{without gtk}
 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/systemadm.1*
-%endif
 
 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
 %{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_systemd.la
@@ -489,6 +489,12 @@ rm -f %{_sysconfdir}/systemd/system/multi-user.target.wants/network-post.service
 %post no-compat-tmpfiles
 %{__sed} -i -e '/^#/!s/^/# /g' %{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
 
+%post plymouth
+%systemd_reload
+
+%postun plymouth
+%systemd_reload
+
 %files
 %defattr(644,root,root,755)
 %doc DISTRO_PORTING README TODO
@@ -516,7 +522,6 @@ rm -f %{_sysconfdir}/systemd/system/multi-user.target.wants/network-post.service
 %attr(755,root,root) /bin/systemd-machine-id-setup
 %attr(755,root,root) /bin/systemd-notify
 %attr(755,root,root) /bin/systemd-tty-ask-password-agent
-%attr(755,root,root) %{_bindir}/systemd-analyze
 %attr(755,root,root) %{_bindir}/systemd-cat
 %attr(755,root,root) %{_bindir}/systemd-cgtop
 %attr(755,root,root) %{_bindir}/systemd-cgls
@@ -574,6 +579,8 @@ rm -f %{_sysconfdir}/systemd/system/multi-user.target.wants/network-post.service
 %{_mandir}/man7/sd-login.7*
 %{_mandir}/man7/sd-readahead.7*
 %{_mandir}/man7/systemd.special.7*
+%dir /var/lib/%{name}
+%dir /var/lib/%{name}/coredump
 %attr(640,root,root) %ghost /var/log/btmp
 %attr(664,root,utmp) %ghost /var/log/wtmp
 
@@ -689,13 +696,9 @@ rm -f %{_sysconfdir}/systemd/system/multi-user.target.wants/network-post.service
 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/plymouth-start.service
 %endif
 
-%if %{with gtk}
-%files gtk
+%files analyze
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/systemadm
-%attr(755,root,root) %{_bindir}/systemd-gnome-ask-password-agent
-%{_mandir}/man1/systemadm.1*
-%endif
+%attr(755,root,root) %{_bindir}/systemd-analyze
 
 %files libs
 %defattr(644,root,root,755)
This page took 0.113892 seconds and 4 git commands to generate.