]> git.pld-linux.org Git - packages/systemd.git/blobdiff - systemd.spec
- added patch for ploop rules
[packages/systemd.git] / systemd.spec
index 1dfd1906d080a6ab77ef6cea878a760856be9b8c..7d96fe8ff90fcf4439a9c4db93a61aed8b7cdce1 100644 (file)
@@ -1,13 +1,16 @@
-#
 # TODO:
 #      - remove compat-pld-var-run.tmpfiles and maybe tmpfiles-not-fatal.patch
 #        after enough packages provide their own tmpfiles.d configs for
 #        /var/run directories
+# - pldize vconsole setup:
+#   - http://cgit.freedesktop.org/systemd/systemd/tree/src/vconsole/vconsole-setup.c
+# - for systemd-45+
+#   - restore var-{run,lock}: http://cgit.freedesktop.org/systemd/systemd/commit/?id=55d029addf7d97b15faacea597a4ff65542aaf0e
+#   - WARNING: http://cgit.freedesktop.org/systemd/systemd/commit/?id=623ac9d2fce3170125ead9be20f56bfe68ea125e
 #
 # Conditional build:
 %bcond_without audit           # without audit support
 %bcond_without cryptsetup      # without cryptsetup support
-%bcond_without gtk             # build gtk tools
 %bcond_without pam             # PAM authentication support
 %bcond_without plymouth        # do not install plymouth units
 %bcond_without selinux         # without SELinux support
@@ -17,7 +20,7 @@ Summary:      A System and Service Manager
 Summary(pl.UTF-8):     systemd - zarządca systemu i usług dla Linuksa
 Name:          systemd
 Version:       44
-Release:       3.4
+Release:       14
 License:       GPL v2+
 Group:         Base
 Source0:       http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.xz
@@ -25,19 +28,22 @@ Source0:    http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.xz
 Source1:       %{name}-sysv-convert
 Source2:       %{name}_booted.c
 Source3:       network.service
-Source4:       compat-pld-media.tmpfiles
 Source5:       compat-pld-var-run.tmpfiles
 Source10:      pld-storage-init-late.service
 Source11:      pld-storage-init.service
 Source12:      pld-wait-storage.service
 Source13:      pld-storage-init.sh
+Source14:      pld-clean-tmp.service
+Source15:      pld-clean-tmp.sh
 Patch0:                target-pld.patch
 Patch1:                config-pld.patch
 Patch2:                shut-sysv-up.patch
 Patch3:                pld-sysv-network.patch
 Patch4:                tmpfiles-not-fatal.patch
 Patch5:                CVE-2012-1174.patch
-Patch6:                rc.local.patch
+Patch6:                ReleaseSession.patch
+Patch7:                control-subcgroup.patch
+Patch8:                kmsg-to-syslog.patch
 URL:           http://www.freedesktop.org/wiki/Software/systemd
 BuildRequires: acl-devel
 %{?with_audit:BuildRequires:   audit-libs-devel}
@@ -60,15 +66,7 @@ BuildRequires:       m4
 BuildRequires: pkgconfig >= 0.9.0
 BuildRequires: rpmbuild(macros) >= 1.627
 BuildRequires: udev-devel >= 1:172
-# not required for building from release (which contains *.c for *.vala)
-#BuildRequires:        vala >= 0.10.0
 BuildRequires: xz-devel
-%if %{with gtk}
-BuildRequires: glib2-devel >= 1:2.26.1
-BuildRequires: gtk+2-devel >= 2:2.24.0
-BuildRequires: libgee-devel
-BuildRequires: libnotify-devel >= 0.7.0
-%endif
 Requires:      %{name}-libs = %{version}-%{release}
 Requires:      %{name}-units = %{version}-%{release}
 Requires:      /etc/os-release
@@ -77,7 +75,7 @@ Requires:     agetty
 Requires:      dbus >= 1.4.16-6
 Requires:      filesystem >= 4.0-2
 Requires:      libutempter
-Requires:      rc-scripts >= 0.4.5.3-6
+Requires:      rc-scripts >= 0.4.5.3-7
 Requires:      setup >= 2.8.0-2
 Requires:      udev-core >= 1:175-5
 Requires:      udev-libs >= 1:172
@@ -98,6 +96,9 @@ Conflicts:    pam < 1:1.1.5-5
 Conflicts:     sudo < 1:1.7.8p2-4
 # for prefdm script
 Conflicts:     xinitrc-ng < 1.0
+# systemd scripts use options not present in older versions
+Conflicts:     kpartx < 0.4.9-7
+Conflicts:     multipath-tools < 0.4.9-7
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _libexecdir     %{_prefix}/lib
@@ -175,19 +176,6 @@ Plymouth (graphical boot) support units for systemd.
 %description plymouth -l pl.UTF-8
 Jednostki wspierające Plymouth (graficzny start systemu) dla systemd.
 
-%package gtk
-Summary:       Graphical frontend for systemd
-Summary(pl.UTF-8):     Graficzny interfejs do systemd
-Group:         Base
-Requires:      %{name} = %{version}-%{release}
-Requires:      polkit
-
-%description gtk
-Graphical front-end for systemd.
-
-%description gtk -l pl.UTF-8
-Graficzny interfejs do systemd.
-
 %package analyze
 Summary:       Tool for processing systemd profiling information
 Group:         Base
@@ -229,7 +217,7 @@ Pliki nagłówkowe bibliotek systemd.
 Summary:       bash-completion for systemd
 Summary(pl.UTF-8):     Bashowe dopełnianie składni dla systemd
 Group:         Applications/Shells
-Requires:      %{name}
+Requires:      %{name} = %{version}
 Requires:      bash-completion
 
 %description -n bash-completion-systemd
@@ -241,6 +229,7 @@ Bashowe dopełnianie składni dla systemd
 %package no-compat-tmpfiles
 Summary:       Force update of packages that provide tmpfiles.d configuration
 Group:         Base
+Requires:      %{name} = %{version}-%{release}
 Requires(post):        sed > 4.0
 Conflicts:     ConsoleKit-dirs < 0.4.5-7
 Conflicts:     NetworkManager < 2:0.9.2.0-3
@@ -335,6 +324,8 @@ Force update of packages that provide tmpfiles.d configuration
 %patch4 -p1
 %patch5 -p1
 %patch6 -p1
+%patch7 -p1
+%patch8 -p1
 cp -p %{SOURCE2} src/systemd_booted.c
 
 %build
@@ -345,7 +336,7 @@ cp -p %{SOURCE2} src/systemd_booted.c
 %configure \
        %{__enable_disable audit} \
        %{__enable_disable cryptsetup libcryptsetup} \
-       %{__enable_disable gtk} \
+       --disable-gtk \
        %{__enable_disable pam} \
        %{__enable_disable plymouth} \
        %{__enable_disable selinux} \
@@ -397,21 +388,22 @@ ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/random.service
 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{systemdunitdir}/network.service
 
 # install compatibility tmpfiles configs
-cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-media.conf
 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
 
 # Install and enable storage subsystems support services (RAID, LVM, etc.)
 cp -p %{SOURCE10} $RPM_BUILD_ROOT%{systemdunitdir}/pld-storage-init-late.service
 cp -p %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}/pld-storage-init.service
 cp -p %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/pld-wait-storage.service
+cp -p %{SOURCE14} $RPM_BUILD_ROOT%{systemdunitdir}/pld-clean-tmp.service
 install -p %{SOURCE13} $RPM_BUILD_ROOT/lib/systemd/pld-storage-init
+install -p %{SOURCE15} $RPM_BUILD_ROOT/lib/systemd/pld-clean-tmp
 
-ln -s ../pld-storage-init-late.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants/pld-storage-init-late.service
-ln -s ../pld-storage-init.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants/pld-storage-init.service
+ln -s ../pld-storage-init-late.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants
+ln -s ../pld-storage-init.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants
+ln -s ../pld-clean-tmp.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants
 
 # handled by rc-local sysv service, no need for generator
 %{__rm} $RPM_BUILD_ROOT/lib/systemd/system-generators/systemd-rc-local-generator
-%{__rm} $RPM_BUILD_ROOT%{systemdunitdir}/multi-user.target.wants/rc-local.service
 
 # Make sure these directories are properly owned:
 #      - halt,kexec,poweroff,reboot: generic ones used by ConsoleKit-systemd,
@@ -429,9 +421,7 @@ install -d $RPM_BUILD_ROOT/var/log
 :> $RPM_BUILD_ROOT/var/log/btmp
 :> $RPM_BUILD_ROOT/var/log/wtmp
 
-%if %{without gtk}
 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/systemadm.1*
-%endif
 
 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
 %{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_systemd.la
@@ -509,6 +499,12 @@ rm -f %{_sysconfdir}/systemd/system/multi-user.target.wants/network-post.service
 %post no-compat-tmpfiles
 %{__sed} -i -e '/^#/!s/^/# /g' %{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
 
+%post plymouth
+%systemd_reload
+
+%postun plymouth
+%systemd_reload
+
 %files
 %defattr(644,root,root,755)
 %doc DISTRO_PORTING README TODO
@@ -542,6 +538,7 @@ rm -f %{_sysconfdir}/systemd/system/multi-user.target.wants/network-post.service
 %attr(755,root,root) %{_bindir}/systemd-nspawn
 %attr(755,root,root) %{_bindir}/systemd-stdio-bridge
 %attr(755,root,root) %{_bindir}/systemd-sysv-convert
+%attr(755,root,root) /lib/systemd/pld-clean-tmp
 %attr(755,root,root) /lib/systemd/pld-storage-init
 %attr(755,root,root) /lib/systemd/systemd-*
 %dir /lib/systemd/system-generators
@@ -633,7 +630,10 @@ rm -f %{_sysconfdir}/systemd/system/multi-user.target.wants/network-post.service
 %dir %{_libexecdir}/binfmt.d
 %dir %{_libexecdir}/modules-load.d
 %dir %{_libexecdir}/sysctl.d
-%{_libexecdir}/sysctl.d/coredump.conf
+# Don't package the kernel.core_pattern setting until systemd-coredump
+# is a part of an actual systemd release and it's made clear how to
+# get the core dumps out of the journal.
+#%{_libexecdir}/sysctl.d/coredump.conf
 %attr(755,root,root) /bin/systemctl
 %attr(755,root,root) /bin/systemd-tmpfiles
 %attr(755,root,root) /bin/systemd_booted
@@ -673,13 +673,14 @@ rm -f %{_sysconfdir}/systemd/system/multi-user.target.wants/network-post.service
 %config(noreplace,missingok) %{systemdunitdir}/graphical.target.wants/*
 %config(noreplace,missingok) %{systemdunitdir}/local-fs.target.wants/*
 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/getty.target
+%config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/rc-local.service
 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-ask-password-wall.path
 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-logind.service
 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-user-sessions.service
 %config(noreplace,missingok) %{systemdunitdir}/runlevel[12345].target.wants/*
 %config(noreplace,missingok) %{systemdunitdir}/shutdown.target.wants/*
 %config(noreplace,missingok) %{systemdunitdir}/sockets.target.wants/*
-%config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/cryptsetup.target
+%{?with_cryptsetup:%config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/cryptsetup.target}
 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/dev-hugepages.mount
 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/dev-mqueue.mount
 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/proc-sys-fs-binfmt_misc.automount
@@ -709,14 +710,6 @@ rm -f %{_sysconfdir}/systemd/system/multi-user.target.wants/network-post.service
 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/plymouth-start.service
 %endif
 
-%if %{with gtk}
-%files gtk
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/systemadm
-%attr(755,root,root) %{_bindir}/systemd-gnome-ask-password-agent
-%{_mandir}/man1/systemadm.1*
-%endif
-
 %files analyze
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/systemd-analyze
This page took 0.032479 seconds and 4 git commands to generate.