]> git.pld-linux.org Git - packages/systemd.git/blobdiff - systemd.spec
Added handling lxc-stop SIGPWR via stolen from Ubuntu service.
[packages/systemd.git] / systemd.spec
index d108f2e9982ed4c56e8f3387ea0400c7386571ce..1f3c6f1227ee864edbada2be65e6ea4d41870b6d 100644 (file)
@@ -28,7 +28,7 @@ Summary(pl.UTF-8):    systemd - zarządca systemu i usług dla Linuksa
 Name:          systemd
 # Verify ChangeLog and NEWS when updating (since there are incompatible/breaking changes very often)
 Version:       221
-Release:       5
+Release:       12.1
 Epoch:         1
 License:       GPL v2+ (udev), LGPL v2.1+ (the rest)
 Group:         Base
@@ -49,10 +49,14 @@ Source16:   pld-rc-inetd-generator.sh
 Source17:      rc-inetd.service
 Source18:      default.preset
 Source19:      prefdm.service
+Source20:      sigpwr-container-shutdown.service
+
 # rules
 Source101:     udev-alsa.rules
 Source102:     udev.rules
 Source103:     udev-links.conf
+Source104:     udev-uinput.rules
+Source105:     udev-steam_controller.rules
 # scripts / helpers
 Source110:     udev-net.helper
 Source111:     start_udev
@@ -73,6 +77,7 @@ Patch10:      pld-boot_efi_mount.patch
 Patch11:       optional-tmp-on-tmpfs.patch
 Patch12:       uids_gids.patch
 Patch13:       sysctl.patch
+Patch14:       journal-gatewayd-fdopen.patch
 URL:           http://www.freedesktop.org/wiki/Software/systemd
 BuildRequires: acl-devel
 BuildRequires: attr-devel
@@ -116,6 +121,7 @@ BuildRequires:      python-modules
 BuildRequires: python3-devel
 BuildRequires: python3-lxml
 BuildRequires: python3-modules
+BuildRequires: rpm-build >= 5.4.15-28
 %endif
 %{?with_qrencode:BuildRequires:        qrencode-devel}
 BuildRequires: rpm-pythonprov
@@ -219,6 +225,8 @@ Conflicts:  libgpod < 0.8.0-6
 Conflicts:     libvirt-utils < 0.9.9-4
 Conflicts:     lighttpd < 1.4.30-5
 Conflicts:     lirc < 0.9.0-20
+# Needed for vgscan --cache  ( perhaps < 2.02.96 would be enough, but not tested)
+Conflicts:     lvm2 < 2.02.132
 Conflicts:     mailman < 5:2.1.14-4
 Conflicts:     memcached < 1.4.11-2
 Conflicts:     mpd < 0.16.5-4
@@ -472,6 +480,7 @@ Summary:    Header files for systemd libraries
 Summary(pl.UTF-8):     Pliki nagłówkowe bibliotek systemd
 Group:         Development/Libraries
 Requires:      %{name}-libs = %{epoch}:%{version}-%{release}
+Requires:      %{name}-units = %{epoch}:%{version}-%{release}
 Obsoletes:     systemd-static
 
 %description devel
@@ -662,6 +671,7 @@ Uzupełnianie parametrów w zsh dla poleceń udev.
 %patch11 -p1
 %patch12 -p1
 %patch13 -p1
+%patch14 -p1
 cp -p %{SOURCE2} src/systemd_booted.c
 
 %build
@@ -740,11 +750,13 @@ ln -s /lib/udev/udevd $RPM_BUILD_ROOT%{_sbindir}/udevd
 # compat symlinks for "/ merged into /usr" programs
 mv $RPM_BUILD_ROOT/{,s}bin/udevadm
 ln -s %{_sbindir}/udevadm $RPM_BUILD_ROOT/bin
-ln -s /lib/udev $RPM_BUILD_ROOT/usr/lib/
+ln -s /lib/udev $RPM_BUILD_ROOT%{_prefix}/lib
 
 # install custom udev rules from pld package
 cp -a %{SOURCE101} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d/40-alsa-restore.rules
 cp -a %{SOURCE102} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d/70-udev-pld.rules
+cp -a %{SOURCE104} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d/70-uinput.rules
+cp -a %{SOURCE105} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d/70-steam_controller.rules
 
 # http://www.freedesktop.org/wiki/Software/systemd/PredictableNetworkInterfaceNames
 ln -s /dev/null $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d/80-net-setup-link.rules
@@ -814,6 +826,11 @@ ln -s ../pld-storage-init-late.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs
 ln -s ../pld-storage-init.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants
 ln -s ../pld-clean-tmp.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants
 
+# Add inside container only SIGPWR handler which is used by lxc-stop
+install -p %{SOURCE20} $RPM_BUILD_ROOT%{systemdunitdir}/sigpwr-container-shutdown.service
+install -d $RPM_BUILD_ROOT%{systemdunitdir}/sigpwr.target.wants
+ln -s  ../sigpwr-container-shutdown.service  $RPM_BUILD_ROOT%{systemdunitdir}/sigpwr.target.wants
+
 # As of 207 the systemd-sysctl tool no longer natively reads the file /etc/sysctl.conf.
 # If desired, the file should be symlinked from /etc/sysctl.d/99-sysctl.conf.
 ln -s /etc/sysctl.conf $RPM_BUILD_ROOT/etc/sysctl.d/99-sysctl.conf
@@ -870,7 +887,7 @@ install -d $RPM_BUILD_ROOT/var/log
 # install Python2 files, binaries built and saved earlier
 install -d $RPM_BUILD_ROOT%{py_sitedir}/systemd
 cp -a $RPM_BUILD_ROOT%{py3_sitedir}/systemd/*.py $RPM_BUILD_ROOT%{py_sitedir}/systemd
-install -p .libs/python/*.so $RPM_BUILD_ROOT%{py_sitedir}/systemd
+install -p .libs/python2/*.so $RPM_BUILD_ROOT%{py_sitedir}/systemd
 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
 %else
@@ -1208,7 +1225,6 @@ fi
 %attr(755,root,root) /lib/systemd/systemd-vconsole-setup
 %attr(755,root,root) /lib/systemd/systemd
 %{?with_cryptsetup:%attr(755,root,root) /lib/systemd/system-generators/systemd-cryptsetup-generator}
-%attr(755,root,root) /lib/systemd/system-generators/systemd-dbus1-generator
 %attr(755,root,root) /lib/systemd/system-generators/systemd-debug-generator
 %attr(755,root,root) /lib/systemd/system-generators/systemd-efi-boot-generator
 %attr(755,root,root) /lib/systemd/system-generators/systemd-fstab-generator
@@ -1489,6 +1505,7 @@ fi
 %{_libexecdir}/systemd/user-generators/systemd-dbus1-generator
 %dir /lib/systemd/pld-helpers.d
 %dir /lib/systemd/system-generators
+%attr(755,root,root) /lib/systemd/system-generators/systemd-dbus1-generator
 %dir /lib/systemd/system-preset
 /lib/systemd/system-preset/90-systemd.preset
 %dir /lib/systemd/system-sleep
@@ -1560,6 +1577,7 @@ fi
 %{systemdunitdir}/rescue.service
 %{systemdunitdir}/serial-getty@.service
 %{systemdunitdir}/single.service
+%{systemdunitdir}/sigpwr-container-shutdown.service
 %{systemdunitdir}/sys-kernel-config.service
 %{systemdunitdir}/systemd-ask-password-console.service
 %{systemdunitdir}/systemd-ask-password-wall.service
@@ -1701,6 +1719,7 @@ fi
 %dir %{systemdunitdir}/rescue.target.wants
 %dir %{systemdunitdir}/runlevel[12345].target.wants
 %dir %{systemdunitdir}/shutdown.target.wants
+%dir %{systemdunitdir}/sigpwr.target.wants
 %dir %{systemdunitdir}/sockets.target.wants
 %dir %{systemdunitdir}/sysinit.target.wants
 %dir %{systemdunitdir}/syslog.target.wants
@@ -1731,6 +1750,7 @@ fi
 %{systemdunitdir}/multi-user.target.wants/systemd-update-utmp-runlevel.service
 %{systemdunitdir}/multi-user.target.wants/systemd-user-sessions.service
 %{systemdunitdir}/rescue.target.wants/systemd-update-utmp-runlevel.service
+%{systemdunitdir}/sigpwr.target.wants/sigpwr-container-shutdown.service
 %{systemdunitdir}/sockets.target.wants/systemd-initctl.socket
 %{systemdunitdir}/sockets.target.wants/systemd-journald-audit.socket
 %{systemdunitdir}/sockets.target.wants/systemd-journald-dev-log.socket
@@ -1987,7 +2007,7 @@ fi
 %files -n udev-core
 %defattr(644,root,root,755)
 
-/usr/lib/udev
+%{_prefix}/lib/udev
 
 %attr(755,root,root) /lib/udev/collect
 
@@ -2035,6 +2055,8 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/udev/links.conf
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/udev/rules.d/40-alsa-restore.rules
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/udev/rules.d/70-udev-pld.rules
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/udev/rules.d/70-uinput.rules
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/udev/rules.d/70-steam_controller.rules
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/udev/rules.d/80-net-setup-link.rules
 
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/udev/udev.conf
This page took 0.03387 seconds and 4 git commands to generate.