]> git.pld-linux.org Git - packages/systemd.git/blobdiff - systemd.spec
Added preset config
[packages/systemd.git] / systemd.spec
index 4dde11f177656412f2214e3283c2b0c670c3069e..0017d75d9e89f2f824f54d4ea3fe948a564db848 100644 (file)
@@ -2,12 +2,12 @@
 # - pldize vconsole setup:
 #      http://cgit.freedesktop.org/systemd/systemd/tree/src/vconsole/vconsole-setup.c
 # - udev initrd needs love (is probably completly unusable in current form)
+# - replace our rpm macros with systemd provided?
 #
 # Conditional build:
 %bcond_without audit           # without audit support
 %bcond_without cryptsetup      # without cryptsetup support
 %bcond_without pam             # PAM authentication support
-%bcond_without plymouth        # do not install plymouth units
 %bcond_without selinux         # without SELinux support
 %bcond_without tcpd            # libwrap (tcp_wrappers) support
 
@@ -38,13 +38,13 @@ Summary:    A System and Service Manager
 Summary(pl.UTF-8):     systemd - zarządca systemu i usług dla Linuksa
 Name:          systemd
 # Verify ChangeLog and NEWS when updating (since there are incompatible/breaking changes very often)
-Version:       185
-Release:       1.1
+Version:       187
+Release:       3
 Epoch:         1
 License:       GPL v2+
 Group:         Base
 Source0:       http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.xz
-# Source0-md5: a7dbbf05986eb0d2c164ec8e570eb78f
+# Source0-md5: 26606e3c84448800ef0b3ffd57e6e8b6
 Source1:       %{name}-sysv-convert
 Source2:       %{name}_booted.c
 Source3:       network.service
@@ -58,6 +58,7 @@ Source14:     pld-clean-tmp.service
 Source15:      pld-clean-tmp.sh
 Source16:      pld-rc-inetd-generator.sh
 Source17:      rc-inetd.service
+Source18:      default.preset
 # rules
 Source101:     udev-alsa.rules
 Source102:     udev.rules
@@ -77,17 +78,16 @@ Patch5:             kmsg-to-syslog.patch
 Patch6:                udev-so.patch
 Patch7:                udev-uClibc.patch
 Patch8:                udev-ploop-rules.patch
-Patch9:                udevlibexecdir.patch
-Patch10:       static-udev.patch
-Patch11:       systemd-udev-service.patch
-Patch12:       udevadm-in-sbin.patch
+Patch9:                udevadm-in-sbin.patch
+# hack set to allow static udev build
+Patch100:      static-udev.patch
 URL:           http://www.freedesktop.org/wiki/Software/systemd
 BuildRequires: acl-devel
 %{?with_audit:BuildRequires:   audit-libs-devel}
 BuildRequires: autoconf >= 2.64
 BuildRequires: automake >= 1:1.11
 BuildRequires: binutils >= 3:2.22.52.0.1-2
-%{?with_cryptsetup:BuildRequires:      cryptsetup-luks-devel}
+%{?with_cryptsetup:BuildRequires:      cryptsetup-devel >= 1.4.3}
 BuildRequires: dbus-devel >= 1.3.2
 BuildRequires: docbook-style-xsl
 BuildRequires: glib2-devel >= 1:2.22.0
@@ -335,19 +335,6 @@ Ten pakiet zawiera generator usług inet udostępniający funkcjonalność
 serwisu rc-inetd i zastępujący osobny demon inet przez systemd i
 aktywację usług przez gniazda.
 
-%package plymouth
-Summary:       Plymouth support units for systemd
-Summary(pl.UTF-8):     Jednostki wspierające Plymouth dla systemd
-Group:         Base
-Requires:      %{name}-units = %{epoch}:%{version}-%{release}
-Requires:      plymouth
-
-%description plymouth
-Plymouth (graphical boot) support units for systemd.
-
-%description plymouth -l pl.UTF-8
-Jednostki wspierające Plymouth (graficzny start systemu) dla systemd.
-
 %package analyze
 Summary:       Tool for processing systemd profiling information
 Summary(pl.UTF-8):     Narzędzie do przetwarzania informacji profilujących systemd
@@ -356,7 +343,7 @@ Requires:   %{name} = %{epoch}:%{version}-%{release}
 Requires:      python-dbus
 Requires:      python-modules
 Requires:      python-pycairo
-Conflicts:     %{name} < 44-3
+Conflicts:     systemd < 44-3
 
 %description analyze
 'systemd-analyze blame' lists which systemd unit needed how much time
@@ -416,7 +403,6 @@ Obsoletes:  hotplug
 Obsoletes:     hotplug-input
 Obsoletes:     hotplug-net
 Obsoletes:     hotplug-pci
-Obsoletes:     udev-compat
 Obsoletes:     udev-dev
 Obsoletes:     udev-extras < 20090628
 Obsoletes:     udev-tools
@@ -443,6 +429,7 @@ Requires:   uname(release) >= 2.6.32
 Conflicts:     rc-scripts < 0.4.5.3-1
 Conflicts:     systemd-units < 1:183
 Conflicts:     udev < 1:118-1
+Obsoletes:     udev-compat
 
 %description -n udev-core
 A userspace implementation of devfs - core part of udev.
@@ -577,8 +564,6 @@ initrd.
 %endif
 %patch8 -p1
 %patch9 -p1
-%patch11 -p1
-%patch12 -p1
 cp -p %{SOURCE2} src/systemd_booted.c
 
 %build
@@ -589,7 +574,7 @@ cp -p %{SOURCE2} src/systemd_booted.c
 %{__autoheader}
 %{__automake}
 %if %{with initrd}
-patch -p1 <%{PATCH10}
+patch -p1 <%{PATCH100}
 %configure \
 %if "%{?configure_cache}" == "1"
        --cache-file=%{?configure_cache_file}%{!?configure_cache_file:configure}-initrd.cache \
@@ -642,7 +627,7 @@ cp -a systemd-udevd \
        udev-initrd/
 
 %{__make} clean
-patch -p1 -R <%{PATCH10}
+patch -p1 -R <%{PATCH100}
 %endif
 
 %configure \
@@ -650,9 +635,9 @@ patch -p1 -R <%{PATCH10}
        %{__enable_disable audit} \
        %{__enable_disable cryptsetup libcryptsetup} \
        %{__enable_disable pam} \
-       %{__enable_disable plymouth} \
        %{__enable_disable selinux} \
        %{__enable_disable tcpd tcpwrap} \
+       --disable-plymouth \
        --disable-silent-rules \
        --enable-shared \
        --enable-static \
@@ -671,7 +656,7 @@ patch -p1 -R <%{PATCH10}
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT/var/lib/%{name}/coredump \
-       $RPM_BUILD_ROOT{%{_sysconfdir}/modprobe.d,%{_sbindir}}
+       $RPM_BUILD_ROOT{%{_sysconfdir}/{modprobe.d,systemd/system-preset},%{_sbindir}}
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
@@ -772,6 +757,8 @@ ln -s ../pld-clean-tmp.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.
 cp -p %{SOURCE16} $RPM_BUILD_ROOT/lib/systemd/system-generators/pld-rc-inetd-generator
 cp -p %{SOURCE17} $RPM_BUILD_ROOT%{systemdunitdir}/rc-inetd.service
 
+cp -p %{SOURCE18} $RPM_BUILD_ROOT%{_sysconfdir}/systemd/system-preset/default.preset
+
 # handled by rc-local sysv service, no need for generator
 %{__rm} $RPM_BUILD_ROOT/lib/systemd/system-generators/systemd-rc-local-generator
 
@@ -879,6 +866,14 @@ if [ -f /etc/systemd/systemd-logind.conf.rpmsave ]; then
        %{__mv} -f /etc/systemd/systemd-logind.conf.rpmsave /etc/systemd/logind.conf
 fi
 
+%triggerpostun units -- systemd-units < 1:187-3
+if [ -f /etc/sysconfig/rpm ]; then
+       . /etc/sysconfig/rpm
+       if [ ${RPM_ENABLE_SYSTEMD_SERVICE:-yes} = no ]; then
+               echo "disable *" >>%{_sysconfdir}/systemd/system-preset/default.preset
+       fi
+fi
+
 %post inetd
 %systemd_reload
 # Do not change it to restart, we only want to start new services here
@@ -887,12 +882,6 @@ fi
 %postun inetd
 %systemd_reload
 
-%post plymouth
-%systemd_reload
-
-%postun plymouth
-%systemd_reload
-
 %triggerpostun -n udev-core -- dev
 if [ "$2" = 0 ]; then
        # need to kill and restart udevd as after obsoleting dev package the
@@ -920,7 +909,7 @@ if [ $1 -gt 1 ]; then
                fi
        else
                SYSTEMD_LOG_LEVEL=warning SYSTEMD_LOG_TARGET=syslog \
-               /bin/systemctl --quiet try-restart systemd-udev.service || :
+               /bin/systemctl --quiet try-restart systemd-udevd.service || :
        fi
 fi
 
@@ -992,8 +981,7 @@ fi
 %attr(755,root,root) /lib/systemd/systemd-multi-seat-x
 %attr(755,root,root) /lib/systemd/systemd-quotacheck
 %attr(755,root,root) /lib/systemd/systemd-random-seed
-%attr(755,root,root) /lib/systemd/systemd-readahead-collect
-%attr(755,root,root) /lib/systemd/systemd-readahead-replay
+%attr(755,root,root) /lib/systemd/systemd-readahead
 %attr(755,root,root) /lib/systemd/systemd-remount-fs
 %attr(755,root,root) /lib/systemd/systemd-reply-password
 %attr(755,root,root) /lib/systemd/systemd-shutdown
@@ -1009,7 +997,6 @@ fi
 %dir /lib/systemd/system-generators
 %attr(755,root,root) /lib/systemd/systemd
 %attr(755,root,root) /lib/systemd/system-generators/systemd-*-generator
-%dir /lib/systemd/system-shutdown
 /lib/udev/rules.d/99-systemd.rules
 /lib/udev/rules.d/70-uaccess.rules
 /lib/udev/rules.d/71-seat.rules
@@ -1017,10 +1004,10 @@ fi
 %dir %{_libexecdir}/systemd
 %{_libexecdir}/systemd/user
 %dir %{_libexecdir}/systemd/user-generators
-%config(noreplace,missingok) %{_libexecdir}/tmpfiles.d/legacy.conf
-%config(noreplace,missingok) %{_libexecdir}/tmpfiles.d/systemd.conf
-%config(noreplace,missingok) %{_libexecdir}/tmpfiles.d/tmp.conf
-%config(noreplace,missingok) %{_libexecdir}/tmpfiles.d/x11.conf
+%{_libexecdir}/tmpfiles.d/legacy.conf
+%{_libexecdir}/tmpfiles.d/systemd.conf
+%{_libexecdir}/tmpfiles.d/tmp.conf
+%{_libexecdir}/tmpfiles.d/x11.conf
 %{_datadir}/dbus-1/interfaces/org.freedesktop.hostname1.xml
 %{_datadir}/dbus-1/interfaces/org.freedesktop.locale1.xml
 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.*.xml
@@ -1051,7 +1038,10 @@ fi
 %{_mandir}/man1/systemd-machine-id-setup.1*
 %{_mandir}/man1/systemd-notify.1*
 %{_mandir}/man1/systemd-nspawn.1*
+%{_mandir}/man1/systemd-tty-ask-password-agent.1*
 %{_mandir}/man5/binfmt.d.5*
+# cfl with rc-scripts
+#%{_mandir}/man5/crypttab.5*
 %{_mandir}/man5/hostname.5*
 %{_mandir}/man5/journald.conf.5*
 %{_mandir}/man5/locale.conf.5*
@@ -1064,23 +1054,35 @@ fi
 %{_mandir}/man5/systemd.*.5*
 %{_mandir}/man5/timezone.5*
 %{_mandir}/man5/vconsole.conf.5*
+%{_mandir}/man7/bootup.7*
 %{_mandir}/man7/daemon.7*
-%{_mandir}/man7/sd-daemon.7*
-%{_mandir}/man7/sd-login.7*
-%{_mandir}/man7/sd-readahead.7*
-%{_mandir}/man7/systemd.special.7*
+%{_mandir}/man7/kernel-command-line.7*
 %{_mandir}/man7/systemd.journal-fields.7*
+%{_mandir}/man7/systemd.special.7*
 %{_mandir}/man8/systemd-binfmt.8*
-%{_mandir}/man8/systemd-binfmt.service.8*
+%{_mandir}/man8/systemd-cryptsetup-generator.8*
+%{_mandir}/man8/systemd-fstab-generator.8*
+%{_mandir}/man8/systemd-getty-generator.8*
+%{_mandir}/man8/systemd-hostnamed.8*
+%{_mandir}/man8/systemd-initctl.8*
 %{_mandir}/man8/systemd-journald.8*
-%{_mandir}/man8/systemd-journald.service.8*
+%{_mandir}/man8/systemd-localed.8*
 %{_mandir}/man8/systemd-logind.8*
-%{_mandir}/man8/systemd-logind.service.8*
 %{_mandir}/man8/systemd-modules-load.8*
-%{_mandir}/man8/systemd-modules-load.service.8*
+%{_mandir}/man8/systemd-quotacheck.8*
+%{_mandir}/man8/systemd-random-seed.8*
+%{_mandir}/man8/systemd-readahead.8*
+%{_mandir}/man8/systemd-remount-fs.8*
+%{_mandir}/man8/systemd-shutdown.8*
+%{_mandir}/man8/systemd-shutdownd.8*
+%{_mandir}/man8/systemd-sleep.8*
 %{_mandir}/man8/systemd-sysctl.8*
-%{_mandir}/man8/systemd-sysctl.service.8*
+%{_mandir}/man8/systemd-system-update-generator.8*
+%{_mandir}/man8/systemd-timedated.8*
 %{_mandir}/man8/systemd-udevd.8*
+%{_mandir}/man8/systemd-update-utmp.8*
+%{_mandir}/man8/systemd-user-sessions.8*
+%{_mandir}/man8/systemd-vconsole-setup.8*
 %dir /var/lib/%{name}
 %dir /var/lib/%{name}/coredump
 %attr(640,root,root) %ghost /var/log/btmp
@@ -1116,10 +1118,13 @@ fi
 %dir %{_sysconfdir}/sysctl.d
 %dir %{_sysconfdir}/systemd
 %dir %{_sysconfdir}/systemd/system
+%dir %{_sysconfdir}/systemd/system-preset
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system-preset/default.preset
 %dir %{_sysconfdir}/tmpfiles.d
 %dir %{_libexecdir}/binfmt.d
 %dir %{_libexecdir}/modules-load.d
 %dir %{_libexecdir}/sysctl.d
+%dir /lib/systemd/system-shutdown
 # Don't package the kernel.core_pattern setting until systemd-coredump
 # is a part of an actual systemd release and it's made clear how to
 # get the core dumps out of the journal.
@@ -1139,10 +1144,6 @@ fi
 %{systemdunitdir}/*.socket
 %{systemdunitdir}/*.target
 %{systemdunitdir}/*.timer
-%if %{with plymouth}
-%exclude %{systemdunitdir}/plymouth*.service
-%exclude %{systemdunitdir}/systemd-ask-password-plymouth.*
-%endif
 %dir %{systemdunitdir}/basic.target.wants
 %dir %{systemdunitdir}/dbus.target.wants
 %dir %{systemdunitdir}/final.target.wants
@@ -1158,56 +1159,77 @@ fi
 %dir %{systemdunitdir}/sockets.target.wants
 %dir %{systemdunitdir}/sysinit.target.wants
 %dir %{systemdunitdir}/syslog.target.wants
-%config(noreplace,missingok) %{systemdunitdir}/basic.target.wants/*
-%config(noreplace,missingok) %{systemdunitdir}/final.target.wants/*
-%config(noreplace,missingok) %{systemdunitdir}/graphical.target.wants/*
-%config(noreplace,missingok) %{systemdunitdir}/local-fs.target.wants/*
-%config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/getty.target
-%config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/rc-local.service
-%config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-ask-password-wall.path
-%config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-logind.service
-%config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-user-sessions.service
-%config(noreplace,missingok) %{systemdunitdir}/runlevel[12345].target.wants/*
-%config(noreplace,missingok) %{systemdunitdir}/shutdown.target.wants/*
-%config(noreplace,missingok) %{systemdunitdir}/sockets.target.wants/*
-%{?with_cryptsetup:%config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/cryptsetup.target}
-%config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/dev-hugepages.mount
-%config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/dev-mqueue.mount
-%config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/proc-sys-fs-binfmt_misc.automount
-%config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/sys-*.mount
-%config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/systemd-*
+%{systemdunitdir}/basic.target.wants/*
+%{systemdunitdir}/final.target.wants/*
+%{systemdunitdir}/graphical.target.wants/*
+%{systemdunitdir}/local-fs.target.wants/*
+%{systemdunitdir}/multi-user.target.wants/getty.target
+%{systemdunitdir}/multi-user.target.wants/rc-local.service
+%{systemdunitdir}/multi-user.target.wants/systemd-ask-password-wall.path
+%{systemdunitdir}/multi-user.target.wants/systemd-logind.service
+%{systemdunitdir}/multi-user.target.wants/systemd-user-sessions.service
+%{systemdunitdir}/runlevel[12345].target.wants/*
+%{systemdunitdir}/shutdown.target.wants/*
+%{systemdunitdir}/sockets.target.wants/*
+%{?with_cryptsetup:%{systemdunitdir}/sysinit.target.wants/cryptsetup.target}
+%{systemdunitdir}/sysinit.target.wants/dev-hugepages.mount
+%{systemdunitdir}/sysinit.target.wants/dev-mqueue.mount
+%{systemdunitdir}/sysinit.target.wants/proc-sys-fs-binfmt_misc.automount
+%{systemdunitdir}/sysinit.target.wants/sys-*.mount
+%{systemdunitdir}/sysinit.target.wants/systemd-*
+%{_mandir}/man8/systemd-ask-password-console.path.8*
+%{_mandir}/man8/systemd-ask-password-console.service.8*
+%{_mandir}/man8/systemd-ask-password-wall.path.8*
+%{_mandir}/man8/systemd-ask-password-wall.service.8*
+%{_mandir}/man8/systemd-binfmt.service.8*
+%{_mandir}/man8/systemd-cryptsetup.8*
+%{_mandir}/man8/systemd-cryptsetup@.service.8*
+%{_mandir}/man8/systemd-fsck-root.service.8*
+%{_mandir}/man8/systemd-fsck@.service.8*
+%{_mandir}/man8/systemd-halt.service.8*
+%{_mandir}/man8/systemd-hibernate.service.8*
+%{_mandir}/man8/systemd-hostnamed.service.8*
+%{_mandir}/man8/systemd-initctl.service.8*
+%{_mandir}/man8/systemd-initctl.socket.8*
+%{_mandir}/man8/systemd-journald.service.8*
+%{_mandir}/man8/systemd-journald.socket.8*
+%{_mandir}/man8/systemd-kexec.service.8*
+%{_mandir}/man8/systemd-localed.service.8*
+%{_mandir}/man8/systemd-logind.service.8*
+%{_mandir}/man8/systemd-modules-load.service.8*
+%{_mandir}/man8/systemd-poweroff.service.8*
+%{_mandir}/man8/systemd-quotacheck.service.8*
+%{_mandir}/man8/systemd-random-seed-load.service.8*
+%{_mandir}/man8/systemd-random-seed-save.service.8*
+%{_mandir}/man8/systemd-readahead-collect.service.8*
+%{_mandir}/man8/systemd-readahead-done.service.8*
+%{_mandir}/man8/systemd-readahead-done.timer.8*
+%{_mandir}/man8/systemd-readahead-replay.service.8*
+%{_mandir}/man8/systemd-reboot.service.8*
+%{_mandir}/man8/systemd-remount-fs.service.8*
+%{_mandir}/man8/systemd-shutdownd.service.8*
+%{_mandir}/man8/systemd-shutdownd.socket.8*
+%{_mandir}/man8/systemd-suspend.service.8*
+%{_mandir}/man8/systemd-sysctl.service.8*
+%{_mandir}/man8/systemd-timedated.service.8*
+%{_mandir}/man8/systemd-tmpfiles-clean.service.8*
+%{_mandir}/man8/systemd-tmpfiles-clean.timer.8*
+%{_mandir}/man8/systemd-tmpfiles-setup.service.8*
+%{_mandir}/man8/systemd-udevd.service.8*
+%{_mandir}/man8/systemd-update-utmp-runlevel.service.8*
+%{_mandir}/man8/systemd-update-utmp-shutdown.service.8*
+%{_mandir}/man8/systemd-user-sessions.service.8*
+%{_mandir}/man8/systemd-vconsole-setup.service.8*
 
 %files inetd
 %defattr(644,root,root,755)
 %attr(755,root,root) /lib/systemd/system-generators/pld-rc-inetd-generator
 %{systemdunitdir}/rc-inetd.service
 
-%if %{with plymouth}
-%files plymouth
-%defattr(644,root,root,755)
-%{systemdunitdir}/plymouth-halt.service
-%{systemdunitdir}/plymouth-kexec.service
-%{systemdunitdir}/plymouth-poweroff.service
-%{systemdunitdir}/plymouth-quit-wait.service
-%{systemdunitdir}/plymouth-quit.service
-%{systemdunitdir}/plymouth-read-write.service
-%{systemdunitdir}/plymouth-reboot.service
-%{systemdunitdir}/plymouth-start.service
-%{systemdunitdir}/systemd-ask-password-plymouth.path
-%{systemdunitdir}/systemd-ask-password-plymouth.service
-%config(noreplace,missingok) %{systemdunitdir}/halt.target.wants/plymouth-halt.service
-%config(noreplace,missingok) %{systemdunitdir}/kexec.target.wants/plymouth-kexec.service
-%config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/plymouth-quit.service
-%config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/plymouth-quit-wait.service
-%config(noreplace,missingok) %{systemdunitdir}/poweroff.target.wants/plymouth-poweroff.service
-%config(noreplace,missingok) %{systemdunitdir}/reboot.target.wants/plymouth-reboot.service
-%config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/plymouth-read-write.service
-%config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/plymouth-start.service
-%endif
-
 %files analyze
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/systemd-analyze
+%{_mandir}/man1/systemd-analyze.1*
 
 %files libs
 %defattr(644,root,root,755)
@@ -1231,40 +1253,8 @@ fi
 %{_pkgconfigdir}/libsystemd-id128.pc
 %{_pkgconfigdir}/libsystemd-journal.pc
 %{_pkgconfigdir}/libsystemd-login.pc
-%{_mandir}/man3/sd_booted.3*
-%{_mandir}/man3/sd_get_seats.3*
-%{_mandir}/man3/sd_get_sessions.3*
-%{_mandir}/man3/sd_get_uids.3*
-%{_mandir}/man3/sd_is_fifo.3*
-%{_mandir}/man3/sd_is_mq.3*
-%{_mandir}/man3/sd_is_socket.3
-%{_mandir}/man3/sd_is_socket_inet.3
-%{_mandir}/man3/sd_is_socket_unix.3
-%{_mandir}/man3/sd_listen_fds.3*
-%{_mandir}/man3/sd_login_monitor_flush.3*
-%{_mandir}/man3/sd_login_monitor_get_fd.3*
-%{_mandir}/man3/sd_login_monitor_new.3*
-%{_mandir}/man3/sd_login_monitor_unref.3*
-%{_mandir}/man3/sd_notify.3*
-%{_mandir}/man3/sd_notifyf.3
-%{_mandir}/man3/sd_pid_get_owner_uid.3*
-%{_mandir}/man3/sd_pid_get_session.3*
-%{_mandir}/man3/sd_pid_get_unit.3*
-%{_mandir}/man3/sd_readahead.3*
-%{_mandir}/man3/sd_seat_can_multi_session.3*
-%{_mandir}/man3/sd_seat_get_active.3*
-%{_mandir}/man3/sd_seat_get_sessions.3*
-%{_mandir}/man3/sd_session_get_class.3*
-%{_mandir}/man3/sd_session_get_display.3*
-%{_mandir}/man3/sd_session_get_seat.3*
-%{_mandir}/man3/sd_session_get_service.3*
-%{_mandir}/man3/sd_session_get_type.3*
-%{_mandir}/man3/sd_session_get_uid.3*
-%{_mandir}/man3/sd_session_is_active.3*
-%{_mandir}/man3/sd_uid_get_seats.3*
-%{_mandir}/man3/sd_uid_get_sessions.3*
-%{_mandir}/man3/sd_uid_get_state.3*
-%{_mandir}/man3/sd_uid_is_on_seat.3*
+%{_mandir}/man3/SD_*.3*
+%{_mandir}/man3/sd*.3*
 
 %files -n bash-completion-systemd
 %defattr(644,root,root,755)
@@ -1281,11 +1271,6 @@ fi
 
 /usr/lib/udev
 
-# /lib/udev/devices/ are not read anymore; systemd-tmpfiles
-# should be used to create dead device nodes as workarounds for broken
-# subsystems.
-%dir /lib/udev/devices
-
 %attr(755,root,root) /lib/udev/collect
 
 %attr(755,root,root) /lib/udev/keyboard-force-release.sh
This page took 0.143544 seconds and 4 git commands to generate.