]> git.pld-linux.org Git - packages/swig.git/blobdiff - swig.spec
- updated to 2.0.4
[packages/swig.git] / swig.spec
index 6a19bd0a210ea40881c9c3aa47e71fb480c7daf2..88a15e851a76ec2ca428df44944b04b12b50a447 100644 (file)
--- a/swig.spec
+++ b/swig.spec
@@ -2,6 +2,7 @@
 # Conditional build:
 %bcond_without guile   # disable guile support
 %bcond_without ocaml   # disable ocaml support
+%bcond_without octave  # disable octave support
 %bcond_without perl    # disable perl support
 %bcond_without php     # disable php support
 %bcond_without ruby    # disable ruby support
@@ -11,27 +12,27 @@ Summary:    Interface generator for Perl, Tcl, Guile and Python
 Summary(pl.UTF-8):     Generator interfejsów do Perla, Tcl-a, Guile'a i Pythona
 Summary(pt_BR.UTF-8):  Gerador de Interfaces e "Wrappers" Simplificado (SWIG)
 Name:          swig
-Version:       1.3.32
+Version:       2.0.4
 Release:       1
-License:       distributable
+License:       GPL v3+ (utility), free (library)
 Group:         Development/Languages
-Source0:       http://dl.sourceforge.net/swig/%{name}-%{version}.tar.gz
-# Source0-md5: 5db15e9265ade86b349fcb61c82299ea
-Patch0:                %{name}-format.patch
-Patch1:                %{name}-php.patch
-Patch2:                %{name}-php-freearg.patch
-Patch3:                %{name}-php-vdecl.patch
+Source0:       http://downloads.sourceforge.net/swig/%{name}-%{version}.tar.gz
+# Source0-md5: 4319c503ee3a13d2a53be9d828c3adc0
+Patch0:                %{name}-php-freearg.patch
+Patch1:                %{name}-guile2.patch
 URL:           http://www.swig.org/
-BuildRequires: autoconf
-BuildRequires: automake
+BuildRequires: autoconf >= 2.58
+BuildRequires: automake >= 1:1.7.2
 %{?with_guile:BuildRequires:   guile-devel}
 BuildRequires: libstdc++-devel
-BuildRequires: libtool
 %{?with_ocaml:BuildRequires:   ocaml}
+%{?with_octave:BuildRequires:  octave-devel}
 %{?with_perl:BuildRequires:    perl-devel >= 1:5.6.1}
 %{?with_php:BuildRequires:     php-cli}
 %{?with_php:BuildRequires:     php-devel >= 4.1.0}
 BuildRequires: python-devel >= 1:2.3.2
+BuildRequires: python-modules
+BuildRequires: rpm-pythonprov
 %if %{with ruby}
 BuildRequires: rpmbuild(macros) >= 1.277
 BuildRequires: ruby-devel >= 1:1.6.3
@@ -79,6 +80,7 @@ com um mínimo de esforço.
 %package guile
 Summary:       SWIG library: guile
 Summary(pl.UTF-8):     Biblioteka SWIG: guile
+License:       free
 Group:         Libraries
 Requires:      %{name} = %{version}-%{release}
 
@@ -91,6 +93,7 @@ Biblioteka SWIG: guile.
 %package perl
 Summary:       SWIG library: Perl
 Summary(pl.UTF-8):     Biblioteka SWIG: Perl
+License:       free
 Group:         Libraries
 Requires:      %{name} = %{version}-%{release}
 
@@ -103,6 +106,7 @@ Biblioteka SWIG: perl.
 %package php
 Summary:       SWIG library: php
 Summary(pl.UTF-8):     Biblioteka SWIG: php
+License:       free
 Group:         Libraries
 Requires:      %{name} = %{version}-%{release}
 
@@ -115,6 +119,7 @@ Biblioteka SWIG: php.
 %package python
 Summary:       SWIG library: python
 Summary(pl.UTF-8):     Biblioteka SWIG: python
+License:       free
 Group:         Libraries
 Requires:      %{name} = %{version}-%{release}
 
@@ -127,6 +132,7 @@ Biblioteka SWIG: python.
 %package ruby
 Summary:       SWIG library: ruby
 Summary(pl.UTF-8):     Biblioteka SWIG: ruby
+License:       free
 Group:         Libraries
 Requires:      %{name} = %{version}-%{release}
 %{?ruby_mod_ver_requires_eq}
@@ -140,6 +146,7 @@ Biblioteka SWIG: ruby.
 %package tcl
 Summary:       SWIG library: tcl
 Summary(pl.UTF-8):     Biblioteka SWIG: tcl
+License:       free
 Group:         Libraries
 Requires:      %{name} = %{version}-%{release}
 
@@ -153,11 +160,8 @@ Biblioteka SWIG: tcl.
 %setup -q
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
-%patch3 -p1
 
 %build
-%{__libtoolize}
 %{__aclocal} -I Tools/config
 %{__autoconf}
 %{__automake}
@@ -179,38 +183,19 @@ cp -a Examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post  -p /sbin/ldconfig
-%postun        -p /sbin/ldconfig
-
-%post  guile -p /sbin/ldconfig
-%postun        guile -p /sbin/ldconfig
-
-%post  perl -p /sbin/ldconfig
-%postun        perl -p /sbin/ldconfig
-
-%post  php -p /sbin/ldconfig
-%postun        php -p /sbin/ldconfig
-
-%post  python -p /sbin/ldconfig
-%postun        python -p /sbin/ldconfig
-
-%post  ruby -p /sbin/ldconfig
-%postun        ruby -p /sbin/ldconfig
-
-%post  tcl -p /sbin/ldconfig
-%postun        tcl -p /sbin/ldconfig
-
 %files
 %defattr(644,root,root,755)
-%doc Doc CHANGES CHANGES.current NEW README ANNOUNCE TODO LICENSE
+%doc ANNOUNCE CHANGES CHANGES.current COPYRIGHT LICENSE LICENSE-UNIVERSITIES README RELEASENOTES TODO Doc
+%attr(755,root,root) %{_bindir}/ccache-swig
 %attr(755,root,root) %{_bindir}/swig
 %{_datadir}/%{name}
 %{?with_guile:%exclude %{_datadir}/%{name}/%{version}/guile}
 %{?with_perl:%exclude %{_datadir}/%{name}/%{version}/perl5}
-%{?with_php:%exclude %{_datadir}/%{name}/%{version}/php4}
+%{?with_php:%exclude %{_datadir}/%{name}/%{version}/php}
 %exclude %{_datadir}/%{name}/%{version}/python
 %{?with_ruby:%exclude %{_datadir}/%{name}/%{version}/ruby}
 %{?with_tcl:%exclude %{_datadir}/%{name}/%{version}/tcl}
+%{_mandir}/man1/ccache-swig.1*
 %{_examplesdir}/%{name}-%{version}
 
 %if %{with guile}
@@ -228,7 +213,7 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with php}
 %files php
 %defattr(644,root,root,755)
-%{_datadir}/%{name}/%{version}/php4
+%{_datadir}/%{name}/%{version}/php
 %endif
 
 %files python
This page took 0.069909 seconds and 4 git commands to generate.