]> git.pld-linux.org Git - packages/subversion.git/blobdiff - subversion.spec
- pl for java-
[packages/subversion.git] / subversion.spec
index 2bc563760de5e0e7569e460fc98422b3b2400a6a..bd04f648bde279a745db0555ef91d4c4231fdf25 100644 (file)
@@ -3,25 +3,30 @@
 #   without db => net_client_only - spec will be more simpler, I think)
 #
 # Conditional build:
-%bcond_with    net_client_only                 # build only net client
-%bcond_without python                          # build without python bindings (broken)
-%bcond_without perl                            # build without perl bindings
-%bcond_without apache                          # build without apache support (webdav, etc)
+%bcond_with    net_client_only         # build only net client
+%bcond_without python                  # build without python bindings (broken)
+%bcond_without perl                    # build without perl bindings
+%bcond_without apache                  # build without apache support (webdav, etc)
+%bcond_without javahl                  # build without javahl support (Java high-level bindings)
+%bcond_without tests                   # don't perform "make check"
 #
 %{!?with_net_client_only:%include      /usr/lib/rpm/macros.perl}
 %define        apxs    /usr/sbin/apxs
 %define        pdir    SVN
 %define        pnam    _Core
+#
+%define        snap    rc4
 Summary:       A Concurrent Versioning system similar to but better than CVS
 Summary(pl.UTF-8):     System kontroli wersji podobny, ale lepszy, niż CVS
 Summary(pt_BR.UTF-8):  Sistema de versionamento concorrente
 Name:          subversion
-Version:       1.4.6
-Release:       3
+Version:       1.5.0
+Release:       0.%{snap}.1
 License:       Apache/BSD-like
 Group:         Development/Version Control
-Source0:       http://subversion.tigris.org/downloads/%{name}-%{version}.tar.gz
-# Source0-md5: 32786fe2f322982c0567346de18f6460
+# Source0:     http://subversion.tigris.org/downloads/%{name}-%{version}.tar.gz
+Source0:       http://orac.ece.utexas.edu/pub/svn/%{version}-%{snap}/leander-hackberry/%{name}-%{version}-%{snap}.tar.gz
+# Source0-md5: 905fc5030be179d4d387803b8397668a
 Source1:       %{name}-dav_svn.conf
 Source2:       %{name}-authz_svn.conf
 Source3:       %{name}-svnserve.init
@@ -29,9 +34,6 @@ Source4:      %{name}-svnserve.sysconfig
 Source5:       %{name}-convert-typemaps-to-ifdef.py
 Patch0:                %{name}-home_etc.patch
 Patch1:                %{name}-DESTDIR.patch
-Patch2:                %{name}-neon.patch
-Patch3:                %{name}-python_bindings.patch
-Patch4:                %{name}-swig.patch
 URL:           http://subversion.tigris.org/
 %if %{with net_client_only}
 %global apache_modules_api 0
@@ -45,11 +47,13 @@ BuildRequires:      perl-devel >= 1:5.8.0
 BuildRequires: rpm-perlprov >= 4.1-13
 BuildRequires: swig-perl >= 1.3.24
 %endif
+%{?with_javahl:BuildRequires:  jdk}
 %endif
 BuildRequires: apr-devel >= 1:1.0.0
 BuildRequires: apr-util-devel >= 1:1.2.8-3
 BuildRequires: autoconf >= 2.59
 BuildRequires: bison
+BuildRequires: cyrus-sasl-devel
 BuildRequires: expat-devel
 BuildRequires: gettext-devel
 BuildRequires: libtool >= 1.4-9
@@ -167,8 +171,18 @@ Summary:   Subversion svnserve
 Summary(pl.UTF-8):     Subversion svnserve
 Group:         Networking/Daemons
 Requires(post,preun):  /sbin/chkconfig
+Requires(postun):      /usr/sbin/groupdel
+Requires(postun):      /usr/sbin/userdel
+Requires(pre): /bin/id
+Requires(pre): /usr/bin/getgid
+Requires(pre): /usr/lib/rpm/user_group.sh
+Requires(pre): /usr/sbin/groupadd
+Requires(pre): /usr/sbin/useradd
+Requires(pre): /usr/sbin/usermod
 Requires:      %{name} = %{version}-%{release}
 Requires:      rc-scripts
+Provides:      group(svn)
+Provides:      user(svn)
 
 %description svnserve
 Subversion svnserve server.
@@ -206,40 +220,59 @@ Bash completion for subversion.
 %description -n bash-completion-subversion -l pl.UTF-8
 Dopełnienia basha dla subversion.
 
+%package -n java-subversion
+Summary:       Subversion Java bindings
+Summary(pl.UTF-8):     Dowiązania do Subversion dla Javy
+Group:         Development/Languages/Java
+Requires:      %{name}-libs = %{version}-%{release}
+
+%description -n java-subversion
+This is a set of Java classes which provide the functionality of
+subversion-libs, the Subversion libraries. It is useful if you want
+to, for example, write a Java class that manipulates a Subversion
+repository or working copy. See the 'subversion' package for more
+information.
+
+%description -n java-subversion -l pl.UTF-8
+Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
+subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
+pisaniu klas Javy np. modyfikujących repozytorium Subversion lub
+kopię roboczą. Więcej informacji w pakiecie subversion.
+
 %package -n python-subversion
-Summary:       Subversion python bindings
-Summary(pl.UTF-8):     Dowiązania do subversion dla pythona
-Summary(pt_BR.UTF-8):  Módulos python para acessar os recursos do Subversion
+Summary:       Subversion Python bindings
+Summary(pl.UTF-8):     Dowiązania do Subversion dla Pythona
+Summary(pt_BR.UTF-8):  Módulos Python para acessar os recursos do Subversion
 Group:         Development/Languages/Python
 %pyrequires_eq python
 Requires:      %{name}-libs = %{version}-%{release}
 Obsoletes:     subversion-python
 
 %description -n python-subversion
-Subversion python bindings.
+Subversion Python bindings.
 
 %description -n python-subversion -l pl.UTF-8
-Dowiązania do subversion dla pythona.
+Dowiązania do Subversion dla Pythona.
 
 %description -n python-subversion -l pt_BR.UTF-8
-Módulos python para acessar os recursos do Subversion.
+Módulos Python para acessar os recursos do Subversion.
 
 %package -n perl-subversion
-Summary:       Subversion perl bindings
-Summary(pl.UTF-8):     Dowiązania do subversion dla perla
-Summary(pt_BR.UTF-8):  Módulos perl para acessar os recursos do Subversion
+Summary:       Subversion Perl bindings
+Summary(pl.UTF-8):     Dowiązania do Subversion dla Perla
+Summary(pt_BR.UTF-8):  Módulos Perl para acessar os recursos do Subversion
 Group:         Development/Languages/Perl
 Requires:      %{name}-libs = %{version}-%{release}
 Obsoletes:     subversion-perl
 
 %description -n perl-subversion
-Subversion perl bindings.
+Subversion Perl bindings.
 
 %description -n perl-subversion -l pl.UTF-8
-Dowiązania do subversion dla perl.
+Dowiązania do Subversion dla Perla.
 
 %description -n perl-subversion -l pt_BR.UTF-8
-Módulos perl para acessar os recursos do Subversion.
+Módulos Perl para acessar os recursos do Subversion.
 
 %package -n apache-mod_dav_svn
 Summary:       Apache module: Subversion Server
@@ -269,16 +302,13 @@ Apache module: Subversion Server - path-based authorization.
 Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
 
 %prep
-%setup -q
+%setup -q -n %{name}-%{version}-%{snap}
 rm -rf apr apr-util neon
 %patch0 -p0
 %patch1 -p1
-%patch2 -p1
-%patch3 -p1
-%patch4 -p1
 
 %build
-rm subversion/bindings/swig/proxy/*.swg 
+rm subversion/bindings/swig/proxy/*.swg
 cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
 cp -f /usr/share/automake/config.sub ac-helpers
 chmod +x ./autogen.sh && ./autogen.sh
@@ -286,9 +316,9 @@ chmod +x ./autogen.sh && ./autogen.sh
 # don't enable dso - currently it's broken
 %configure \
        --with-editor=vi \
-       --with-zlib \
-       --with-python=%{_bindir}/python \
-       --with-perl5=%{_bindir}/perl \
+       --with-zlib=%{_libdir} \
+       --with-python=%{__python} \
+       --with-perl5=%{__perl} \
 %if %{with net_client_only}
        --without-apache \
        --without-swig \
@@ -307,7 +337,9 @@ chmod +x ./autogen.sh && ./autogen.sh
 %if !%{with python} && !%{with perl}
        --without-swig \
 %endif
+       --%{?with_javahl:en}%{!?with_javahl:dis}able-javahl \
 %endif
+       --with-jdk="%{java_home}" \
        --with-neon=%{_prefix} \
        --disable-neon-version-check \
        --with-apr=%{_bindir}/apr-1-config \
@@ -331,6 +363,14 @@ cd subversion/bindings/swig/perl/native
 %{__make}
 cd $odir
 %endif
+%if %{with javahl}
+%{__make} javahl \
+       javahl_javadir="%{_javadir}"
+%endif
+%endif
+
+%if %{with tests}
+%{__make} check
 %endif
 
 %install
@@ -341,6 +381,10 @@ install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
        $RPM_BUILD_ROOT/home/services/subversion{,/repos}
 
 %{__make} install -j1 \
+%if %{with javahl}
+       install-javahl \
+       javahl_javadir="%{_javadir}" \
+%endif
 %if !%{with net_client_only} && %{with python}
        install-swig-py \
 %endif
@@ -388,6 +432,10 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/lib*swig*.la
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%pre svnserve
+%groupadd -g 86 svn
+%useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
+
 %post devel    -p      /sbin/postshell
 -/usr/sbin/fix-info-dir -c %{_infodir}
 
@@ -409,6 +457,12 @@ if [ "$1" = "0" ]; then
        /sbin/chkconfig --del svnserve
 fi
 
+%postun svnserve
+if [ "$1" = "0" ]; then
+        %userremove svn
+        %groupremove svn
+fi
+
 %post -n apache-mod_dav_svn
 %service -q httpd restart
 
@@ -440,6 +494,11 @@ fi
 %if %{with perl} || %{with python}
 %exclude %{_libdir}/lib*_swig_*.so.*
 %endif
+%if %{with javahl}
+%exclude %{_libdir}/libsvnjavahl*.so.*.*.*
+%exclude %{_libdir}/libsvnjavahl*.so.?
+%exclude %{_libdir}/libsvnjavahl*.so
+%endif
 
 %files devel
 %defattr(644,root,root,755)
@@ -449,6 +508,9 @@ fi
 %if %{with perl} || %{with python}
 %exclude %{_libdir}/lib*_swig_*.so
 %endif
+%if %{with javahl}
+%exclude %{_libdir}/libsvnjavahl*.so
+%endif
 %{_examplesdir}/%{name}-%{version}
 
 %files static
@@ -460,8 +522,8 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/svnserve
 %{_mandir}/man?/svnserve*
-%dir /home/services/subversion
-%dir /home/services/subversion/repos
+%dir %attr(750,svn,svn) /home/services/subversion
+%dir %attr(750,svn,svn) /home/services/subversion/repos
 %if %{with apache}
 %attr(754,root,root) /etc/rc.d/init.d/svnserve
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
@@ -475,6 +537,15 @@ fi
 %defattr(644,root,root,755)
 /etc/bash_completion.d/%{name}
 
+%if %{with javahl}
+%files -n java-subversion
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libsvnjavahl*.so.*.*.*
+%attr(755,root,root) %{_libdir}/libsvnjavahl*.so.?
+%attr(755,root,root) %{_libdir}/libsvnjavahl*.so
+%{_javadir}/svn-javahl.jar
+%endif
+
 %if %{with python}
 %files -n python-subversion
 %defattr(644,root,root,755)
This page took 0.091264 seconds and 4 git commands to generate.