]> git.pld-linux.org Git - packages/subversion.git/blobdiff - subversion.spec
- updated/new for 0.34.0
[packages/subversion.git] / subversion.spec
index 790025c39abd758c8fe6a574eedf75793fa1d91b..b0c60a279547e736d9b2c8c260032d72faa6c595 100644 (file)
@@ -1,32 +1,43 @@
-%bcond_with    internal_neon
-%bcond_with    net_client_only
-%include        /usr/lib/rpm/macros.python
-%define        distdir 15/6494
+#
+# TODO:
+# - separate subpackage with svnserve + init.d script + sysconfig file
+#
+# Conditional build:
+%bcond_with    internal_neon           # build with internal neon
+%bcond_with    net_client_only         # build only net client
+#      
+%include       /usr/lib/rpm/macros.python
+%{!?with_net_client_only:%include      /usr/lib/rpm/macros.perl}
 Summary:       A Concurrent Versioning system similar to but better than CVS
 Summary(pl):   System kontroli wersji podobny, ale lepszy, ni¿ CVS
 Summary(pt_BR):        Sistema de versionamento concorrente
 Name:          subversion
-Version:       0.30.0
-Release:       0.1
+Version:       0.34.0
+Release:       1
 License:       Apache/BSD Style
 Group:         Development/Version Control
-#Source0Download:      http://subversion.tigris.org/servlets/ProjectDocumentList?folderID=260
-Source0:       http://subversion.tigris.org/files/documents/%{distdir}/subversion-%{version}.tar.gz
-# Source0-md5: 9dac76a67a217dc6b7f63259761ff93f
+Source0:       http://svn.collab.net/tarballs/%{name}-%{version}.tar.gz
+# Source0-md5: 52f3a73858566d4d7045e449d94390e3
 Source1:       %{name}-dav_svn.conf
 Source2:       %{name}-authz_svn.conf
+Source3:       %{name}-svnserve.init
+Source4:       %{name}-svnserve.sysconfig
+Patch0:                %{name}-perl.patch
+Patch1:                %{name}-svnlook.patch
 URL:           http://subversion.tigris.org/
 %if %{with net_client_only}
 %global apache_modules_api 0
 %else
 BuildRequires: apache-devel >= 2.0.47-0.6
-BuildRequires:  db-devel >= 4.1.25
-BuildRequires:  rpmbuild(macros) >= 1.120
-BuildRequires:  swig >= 1.3.17
-BuildRequires:  swig-python >= 1.3.17
+BuildRequires: db-devel >= 4.1.25
+BuildRequires: rpmbuild(macros) >= 1.120
+BuildRequires: swig >= 1.3.17
+BuildRequires: swig-python >= 1.3.17
+BuildRequires: perl-devel >= 5.8.0
+BuildRequires: rpm-perlprov
 %endif
-BuildRequires: apr-devel >= 1:0.9.4
-BuildRequires: apr-util-devel >= 1:0.9.4
+BuildRequires: apr-devel >= 1:0.9.5
+BuildRequires: apr-util-devel >= 1:0.9.5
 BuildRequires: autoconf >= 2.53
 BuildRequires: bison
 BuildRequires: docbook-style-xsl >= 1.56
@@ -34,11 +45,9 @@ BuildRequires:       expat-devel
 BuildRequires: libtool >= 1.4-9
 BuildRequires: libxslt-progs
 %{!?with_internal_neon:BuildRequires:  neon-devel >= 0.24.1}
-BuildRequires:  python >= 2.2
-BuildRequires:  rpm-pythonprov >= 4.0.2-50
+BuildRequires: python >= 2.2
+BuildRequires: rpm-pythonprov >= 4.0.2-50
 BuildRequires: texinfo
-Requires(post):        /usr/sbin/fix-info-dir
-Requires(postun):      /usr/sbin/fix-info-dir
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _apachelibdir   /usr/lib/apache
@@ -133,14 +142,26 @@ Biblioteka statyczna subversion.
 %description static -l pt_BR
 Este pacote provê um cliente estático do subversion.
 
+%package svnserve
+Summary:       Subversion svnserve
+Summary(pl):   Subversion svnserve
+Group:         Networking/Daemons
+PreReq:                rc-scripts
+Requires(post,preun):  /sbin/chkconfig
+
+%description svnserve
+Subversion svnserve server.
+
+%description svnserve -l pl
+Serwer subversion svnserve.
+
 %package tools
 Summary:       Subversion tools and scripts
 Summary(pl):   Narzêdzia oraz skrypty dla subversion
 Summary(pt_BR):        Módulos python para acessar os recursos do Subversion
 Group:         Applications
-Requires:      python >= 2.2
 %pyrequires_eq python
-Requires:      python-rcsparse
+Requires:      python-rcsparse >= 0.1-0.20031026.0
 Requires:      python-subversion = %{version}
 
 %description tools
@@ -149,15 +170,13 @@ Subversion tools and scripts.
 %description tools -l pl
 Narzêdzia oraz skrypty dla subversion.
 
-
 %package -n python-subversion
 Summary:       Subversion python bindings
 Summary(pl):   Dowi±zania do subversion dla pythona
 Summary(pt_BR):        Módulos python para acessar os recursos do Subversion
 Group:         Development/Languages/Python
-Requires:      python >= 2.2
-Obsoletes:     subversion-python
 %pyrequires_eq python
+Obsoletes:     subversion-python
 
 %description -n python-subversion
 Subversion python bindings.
@@ -168,6 +187,22 @@ Dowi
 %description -n python-subversion -l pt_BR
 Módulos python para acessar os recursos do Subversion.
 
+%package -n perl-subversion
+Summary:       Subversion perl bindings
+Summary(pl):   Dowi±zania do subversion dla perla
+Summary(pt_BR):        Módulos perl para acessar os recursos do Subversion
+Group:         Development/Languages/Perl
+Obsoletes:     subversion-perl
+
+%description -n perl-subversion
+Subversion perl bindings.
+
+%description -n perl-subversion -l pl
+Dowi±zania do subversion dla perl.
+
+%description -n perl-subversion -l pt_BR
+Módulos perl para acessar os recursos do Subversion.
+
 %package -n apache-mod_dav_svn
 Summary:       Apache module: Subversion Server
 Summary(pl):   Modu³ apache: Serwer Subversion
@@ -198,6 +233,8 @@ Modu
 
 %prep
 %setup -q
+%patch0 -p1
+%patch1 -p0
 
 %build
 chmod +x ./autogen.sh && ./autogen.sh
@@ -222,16 +259,29 @@ chmod +x ./autogen.sh && ./autogen.sh
 %{__make}
 
 %if ! %{with net_client_only}
+# python
 %{__make} swig-py \
        swig_pydir=%{py_sitedir}/libsvn \
        swig_pydir_extra=%{py_sitedir}/svn
+# perl
+bdir=$(pwd)
+%{__make} install-swig-pl-lib \
+       LC_ALL=C \
+       DESTDIR=${bdir}/swig-pl-lib-buildroot
+%{__make}
+cd subversion/bindings/swig/perl
+env APR_CONFIG=%{_bindir}/apr-config \
+       %{__perl} Makefile.PL \
+       INSTALLDIRS=vendor
+env LIBRARY_PATH=${bdir}/swig-pl-lib-buildroot%{_libdir} %{__make}
+cd ../../../../
 %endif
 
 # build documentation; build process for documentation is severely
 # braindamaged -- authors suggests to untar docbook distribution in
 # build directory, hence the hack here
-%{__make} -C doc/book all-html \
-       XSL_DIR=/usr/share/sgml/docbook/xsl-stylesheets/
+ln -s /usr/share/sgml/docbook/xsl-stylesheets doc/book/tools/xsl
+%{__make} -C doc/book all-html
 
 # prepare for %%doc below
 mv -f doc/book/book/html-chunk svn-handbook
@@ -240,6 +290,7 @@ cp -f doc/book/book/images/*.png svn-handbook/images/
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/httpd/httpd.conf,%{_apachelibdir},%{_infodir}}
 
 %{__make} install \
@@ -249,12 +300,22 @@ install -d $RPM_BUILD_ROOT{%{_sysconfdir}/httpd/httpd.conf,%{_apachelibdir},%{_i
        swig_pydir=%{py_sitedir}/libsvn \
        swig_pydir_extra=%{py_sitedir}/svn
 
+%if ! %{with net_client_only}
+%{__make} install-swig-pl-lib \
+       LC_ALL=C \
+       DESTDIR=$RPM_BUILD_ROOT
+%{__make} -C subversion/bindings/swig/perl install \
+       DESTDIR=$RPM_BUILD_ROOT
+%endif
+
 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/65_mod_dav_svn.conf
 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/66_mod_authz_svn.conf
+install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
+install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
 install doc/programmer/design/*.info* $RPM_BUILD_ROOT%{_infodir}/
 
 %if ! %{with net_client_only}
-install tools/cvs2svn/cvs2svn.py       $RPM_BUILD_ROOT%{_bindir}
+install tools/cvs2svn/cvs2svn.py       $RPM_BUILD_ROOT%{_bindir}/cvs2svn
 install tools/cvs2svn/cvs2svn.1                $RPM_BUILD_ROOT%{_mandir}/man1
 cp tools/cvs2svn/README tools/cvs2svn/README.cvs2svn
 
@@ -274,18 +335,32 @@ rm -rf $RPM_BUILD_ROOT
 %post  libs -p /sbin/ldconfig
 %postun        libs -p /sbin/ldconfig
 
+%post svnserve
+if [ -f /var/lock/subsys/svnserve ]; then
+       /etc/rc.d/init.d/svnserve restart 1>&2
+else
+       echo "Run \"/etc/rc.d/init.d/svnserve start\" to start subversion svnserve daemon."
+fi
+
+%preun svnserve
+if [ "$1" = "0" ]; then
+       if [ -f /var/lock/subsys/svnserve ]; then
+               /etc/rc.d/init.d/svnserve restart 1>&2
+       fi
+fi
+
 %post -n apache-mod_dav_svn
 if [ -f /var/lock/subsys/httpd ]; then
-        /etc/rc.d/init.d/httpd restart 1>&2
+       /etc/rc.d/init.d/httpd restart 1>&2
 else
-        echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
+       echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
 fi
 
 %preun -n apache-mod_dav_svn
 if [ "$1" = "0" ]; then
-        if [ -f /var/lock/subsys/httpd ]; then
-                /etc/rc.d/init.d/httpd restart 1>&2
-        fi
+       if [ -f /var/lock/subsys/httpd ]; then
+               /etc/rc.d/init.d/httpd restart 1>&2
+       fi
 fi
 
 %files
@@ -295,8 +370,11 @@ fi
 %doc tools/hook-scripts/*.{pl,py,example}
 %doc tools/hook-scripts/mailer/*.{py,example}
 %attr(755,root,root) %{_bindir}/svn*
-#%exclude %{_bindir}/svn-config
+%exclude %{_bindir}/svnserve
 %{_mandir}/man1/*
+%{_mandir}/man5/*
+%{_mandir}/man8/*
+%exclude %{_mandir}/man?/svnserve*
 %{?with_internal_neon:%exclude %{_mandir}/man1/neon*}
 
 %files libs
@@ -306,7 +384,6 @@ fi
 %files devel
 %defattr(644,root,root,755)
 %{_includedir}/%{name}*
-#%attr(755,root,root) %{_bindir}/svn-config
 %attr(755,root,root) %{_libdir}/lib*.so
 %{_libdir}/lib*.la
 %{_infodir}/svn*
@@ -316,6 +393,13 @@ fi
 %{_libdir}/lib*.a
 
 %if ! %{with net_client_only}
+%files svnserve
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/svnserve
+%{_mandir}/man?/svnserve*
+%attr(754,root,root) /etc/rc.d/init.d/svnserve
+%attr(640,root,root) %config(noreplace) %verify(not mtime md5 size) /etc/sysconfig/svnserve
+
 %files tools
 %defattr(644,root,root,755)
 %doc tools/cvs2svn/README*
@@ -331,6 +415,15 @@ fi
 %{py_sitedir}/libsvn/*.py[co]
 %attr(755,root,root) %{py_sitedir}/libsvn/*.so
 
+%files -n perl-subversion
+%defattr(644,root,root,755)
+%{perl_vendorarch}/SVN
+%dir %{perl_vendorarch}/auto/SVN
+%dir %{perl_vendorarch}/auto/SVN/*
+%attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
+%{perl_vendorarch}/auto/SVN/*/*.bs
+%{_mandir}/man3/*.3pm*
+
 %files -n apache-mod_dav_svn
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/httpd.conf/*_mod_dav_svn.conf
@@ -341,5 +434,4 @@ fi
 %doc subversion/mod_authz_svn/INSTALL
 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/httpd.conf/*_mod_authz_svn.conf
 %attr(755,root,root) %{_apachelibdir}/mod_authz_svn.so
-
 %endif
This page took 0.045796 seconds and 4 git commands to generate.