]> git.pld-linux.org Git - packages/subversion.git/blobdiff - subversion.spec
- updated/new for 0.34.0
[packages/subversion.git] / subversion.spec
index 49cb3c113ad55f3613dad2c836cb2353902e03ce..b0c60a279547e736d9b2c8c260032d72faa6c595 100644 (file)
@@ -6,34 +6,35 @@
 %bcond_with    internal_neon           # build with internal neon
 %bcond_with    net_client_only         # build only net client
 #      
-%include        /usr/lib/rpm/macros.python
+%include       /usr/lib/rpm/macros.python
 %{!?with_net_client_only:%include      /usr/lib/rpm/macros.perl}
 Summary:       A Concurrent Versioning system similar to but better than CVS
 Summary(pl):   System kontroli wersji podobny, ale lepszy, ni¿ CVS
 Summary(pt_BR):        Sistema de versionamento concorrente
 Name:          subversion
-Version:       0.33.1
-Release:       4
+Version:       0.34.0
+Release:       1
 License:       Apache/BSD Style
 Group:         Development/Version Control
 Source0:       http://svn.collab.net/tarballs/%{name}-%{version}.tar.gz
-# Source0-md5: 2d45e838243cb0bc71c80582d089be15
+# Source0-md5: 52f3a73858566d4d7045e449d94390e3
 Source1:       %{name}-dav_svn.conf
 Source2:       %{name}-authz_svn.conf
 Source3:       %{name}-svnserve.init
 Source4:       %{name}-svnserve.sysconfig
 Patch0:                %{name}-perl.patch
+Patch1:                %{name}-svnlook.patch
 URL:           http://subversion.tigris.org/
 %if %{with net_client_only}
 %global apache_modules_api 0
 %else
 BuildRequires: apache-devel >= 2.0.47-0.6
-BuildRequires:  db-devel >= 4.1.25
-BuildRequires:  rpmbuild(macros) >= 1.120
-BuildRequires:  swig >= 1.3.17
-BuildRequires:  swig-python >= 1.3.17
+BuildRequires: db-devel >= 4.1.25
+BuildRequires: rpmbuild(macros) >= 1.120
+BuildRequires: swig >= 1.3.17
+BuildRequires: swig-python >= 1.3.17
 BuildRequires: perl-devel >= 5.8.0
-BuildRequires:  rpm-perlprov
+BuildRequires: rpm-perlprov
 %endif
 BuildRequires: apr-devel >= 1:0.9.5
 BuildRequires: apr-util-devel >= 1:0.9.5
@@ -44,8 +45,8 @@ BuildRequires:        expat-devel
 BuildRequires: libtool >= 1.4-9
 BuildRequires: libxslt-progs
 %{!?with_internal_neon:BuildRequires:  neon-devel >= 0.24.1}
-BuildRequires:  python >= 2.2
-BuildRequires:  rpm-pythonprov >= 4.0.2-50
+BuildRequires: python >= 2.2
+BuildRequires: rpm-pythonprov >= 4.0.2-50
 BuildRequires: texinfo
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -145,8 +146,8 @@ Este pacote prov
 Summary:       Subversion svnserve
 Summary(pl):   Subversion svnserve
 Group:         Networking/Daemons
-PreReq:         rc-scripts
-Requires(post,preun):   /sbin/chkconfig
+PreReq:                rc-scripts
+Requires(post,preun):  /sbin/chkconfig
 
 %description svnserve
 Subversion svnserve server.
@@ -169,7 +170,6 @@ Subversion tools and scripts.
 %description tools -l pl
 Narzêdzia oraz skrypty dla subversion.
 
-
 %package -n python-subversion
 Summary:       Subversion python bindings
 Summary(pl):   Dowi±zania do subversion dla pythona
@@ -234,6 +234,7 @@ Modu
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p0
 
 %build
 chmod +x ./autogen.sh && ./autogen.sh
@@ -265,12 +266,12 @@ chmod +x ./autogen.sh && ./autogen.sh
 # perl
 bdir=$(pwd)
 %{__make} install-swig-pl-lib \
-        LC_ALL=C \
-        DESTDIR=${bdir}/swig-pl-lib-buildroot
+       LC_ALL=C \
+       DESTDIR=${bdir}/swig-pl-lib-buildroot
 %{__make}
 cd subversion/bindings/swig/perl
 env APR_CONFIG=%{_bindir}/apr-config \
-        %{__perl} Makefile.PL \
+       %{__perl} Makefile.PL \
        INSTALLDIRS=vendor
 env LIBRARY_PATH=${bdir}/swig-pl-lib-buildroot%{_libdir} %{__make}
 cd ../../../../
@@ -279,8 +280,8 @@ cd ../../../../
 # build documentation; build process for documentation is severely
 # braindamaged -- authors suggests to untar docbook distribution in
 # build directory, hence the hack here
-%{__make} -C doc/book all-html \
-       XSL_DIR=/usr/share/sgml/docbook/xsl-stylesheets/
+ln -s /usr/share/sgml/docbook/xsl-stylesheets doc/book/tools/xsl
+%{__make} -C doc/book all-html
 
 # prepare for %%doc below
 mv -f doc/book/book/html-chunk svn-handbook
@@ -336,33 +337,32 @@ rm -rf $RPM_BUILD_ROOT
 
 %post svnserve
 if [ -f /var/lock/subsys/svnserve ]; then
-        /etc/rc.d/init.d/svnserve restart 1>&2
+       /etc/rc.d/init.d/svnserve restart 1>&2
 else
-        echo "Run \"/etc/rc.d/init.d/svnserve start\" to start subversion svnserve daemon."
+       echo "Run \"/etc/rc.d/init.d/svnserve start\" to start subversion svnserve daemon."
 fi
 
 %preun svnserve
 if [ "$1" = "0" ]; then
-        if [ -f /var/lock/subsys/svnserve ]; then
-                /etc/rc.d/init.d/svnserve restart 1>&2
-        fi
+       if [ -f /var/lock/subsys/svnserve ]; then
+               /etc/rc.d/init.d/svnserve restart 1>&2
+       fi
 fi
 
 %post -n apache-mod_dav_svn
 if [ -f /var/lock/subsys/httpd ]; then
-        /etc/rc.d/init.d/httpd restart 1>&2
+       /etc/rc.d/init.d/httpd restart 1>&2
 else
-        echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
+       echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
 fi
 
 %preun -n apache-mod_dav_svn
 if [ "$1" = "0" ]; then
-        if [ -f /var/lock/subsys/httpd ]; then
-                /etc/rc.d/init.d/httpd restart 1>&2
-        fi
+       if [ -f /var/lock/subsys/httpd ]; then
+               /etc/rc.d/init.d/httpd restart 1>&2
+       fi
 fi
 
-
 %files
 %defattr(644,root,root,755)
 %doc BUGS CHANGES COPYING INSTALL README
@@ -384,7 +384,6 @@ fi
 %files devel
 %defattr(644,root,root,755)
 %{_includedir}/%{name}*
-#%attr(755,root,root) %{_bindir}/svn-config
 %attr(755,root,root) %{_libdir}/lib*.so
 %{_libdir}/lib*.la
 %{_infodir}/svn*
@@ -401,7 +400,6 @@ fi
 %attr(754,root,root) /etc/rc.d/init.d/svnserve
 %attr(640,root,root) %config(noreplace) %verify(not mtime md5 size) /etc/sysconfig/svnserve
 
-
 %files tools
 %defattr(644,root,root,755)
 %doc tools/cvs2svn/README*
@@ -436,5 +434,4 @@ fi
 %doc subversion/mod_authz_svn/INSTALL
 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/httpd.conf/*_mod_authz_svn.conf
 %attr(755,root,root) %{_apachelibdir}/mod_authz_svn.so
-
 %endif
This page took 0.053212 seconds and 4 git commands to generate.