]> git.pld-linux.org Git - packages/subversion.git/blobdiff - subversion.spec
- prepare for final 1.5.0 (rc4 for now); run test suite when building
[packages/subversion.git] / subversion.spec
index f56c826a2f2e216aaa5cb5c9869552a1f1d6b4de..361e74628138848418859e0408b0ed4a4376542b 100644 (file)
@@ -4,31 +4,35 @@
 #
 # Conditional build:
 %bcond_with    net_client_only                 # build only net client
-%bcond_without python                          # build without python bindings
+%bcond_without python                          # build without python bindings (broken)
 %bcond_without perl                            # build without perl bindings
 %bcond_without apache                          # build without apache support (webdav, etc)
+%bcond_without tests
 #
 %{!?with_net_client_only:%include      /usr/lib/rpm/macros.perl}
 %define        apxs    /usr/sbin/apxs
 %define        pdir    SVN
 %define        pnam    _Core
+#
+%define        snap    rc4
 Summary:       A Concurrent Versioning system similar to but better than CVS
 Summary(pl.UTF-8):     System kontroli wersji podobny, ale lepszy, niż CVS
 Summary(pt_BR.UTF-8):  Sistema de versionamento concorrente
 Name:          subversion
-Version:       1.4.3
-Release:       2
-License:       Apache/BSD Style
+Version:       1.5.0
+Release:       0.%{snap}.1
+License:       Apache/BSD-like
 Group:         Development/Version Control
-Source0:       http://subversion.tigris.org/downloads/%{name}-%{version}.tar.gz
-# Source0-md5: 6b991b63e3e1f69670c9e15708e40176
+# Source0:     http://subversion.tigris.org/downloads/%{name}-%{version}.tar.gz
+Source0:       http://orac.ece.utexas.edu/pub/svn/%{version}-%{snap}/leander-hackberry/%{name}-%{version}-%{snap}.tar.gz
+# Source0-md5: 905fc5030be179d4d387803b8397668a
 Source1:       %{name}-dav_svn.conf
 Source2:       %{name}-authz_svn.conf
 Source3:       %{name}-svnserve.init
 Source4:       %{name}-svnserve.sysconfig
+Source5:       %{name}-convert-typemaps-to-ifdef.py
 Patch0:                %{name}-home_etc.patch
 Patch1:                %{name}-DESTDIR.patch
-Patch2:                %{name}-neon.patch
 URL:           http://subversion.tigris.org/
 %if %{with net_client_only}
 %global apache_modules_api 0
@@ -47,26 +51,26 @@ BuildRequires:      apr-devel >= 1:1.0.0
 BuildRequires: apr-util-devel >= 1:1.2.8-3
 BuildRequires: autoconf >= 2.59
 BuildRequires: bison
+BuildRequires: cyrus-sasl-devel
 BuildRequires: expat-devel
 BuildRequires: gettext-devel
 BuildRequires: libtool >= 1.4-9
 BuildRequires: neon-devel >= 0.26.0
-%if %{with python}
 BuildRequires: python >= 2.2
-BuildRequires: python-devel >= 2.2
 BuildRequires: python-modules >= 2.2
+%if %{with python}
+BuildRequires: python-devel >= 2.2
 BuildRequires: sed >= 4.0
 BuildRequires: swig-python >= 1.3.24
 %endif
 BuildRequires: texinfo
 BuildRequires: which
-# update -neon patch before messing with this BC
-BuildConflicts:        neon-devel > 0.26.3
 Requires:      %{name}-libs = %{version}-%{release}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _apachelibdir   %(%{apxs} -q LIBEXECDIR 2>/dev/null)
 %define                _libexecdir             %{_libdir}/svn
+%define                apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
+%define                apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
 
 %description
 The goal of the Subversion project is to build a version control
@@ -93,12 +97,12 @@ zamiennika dla CVS.
 
 Cele projektu to:
 - Wszystkie aktualne możliwości CVS.
-- Katalogi, zmiany nazw oraz meta-dane plików są wersjonowane.
-- Wsparcie dla linków symbolicznych itp.
+- Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
+- Obsługa dowiązań symbolicznych itp.
 - Commity są w pełni atomowe.
 - Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
-- Powtarzające merge.
-- Wsparcie dla pluginów diff'a po stronie klienta.
+- Dobra obsługa powtarzanego łączenia (merge).
+- Obsługa wtyczek diff po stronie klienta.
 - Natywny klient/serwer.
 - Klient/Serwer przesyłają diffy w obu kierunkach.
 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
@@ -114,7 +118,7 @@ System) na comunidade opensource, fornecendo grandes melhorias.
 Summary:       Subversion libraries and modules
 Summary(pl.UTF-8):     Biblioteka subversion oraz ładowalne moduły
 Group:         Libraries
-Requires:      neon >= 0.24.7
+Requires:      neon >= 0.26.0
 Obsoletes:     libsubversion0
 
 %description libs
@@ -130,7 +134,7 @@ Summary(pt_BR.UTF-8):       Arquivos de desenvolvimento para o Subversion
 Group:         Development/Libraries
 Requires:      %{name}-libs = %{version}-%{release}
 Requires:      apr-util-devel >= 1:1.0.0
-Requires:      neon-devel >= 0.24.7
+Requires:      neon-devel >= 0.26.0
 Obsoletes:     libsubversion0-devel
 
 %description devel
@@ -267,20 +271,21 @@ Apache module: Subversion Server - path-based authorization.
 Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
 
 %prep
-%setup -q
+%setup -q -n %{name}-%{version}-%{snap}
 rm -rf apr apr-util neon
 %patch0 -p0
 %patch1 -p1
-%patch2 -p1
 
 %build
+rm subversion/bindings/swig/proxy/*.swg 
+cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
 cp -f /usr/share/automake/config.sub ac-helpers
 chmod +x ./autogen.sh && ./autogen.sh
 
 # don't enable dso - currently it's broken
 %configure \
        --with-editor=vi \
-       --with-zlib \
+       --with-zlib=%{_libdir} \
        --with-python=%{_bindir}/python \
        --with-perl5=%{_bindir}/perl \
 %if %{with net_client_only}
@@ -327,10 +332,14 @@ cd $odir
 %endif
 %endif
 
+%if %{with tests}
+%{__make} check
+%endif
+
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
-       $RPM_BUILD_ROOT{%{_sysconfdir}/httpd/httpd.conf,%{_apachelibdir},%{_infodir}} \
+       $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
        $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
        $RPM_BUILD_ROOT/home/services/subversion{,/repos}
 
@@ -356,8 +365,8 @@ cd $odir
 %endif
 
 %if %{with apache}
-install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/65_mod_dav_svn.conf
-install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/66_mod_authz_svn.conf
+install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
+install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
 %endif
@@ -382,11 +391,11 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/lib*swig*.la
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post devel
-[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
+%post devel    -p      /sbin/postshell
+-/usr/sbin/fix-info-dir -c %{_infodir}
 
-%postun devel
-[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
+%postun devel  -p      /sbin/postshell
+-/usr/sbin/fix-info-dir -c %{_infodir}
 
 %post  libs -p /sbin/ldconfig
 %postun        libs -p /sbin/ldconfig
@@ -497,14 +506,14 @@ fi
 %if %{with apache}
 %files -n apache-mod_dav_svn
 %defattr(644,root,root,755)
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd/httpd.conf/*_mod_dav_svn.conf
-%attr(755,root,root) %{_apachelibdir}/mod_dav_svn.so
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
+%attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
 
 %files -n apache-mod_authz_svn
 %defattr(644,root,root,755)
 %doc subversion/mod_authz_svn/INSTALL
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd/httpd.conf/*_mod_authz_svn.conf
-%attr(755,root,root) %{_apachelibdir}/mod_authz_svn.so
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
+%attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
 %endif
 
 %endif # net_client_only
This page took 0.09923 seconds and 4 git commands to generate.