]> git.pld-linux.org Git - packages/subversion.git/blobdiff - subversion.spec
- up to 1.6.13
[packages/subversion.git] / subversion.spec
index 73df2312388a06053137f54009eeceedff526a99..248ec597e7d9c4d18abb7103685585e54486039d 100644 (file)
 # TODO:
 # - remove net_client_only and add db bcond (then without apache and
 #   without db => net_client_only - spec will be more simpler, I think)
+# - finish ruby
+# - http://subversion.tigris.org/issues/show_bug.cgi?id=2753
 #
 # Conditional build:
-%bcond_with    net_client_only                 # build only net client
-%bcond_without python                          # build without python bindings (broken)
-%bcond_without perl                            # build without perl bindings
-%bcond_without apache                          # build without apache support (webdav, etc)
-%bcond_without javahl                          # build without javahl support (Java high-level bindings)
-%bcond_without tests
+%bcond_with    net_client_only         # build only net client
+%bcond_without neon                    # use serf instead of neon
+%bcond_without python                  # build without python bindings (broken)
+%bcond_without perl                    # build without perl bindings
+%bcond_without ruby                    # build without ruby bindings
+%bcond_without apache                  # build without apache support (webdav, etc)
+%bcond_without javahl                  # build without javahl support (Java high-level bindings)
+%bcond_without tests                   # don't perform "make check"
+%bcond_without kwallet                 # build without kde4 wallet support
+%bcond_without gnome                   # build without gnome keyring support
 #
 %{!?with_net_client_only:%include      /usr/lib/rpm/macros.perl}
 %define        apxs    /usr/sbin/apxs
 %define        pdir    SVN
 %define        pnam    _Core
 #
-%define        snap    rc4
+%if %{with neon}
+%define        webdavlib       neon
+%else
+%define        webdavlib       serf
+%endif
+#
 Summary:       A Concurrent Versioning system similar to but better than CVS
 Summary(pl.UTF-8):     System kontroli wersji podobny, ale lepszy, niż CVS
 Summary(pt_BR.UTF-8):  Sistema de versionamento concorrente
 Name:          subversion
-Version:       1.5.0
-Release:       0.%{snap}.1
+Version:       1.6.13
+Release:       1
 License:       Apache/BSD-like
 Group:         Development/Version Control
-# Source0:     http://subversion.tigris.org/downloads/%{name}-%{version}.tar.gz
-Source0:       http://orac.ece.utexas.edu/pub/svn/%{version}-%{snap}/leander-hackberry/%{name}-%{version}-%{snap}.tar.gz
-# Source0-md5: 905fc5030be179d4d387803b8397668a
+Source0:       http://subversion.tigris.org/downloads/%{name}-%{version}.tar.bz2
+# Source0-md5: 7ae1c827689f21cf975804005be30aeb
 Source1:       %{name}-dav_svn.conf
 Source2:       %{name}-authz_svn.conf
 Source3:       %{name}-svnserve.init
 Source4:       %{name}-svnserve.sysconfig
+# current subversion tarball has correct *.swg files
+# but after regeneration these are broken again, so
+# we still need this script
 Source5:       %{name}-convert-typemaps-to-ifdef.py
 Patch0:                %{name}-home_etc.patch
 Patch1:                %{name}-DESTDIR.patch
-URL:           http://subversion.tigris.org/
+Patch2:                %{name}-ruby-datadir-path.patch
+URL:           http://subversion.apache.org/
 %if %{with net_client_only}
 %global apache_modules_api 0
 %else
 %{?with_apache:BuildRequires:  apache-devel >= 2.2.0-8}
 BuildRequires: automake
 BuildRequires: db-devel >= 4.1.25
-BuildRequires: rpmbuild(macros) >= 1.268
+BuildRequires: rpmbuild(macros) >= 1.559
 %if %{with perl}
 BuildRequires: perl-devel >= 1:5.8.0
 BuildRequires: rpm-perlprov >= 4.1-13
 BuildRequires: swig-perl >= 1.3.24
 %endif
-%{?with_javahl:BuildRequires:  jdk}
+%if %{with python}
+BuildRequires: python-ctypesgen
+BuildRequires: python-devel >= 2.2
+BuildRequires: swig-python >= 1.3.24
+%endif
+%if %{with ruby}
+BuildRequires: ruby-devel
+BuildRequires: swig-ruby >= 1.3.24
+%endif
+%if %{with javahl}
+BuildRequires: jdk
+%endif
+BuildRequires: cyrus-sasl-devel
 %endif
 BuildRequires: apr-devel >= 1:1.0.0
 BuildRequires: apr-util-devel >= 1:1.2.8-3
 BuildRequires: autoconf >= 2.59
 BuildRequires: bison
-BuildRequires: cyrus-sasl-devel
 BuildRequires: expat-devel
 BuildRequires: gettext-devel
+%{?with_gnome:BuildRequires:   libgnome-keyring-devel}
+%{?with_kwallet:BuildRequires: kde4-kdelibs-devel}
 BuildRequires: libtool >= 1.4-9
-BuildRequires: neon-devel >= 0.26.0
-BuildRequires: python >= 2.2
-BuildRequires: python-modules >= 2.2
-%if %{with python}
-BuildRequires: python-devel >= 2.2
+BuildRequires: pkgconfig
 BuildRequires: sed >= 4.0
-BuildRequires: swig-python >= 1.3.24
-%endif
+BuildRequires: sqlite3-devel >= 3.6.11
 BuildRequires: texinfo
 BuildRequires: which
+%if %{with neon}
+BuildRequires: neon-devel >= 0.26.0
+%else
+BuildRequires: serf-devel
+%endif
+BuildRequires: python >= 2.2
+BuildRequires: python-modules >= 2.2
 Requires:      %{name}-libs = %{version}-%{release}
+%requires_ge   sqlite3
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _libexecdir             %{_libdir}/svn
@@ -120,7 +150,7 @@ System) na comunidade opensource, fornecendo grandes melhorias.
 Summary:       Subversion libraries and modules
 Summary(pl.UTF-8):     Biblioteka subversion oraz ładowalne moduły
 Group:         Libraries
-Requires:      neon >= 0.26.0
+%{?with_neon:Requires: neon >= 0.26.0}
 Obsoletes:     libsubversion0
 
 %description libs
@@ -136,7 +166,7 @@ Summary(pt_BR.UTF-8):       Arquivos de desenvolvimento para o Subversion
 Group:         Development/Libraries
 Requires:      %{name}-libs = %{version}-%{release}
 Requires:      apr-util-devel >= 1:1.0.0
-Requires:      neon-devel >= 0.26.0
+%{?with_neon:Requires: neon-devel >= 0.26.0}
 Obsoletes:     libsubversion0-devel
 
 %description devel
@@ -171,14 +201,14 @@ Summary:  Subversion svnserve
 Summary(pl.UTF-8):     Subversion svnserve
 Group:         Networking/Daemons
 Requires(post,preun):  /sbin/chkconfig
-Requires(postun):       /usr/sbin/groupdel
-Requires(postun):       /usr/sbin/userdel
-Requires(pre):  /bin/id
-Requires(pre):  /usr/bin/getgid
-Requires(pre):  /usr/lib/rpm/user_group.sh
-Requires(pre):  /usr/sbin/groupadd
-Requires(pre):  /usr/sbin/useradd
-Requires(pre):  /usr/sbin/usermod
+Requires(postun):      /usr/sbin/groupdel
+Requires(postun):      /usr/sbin/userdel
+Requires(pre): /bin/id
+Requires(pre): /usr/bin/getgid
+Requires(pre): /usr/lib/rpm/user_group.sh
+Requires(pre): /usr/sbin/groupadd
+Requires(pre): /usr/sbin/useradd
+Requires(pre): /usr/sbin/usermod
 Requires:      %{name} = %{version}-%{release}
 Requires:      rc-scripts
 Provides:      group(svn)
@@ -197,7 +227,6 @@ Summary(pt_BR.UTF-8):       Módulos python para acessar os recursos do Subversion
 Group:         Applications
 %pyrequires_eq python
 Requires:      %{name} = %{version}-%{release}
-Requires:      python-rcsparse >= 0.1-0.20031026.0
 Requires:      python-subversion = %{version}
 
 %description tools
@@ -221,7 +250,8 @@ Bash completion for subversion.
 Dopełnienia basha dla subversion.
 
 %package -n java-subversion
-Summary:       Subversion java bindings
+Summary:       Subversion Java bindings
+Summary(pl.UTF-8):     Dowiązania do Subversion dla Javy
 Group:         Development/Languages/Java
 Requires:      %{name}-libs = %{version}-%{release}
 
@@ -232,40 +262,80 @@ to, for example, write a Java class that manipulates a Subversion
 repository or working copy. See the 'subversion' package for more
 information.
 
+%description -n java-subversion -l pl.UTF-8
+Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
+subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
+pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
+roboczą. Więcej informacji w pakiecie subversion.
+
 %package -n python-subversion
-Summary:       Subversion python bindings
-Summary(pl.UTF-8):     Dowiązania do subversion dla pythona
-Summary(pt_BR.UTF-8):  Módulos python para acessar os recursos do Subversion
+Summary:       Subversion Python bindings
+Summary(pl.UTF-8):     Dowiązania do Subversion dla Pythona
+Summary(pt_BR.UTF-8):  Módulos Python para acessar os recursos do Subversion
 Group:         Development/Languages/Python
 %pyrequires_eq python
 Requires:      %{name}-libs = %{version}-%{release}
 Obsoletes:     subversion-python
 
 %description -n python-subversion
-Subversion python bindings.
+Subversion Python bindings.
 
 %description -n python-subversion -l pl.UTF-8
-Dowiązania do subversion dla pythona.
+Dowiązania do Subversion dla Pythona.
 
 %description -n python-subversion -l pt_BR.UTF-8
-Módulos python para acessar os recursos do Subversion.
+Módulos Python para acessar os recursos do Subversion.
+
+%package -n python-csvn
+Summary:       CTypes Subversion Python bindings
+Summary(pl.UTF-8):     Dowiązania do Subversion dla Pythona
+Summary(pt_BR.UTF-8):  Módulos Python para acessar os recursos do Subversion
+Group:         Development/Languages/Python
+%pyrequires_eq python
+Requires:      %{name}-libs = %{version}-%{release}
+
+%description -n python-csvn
+Subversion CTypes Python bindings.
+
+%description -n python-csvn -l pl.UTF-8
+Dowiązania do Subversion dla Pythona używające CTypes.
+
+%description -n python-csvn -l pt_BR.UTF-8
+Módulos Python para acessar os recursos do Subversion.
 
 %package -n perl-subversion
-Summary:       Subversion perl bindings
-Summary(pl.UTF-8):     Dowiązania do subversion dla perla
-Summary(pt_BR.UTF-8):  Módulos perl para acessar os recursos do Subversion
+Summary:       Subversion Perl bindings
+Summary(pl.UTF-8):     Dowiązania do Subversion dla Perla
+Summary(pt_BR.UTF-8):  Módulos Perl para acessar os recursos do Subversion
 Group:         Development/Languages/Perl
 Requires:      %{name}-libs = %{version}-%{release}
 Obsoletes:     subversion-perl
 
 %description -n perl-subversion
-Subversion perl bindings.
+Subversion Perl bindings.
 
 %description -n perl-subversion -l pl.UTF-8
-Dowiązania do subversion dla perl.
+Dowiązania do Subversion dla Perla.
 
 %description -n perl-subversion -l pt_BR.UTF-8
-Módulos perl para acessar os recursos do Subversion.
+Módulos Perl para acessar os recursos do Subversion.
+
+%package -n ruby-subversion
+Summary:       Subversion Ruby bindings
+Summary(pl.UTF-8):     Dowiązania do Subversion dla języka Ruby
+Summary(pt_BR.UTF-8):  Módulos Ruby para acessar os recursos do Subversion
+Group:         Development/Languages
+Requires:      %{name}-libs = %{version}-%{release}
+Obsoletes:     subversion-ruby
+
+%description -n ruby-subversion
+Subversion Ruby bindings.
+
+%description -n ruby-subversion -l pl.UTF-8
+Dowiązania do Subversion dla języka Ruby.
+
+%description -n ruby-subversion -l pt_BR.UTF-8
+Módulos Ruby para acessar os recursos do Subversion.
 
 %package -n apache-mod_dav_svn
 Summary:       Apache module: Subversion Server
@@ -294,76 +364,132 @@ Apache module: Subversion Server - path-based authorization.
 %description -n apache-mod_authz_svn -l pl.UTF-8
 Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
 
+%package -n gnome-keyring-subversion
+Summary:       Subversion module for Gnome Keyring
+Summary(pl.UTF-8):     Moduł subversion dla zarządcy kluczy Gnome
+Group:         X11/Applications
+
+%description -n gnome-keyring-subversion
+Subversion module for Gnome Keyring.
+
+%description -n gnome-keyring-subversion -l pl.UTF-8
+Moduł subversion dla zarządcy kluczy Gnome.
+
+%package -n kde4-kwallet-subversion
+Summary:       Subversion module for KDE Wallet
+Summary(pl.UTF-8):     Moduł subversion dla Portfela KDE
+Group:         X11/Applications
+
+%description -n kde4-kwallet-subversion
+Subversion module for KDE Wallet.
+
+%description -n kde4-kwallet-subversion -l pl.UTF-8
+Moduł subversion dla Portfela KDE.
+
 %prep
-%setup -q -n %{name}-%{version}-%{snap}
+%setup -q
 rm -rf apr apr-util neon
 %patch0 -p0
 %patch1 -p1
+%patch2 -p0
+
+sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
+
+# serf.m4 macro is broken and ignores --without serf
+%{?with_neon:sed -i -e 's#serf_found="yes"#serf_found="no"#g' build/ac-macros/serf.m4}
 
 %build
-rm subversion/bindings/swig/proxy/*.swg 
+rm subversion/bindings/swig/proxy/*.swg
 cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
 cp -f /usr/share/automake/config.sub ac-helpers
 chmod +x ./autogen.sh && ./autogen.sh
 
-# don't enable dso - currently it's broken
 %configure \
        --with-editor=vi \
        --with-zlib=%{_libdir} \
-       --with-python=%{_bindir}/python \
-       --with-perl5=%{_bindir}/perl \
 %if %{with net_client_only}
        --without-apache \
        --without-swig \
        --without-apxs \
        --without-berkeley-db \
 %else
-       --disable-dso \
+       --disable-runtime-module-search \
        --disable-mod-activation \
+       --with-berkeley-db="db.h:%{_includedir}:%{_libdir}:db" \
 %if %{with apache}
        --with-apxs=%{_sbindir}/apxs \
 %else
        --without-apache \
        --without-apxs \
-       --with-berkeley-db=%{_includedir}/db4:%{_libdir} \
 %endif
-%if !%{with python} && !%{with perl}
+%if !%{with python} && !%{with perl} && !%{with ruby}
        --without-swig \
 %endif
+       %{?with_python:--with-ctypesgen=%{_bindir}/ctypesgen.py} \
        --%{?with_javahl:en}%{!?with_javahl:dis}able-javahl \
 %endif
        --with-jdk="%{java_home}" \
+       --without-jikes \
+%if %{with neon}
+       --without-serf \
        --with-neon=%{_prefix} \
        --disable-neon-version-check \
+%else
+       --with-serf=%{_prefix} \
+       --without-neon \
+%endif
        --with-apr=%{_bindir}/apr-1-config \
-       --with-apr-util=%{_bindir}/apu-1-config
+       --with-apr-util=%{_bindir}/apu-1-config \
+%if %{with kwallet}
+       --with-kwallet \
+%endif
+%if %{with gnome}
+       --with-gnome-keyring
+%endif
 
 %{__make} -j1
 
 %if !%{with net_client_only}
 # python
 %if %{with python}
+# ctypes bindings
+%{__make} ctypes-python
+# swig bindings
 %{__make} swig-py \
        swig_pydir=%{py_sitedir}/libsvn \
        swig_pydir_extra=%{py_sitedir}/svn
 %endif
 # perl
 %if %{with perl}
-%{__make} swig-pl-lib
+%{__make} -j1 swig-pl-lib
 odir=$(pwd)
 cd subversion/bindings/swig/perl/native
 %{__perl} Makefile.PL INSTALLDIRS=vendor
-%{__make}
+%{__make} -j1
 cd $odir
 %endif
 %if %{with javahl}
-%{__make} javahl \
+%{__make} -j1 javahl \
        javahl_javadir="%{_javadir}"
 %endif
+# ruby
+%if %{with ruby}
+%{__make} swig-rb
+%endif
 %endif
 
 %if %{with tests}
 %{__make} check
+%if %{with python}
+%{__make} check-ctypes-python
+%{__make} check-swig-py
+%endif
+%if %{with perl}
+%{__make} check-swig-pl
+%endif
+%if %{with ruby}
+%{__make} check-swig-rb
+%endif
 %endif
 
 %install
@@ -378,8 +504,14 @@ install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
        install-javahl \
        javahl_javadir="%{_javadir}" \
 %endif
-%if !%{with net_client_only} && %{with python}
+%if !%{with net_client_only}
+%if %{with python}
        install-swig-py \
+       install-ctypes-python \
+%endif
+%if %{with ruby}
+       install-swig-rb install-swig-rb-doc \
+%endif
 %endif
        APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
        DESTDIR=$RPM_BUILD_ROOT \
@@ -389,13 +521,10 @@ install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
 %if !%{with net_client_only} && %{with perl}
 %{__make} install-swig-pl-lib \
        DESTDIR=$RPM_BUILD_ROOT
-odir=$(pwd)
-cd subversion/bindings/swig/perl/native
-%{__make} install \
+%{__make} -C subversion/bindings/swig/perl/native install \
        DESTDIR=$RPM_BUILD_ROOT \
        PREFIX=$RPM_BUILD_ROOT%{_prefix} \
        LIBDIR=$RPM_BUILD_ROOT%{_libdir}
-cd $odir
 %endif
 
 %if %{with apache}
@@ -420,7 +549,9 @@ install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
 %find_lang %{name}
 
-rm -f $RPM_BUILD_ROOT%{_libdir}/lib*swig*.la
+%{?with_javahl:rm $RPM_BUILD_ROOT%{_libdir}/libsvnjavahl*.{la,a}}
+rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn_swig*.{la,a}
+rm -f $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/*/svn/ext/*.la
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -429,16 +560,20 @@ rm -rf $RPM_BUILD_ROOT
 %groupadd -g 86 svn
 %useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
 
-%post devel    -p      /sbin/postshell
+%post  libs -p /sbin/ldconfig
+%postun        libs -p /sbin/ldconfig
+
+%post  devel -p /sbin/postshell
 -/usr/sbin/fix-info-dir -c %{_infodir}
 
-%postun devel  -p      /sbin/postshell
+%postun        devel -p /sbin/postshell
 -/usr/sbin/fix-info-dir -c %{_infodir}
 
-%post  libs -p /sbin/ldconfig
-%postun        libs -p /sbin/ldconfig
-%post   -n python-subversion -p /sbin/ldconfig
-%postun -n perl-subversion -p /sbin/ldconfig
+%post  -n perl-subversion -p /sbin/ldconfig
+%postun        -n perl-subversion -p /sbin/ldconfig
+
+%post  -n python-subversion -p /sbin/ldconfig
+%postun        -n python-subversion -p /sbin/ldconfig
 
 %post svnserve
 /sbin/chkconfig --add svnserve
@@ -459,7 +594,15 @@ fi
 %post -n apache-mod_dav_svn
 %service -q httpd restart
 
-%preun -n apache-mod_dav_svn
+%postun -n apache-mod_dav_svn
+if [ "$1" = "0" ]; then
+       %service -q httpd restart
+fi
+
+%post -n apache-mod_authz_svn
+%service -q httpd restart
+
+%postun -n apache-mod_authz_svn
 if [ "$1" = "0" ]; then
        %service -q httpd restart
 fi
@@ -471,50 +614,120 @@ fi
 %doc tools/hook-scripts/*.{pl,py,example}
 %doc tools/hook-scripts/mailer/*.{py,example}
 %doc tools/xslt/*
-%attr(755,root,root) %{_bindir}/svn*
-%exclude %{_bindir}/svnserve
-%if !%{with net_client_only}
-%exclude %{_bindir}/svn-hot-backup
-%endif
-%{_mandir}/man1/*
-%{_mandir}/man5/*
-%{_mandir}/man8/*
-%exclude %{_mandir}/man?/svnserve*
+%attr(755,root,root) %{_bindir}/svn
+%attr(755,root,root) %{_bindir}/svnadmin
+%attr(755,root,root) %{_bindir}/svndumpfilter
+%attr(755,root,root) %{_bindir}/svnlook
+%attr(755,root,root) %{_bindir}/svnsync
+%attr(755,root,root) %{_bindir}/svnversion
+%{_mandir}/man1/svn.1*
+%{_mandir}/man1/svnadmin.1*
+%{_mandir}/man1/svndumpfilter.1*
+%{_mandir}/man1/svnlook.1*
+%{_mandir}/man1/svnsync.1*
+%{_mandir}/man1/svnversion.1*
 
 %files libs -f %{name}.lang
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/lib*.so.*
-%if %{with perl} || %{with python}
-%exclude %{_libdir}/lib*_swig_*.so.*
-%endif
-%if %{with javahl}
-%exclude %{_libdir}/libsvnjavahl*.so.*.*.*
-%exclude %{_libdir}/libsvnjavahl*.so.?
-%exclude %{_libdir}/libsvnjavahl*.so
-%endif
+%attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
+%attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
+%attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
+%attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
+%attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
+%attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
+%attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
+%attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
+%attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
+%attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_%{webdavlib}-1.so.0
+%attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
+%attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
+%attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
+%attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
 
 %files devel
 %defattr(644,root,root,755)
-%{_includedir}/%{name}*
-%attr(755,root,root) %{_libdir}/lib*.so
-%{_libdir}/lib*.la
-%if %{with perl} || %{with python}
-%exclude %{_libdir}/lib*_swig_*.so
-%endif
-%if %{with javahl}
-%exclude %{_libdir}/libsvnjavahl*.so
-%endif
+%attr(755,root,root) %{_libdir}/libsvn_client-1.so
+%attr(755,root,root) %{_libdir}/libsvn_delta-1.so
+%attr(755,root,root) %{_libdir}/libsvn_diff-1.so
+%attr(755,root,root) %{_libdir}/libsvn_fs-1.so
+%attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
+%attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
+%attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
+%attr(755,root,root) %{_libdir}/libsvn_ra-1.so
+%attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
+%attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so
+%attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
+%attr(755,root,root) %{_libdir}/libsvn_repos-1.so
+%attr(755,root,root) %{_libdir}/libsvn_subr-1.so
+%attr(755,root,root) %{_libdir}/libsvn_wc-1.so
+%{_libdir}/libsvn_client-1.la
+%{_libdir}/libsvn_delta-1.la
+%{_libdir}/libsvn_diff-1.la
+%{_libdir}/libsvn_fs-1.la
+%{_libdir}/libsvn_fs_base-1.la
+%{_libdir}/libsvn_fs_fs-1.la
+%{_libdir}/libsvn_fs_util-1.la
+%{_libdir}/libsvn_ra-1.la
+%{_libdir}/libsvn_ra_local-1.la
+%{_libdir}/libsvn_ra_%{webdavlib}-1.la
+%{_libdir}/libsvn_ra_svn-1.la
+%{_libdir}/libsvn_repos-1.la
+%{_libdir}/libsvn_subr-1.la
+%{_libdir}/libsvn_wc-1.la
+%{_includedir}/%{name}-1
 %{_examplesdir}/%{name}-%{version}
 
 %files static
 %defattr(644,root,root,755)
-%{_libdir}/lib*.a
+%{_libdir}/libsvn_client-1.a
+%{_libdir}/libsvn_delta-1.a
+%{_libdir}/libsvn_diff-1.a
+%{_libdir}/libsvn_fs-1.a
+%{_libdir}/libsvn_fs_base-1.a
+%{_libdir}/libsvn_fs_fs-1.a
+%{_libdir}/libsvn_fs_util-1.a
+%{_libdir}/libsvn_ra-1.a
+%{_libdir}/libsvn_ra_local-1.a
+%{_libdir}/libsvn_ra_%{webdavlib}-1.a
+%{_libdir}/libsvn_ra_svn-1.a
+%{_libdir}/libsvn_repos-1.a
+%{_libdir}/libsvn_subr-1.a
+%{_libdir}/libsvn_wc-1.a
+
+%if %{with gnome}
+%files -n gnome-keyring-subversion
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libsvn_auth_gnome_keyring-1.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libsvn_auth_gnome_keyring-1.so.0
+%endif
+
+%if %{with kwallet}
+%files -n kde4-kwallet-subversion
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
+%endif
 
 %if !%{with net_client_only}
 %files svnserve
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/svnserve
-%{_mandir}/man?/svnserve*
+%{_mandir}/man5/svnserve.conf.5*
+%{_mandir}/man8/svnserve.8*
 %dir %attr(750,svn,svn) /home/services/subversion
 %dir %attr(750,svn,svn) /home/services/subversion/repos
 %if %{with apache}
@@ -533,9 +746,9 @@ fi
 %if %{with javahl}
 %files -n java-subversion
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libsvnjavahl*.so.*.*.*
-%attr(755,root,root) %{_libdir}/libsvnjavahl*.so.?
-%attr(755,root,root) %{_libdir}/libsvnjavahl*.so
+%attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
+%attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
 %{_javadir}/svn-javahl.jar
 %endif
 
@@ -543,25 +756,55 @@ fi
 %files -n python-subversion
 %defattr(644,root,root,755)
 %doc tools/backup/*.py tools/examples/*.py
-%dir %{py_sitedir}/svn
+%attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
+%attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
 %dir %{py_sitedir}/libsvn
-%{py_sitedir}/svn/*.py[co]
 %{py_sitedir}/libsvn/*.py[co]
+%dir %{py_sitedir}/svn
+%{py_sitedir}/svn/*.py[co]
 %attr(755,root,root) %{py_sitedir}/libsvn/*.so
 %{_examplesdir}/python-%{name}-%{version}
-%attr(755,root,root) %{_libdir}/lib*_swig_py*.so*
+
+%files -n python-csvn
+%defattr(644,root,root,755)
+%doc subversion/bindings/ctypes-python/{README,TODO}
+%doc subversion/bindings/ctypes-python/examples/*.py
+%dir %{py_sitescriptdir}/csvn
+%{py_sitescriptdir}/csvn/*.py[co]
+%dir %{py_sitescriptdir}/csvn/core
+%{py_sitescriptdir}/csvn/core/*.py[co]
+%dir %{py_sitescriptdir}/csvn/ext
+%{py_sitescriptdir}/csvn/ext/*.py[co]
+%{py_sitescriptdir}/*.egg-info
 %endif
 
 %if %{with perl}
 %files -n perl-subversion
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
+%attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
 %{perl_vendorarch}/SVN
 %dir %{perl_vendorarch}/auto/SVN
 %dir %{perl_vendorarch}/auto/SVN/*
 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
 %{perl_vendorarch}/auto/SVN/*/*.bs
 %{_mandir}/man3/*.3pm*
-%attr(755,root,root) %{_libdir}/lib*_swig_perl*.so*
+%endif
+
+%if %{with ruby}
+%files -n ruby-subversion
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
+%attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
+%dir %{ruby_sitelibdir}/svn
+%{ruby_sitelibdir}/svn/*.rb
+%dir %{ruby_sitearchdir}/svn
+%dir %{ruby_sitearchdir}/svn/ext
+%attr(755,root,root) %{ruby_sitearchdir}/svn/ext/*.so
+%{ruby_ridir}/Svn
 %endif
 
 %if %{with apache}
This page took 0.060193 seconds and 4 git commands to generate.