]> git.pld-linux.org Git - packages/strace.git/blobdiff - strace.spec
Release 2 (by relup.sh)
[packages/strace.git] / strace.spec
index f509c1fd29d672e3527d00a6ab7f541448e9a66c..a96f1c613f946caba8186de36081e766829a5cbd 100644 (file)
@@ -1,3 +1,16 @@
+#
+# Conditional build:
+%bcond_without libunwind       # strack tracing using libunwind
+%bcond_without libiberty       # symbol demangling in stack backtraces
+#
+%ifnarch %{ix86} %{x8664} x32 %{arm} hppa ia64 mips ppc ppc64 sh
+%undefine      with_libunwind
+%endif
+
+%ifnarch aarch64
+%define                with_mpers      1
+%endif
+
 Summary:       prints system call strace of a running process
 Summary(de.UTF-8):     druckt ein Protokoll der Systemaufrufe eines laufenden Prozesses
 Summary(es.UTF-8):     Enseña las llamadas de sistema de un proceso en ejecución
@@ -8,21 +21,22 @@ Summary(ru.UTF-8):   Отслеживает и показывает системн
 Summary(tr.UTF-8):     Çalışan bir sürecin yaptığı sistem çağrılarını listeler
 Summary(uk.UTF-8):     Відслідковує та показує системні виклики, пов'язані із запущеним процесом
 Name:          strace
-Version:       4.5.15
+Version:       5.19
 Release:       2
-License:       BSD-like
+License:       LGPL v2.1+
 Group:         Development/Debuggers
-Source0:       http://dl.sourceforge.net/strace/%{name}-%{version}.tar.bz2
-# Source0-md5: ef40944118841803391d212cb64d3c5b
+Source0:       https://github.com/strace/strace/releases/download/v%{version}/%{name}-%{version}.tar.xz
+# Source0-md5: 13a37bd709b452a7c30e89f0db39b535
 Source1:       %{name}.1.pl
-Patch0:                %{name}-newsysc.patch
-Patch1:                %{name}-getdents64.patch
-Patch2:                %{name}-kernel26_userspace.patch
-Patch3:                %{name}-stat64.patch
-Patch4:                %{name}-sparc64.patch
-URL:           http://sourceforge.net/projects/strace/
-BuildRequires: autoconf >= 2.57
-BuildRequires: automake
+Patch0:                %{name}-binutils2.36.patch
+URL:           https://strace.io/
+# acl and libaio for headers only
+BuildRequires: acl-devel
+%{?with_libiberty:BuildRequires:       binutils-devel >= 4:2.30-1}
+BuildRequires: libaio-devel
+%{?with_libunwind:BuildRequires:       libunwind-devel}
+BuildRequires: tar >= 1:1.22
+BuildRequires: xz
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -83,8 +97,8 @@ strace-graph script processes strace -f output. It displays a graph of
 invoked subprocesses, and is useful for finding out what complex
 commands do.
 
-The script can also handle the output with strace -t, -tt, or -ttt.
-It will add elapsed time for each process in that case.
+The script can also handle the output with strace -t, -tt, or -ttt. It
+will add elapsed time for each process in that case.
 
 %description graph -l pl.UTF-8
 Skrypt strace-graph przetwarza wynik strace -f i wyświetla graf
@@ -97,17 +111,19 @@ Doda wtedy upływający czas dla każdego procesu.
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p1
-%patch2 -p1
-%patch3 -p1
-%patch4 -p1
 
 %build
-%{__aclocal}
-%{__autoconf}
-%{__autoheader}
-%{__automake}
-%configure
+%if %{with libunwind}
+# workaround for:
+# /usr/bin/ld: copy reloc against protected `_UPT_accessors' is invalid
+# /usr/bin/ld: failed to set dynamic section sizes: Bad value
+# (should be fixed in gcc >(=?) 5.1)
+CFLAGS="%{rpmcflags} -fPIE"
+%endif
+%configure \
+       %{!?with_libiberty:--without-libiberty} \
+       %{!?with_libunwind:--without-libunwind} \
+        --enable-mpers=%{?with_mpers:yes}%{!?with_mpers:no}
 %{__make}
 
 %install
@@ -118,15 +134,19 @@ rm -rf $RPM_BUILD_ROOT
 
 install -D %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/pl/man1/strace.1
 
+cp -p src/strace-graph $RPM_BUILD_ROOT%{_bindir}
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc COPYRIGHT CREDITS ChangeLog NEWS README-linux TODO
+%doc COPYING CREDITS ChangeLog NEWS doc/README-linux-ptrace
 %attr(755,root,root) %{_bindir}/strace
-%{_mandir}/man1/*
-%lang(pl) %{_mandir}/pl/man1/*
+%attr(755,root,root) %{_bindir}/strace-log-merge
+%{_mandir}/man1/strace.1*
+%{_mandir}/man1/strace-log-merge.1*
+%lang(pl) %{_mandir}/pl/man1/strace.1*
 
 %files graph
 %defattr(644,root,root,755)
This page took 0.036288 seconds and 4 git commands to generate.