]> git.pld-linux.org Git - packages/strace.git/blobdiff - strace.spec
Release 2 (by relup.sh)
[packages/strace.git] / strace.spec
index d883517a90068b085e97cab2188dbc97fc91c484..a96f1c613f946caba8186de36081e766829a5cbd 100644 (file)
@@ -1,3 +1,16 @@
+#
+# Conditional build:
+%bcond_without libunwind       # strack tracing using libunwind
+%bcond_without libiberty       # symbol demangling in stack backtraces
+#
+%ifnarch %{ix86} %{x8664} x32 %{arm} hppa ia64 mips ppc ppc64 sh
+%undefine      with_libunwind
+%endif
+
+%ifnarch aarch64
+%define                with_mpers      1
+%endif
+
 Summary:       prints system call strace of a running process
 Summary(de.UTF-8):     druckt ein Protokoll der Systemaufrufe eines laufenden Prozesses
 Summary(es.UTF-8):     Enseña las llamadas de sistema de un proceso en ejecución
@@ -8,20 +21,22 @@ Summary(ru.UTF-8):   Отслеживает и показывает системн
 Summary(tr.UTF-8):     Çalışan bir sürecin yaptığı sistem çağrılarını listeler
 Summary(uk.UTF-8):     Відслідковує та показує системні виклики, пов'язані із запущеним процесом
 Name:          strace
-Version:       4.6
-Release:       1
-License:       BSD-like
+Version:       5.19
+Release:       2
+License:       LGPL v2.1+
 Group:         Development/Debuggers
-Source0:       http://downloads.sourceforge.net/strace/%{name}-%{version}.tar.xz
-# Source0-md5: e537b2b1afeec70c0e6e27a0d0fd671e
+Source0:       https://github.com/strace/strace/releases/download/v%{version}/%{name}-%{version}.tar.xz
+# Source0-md5: 13a37bd709b452a7c30e89f0db39b535
 Source1:       %{name}.1.pl
-Patch0:                %{name}-stat64.patch
-URL:           http://sourceforge.net/projects/strace/
+Patch0:                %{name}-binutils2.36.patch
+URL:           https://strace.io/
 # acl and libaio for headers only
 BuildRequires: acl-devel
-BuildRequires: autoconf >= 2.57
-BuildRequires: automake
+%{?with_libiberty:BuildRequires:       binutils-devel >= 4:2.30-1}
 BuildRequires: libaio-devel
+%{?with_libunwind:BuildRequires:       libunwind-devel}
+BuildRequires: tar >= 1:1.22
+BuildRequires: xz
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -98,11 +113,17 @@ Doda wtedy upływający czas dla każdego procesu.
 %patch0 -p1
 
 %build
-%{__aclocal} -I m4
-%{__autoconf}
-%{__autoheader}
-%{__automake}
-%configure
+%if %{with libunwind}
+# workaround for:
+# /usr/bin/ld: copy reloc against protected `_UPT_accessors' is invalid
+# /usr/bin/ld: failed to set dynamic section sizes: Bad value
+# (should be fixed in gcc >(=?) 5.1)
+CFLAGS="%{rpmcflags} -fPIE"
+%endif
+%configure \
+       %{!?with_libiberty:--without-libiberty} \
+       %{!?with_libunwind:--without-libunwind} \
+        --enable-mpers=%{?with_mpers:yes}%{!?with_mpers:no}
 %{__make}
 
 %install
@@ -113,14 +134,18 @@ rm -rf $RPM_BUILD_ROOT
 
 install -D %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/pl/man1/strace.1
 
+cp -p src/strace-graph $RPM_BUILD_ROOT%{_bindir}
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc COPYRIGHT CREDITS ChangeLog NEWS README-linux TODO
+%doc COPYING CREDITS ChangeLog NEWS doc/README-linux-ptrace
 %attr(755,root,root) %{_bindir}/strace
+%attr(755,root,root) %{_bindir}/strace-log-merge
 %{_mandir}/man1/strace.1*
+%{_mandir}/man1/strace-log-merge.1*
 %lang(pl) %{_mandir}/pl/man1/strace.1*
 
 %files graph
This page took 0.060336 seconds and 4 git commands to generate.