]> git.pld-linux.org Git - packages/sqlite3.git/blobdiff - sqlite3.spec
- updated to 3.27.0, separte wal replication patch version
[packages/sqlite3.git] / sqlite3.spec
index 9b5a7169ae5b443b6421489a078a9b5b5ce6c9f8..fd967180a8b990132594c1db53029fc21b30b870 100644 (file)
@@ -11,6 +11,7 @@
 %bcond_without unlock_notify   # disable unlock notify API
 %bcond_without load_extension  # enable load extension API
 %bcond_with    icu             # ICU tokenizer support
+%bcond_without wal_replication         # WAL replication support
 
 %ifarch alpha sparc %{x8664}
 %undefine      with_tests
 
 # sqlite3 version with zero padded without any dots (3 08 10 01 is 3.8.10.1)
 # but trailing 00 means no 4rd part (3 11 01 00 is 3.11.1)
-%define                vnum    3230100
+%define                vnum    3270000
 %define                ver             %{lua:vn=rpm.expand("%vnum");v="";for i in string.gmatch(string.format("%08d", vn), "..") do v=v.."."..i:gsub("^0", "");end;v=v:gsub("^.",""):gsub("\.0$","");print(v)}
 
+# wal replication version
+%define                walver  3.26.0
+
 %define                tclver          8.6
 Summary:       SQLite3 library
 Summary(pl.UTF-8):     Biblioteka SQLite3
 Name:          sqlite3
 Version:       %{ver}
-Release:       3
+Release:       1
 License:       Public Domain
 Group:         Libraries
 # Source0Download: http://www.sqlite.org/download.html
-Source0:       http://www.sqlite.org/2018/sqlite-src-%{vnum}.zip
-# Source0-md5: e7932e95208f9fd903f19459e2c09121
+Source0:       http://www.sqlite.org/2019/sqlite-src-%{vnum}.zip
+# Source0-md5: e0fb6e677048c95637fd10408a811011
 Patch0:                %{name}-sign-function.patch
+# https://github.com/CanonicalLtd/dqlite/issues/91
+Patch1:                https://github.com/CanonicalLtd/sqlite/releases/download/version-%{walver}%%2Breplication3/sqlite-%{walver}.diff
+# Patch1-md5:  4a279faaf27e95760b73423875c6d002
 URL:           http://www.sqlite.org/
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
@@ -53,6 +60,7 @@ Requires:     %{name}-libs = %{version}-%{release}
 %{?with_icu:Provides:  %{name}(icu) = %{version}}
 %{?with_load_extension:Provides:       %{name}(load_extension) = %{version}}
 %{?with_unlock_notify:Provides:        %{name}(unlock_notify) = %{version}}
+%{?with_wal_replication:Provides:      %{name}(wal_replication) = %{version}}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _ulibdir        /usr/lib
@@ -89,6 +97,7 @@ Group:                Libraries
 %{?with_icu:Provides:  %{name}-libs(icu) = %{version}}
 %{?with_load_extension:Provides:       %{name}-libs(load_extension) = %{version}}
 %{?with_unlock_notify:Provides:        %{name}-libs(unlock_notify) = %{version}}
+%{?with_wal_replication:Provides:      %{name}-libs(wal_replication) = %{version}}
 Conflicts:     sqlite3 < 3.23.1-2
 
 %description libs
@@ -111,6 +120,7 @@ Provides:   %{name}-devel(load_extension) = %{version}
 %if %{with icu}
 Provides:      %{name}-devel(icu) = %{version}
 %endif
+%{?with_wal_replication:Provides:      %{name}-devel(wal_replication) = %{version}}
 
 %description devel
 SQLite is a C library that implements an SQL database engine. A large
@@ -154,6 +164,7 @@ Provides:   %{name}-static(unlock_notify)
 %if %{with load_extension}
 Provides:      %{name}-static(load_extension)
 %endif
+%{?with_wal_replication:Provides:      %{name}-static(wal_replication)}
 
 %description static
 SQLite is a C library that implements an SQL database engine. A large
@@ -198,6 +209,7 @@ Rozszerzenie sqlite3 dla Tcl.
 %prep
 %setup -q -n sqlite-src-%{vnum}
 %patch0 -p1
+%{?with_wal_replication:%patch1 -p1}
 
 %{__sed} -i 's/mkdir doc/#mkdir doc/' Makefile.in
 
@@ -225,6 +237,9 @@ export TCLLIBDIR="%{tcl_sitearch}/sqlite3"
 
 append-cppflags -DSQLITE_DISABLE_DIRSYNC=1 -DSQLITE_SECURE_DELETE
 
+# Support for optional ORDER BY and LIMIT clause on UPDATE and DELETE statements
+append-cppflags -DSQLITE_ENABLE_UPDATE_DELETE_LIMIT
+
 # Support column metadata functions.
 # http://sqlite.org/c3ref/column_database_name.html
 # http://sqlite.org/c3ref/table_column_metadata.html
@@ -240,6 +255,10 @@ append-cppflags -DSQLITE_ENABLE_FTS3_TOKENIZER
 # http://sqlite.org/rtree.html
 append-cppflags -DSQLITE_ENABLE_RTREE
 
+# Support Geopoly module (new as of 3.25.0)
+# https://www.sqlite.org/geopoly.html
+append-cppflags -DSQLITE_ENABLE_GEOPOLY
+
 # Support soundex() function.
 # http://sqlite.org/lang_corefunc.html#soundex
 #append-cppflags -DSQLITE_SOUNDEX
@@ -248,6 +267,10 @@ append-cppflags -DSQLITE_ENABLE_RTREE
 # https://www.sqlite.org/dbstat.html
 append-cppflags -DSQLITE_ENABLE_DBSTAT_VTAB
 
+# Support for session extension (record changes to a changeset).
+# https://www.sqlite.org/sessionintro.html
+append-cppflags -DSQLITE_ENABLE_SESSION -DSQLITE_ENABLE_PREUPDATE_HOOK
+
 %if %{with unlock_notify}
 # Support unlock notification.
 # http://sqlite.org/unlock_notify.html
@@ -263,6 +286,11 @@ append-libs "-licui18n -licuuc"
 append-libs "-ldl"
 %endif
 
+%if %{with wal_replication}
+# A patched version of SQLite with support for WAL-based replication
+append-cppflags -DSQLITE_ENABLE_WAL_REPLICATION
+%endif
+
 %configure \
        %{?with_readline:--disable-editline} \
        %{!?with_tcl:--disable-tcl}%{?with_tcl:--with-tcl=%{_ulibdir}} \
This page took 0.060224 seconds and 4 git commands to generate.