]> git.pld-linux.org Git - packages/sqlite3.git/blobdiff - sqlite3.spec
- updated to 3.6.21
[packages/sqlite3.git] / sqlite3.spec
index 7884b790aece9ffacaa76a9a083dbc4d71ec1add..a3b347f0f4400612ff7297f680801500b7987f9e 100644 (file)
@@ -1,42 +1,43 @@
 # TODO:
 # - some tests fail with tcl8.5, it's tcl fault,
 #      if someone REALLY cares (s)he can look into it
+# - enable --enable-load-extension?
 #
 # Conditional build:
 %bcond_with    tests   # run tests
-%bcond_without tcl     # disable tcl extension
+%bcond_with    tcl     # enable tcl extension
 %bcond_without doc     # disable documentation building
-#
+
 %ifarch alpha sparc %{x8664}
 %undefine      with_tests
 %endif
 
 # disabling tcl currently breaks making test target,
 # some hack in Makefile needs to be done
-%if !%{with tcl}
+%if %{without tcl}
 %undefine      with_tests
 %endif
 
-%define         _ulibdir        /usr/lib
-%define                tclver          %(rpm -q --qf '%{V}' tcl)
+%define                _ulibdir        /usr/lib
+%define                tclver          8.5
 
 Summary:       SQLite library
 Summary(pl.UTF-8):     Biblioteka SQLite
 Name:          sqlite3
-Version:       3.5.4
+Version:       3.6.21
 Release:       1
 License:       LGPL
 Group:         Libraries
-# Source0Download: http://sqlite.org/download.html
-Source0:       http://sqlite.org/sqlite-%{version}.tar.gz
-# Source0-md5: f17da840eed792e896c3408d0ce97718
+# Source0Download: http://www.sqlite.org/download.html
+Source0:       http://www.sqlite.org/sqlite-%{version}.tar.gz
+# Source0-md5: 03a8498828866b407c61c0aaf8ebe66c
 Patch0:                %{name}-sign-function.patch
-Patch1:                %{name}-pkgconfig.patch
-URL:           http://sqlite.org/
+URL:           http://www.sqlite.org/
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: libtool
 BuildRequires: readline-devel
+BuildRequires: tcl
 %{?with_tcl:BuildRequires:     tcl-devel}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -151,16 +152,15 @@ Rozszerzenie sqlite3 dla Tcl.
 %prep
 %setup -q -n sqlite-%{version}
 %patch0 -p1
-%patch1 -p1
 
-sed -i 's/mkdir doc/#mkdir doc/' Makefile*
+%{__sed} -i 's/mkdir doc/#mkdir doc/' Makefile*
 
 %build
 %{__libtoolize}
 cp -f /usr/share/automake/config.sub .
 %{__aclocal}
 %{__autoconf}
-CFLAGS="%{rpmcflags} -DSQLITE_ENABLE_COLUMN_METADATA=1"
+CFLAGS="%{rpmcflags} -DSQLITE_ENABLE_COLUMN_METADATA=1 -DSQLITE_DISABLE_DIRSYNC=1 -DSQLITE_ENABLE_FTS3=3 -DSQLITE_ENABLE_RTREE=1"
 export CFLAGS
 %configure \
        %{?with_tcl:--with-tcl=%{_ulibdir}} \
@@ -186,7 +186,7 @@ install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir},%{_mandir}/man1}
 sed -i -e "s#$RPM_BUILD_ROOT##g" $RPM_BUILD_ROOT%{_libdir}/tcl%{tclver}/sqlite3/pkgIndex.tcl
 %endif
 
-install sqlite3.1 $RPM_BUILD_ROOT%{_mandir}/man1
+cp -a sqlite3.1 $RPM_BUILD_ROOT%{_mandir}/man1
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -204,7 +204,6 @@ rm -rf $RPM_BUILD_ROOT
 
 %files devel
 %defattr(644,root,root,755)
-%doc doc/lemon.html doc/report1.txt
 %attr(755,root,root) %{_libdir}/libsqlite3.so
 %{_libdir}/libsqlite3.la
 %{_includedir}/sqlite3.h
This page took 0.027125 seconds and 4 git commands to generate.