]> git.pld-linux.org Git - packages/sqlite3.git/blobdiff - sqlite3.spec
- updated to 3.12.2[.0]
[packages/sqlite3.git] / sqlite3.spec
index 49431b40b3449af6cf3fbfef4d91cc4ba48ff95a..9f2f418a4334a95fc372b4ee493fafffe208d304 100644 (file)
@@ -8,7 +8,7 @@
 %bcond_without doc             # disable documentation building
 %bcond_without unlock_notify   # disable unlock notify API
 %bcond_without load_extension  # enable load extension API
-%bcond_with            icu             # ICU tokenizer support
+%bcond_with    icu             # ICU tokenizer support
 
 %ifarch alpha sparc %{x8664}
 %undefine      with_tests
 %undefine      with_tests
 %endif
 
-#define                version_num %(echo %{version} |  awk -F. '{printf("%d%02d%02d%02d", $1, $2, $3, $4)}')
-%define                version_num 3071700
-%define                _ulibdir        /usr/lib
-%define                tclver          8.5
+# sqlite3 version with zero padded without any dots (3 08 10 01 is 3.8.10.1)
+# but trailing 00 means no 4rd part (3 11 01 00 is 3.11.1)
+%define                vnum    3120200
+%define                ver             %{lua:vn=rpm.expand("%vnum");v="";for i in string.gmatch(string.format("%08d", vn), "..") do v=v.."."..i:gsub("^0", "");end;v=v:gsub("^.",""):gsub("\.0$","");print(v)}
 
-Summary:       SQLite library
-Summary(pl.UTF-8):     Biblioteka SQLite
+%define                tclver          8.6
+Summary:       SQLite3 library
+Summary(pl.UTF-8):     Biblioteka SQLite3
 Name:          sqlite3
-Version:       3.7.17
+Version:       %{ver}
 Release:       1
 License:       Public Domain
 Group:         Libraries
 # Source0Download: http://www.sqlite.org/download.html
-Source0:       http://www.sqlite.org/2013/sqlite-src-%{version_num}.zip
-# Source0-md5: 20f31ef72d9874fd8749c66441eaff74
+Source0:       http://www.sqlite.org/2016/sqlite-src-%{vnum}.zip
+# Source0-md5: ad51fce1593191281c6eca810e0cc629
 Patch0:                %{name}-sign-function.patch
 URL:           http://www.sqlite.org/
 %{?with_load_extension:Provides:       %{name}(load_extension)}
@@ -46,10 +47,12 @@ BuildRequires:      libtool
 BuildRequires: readline-devel
 %{?with_load_extension:BuildRequires:  sed >= 4.0}
 BuildRequires: tcl
-%{?with_tcl:BuildRequires:     tcl-devel}
+%{?with_tcl:BuildRequires:     tcl-devel >= %{tclver}}
 BuildRequires: unzip
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                _ulibdir        /usr/lib
+
 %description
 SQLite is a C library that implements an SQL database engine. A large
 subset of SQL92 is supported. A complete database is stored in a
@@ -174,11 +177,16 @@ sqlite3 tcl extension.
 Rozszerzenie sqlite3 dla Tcl.
 
 %prep
-%setup -q -n sqlite-src-%{version_num}
+%setup -q -n sqlite-src-%{vnum}
 %patch0 -p1
 
 %{__sed} -i 's/mkdir doc/#mkdir doc/' Makefile.in
 
+if [ "$(cat VERSION)" != "%{version}" ]; then
+       echo "Tarball content doesn't match version %{version}." >&2
+       exit 1
+fi
+
 %build
 %{__libtoolize}
 cp -f /usr/share/automake/config.sub .
@@ -206,7 +214,7 @@ append-cppflags -DSQLITE_ENABLE_COLUMN_METADATA
 # Support Full-Text Search versions 3 and 4.
 # http://sqlite.org/fts3.html
 #append-cppflags -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_FTS3_PARENTHESIS -DSQLITE_ENABLE_FTS4 -DSQLITE_ENABLE_FTS4_UNICODE61
-append-cppflags -DSQLITE_ENABLE_FTS3
+append-cppflags -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_FTS3_PARENTHESIS
 
 # Support R*Trees.
 # http://sqlite.org/rtree.html
@@ -216,6 +224,10 @@ append-cppflags -DSQLITE_ENABLE_RTREE
 # http://sqlite.org/lang_corefunc.html#soundex
 #append-cppflags -DSQLITE_SOUNDEX
 
+# Support dbstat virtual table.
+# https://www.sqlite.org/dbstat.html
+append-cppflags -DSQLITE_ENABLE_DBSTAT_VTAB
+
 %if %{with unlock_notify}
 # Support unlock notification.
 # http://sqlite.org/unlock_notify.html
@@ -265,7 +277,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc README
+%doc README.md
 %attr(755,root,root) %{_bindir}/sqlite3
 %attr(755,root,root) /%{_lib}/libsqlite3.so.*.*.*
 %attr(755,root,root) %ghost /%{_lib}/libsqlite3.so.0
This page took 0.035698 seconds and 4 git commands to generate.