]> git.pld-linux.org Git - packages/sqlite3.git/blobdiff - sqlite3.spec
- updated to 3.12.2[.0]
[packages/sqlite3.git] / sqlite3.spec
index 0e3842c078dada833f1587160481f1faba7a3694..9f2f418a4334a95fc372b4ee493fafffe208d304 100644 (file)
 %undefine      with_tests
 %endif
 
-%define                version_year    2015
-#define                version_num %(echo %{version} |  awk -F. '{printf("%d%02d%02d%02d", $1, $2, $3, $4)}')
-%define                version_num     3080803
-%define                _ulibdir        /usr/lib
-%define                tclver          8.6
+# sqlite3 version with zero padded without any dots (3 08 10 01 is 3.8.10.1)
+# but trailing 00 means no 4rd part (3 11 01 00 is 3.11.1)
+%define                vnum    3120200
+%define                ver             %{lua:vn=rpm.expand("%vnum");v="";for i in string.gmatch(string.format("%08d", vn), "..") do v=v.."."..i:gsub("^0", "");end;v=v:gsub("^.",""):gsub("\.0$","");print(v)}
 
-Summary:       SQLite library
-Summary(pl.UTF-8):     Biblioteka SQLite
+%define                tclver          8.6
+Summary:       SQLite3 library
+Summary(pl.UTF-8):     Biblioteka SQLite3
 Name:          sqlite3
-Version:       3.8.8.3
+Version:       %{ver}
 Release:       1
 License:       Public Domain
 Group:         Libraries
 # Source0Download: http://www.sqlite.org/download.html
-Source0:       http://www.sqlite.org/%{version_year}/sqlite-src-%{version_num}.zip
-# Source0-md5: 7aed8084e18c2677c71345cbd8ca0b76
+Source0:       http://www.sqlite.org/2016/sqlite-src-%{vnum}.zip
+# Source0-md5: ad51fce1593191281c6eca810e0cc629
 Patch0:                %{name}-sign-function.patch
 URL:           http://www.sqlite.org/
 %{?with_load_extension:Provides:       %{name}(load_extension)}
@@ -51,6 +51,8 @@ BuildRequires:        tcl
 BuildRequires: unzip
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                _ulibdir        /usr/lib
+
 %description
 SQLite is a C library that implements an SQL database engine. A large
 subset of SQL92 is supported. A complete database is stored in a
@@ -175,7 +177,7 @@ sqlite3 tcl extension.
 Rozszerzenie sqlite3 dla Tcl.
 
 %prep
-%setup -q -n sqlite-src-%{version_num}
+%setup -q -n sqlite-src-%{vnum}
 %patch0 -p1
 
 %{__sed} -i 's/mkdir doc/#mkdir doc/' Makefile.in
@@ -212,7 +214,7 @@ append-cppflags -DSQLITE_ENABLE_COLUMN_METADATA
 # Support Full-Text Search versions 3 and 4.
 # http://sqlite.org/fts3.html
 #append-cppflags -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_FTS3_PARENTHESIS -DSQLITE_ENABLE_FTS4 -DSQLITE_ENABLE_FTS4_UNICODE61
-append-cppflags -DSQLITE_ENABLE_FTS3
+append-cppflags -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_FTS3_PARENTHESIS
 
 # Support R*Trees.
 # http://sqlite.org/rtree.html
@@ -222,6 +224,10 @@ append-cppflags -DSQLITE_ENABLE_RTREE
 # http://sqlite.org/lang_corefunc.html#soundex
 #append-cppflags -DSQLITE_SOUNDEX
 
+# Support dbstat virtual table.
+# https://www.sqlite.org/dbstat.html
+append-cppflags -DSQLITE_ENABLE_DBSTAT_VTAB
+
 %if %{with unlock_notify}
 # Support unlock notification.
 # http://sqlite.org/unlock_notify.html
This page took 0.653362 seconds and 4 git commands to generate.