]> git.pld-linux.org Git - packages/sqlite3.git/blobdiff - sqlite3.spec
- updated to 3.7.16.2
[packages/sqlite3.git] / sqlite3.spec
index b5e35f7f3e3fa3983524f03705e8c52e13606544..98a94d66f533c4afedc8396a6da5e45b32abb766 100644 (file)
@@ -1,12 +1,13 @@
 # TODO:
 # - some tests fail with tcl8.5, it's tcl fault,
 #      if someone REALLY cares (s)he can look into it
-# - enable --enable-load-extension?
 #
 # Conditional build:
-%bcond_with    tests   # run tests
-%bcond_with    tcl     # enable tcl extension
-%bcond_without doc     # disable documentation building
+%bcond_with    tests           # run tests
+%bcond_without tcl             # Tcl extension
+%bcond_without doc             # disable documentation building
+%bcond_without unlock_notify   # disable unlock notify API
+%bcond_without load_extension  # enable load extension API
 
 %ifarch alpha sparc %{x8664}
 %undefine      with_tests
 %undefine      with_tests
 %endif
 
+#define                version_num %(echo %{version} |  awk -F. '{printf("%d%02d%02d%02d", $1, $2, $3, $4)}')
+%define                version_num 3071602
 %define                _ulibdir        /usr/lib
 %define                tclver          8.5
 
 Summary:       SQLite library
 Summary(pl.UTF-8):     Biblioteka SQLite
 Name:          sqlite3
-Version:       3.6.20
-Release:       3
-License:       LGPL
+Version:       3.7.16.2
+Release:       1
+License:       Public Domain
 Group:         Libraries
 # Source0Download: http://www.sqlite.org/download.html
-Source0:       http://www.sqlite.org/sqlite-%{version}.tar.gz
-# Source0-md5: 0faf8fc8ccff5297513c6532b2b4ce23
+Source0:       http://www.sqlite.org/sqlite-src-%{version_num}.zip
+# Source0-md5: 0d821779acdb56eee1fd71343b41a1cc
 Patch0:                %{name}-sign-function.patch
 URL:           http://www.sqlite.org/
-BuildRequires: autoconf
+%{?with_load_extension:Provides:       %{name}(load_extension)}
+%{?with_unlock_notify:Provides:        %{name}(unlock_notify)}
+BuildRequires: autoconf >= 2.50
 BuildRequires: automake
 BuildRequires: libtool
 BuildRequires: readline-devel
+%{?with_load_extension:BuildRequires:  sed >= 4.0}
 BuildRequires: tcl
 %{?with_tcl:BuildRequires:     tcl-devel}
+BuildRequires: unzip
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -71,6 +78,14 @@ Summary:     Header files for SQLite development
 Summary(pl.UTF-8):     Pliki nagłówkowe SQLite
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
+%if %{with unlock_notify}
+Requires:      %{name}(unlock_notify)
+Provides:      %{name}-devel(unlock_notify)
+%endif
+%if %{with load_extension}
+Requires:      %{name}(load_extension)
+Provides:      %{name}-devel(load_extension)
+%endif
 
 %description devel
 SQLite is a C library that implements an SQL database engine. A large
@@ -108,6 +123,14 @@ Summary:   Static libraries for SQLite development
 Summary(pl.UTF-8):     Statyczne biblioteki SQLite
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{version}-%{release}
+%if %{with unclock_notify}
+Requires:      %{name}-devel(unlock_notify)
+Provides:      %{name}-static(unlock_notify)
+%endif
+%if %{with load_extension}
+Requires:      %{name}-devel(load_extension)
+Provides:      %{name}-static(load_extension)
+%endif
 
 %description static
 SQLite is a C library that implements an SQL database engine. A large
@@ -150,7 +173,7 @@ sqlite3 tcl extension.
 Rozszerzenie sqlite3 dla Tcl.
 
 %prep
-%setup -q -n sqlite-%{version}
+%setup -q -n sqlite-src-%{version_num}
 %patch0 -p1
 
 %{__sed} -i 's/mkdir doc/#mkdir doc/' Makefile*
@@ -160,12 +183,21 @@ Rozszerzenie sqlite3 dla Tcl.
 cp -f /usr/share/automake/config.sub .
 %{__aclocal}
 %{__autoconf}
-CFLAGS="%{rpmcflags} -DSQLITE_ENABLE_COLUMN_METADATA=1 -DSQLITE_DISABLE_DIRSYNC=1 -DSQLITE_ENABLE_FTS3=3 -DSQLITE_ENABLE_RTREE=1"
+CFLAGS="%{rpmcflags} -DSQLITE_ENABLE_COLUMN_METADATA=1 -DSQLITE_DISABLE_DIRSYNC=1 -DSQLITE_ENABLE_FTS3=3 -DSQLITE_ENABLE_RTREE=1 -DSQLITE_SECURE_DELETE %{?with_unlock_notify:-DSQLITE_ENABLE_UNLOCK_NOTIFY}"
 export CFLAGS
+%if %{with load_extension}
+LIBS=-ldl
+export LIBS
+%endif
+%if %{with tcl}
+export TCLLIBDIR="%{tcl_sitearch}/sqlite3"
+%endif
 %configure \
        %{?with_tcl:--with-tcl=%{_ulibdir}} \
        %{!?with_tcl:--disable-tcl} \
+       %{__enable_disable load_extension load-extension} \
        --enable-threadsafe
+
 %{__make}
 
 %if %{with doc}
@@ -176,15 +208,15 @@ export CFLAGS
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir},%{_mandir}/man1}
+install -d $RPM_BUILD_ROOT{/%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir}/man1}
 
 %{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT \
-       TCLLIBDIR=%{_libdir}/tcl%{tclver}
+       DESTDIR=$RPM_BUILD_ROOT
 
-%if %{with tcl}
-sed -i -e "s#$RPM_BUILD_ROOT##g" $RPM_BUILD_ROOT%{_libdir}/tcl%{tclver}/sqlite3/pkgIndex.tcl
-%endif
+mv -f $RPM_BUILD_ROOT%{_libdir}/lib*.so.* $RPM_BUILD_ROOT/%{_lib}
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.so
+ln -sf /%{_lib}/$(cd $RPM_BUILD_ROOT/%{_lib}; echo lib*.so.*.*) \
+       $RPM_BUILD_ROOT%{_libdir}/libsqlite3.so
 
 cp -a sqlite3.1 $RPM_BUILD_ROOT%{_mandir}/man1
 
@@ -198,8 +230,8 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc README
 %attr(755,root,root) %{_bindir}/sqlite3
-%attr(755,root,root) %{_libdir}/libsqlite3.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libsqlite3.so.0
+%attr(755,root,root) /%{_lib}/libsqlite3.so.*.*.*
+%attr(755,root,root) %ghost /%{_lib}/libsqlite3.so.0
 %{_mandir}/man1/sqlite3.1*
 
 %files devel
This page took 0.047182 seconds and 4 git commands to generate.