]> git.pld-linux.org Git - packages/sqlite3.git/blobdiff - sqlite3.spec
- updated to 3.6.3
[packages/sqlite3.git] / sqlite3.spec
index 4435e1080be1ce3f0c5aac8be0a698e73f4bc307..95c9d0dd65e30df01335a9a6cfc8b1ac3c470ec8 100644 (file)
@@ -1,6 +1,10 @@
 # TODO:
 # - some tests fail with tcl8.5, it's tcl fault,
 #      if someone REALLY cares (s)he can look into it
+# - alpha build fail:
+#   tclsh ./tool/mksqlite3c.tcl
+#   tclsh: allocatestack.c:404: allocate_stack: Assertion `size != 0' failed.
+#   make: *** [sqlite3.c] Aborted
 #
 # Conditional build:
 %bcond_with    tests   # run tests
 %undefine      with_tests
 %endif
 
-%define         _ulibdir        /usr/lib
-%define                tclver          %(rpm -q --qf '%{V}' tcl)
+%define                _ulibdir        /usr/lib
+%define                tclver          8.5
 
 Summary:       SQLite library
 Summary(pl.UTF-8):     Biblioteka SQLite
 Name:          sqlite3
-Version:       3.5.2
+Version:       3.6.3
 Release:       1
 License:       LGPL
 Group:         Libraries
-# Source0Download: http://sqlite.org/download.html
-Source0:       http://sqlite.org/sqlite-%{version}.tar.gz
-# Source0-md5: b4f631268d811189cfca1d5259cb5dd8
+# Source0Download: http://www.sqlite.org/download.html
+Source0:       http://www.sqlite.org/sqlite-%{version}.tar.gz
+# Source0-md5: 671d2715f33158abc47a7a2ddd6066c5
 Patch0:                %{name}-sign-function.patch
 Patch1:                %{name}-pkgconfig.patch
-URL:           http://sqlite.org/
+URL:           http://www.sqlite.org/
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: libtool
@@ -183,7 +187,7 @@ install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir},%{_mandir}/man1}
        TCLLIBDIR=%{_libdir}/tcl%{tclver}
 
 %if %{with tcl}
-sed -i -e "s#$RPM_BUILD_ROOT##g" $RPM_BUILD_ROOT%{_libdir}/tcl*/sqlite3/*.tcl
+sed -i -e "s#$RPM_BUILD_ROOT##g" $RPM_BUILD_ROOT%{_libdir}/tcl%{tclver}/sqlite3/pkgIndex.tcl
 %endif
 
 install sqlite3.1 $RPM_BUILD_ROOT%{_mandir}/man1
@@ -198,26 +202,26 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc README
 %attr(755,root,root) %{_bindir}/sqlite3
-%attr(755,root,root) %{_libdir}/lib*.so.*.*
+%attr(755,root,root) %{_libdir}/libsqlite3.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libsqlite3.so.0
 %{_mandir}/man1/sqlite3.1*
 
 %files devel
 %defattr(644,root,root,755)
-%doc doc/*
-%attr(755,root,root) %{_libdir}/lib*.so
-%{_libdir}/lib*.la
+%attr(755,root,root) %{_libdir}/libsqlite3.so
+%{_libdir}/libsqlite3.la
 %{_includedir}/sqlite3.h
 %{_includedir}/sqlite3ext.h
-%{_pkgconfigdir}/*.pc
+%{_pkgconfigdir}/sqlite3.pc
 
 %files static
 %defattr(644,root,root,755)
-%{_libdir}/lib*.a
+%{_libdir}/libsqlite3.a
 
 %if %{with tcl}
 %files -n tcl-%{name}
 %defattr(644,root,root,755)
 %dir %{_libdir}/tcl*/sqlite3
-%attr(755,root,root) %{_libdir}/tcl*/sqlite3/*.so
-%{_libdir}/tcl*/sqlite3/*.tcl
+%attr(755,root,root) %{_libdir}/tcl%{tclver}/sqlite3/libtclsqlite3.so
+%{_libdir}/tcl%{tclver}/sqlite3/pkgIndex.tcl
 %endif
This page took 0.042266 seconds and 4 git commands to generate.