]> git.pld-linux.org Git - packages/sqlite3.git/blobdiff - sqlite3.spec
- updated to 3.6.3
[packages/sqlite3.git] / sqlite3.spec
index 1038e0faaa009c15825041b2878720ff496584b6..95c9d0dd65e30df01335a9a6cfc8b1ac3c470ec8 100644 (file)
@@ -1,26 +1,42 @@
 # TODO:
-# - fix lib64 in tcl module
-# - date test fail on tcl8.5 because of missing tcl library initialization
-#   (and thus unavailable clock command)
+# - some tests fail with tcl8.5, it's tcl fault,
+#      if someone REALLY cares (s)he can look into it
+# - alpha build fail:
+#   tclsh ./tool/mksqlite3c.tcl
+#   tclsh: allocatestack.c:404: allocate_stack: Assertion `size != 0' failed.
+#   make: *** [sqlite3.c] Aborted
 #
 # Conditional build:
-%bcond_without tests # don't run tests
-%bcond_without tcl   # disable tcl extension
-%bcond_without doc  # disable documentation building
+%bcond_with    tests   # run tests
+%bcond_without tcl     # disable tcl extension
+%bcond_without doc     # disable documentation building
 #
+%ifarch alpha sparc %{x8664}
+%undefine      with_tests
+%endif
+
+# disabling tcl currently breaks making test target,
+# some hack in Makefile needs to be done
+%if !%{with tcl}
+%undefine      with_tests
+%endif
+
+%define                _ulibdir        /usr/lib
+%define                tclver          8.5
+
 Summary:       SQLite library
 Summary(pl.UTF-8):     Biblioteka SQLite
 Name:          sqlite3
-Version:       3.4.1
+Version:       3.6.3
 Release:       1
 License:       LGPL
 Group:         Libraries
-# Source0Download: http://sqlite.org/download.html
-Source0:       http://sqlite.org/sqlite-%{version}.tar.gz
-# Source0-md5: 0f06955b18da295fecb62d4bf9ded3c6
+# Source0Download: http://www.sqlite.org/download.html
+Source0:       http://www.sqlite.org/sqlite-%{version}.tar.gz
+# Source0-md5: 671d2715f33158abc47a7a2ddd6066c5
 Patch0:                %{name}-sign-function.patch
 Patch1:                %{name}-pkgconfig.patch
-URL:           http://sqlite.org/
+URL:           http://www.sqlite.org/
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: libtool
@@ -28,18 +44,6 @@ BuildRequires:       readline-devel
 %{?with_tcl:BuildRequires:     tcl-devel}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%ifarch alpha sparc %{x8664}
-%undefine      with_tests
-%endif
-
-# disabling tcl currently breaks making test target,
-# some hack in Makefile needs to be done
-%if !%{with tcl}
-%undefine      with_tests
-%endif
-
-%define         _ulibdir        /usr/lib
-
 %description
 SQLite is a C library that implements an SQL database engine. A large
 subset of SQL92 is supported. A complete database is stored in a
@@ -160,6 +164,8 @@ sed -i 's/mkdir doc/#mkdir doc/' Makefile*
 cp -f /usr/share/automake/config.sub .
 %{__aclocal}
 %{__autoconf}
+CFLAGS="%{rpmcflags} -DSQLITE_ENABLE_COLUMN_METADATA=1"
+export CFLAGS
 %configure \
        %{?with_tcl:--with-tcl=%{_ulibdir}} \
        %{!?with_tcl:--disable-tcl} \
@@ -177,9 +183,12 @@ rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir},%{_mandir}/man1}
 
 %{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT
+       DESTDIR=$RPM_BUILD_ROOT \
+       TCLLIBDIR=%{_libdir}/tcl%{tclver}
 
-sed -i -e "s#$RPM_BUILD_ROOT##g" $RPM_BUILD_ROOT%{_ulibdir}/tcl*/sqlite3/*.tcl
+%if %{with tcl}
+sed -i -e "s#$RPM_BUILD_ROOT##g" $RPM_BUILD_ROOT%{_libdir}/tcl%{tclver}/sqlite3/pkgIndex.tcl
+%endif
 
 install sqlite3.1 $RPM_BUILD_ROOT%{_mandir}/man1
 
@@ -193,26 +202,26 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc README
 %attr(755,root,root) %{_bindir}/sqlite3
-%attr(755,root,root) %{_libdir}/lib*.so.*.*
+%attr(755,root,root) %{_libdir}/libsqlite3.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libsqlite3.so.0
 %{_mandir}/man1/sqlite3.1*
 
 %files devel
 %defattr(644,root,root,755)
-%doc doc/*
-%attr(755,root,root) %{_libdir}/lib*.so
-%{_libdir}/lib*.la
+%attr(755,root,root) %{_libdir}/libsqlite3.so
+%{_libdir}/libsqlite3.la
 %{_includedir}/sqlite3.h
 %{_includedir}/sqlite3ext.h
-%{_pkgconfigdir}/*.pc
+%{_pkgconfigdir}/sqlite3.pc
 
 %files static
 %defattr(644,root,root,755)
-%{_libdir}/lib*.a
+%{_libdir}/libsqlite3.a
 
 %if %{with tcl}
 %files -n tcl-%{name}
 %defattr(644,root,root,755)
-%dir %{_ulibdir}/tcl*/sqlite3
-%attr(755,root,root) %{_ulibdir}/tcl*/sqlite3/*.so
-%{_ulibdir}/tcl*/sqlite3/*.tcl
+%dir %{_libdir}/tcl*/sqlite3
+%attr(755,root,root) %{_libdir}/tcl%{tclver}/sqlite3/libtclsqlite3.so
+%{_libdir}/tcl%{tclver}/sqlite3/pkgIndex.tcl
 %endif
This page took 0.054011 seconds and 4 git commands to generate.