]> git.pld-linux.org Git - packages/sqlite3.git/blobdiff - sqlite3.spec
- up to 3.7.6.3
[packages/sqlite3.git] / sqlite3.spec
index b5e35f7f3e3fa3983524f03705e8c52e13606544..5557e4439f56ed58ba3a63a10699f79b34012691 100644 (file)
@@ -4,9 +4,11 @@
 # - enable --enable-load-extension?
 #
 # Conditional build:
-%bcond_with    tests   # run tests
-%bcond_with    tcl     # enable tcl extension
-%bcond_without doc     # disable documentation building
+%bcond_with    tests           # run tests
+%bcond_with    tcl             # enable tcl extension
+%bcond_without doc             # disable documentation building
+%bcond_without unlock_notify   # disable unlock notify API
+%bcond_with    load_extension  # enable load extension API
 
 %ifarch alpha sparc %{x8664}
 %undefine      with_tests
 %undefine      with_tests
 %endif
 
+%define                realver         3070603
+%define                srcver          src
+%define                rpmver          %(echo %{realver}|sed -e "s/00//g" -e "s/0/./g")
 %define                _ulibdir        /usr/lib
 %define                tclver          8.5
 
 Summary:       SQLite library
 Summary(pl.UTF-8):     Biblioteka SQLite
 Name:          sqlite3
-Version:       3.6.20
-Release:       3
+Version:       3.7.6.3
+Release:       1
 License:       LGPL
 Group:         Libraries
 # Source0Download: http://www.sqlite.org/download.html
-Source0:       http://www.sqlite.org/sqlite-%{version}.tar.gz
-# Source0-md5: 0faf8fc8ccff5297513c6532b2b4ce23
+Source0:       http://www.sqlite.org/sqlite-%{srcver}-%{realver}.zip
+# Source0-md5: f8e22ec0931c91f029d539fe3f5ef0f9
 Patch0:                %{name}-sign-function.patch
 URL:           http://www.sqlite.org/
+%{?with_load_extension:Provides:       %{name}(load_extension)}
+%{?with_unlock_notify:Provides:        %{name}(unlock_notify)}
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: libtool
 BuildRequires: readline-devel
+%{?with_load_extension:BuildRequires:  sed >= 4.0}
 BuildRequires: tcl
 %{?with_tcl:BuildRequires:     tcl-devel}
+BuildRequires: unzip
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -71,6 +80,14 @@ Summary:     Header files for SQLite development
 Summary(pl.UTF-8):     Pliki nagłówkowe SQLite
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
+%if %{with unlock_notify}
+Requires:      %{name}(unlock_notify)
+Provides:      %{name}-devel(unlock_notify)
+%endif
+%if %{with load_extension}
+Requires:      %{name}(load_extension)
+Provides:      %{name}-devel(load_extension)
+%endif
 
 %description devel
 SQLite is a C library that implements an SQL database engine. A large
@@ -108,6 +125,14 @@ Summary:   Static libraries for SQLite development
 Summary(pl.UTF-8):     Statyczne biblioteki SQLite
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{version}-%{release}
+%if %{with unclock_notify}
+Requires:      %{name}-devel(unlock_notify)
+Provides:      %{name}-static(unlock_notify)
+%endif
+%if %{with load_extension}
+Requires:      %{name}-devel(load_extension)
+Provides:      %{name}-static(load_extension)
+%endif
 
 %description static
 SQLite is a C library that implements an SQL database engine. A large
@@ -150,7 +175,7 @@ sqlite3 tcl extension.
 Rozszerzenie sqlite3 dla Tcl.
 
 %prep
-%setup -q -n sqlite-%{version}
+%setup -q -n sqlite-%{srcver}-%{realver}
 %patch0 -p1
 
 %{__sed} -i 's/mkdir doc/#mkdir doc/' Makefile*
@@ -160,12 +185,17 @@ Rozszerzenie sqlite3 dla Tcl.
 cp -f /usr/share/automake/config.sub .
 %{__aclocal}
 %{__autoconf}
-CFLAGS="%{rpmcflags} -DSQLITE_ENABLE_COLUMN_METADATA=1 -DSQLITE_DISABLE_DIRSYNC=1 -DSQLITE_ENABLE_FTS3=3 -DSQLITE_ENABLE_RTREE=1"
+CFLAGS="%{rpmcflags} -DSQLITE_ENABLE_COLUMN_METADATA=1 -DSQLITE_DISABLE_DIRSYNC=1 -DSQLITE_ENABLE_FTS3=3 -DSQLITE_ENABLE_RTREE=1 -DSQLITE_SECURE_DELETE %{?with_unlock_notify:-DSQLITE_ENABLE_UNLOCK_NOTIFY}"
 export CFLAGS
+%if %{with load_extension}
+LIBS=-ldl
+export LIBS
+%endif
 %configure \
        %{?with_tcl:--with-tcl=%{_ulibdir}} \
        %{!?with_tcl:--disable-tcl} \
        --enable-threadsafe
+%{?with_load_extension:sed -i~ s/-DSQLITE_OMIT_LOAD_EXTENSION=1// Makefile}
 %{__make}
 
 %if %{with doc}
@@ -176,7 +206,7 @@ export CFLAGS
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir},%{_mandir}/man1}
+install -d $RPM_BUILD_ROOT{/%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir}/man1}
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT \
@@ -186,6 +216,11 @@ install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir},%{_mandir}/man1}
 sed -i -e "s#$RPM_BUILD_ROOT##g" $RPM_BUILD_ROOT%{_libdir}/tcl%{tclver}/sqlite3/pkgIndex.tcl
 %endif
 
+mv -f $RPM_BUILD_ROOT%{_libdir}/lib*.so.* $RPM_BUILD_ROOT/%{_lib}
+rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.so
+ln -sf /%{_lib}/$(cd $RPM_BUILD_ROOT/%{_lib}; echo lib*.so.*.*) \
+       $RPM_BUILD_ROOT%{_libdir}/libsqlite3.so
+
 cp -a sqlite3.1 $RPM_BUILD_ROOT%{_mandir}/man1
 
 %clean
@@ -198,8 +233,8 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc README
 %attr(755,root,root) %{_bindir}/sqlite3
-%attr(755,root,root) %{_libdir}/libsqlite3.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libsqlite3.so.0
+%attr(755,root,root) /%{_lib}/libsqlite3.so.*.*.*
+%attr(755,root,root) %ghost /%{_lib}/libsqlite3.so.0
 %{_mandir}/man1/sqlite3.1*
 
 %files devel
This page took 0.264013 seconds and 4 git commands to generate.