]> git.pld-linux.org Git - packages/sqlite3.git/blobdiff - sqlite3.spec
- 3.8.10.1
[packages/sqlite3.git] / sqlite3.spec
index f6db5e9ddb5e9c2d006d7eb6855ba008d7bd6ab6..3413b80400a63fe23d2f62073388c8ff613ccc7a 100644 (file)
@@ -8,7 +8,7 @@
 %bcond_without doc             # disable documentation building
 %bcond_without unlock_notify   # disable unlock notify API
 %bcond_without load_extension  # enable load extension API
-%bcond_with            icu             # ICU tokenizer support
+%bcond_with    icu             # ICU tokenizer support
 
 %ifarch alpha sparc %{x8664}
 %undefine      with_tests
 %undefine      with_tests
 %endif
 
-#define                version_num %(echo %{version} |  awk -F. '{printf("%d%02d%02d%02d", $1, $2, $3, $4)}')
-%define                version_num 3080702
-%define                _ulibdir        /usr/lib
-%define                tclver          8.6
+# sqlite3 version with zero padded without any dots (3 08 10 01 is 3.8.10.1)
+%define                vnum    3081002
+%define                ver             %{lua:vn=rpm.expand("%vnum");v="";for i in string.gmatch(string.format("%08d", vn), "..") do; v=v.."."..i:gsub("^0", "");end;v=v:gsub("^.","");print(v)}
 
+%define                tclver          8.6
 Summary:       SQLite library
 Summary(pl.UTF-8):     Biblioteka SQLite
 Name:          sqlite3
-Version:       3.8.7.2
-Release:       3
+Version:       %{ver}
+Release:       1
 License:       Public Domain
 Group:         Libraries
 # Source0Download: http://www.sqlite.org/download.html
-Source0:       http://www.sqlite.org/2014/sqlite-src-%{version_num}.zip
-# Source0-md5: d5f7285c59527caeb2e7401454fdc63e
+Source0:       http://www.sqlite.org/2015/sqlite-src-%{vnum}.zip
+# Source0-md5: 5d717638b97b3be1a4d855d957028738
 Patch0:                %{name}-sign-function.patch
 URL:           http://www.sqlite.org/
 %{?with_load_extension:Provides:       %{name}(load_extension)}
@@ -50,6 +50,8 @@ BuildRequires:        tcl
 BuildRequires: unzip
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                _ulibdir        /usr/lib
+
 %description
 SQLite is a C library that implements an SQL database engine. A large
 subset of SQL92 is supported. A complete database is stored in a
@@ -174,7 +176,7 @@ sqlite3 tcl extension.
 Rozszerzenie sqlite3 dla Tcl.
 
 %prep
-%setup -q -n sqlite-src-%{version_num}
+%setup -q -n sqlite-src-%{vnum}
 %patch0 -p1
 
 %{__sed} -i 's/mkdir doc/#mkdir doc/' Makefile.in
This page took 0.034435 seconds and 4 git commands to generate.