]> git.pld-linux.org Git - packages/sqlite3.git/blobdiff - sqlite3.spec
- 3.8.10.1
[packages/sqlite3.git] / sqlite3.spec
index 3fbfba43c9af45c9b7398ac30d09c4e56b8510a5..3413b80400a63fe23d2f62073388c8ff613ccc7a 100644 (file)
@@ -8,7 +8,7 @@
 %bcond_without doc             # disable documentation building
 %bcond_without unlock_notify   # disable unlock notify API
 %bcond_without load_extension  # enable load extension API
-%bcond_with            icu             # ICU tokenizer support
+%bcond_with    icu             # ICU tokenizer support
 
 %ifarch alpha sparc %{x8664}
 %undefine      with_tests
 %undefine      with_tests
 %endif
 
-#define                version_num %(echo %{version} |  awk -F. '{printf("%d%02d%02d%02d", $1, $2, $3, $4)}')
-%define                version_num 3071602
-%define                _ulibdir        /usr/lib
-%define                tclver          8.5
+# sqlite3 version with zero padded without any dots (3 08 10 01 is 3.8.10.1)
+%define                vnum    3081002
+%define                ver             %{lua:vn=rpm.expand("%vnum");v="";for i in string.gmatch(string.format("%08d", vn), "..") do; v=v.."."..i:gsub("^0", "");end;v=v:gsub("^.","");print(v)}
 
+%define                tclver          8.6
 Summary:       SQLite library
 Summary(pl.UTF-8):     Biblioteka SQLite
 Name:          sqlite3
-Version:       3.7.16.2
+Version:       %{ver}
 Release:       1
 License:       Public Domain
 Group:         Libraries
 # Source0Download: http://www.sqlite.org/download.html
-Source0:       http://www.sqlite.org/2013/sqlite-src-%{version_num}.zip
-# Source0-md5: 0d821779acdb56eee1fd71343b41a1cc
+Source0:       http://www.sqlite.org/2015/sqlite-src-%{vnum}.zip
+# Source0-md5: 5d717638b97b3be1a4d855d957028738
 Patch0:                %{name}-sign-function.patch
 URL:           http://www.sqlite.org/
 %{?with_load_extension:Provides:       %{name}(load_extension)}
@@ -46,10 +46,12 @@ BuildRequires:      libtool
 BuildRequires: readline-devel
 %{?with_load_extension:BuildRequires:  sed >= 4.0}
 BuildRequires: tcl
-%{?with_tcl:BuildRequires:     tcl-devel}
+%{?with_tcl:BuildRequires:     tcl-devel >= %{tclver}}
 BuildRequires: unzip
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                _ulibdir        /usr/lib
+
 %description
 SQLite is a C library that implements an SQL database engine. A large
 subset of SQL92 is supported. A complete database is stored in a
@@ -174,30 +176,68 @@ sqlite3 tcl extension.
 Rozszerzenie sqlite3 dla Tcl.
 
 %prep
-%setup -q -n sqlite-src-%{version_num}
+%setup -q -n sqlite-src-%{vnum}
 %patch0 -p1
 
-%{__sed} -i 's/mkdir doc/#mkdir doc/' Makefile*
+%{__sed} -i 's/mkdir doc/#mkdir doc/' Makefile.in
+
+if [ "$(cat VERSION)" != "%{version}" ]; then
+       echo "Tarball content doesn't match version %{version}." >&2
+       exit 1
+fi
 
 %build
 %{__libtoolize}
 cp -f /usr/share/automake/config.sub .
 %{__aclocal}
 %{__autoconf}
-export CFLAGS="%{rpmcflags}
-       -DSQLITE_ENABLE_COLUMN_METADATA=1
-       -DSQLITE_DISABLE_DIRSYNC=1
-       -DSQLITE_ENABLE_FTS3=3
-       -DSQLITE_ENABLE_RTREE=1
-       -DSQLITE_SECURE_DELETE
-       %{?with_unlock_notify:-DSQLITE_ENABLE_UNLOCK_NOTIFY}
-       %{?with_icu:-DSQLITE_ENABLE_ICU}
-"
-export LIBS="%{?with_load_extension:-ldl} %{?with_icu:-licui18n -licuuc}"
+append-cppflags() {
+       CPPFLAGS="$CPPFLAGS $*"
+}
+append-libs() {
+       LIBS="$LIBS $*"
+}
+export CPPFLAGS="%{rpmcflags}"
+export LIBS
 %if %{with tcl}
 export TCLLIBDIR="%{tcl_sitearch}/sqlite3"
 %endif
 
+append-cppflags -DSQLITE_DISABLE_DIRSYNC=1 -DSQLITE_SECURE_DELETE
+
+# Support column metadata functions.
+# http://sqlite.org/c3ref/column_database_name.html
+# http://sqlite.org/c3ref/table_column_metadata.html
+append-cppflags -DSQLITE_ENABLE_COLUMN_METADATA
+
+# Support Full-Text Search versions 3 and 4.
+# http://sqlite.org/fts3.html
+#append-cppflags -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_FTS3_PARENTHESIS -DSQLITE_ENABLE_FTS4 -DSQLITE_ENABLE_FTS4_UNICODE61
+append-cppflags -DSQLITE_ENABLE_FTS3
+
+# Support R*Trees.
+# http://sqlite.org/rtree.html
+append-cppflags -DSQLITE_ENABLE_RTREE
+
+# Support soundex() function.
+# http://sqlite.org/lang_corefunc.html#soundex
+#append-cppflags -DSQLITE_SOUNDEX
+
+%if %{with unlock_notify}
+# Support unlock notification.
+# http://sqlite.org/unlock_notify.html
+append-cppflags -DSQLITE_ENABLE_UNLOCK_NOTIFY
+%endif
+
+%if %{with icu}
+append-cppflags -DSQLITE_ENABLE_ICU
+append-libs "-licui18n -licuuc"
+%endif
+
+%if %{with load_extension}
+append-libs "-ldl"
+%endif
+
 %configure \
        %{!?with_tcl:--disable-tcl}%{?with_tcl:--with-tcl=%{_ulibdir}} \
        %{__enable_disable load_extension load-extension} \
@@ -232,7 +272,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc README
+%doc README.md
 %attr(755,root,root) %{_bindir}/sqlite3
 %attr(755,root,root) /%{_lib}/libsqlite3.so.*.*.*
 %attr(755,root,root) %ghost /%{_lib}/libsqlite3.so.0
This page took 0.034393 seconds and 4 git commands to generate.