]> git.pld-linux.org Git - packages/sqlite3.git/blobdiff - sqlite3.spec
- up to 3.7.0.1
[packages/sqlite3.git] / sqlite3.spec
index 4c7feac60fb54876ae366ada5f4adabb8b3197a9..1c8a0cb340dcd31c84d027b4deb8a934e9c975ce 100644 (file)
@@ -1,24 +1,20 @@
 # TODO:
 # - some tests fail with tcl8.5, it's tcl fault,
 #      if someone REALLY cares (s)he can look into it
-# - alpha build fail:
-#   tclsh ./tool/mksqlite3c.tcl
-#   tclsh: allocatestack.c:404: allocate_stack: Assertion `size != 0' failed.
-#   make: *** [sqlite3.c] Aborted
 # - enable --enable-load-extension?
 #
 # Conditional build:
 %bcond_with    tests   # run tests
 %bcond_with    tcl     # enable tcl extension
 %bcond_without doc     # disable documentation building
-#
+
 %ifarch alpha sparc %{x8664}
 %undefine      with_tests
 %endif
 
 # disabling tcl currently breaks making test target,
 # some hack in Makefile needs to be done
-%if !%{with tcl}
+%if %{without tcl}
 %undefine      with_tests
 %endif
 
 Summary:       SQLite library
 Summary(pl.UTF-8):     Biblioteka SQLite
 Name:          sqlite3
-Version:       3.6.11
-Release:       2
+Version:       3.7.0.1
+Release:       1
 License:       LGPL
 Group:         Libraries
 # Source0Download: http://www.sqlite.org/download.html
 Source0:       http://www.sqlite.org/sqlite-%{version}.tar.gz
-# Source0-md5: 7ebb099696ab76cc6ff65dd496d17858
+# Source0-md5: d25d7551ba6bb310362cb0e7d4906f25
 Patch0:                %{name}-sign-function.patch
 URL:           http://www.sqlite.org/
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: libtool
 BuildRequires: readline-devel
+BuildRequires: tcl
 %{?with_tcl:BuildRequires:     tcl-devel}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -158,33 +155,18 @@ Rozszerzenie sqlite3 dla Tcl.
 
 %{__sed} -i 's/mkdir doc/#mkdir doc/' Makefile*
 
-%ifarch alpha
-# See also LP#276821
-# wrapper script to reset stack to 8192 as if ran from make it's insanely huge!:
-# stack(kbytes)        18014398509481983
-cat <<'EOF' > tclsh.sh
-#!/bin/sh
-ulimit -s 8192
-exec tclsh "$@"
-EOF
-chmod +x tclsh.sh
-%endif
-
 %build
 %{__libtoolize}
 cp -f /usr/share/automake/config.sub .
 %{__aclocal}
 %{__autoconf}
-CFLAGS="%{rpmcflags} -DSQLITE_ENABLE_COLUMN_METADATA=1"
+CFLAGS="%{rpmcflags} -DSQLITE_ENABLE_COLUMN_METADATA=1 -DSQLITE_DISABLE_DIRSYNC=1 -DSQLITE_ENABLE_FTS3=3 -DSQLITE_ENABLE_RTREE=1"
 export CFLAGS
 %configure \
        %{?with_tcl:--with-tcl=%{_ulibdir}} \
        %{!?with_tcl:--disable-tcl} \
        --enable-threadsafe
-%{__make} \
-%ifarch alpha
-       TCLSH_CMD=./tclsh.sh
-%endif
+%{__make}
 
 %if %{with doc}
 %{__make} doc
@@ -194,12 +176,9 @@ export CFLAGS
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir},%{_mandir}/man1}
+install -d $RPM_BUILD_ROOT{/%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir}/man1}
 
 %{__make} install \
-%ifarch alpha
-       TCLSH_CMD=./tclsh.sh \
-%endif
        DESTDIR=$RPM_BUILD_ROOT \
        TCLLIBDIR=%{_libdir}/tcl%{tclver}
 
@@ -207,7 +186,12 @@ install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir},%{_mandir}/man1}
 sed -i -e "s#$RPM_BUILD_ROOT##g" $RPM_BUILD_ROOT%{_libdir}/tcl%{tclver}/sqlite3/pkgIndex.tcl
 %endif
 
-install sqlite3.1 $RPM_BUILD_ROOT%{_mandir}/man1
+mv -f $RPM_BUILD_ROOT%{_libdir}/lib*.so.* $RPM_BUILD_ROOT/%{_lib}
+rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.so
+ln -sf /%{_lib}/$(cd $RPM_BUILD_ROOT/%{_lib}; echo lib*.so.*.*) \
+       $RPM_BUILD_ROOT%{_libdir}/libsqlite3.so
+
+cp -a sqlite3.1 $RPM_BUILD_ROOT%{_mandir}/man1
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -219,8 +203,8 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc README
 %attr(755,root,root) %{_bindir}/sqlite3
-%attr(755,root,root) %{_libdir}/libsqlite3.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libsqlite3.so.0
+%attr(755,root,root) /%{_lib}/libsqlite3.so.*.*.*
+%attr(755,root,root) %ghost /%{_lib}/libsqlite3.so.0
 %{_mandir}/man1/sqlite3.1*
 
 %files devel
This page took 0.034478 seconds and 4 git commands to generate.