]> git.pld-linux.org Git - packages/spl.git/blobdiff - spl.spec
- drop non-dist kernel support
[packages/spl.git] / spl.spec
index 4e2f7945513b2045835cecf17d74d65109408d75..47cff46a62095769d63810902183a669e44153c3 100644 (file)
--- a/spl.spec
+++ b/spl.spec
@@ -1,14 +1,9 @@
 #
 # Conditional build:
-%bcond_without dist_kernel     # allow non-distribution kernel
 %bcond_without kernel          # don't build kernel modules
 %bcond_without userspace       # don't build userspace programs
 %bcond_with    verbose         # verbose build (V=1)
 #
-%if %{without kernel}
-%undefine      with_dist_kernel
-%endif
-
 # The goal here is to have main, userspace, package built once with
 # simple release number, and only rebuild kernel packages with kernel
 # version as part of release number, without the need to bump release
@@ -41,7 +36,7 @@ exit 1
 %define                bkpkg   %(echo %{_build_kernels} | tr , '\\n' | while read n ; do echo %%undefine alt_kernel ; [ -z "$n" ] || echo %%define alt_kernel $n ; echo %%build_kernel_pkg ; done)
 
 %define                pname   spl
-%define                rel     1
+%define                rel     4
 Summary:       Solaris Porting Layer
 Summary(pl.UTF-8):     Solaris Porting Layer - warstwa do portowania kodu z Solarisa
 Name:          %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
@@ -51,9 +46,11 @@ License:     GPL v2+
 Group:         Applications/System
 Source0:       http://archive.zfsonlinux.org/downloads/zfsonlinux/spl/%{pname}-%{version}.tar.gz
 # Source0-md5: 8df6ce3c8f1d9af6526b36f5079cba59
+Patch0:                linux-3.17.patch
+Patch1:                linux-3.18.patch
 URL:           http://zfsonlinux.org/
 BuildRequires: rpmbuild(macros) >= 1.678
-%{?with_dist_kernel:%{expand:%kbrs}}
+%{?with_kernel:%{expand:%kbrs}}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -62,6 +59,19 @@ Solaris Porting Layer.
 %description -l pl.UTF-8
 Solaris Porting Layer - warstwa do portowania kodu z Solarisa.
 
+%package -n kernel-spl-common-devel
+Summary:       Solaris Porting Layer - Linux kernel headers
+Summary(pl.UTF-8):     Solaris Porting Layer - pliki nagłówkowe jądra Linuksa
+Group:         Development/Building
+
+%description -n kernel-spl-common-devel
+Solaris Porting Layer - Linux kernel headers common for all PLD
+kernel versions.
+
+%description -n kernel-spl-common-devel -l pl.UTF-8
+Solaris Porting Layer - pliki nagłówkowe jądra Linuksa wspólne
+dla wszystkich wersji jądrer PLD.
+
 %define        kernel_pkg()\
 %package -n kernel%{_alt_kernel}-spl\
 Summary:       Solaris Porting Layer - Linux kernel modules\
@@ -69,10 +79,8 @@ Summary(pl.UTF-8):   Solaris Porting Layer - moduły jądra Linuksa\
 Release:       %{rel}@%{_kernel_ver_str}\
 Group:         Base/Kernel\
 Requires(post,postun): /sbin/depmod\
-%if %{with dist_kernel}\
 %requires_releq_kernel\
 Requires(postun):      %releq_kernel\
-%endif\
 \
 %description -n kernel%{_alt_kernel}-spl\
 Solaris Porting Layer - Linux kernel modules.\
@@ -85,7 +93,8 @@ Summary:      Solaris Porting Layer - Linux kernel headers\
 Summary(pl.UTF-8):     Solaris Porting Layer - pliki nagłówkowe jądra Linuksa\
 Release:       %{rel}@%{_kernel_ver_str}\
 Group:         Development/Building\
-%{?with_dist_kernel:Requires:  kernel%{_alt_kernel}-headers}\
+Requires:      kernel%{_alt_kernel}-headers\
+Requires:      kernel-spl-common-devel\
 \
 %description -n kernel%{_alt_kernel}-spl-devel\
 Solaris Porting Layer - Linux kernel headers configured for PLD\
@@ -104,9 +113,6 @@ dla jądra PLD z pakietu kernel%{_alt_kernel} w wersji %{_kernel_ver}.\
 \
 %files -n kernel%{_alt_kernel}-spl-devel\
 %defattr(644,root,root,755)\
-%dir /usr/src/spl-%{version}\
-/usr/src/spl-%{version}/spl*.in\
-/usr/src/spl-%{version}/include\
 /usr/src/spl-%{version}/%{_kernel_ver}\
 \
 %post  -n kernel%{_alt_kernel}-spl\
@@ -132,6 +138,8 @@ p=`pwd`\
 
 %prep
 %setup -q -n %{pname}-%{version}
+%patch0 -p1
+%patch1 -p1
 
 %build
 %{__aclocal} -I config
@@ -173,3 +181,11 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/splat.1*
 %{_mandir}/man5/spl-module-parameters.5.gz
 %endif
+
+%if %{with kernel}
+%files -n kernel-spl-common-devel
+%defattr(644,root,root,755)
+%dir /usr/src/spl-%{version}
+/usr/src/spl-%{version}/spl*.in
+/usr/src/spl-%{version}/include
+%endif
This page took 0.087659 seconds and 4 git commands to generate.