]> git.pld-linux.org Git - packages/spice-space.git/blobdiff - spice-space.spec
adapterize
[packages/spice-space.git] / spice-space.spec
index a33890c0e644f6cf831fe7adb7e80ea68f797ca7..c12d5fca97c06eb6d2a6252fa9f3dbabcbc67f33 100644 (file)
@@ -1,43 +1,52 @@
 #
 # Conditional build:
-%bcond_with    slirp           # build with tunneling support (breaks qemu)
+%bcond_without opengl  # OpenGL support
 #
 Summary:       SPICE virtualization solution
 Summary(pl.UTF-8):     System wirtualizacji SPICE
 # real package name (spice) is already occupied
 Name:          spice-space
-Version:       0.12.0
+# NOTE: 0.13.x is unstable (see DEVEL branch for it)
+Version:       0.14.1
 Release:       1
 License:       LGPL v2.1+
 Group:         Applications/Emulators
-Source0:       http://spice-space.org/download/releases/spice-%{version}.tar.bz2
-# Source0-md5: 12c6ea4938215f8f9f10d2925f7bec9b
-Patch0:                spice-sh.patch
-Patch1:                spice-link.patch
-URL:           http://spice-space.org/
-BuildRequires: OpenGL-GLU-devel
+Source0:       https://www.spice-space.org/download/releases/spice-server/spice-%{version}.tar.bz2
+# Source0-md5: 1e2442b08605a5a17430d1aaa0912c24
+Patch0:                spice-am.patch
+URL:           https://www.spice-space.org/
+%{?with_opengl:BuildRequires:  OpenGL-GLU-devel}
+%{?with_opengl:BuildRequires:  OpenGL-devel}
 BuildRequires: alsa-lib-devel
+BuildRequires: asciidoc
+BuildRequires: autoconf >= 2.63
+BuildRequires: automake >= 1:1.11
 BuildRequires: celt051-devel >= 0.5.1.1
-BuildRequires: autoconf >= 2.57
-BuildRequires: automake
 BuildRequires: cyrus-sasl-devel >= 2
+BuildRequires: gcc >= 5:3.2
+BuildRequires: glib2-devel >= 1:2.32
 BuildRequires: libcacard-devel >= 0.1.2
 BuildRequires: libjpeg-devel
-%{?with_slirp:BuildRequires:   libslirp-devel}
 BuildRequires: libstdc++-devel
-BuildRequires: libtool
-BuildRequires: openssl-devel
+BuildRequires: libtool >= 2:2
+BuildRequires: lz4-devel
+BuildRequires: openssl-devel >= 1.0.0
+BuildRequires: opus-devel >= 0.9.14
 BuildRequires: pixman-devel >= 0.17.7
 BuildRequires: pkgconfig
+BuildRequires: python >= 2
+BuildRequires: python-pyparsing
+BuildRequires: python-six
 BuildRequires: rpmbuild(macros) >= 1.527
-BuildRequires: spice-protocol >= 0.10.1
+BuildRequires: spice-protocol >= 0.12.14
+BuildRequires: xorg-lib-libX11-devel
 BuildRequires: xorg-lib-libXext-devel
 BuildRequires: xorg-lib-libXfixes-devel
 BuildRequires: xorg-lib-libXinerama-devel >= 1.0
 BuildRequires: xorg-lib-libXrandr-devel >= 1.2
 BuildRequires: xorg-lib-libXrender-devel
 BuildRequires: zlib-devel
-ExclusiveArch: %{ix86} %{x8664} arm
+ExclusiveArch: %{ix86} %{x8664} x32 arm
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -61,7 +70,11 @@ Summary:     SPICE server library
 Summary(pl.UTF-8):     Biblioteka serwera SPICE
 Group:         Libraries
 Requires:      celt051 >= 0.5.1.1
+Requires:      glib2 >= 1:2.32
+Requires:      openssl >= 1.0.0
+Requires:      opus >= 0.9.14
 Requires:      pixman >= 0.17.7
+Obsoletes:     spice-client
 
 %description -n spice-server-libs
 SPICE server library.
@@ -74,8 +87,8 @@ Summary:      Header files for SPICE server library
 Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki serwera SPICE
 Group:         Development/Libraries
 Requires:      celt051-devel >= 0.5.1.1
-%{?with_slirp:Requires:        libslirp-devel}
-Requires:      openssl-devel
+Requires:      glib2-devel >= 1:2.32
+Requires:      openssl-devel >= 1.0.0
 Requires:      pixman-devel >= 0.17.7
 Requires:      spice-server-libs = %{version}-%{release}
 
@@ -103,9 +116,10 @@ Summary(pl.UTF-8): Klient SPICE dla X11
 Group:         X11/Applications
 Requires:      celt051 >= 0.5.1.1
 Requires:      libcacard >= 0.1.2
+Requires:      opus >= 0.9.14
 Requires:      pixman >= 0.17.7
-Requires:      xorg-lib-libXrandr >= 1.2
 Requires:      xorg-lib-libXinerama >= 1.0
+Requires:      xorg-lib-libXrandr >= 1.2
 
 %description -n spice-client
 SPICE client for X11.
@@ -116,20 +130,28 @@ Klient SPICE dla X11.
 %prep
 %setup -q -n spice-%{version}
 %patch0 -p1
-%patch1 -p1
 
 %build
 %{__libtoolize}
-%{__aclocal}
+%{__aclocal} -I m4
+%{__autoconf}
+%{__autoheader}
+%{__automake}
+cd subprojects/spice-common
+%{__libtoolize}
+%{__aclocal} -I m4
 %{__autoconf}
 %{__autoheader}
 %{__automake}
+cd ../..
 %configure \
        --disable-silent-rules \
-       --enable-opengl \
+       --enable-celt051 \
+       --enable-client \
+       --enable-lz4 \
+       %{?with_opengl:--enable-opengl} \
        --enable-smartcard \
-       %{?with_slirp:en}%{!?with_slirp:dis}able-tunnel
-# --enable-gui         BR: CEGUI-devel >= 0.6.0 < 0.7.0
+       --enable-static
 
 %{__make}
 
@@ -163,7 +185,3 @@ rm -rf $RPM_BUILD_ROOT
 %files -n spice-server-static
 %defattr(644,root,root,755)
 %{_libdir}/libspice-server.a
-
-%files -n spice-client
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/spicec
This page took 0.046173 seconds and 4 git commands to generate.