]> git.pld-linux.org Git - packages/setup.git/blobdiff - setup.spec
- it must be gawk
[packages/setup.git] / setup.spec
index 185a9f64d47eec97e249474f99062ade08ae6620..b4db3dad39e662bb1c73696f8c513e291d355b9a 100644 (file)
@@ -1,6 +1,12 @@
+#
 # TODO:
 # - make some README.PLD with system features description
-# - use joinpasswd in post
+#
+# Conditional build:
+%bcond_with    ssp     # disable stack-smashing protector (vide dietlibc.spec)
+#
+%define        iana_etc_ver    1.03
+#
 Summary:       Simple setup files
 Summary(de):   Einfache Setup-Dateien
 Summary(es):   Varios archivos básicos de configuración
@@ -10,14 +16,21 @@ Summary(pl):        Podstawowe pliki systemu Linux
 Summary(pt_BR):        Vários arquivos básicos de configuração
 Summary(tr):   Basit kurulum dosyalarý
 Name:          setup
-Version:       2.4.4
-Release:       1.1
+Version:       2.4.6
+Release:       8.1
 License:       Public Domain, partially BSD-like
 Group:         Base
-Source0:       http://piorun.ds.pg.gda.pl/~blues/SOURCES/%{name}-%{version}.tar.bz2
-# Source0-md5: 74484812aa2e01e5b2fa5c4e8276969a
-BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+Source0:       %{name}-%{version}.tar.bz2
+# Source0-md5: 33afa2766c28f1fb8331bd9209bf6b04
+Source1:       http://www.sethwklein.net/projects/iana-etc/downloads/iana-etc-%{iana_etc_ver}.tar.bz2
+# Source1-md5: 670da9e41179d618498f5d614b7f4636
+Patch0:                %{name}-fstab.patch
+Patch1:                %{name}-special_users.patch
+BuildRequires: dietlibc-static
+BuildRequires: gawk
+Conflicts:     FHS < 2.3
 AutoReqProv:   no
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _sbindir        /sbin
 
@@ -56,32 +69,32 @@ Bu paket, passwd, group, profile gibi 
 dosyalarýný içerir.
 
 %prep
-%setup -q 
+%setup -q -a1
+%patch0 -p1
+%patch1 -p1
 
 %build
+%{__make} -C iana-etc-%{iana_etc_ver}
+
 %{__make} \
-       OPT_FLAGS="%{rpmcflags}" \
-       CC=%{__cc}
+       OPT_FLAGS="%{rpmcflags} %{?with_ssp:-fno-stack-protector}" \
+       CC="diet %{__cc}"
 
 %install
 rm -rf $RPM_BUILD_ROOT
+
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+install -d $RPM_BUILD_ROOT%{_sysconfdir}/shrc.d
+
+install iana-etc-%{iana_etc_ver}/protocols $RPM_BUILD_ROOT/etc/protocols
+install iana-etc-%{iana_etc_ver}/services $RPM_BUILD_ROOT/etc/services
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-#%triggerin -- %{name} < %{version}-%{release}
-#[ "$1" = "1" ] && exit 0
-#[ ! -e /etc/group.rpmnew ] && exit 0
-#cat /etc/group.rpmnew | while read GROUPLINE ; do
-#      GR="`echo $GROUPLINE | cut -f 1 -d ':'`"
-#      if ! grep -q "^$GR" /etc/group ; then
-#              echo "$GROUPLINE" >> /etc/group
-#      fi
-#done
-
-%post  -p %{_sbindir}/joinpasswd
+%triggerpostun -p %{_sbindir}/joinpasswd -- %{name} < %{version}-%{release}
 
 %files
 %defattr(644,root,root,755)
@@ -90,6 +103,9 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) /etc/profile.d/*.sh
 %attr(755,root,root) /etc/profile.d/*.csh
 %dir /etc/profile.d
+%attr(644,root,root) %config(noreplace,missingok) %verify(not md5 size mtime) %{_sysconfdir}/env.d/*
+%dir %{_sysconfdir}/env.d
+%dir %{_sysconfdir}/shrc.d
 %attr(644,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/fstab
 %attr(644,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/group
 %attr(644,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/host.conf
This page took 0.03842 seconds and 4 git commands to generate.