]> git.pld-linux.org Git - packages/sendmail.git/blobdiff - sendmail.spec
- added smtps and milter lines
[packages/sendmail.git] / sendmail.spec
index cc56c48d9cceeaeb5205e3c36cdfd83358f9fdf1..960950baf851d983f53db1ae5ee673f450a859b9 100644 (file)
@@ -1,9 +1,9 @@
 #
 # Conditional build:
-# _without_ldap                without LDAP support
-# _without_tls         without TLS (SSL) support
-# _with_db3            use db3 instead of db package
-# _with_pgsql          with PostgreSQL support (bluelabs)
+%bcond_without ldap    # without LDAP support
+%bcond_without tls     # without TLS (SSL) support
+%bcond_with    db3     # use db3 instead of db package
+%bcond_with    pgsql   # with PostgreSQL support (bluelabs)
 #
 Summary:       A widely used Mail Transport Agent (MTA)
 Summary(de):   sendmail-Mail-Übertragungsagent
@@ -16,18 +16,18 @@ Summary(ru):        
 Summary(tr):   Elektronik posta hizmetleri sunucusu
 Summary(uk):   ðÏÛÔÏ×ÉÊ ÔÒÁÎÓÐÏÒÔÎÉÊ ÁÇÅÎÔ sendmail
 Name:          sendmail
-Version:       8.12.9
-Release:       2
+Version:       8.12.10
+Release:       5
 License:       BSD
 Group:         Networking/Daemons
 Source0:       ftp://ftp.sendmail.org/pub/sendmail/%{name}.%{version}.tar.gz
-# Source0-md5: 3dba3b6d769b3681640d0a38b0eba48c
+# Source0-md5: 393f5d09d462f522c8288363870b2b42
 Source1:       %{name}.init
 Source2:       %{name}.sysconfig
 Source3:       %{name}.aliases
 # From http://doc.phpauction.org/sendmail/examples/
 Source4:       %{name}-examples.tar.bz2
-# Source4-md5: d00d817cd456a947a7fc6c04072a7d68
+# Source4-md5:  d00d817cd456a947a7fc6c04072a7d68
 Source5:       %{name}-etc-mail-Makefile
 Source6:       %{name}.mc
 Source7:       %{name}-config.m4
@@ -45,13 +45,13 @@ Patch4:             %{name}-m4path.patch
 Patch5:                %{name}-redirect.patch
 Patch6:                %{name}-hprescan-dos.patch
 Patch7:                http://blue-labs.org/clue/bluelabs.patch-8.12.3
-Patch8:                %{name}-parseaddr.patch
 BuildRequires: cyrus-sasl-devel
-%{?_with_db3:BuildRequires:    db3-devel}
-%{!?_with_db3:BuildRequires:   db-devel >= 4.1.25}
-%{!?_without_ldap:BuildRequires:       openldap-devel}
-%{!?_without_tls:BuildRequires:        openssl-devel >= 0.9.7}
-%{?_with_pgsql:BuildRequires:  postgresql-devel}
+BuildRequires: man
+%{?with_db3:BuildRequires:     db3-devel}
+%{!?with_db3:BuildRequires:    db-devel >= 4.1.25}
+%{?with_ldap:BuildRequires:    openldap-devel}
+%{?with_tls:BuildRequires:     openssl-devel >= 0.9.7c}
+%{?with_pgsql:BuildRequires:   postgresql-devel}
 Requires(pre): /bin/id
 Requires(pre): /usr/bin/getgid
 Requires(pre): /usr/sbin/groupadd
@@ -61,20 +61,24 @@ Requires(post):     textutils
 Requires(post,preun):/sbin/chkconfig
 Requires(postun):      /usr/sbin/groupdel
 Requires(postun):      /usr/sbin/userdel
-%{!?_with_db3:Requires:        db >= 4.1.25}
+%{!?with_db3:Requires: db >= 4.1.25}
 Requires:      m4
 Requires:      procmail
+Requires:      pam >= 0.77.3
 Provides:      smtpdaemon
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
-Obsoletes:     smtpdaemon
+Obsoletes:     courier
 Obsoletes:     exim
 Obsoletes:     masqmail
+Obsoletes:     nullmailer
 Obsoletes:     omta
 Obsoletes:     postfix
 Obsoletes:     qmail
 Obsoletes:     sendmail-cf
 Obsoletes:     sendmail-doc
 Obsoletes:     smail
+Obsoletes:     smtpdaemon
+Obsoletes:     ssmtp
 Obsoletes:     zmailer
 
 %define                _sysconfdir     /etc/mail
@@ -157,10 +161,7 @@ Sendmail - 
 %patch4 -p1
 %patch5 -p1
 %patch6 -p1
-%if %{?_with_pgsql:1}%{!?_with_pgsql:0}
-%patch7 -p1
-%endif
-%patch8 -p1
+%{?with_pgsql:%patch7 -p1}
 
 sed -e 's|@@PATH@@|\.\.|' < %{SOURCE6} > cf/cf/pld.mc
 
@@ -171,21 +172,22 @@ echo "define(\`confCC', \`%{__cc}')" >> config.m4
 echo "define(\`confOPTIMIZE', \`%{rpmcflags} -DUSE_VENDOR_CF_PATH=1 -DNETINET6')" >> config.m4
 echo "APPENDDEF(\`confINCDIRS', \`-I/usr/include/sasl')" >> config.m4
 echo "define(\`confLIBSEARCH', \`db resolv')" >> config.m4
-%if %{?debug:0}%{!?debug:1}
+%if 0%{!?debug:1}
 echo "define(\`confLDOPTS', \`-s')" >> config.m4
 %endif
-%if %{?_without_ldap:0}%{!?_without_ldap:1}
+%if %{with ldap}
 echo "APPENDDEF(\`confMAPDEF', \`-DLDAPMAP')" >> config.m4
 echo "APPENDDEF(\`confLIBS', \`-lldap -llber')" >> config.m4
 %endif
-%if %{?_with_pgsql:1}%{!?_with_pgsql:0}
+%if %{with pgsql}
 echo "APPENDDEF(\`confENVDEF', \`-DSASL')" >> config.m4
 echo "APPENDDEF(\`confMAPDEF', \`-DPGSQLMAP')" >> config.m4
 echo "APPENDDEF(\`confLIBS', \`-lpq -lresolv')" >> config.m4
 echo "APPENDDEF(\`confLIBS', \`-lsasl -lcrypto')" >> config.m4
 %endif
-%if %{?_without_tls:0}%{!?_without_tls:1}
+%if %{with tls}
 echo "APPENDDEF(\`confENVDEF', \`-DSTARTTLS')" >> config.m4
+echo "APPENDDEF(\`confENVDEF', \`-D_FFR_DEAL_WITH_ERROR_SSL')" >> config.m4
 echo "APPENDDEF(\`confLIBS', \`-lssl -lcrypto')" >> config.m4
 %endif
 
@@ -215,13 +217,20 @@ SMINSTOPT="DESTDIR=$RPM_BUILD_ROOT SBINOWN=$IDNU SBINGRP=$IDNG \
        UBINOWN=$IDNU UBINGRP=$IDNG MANOWN=$IDNU MANGRP=$IDNG \
        CFOWN=$IDNU CFGRP=$IDNG MSPQOWN=$IDNU GBINGRP=$IDNG GBINOWN=$IDNU \
        BINOWN=$IDNU BINGRP=$IDNG"
-%{__make} $SMINSTOPT install -C $OBJDIR/sendmail
-%{__make} $SMINSTOPT install -C $OBJDIR/mailstats
-%{__make} $SMINSTOPT install -C $OBJDIR/praliases
-%{__make} $SMINSTOPT force-install -C $OBJDIR/rmail
-%{__make} $SMINSTOPT install -C $OBJDIR/makemap
+%{__make} -C $OBJDIR/sendmail install \
+       $SMINSTOPT
+%{__make} -C $OBJDIR/mailstats install \
+       $SMINSTOPT
+%{__make} -C $OBJDIR/praliases install \
+       $SMINSTOPT
+%{__make} -C $OBJDIR/rmail force-install \
+       $SMINSTOPT
+%{__make} -C $OBJDIR/makemap install \
+       $SMINSTOPT
+%{__make} -C $OBJDIR/smrsh install \
+       $SMINSTOPT
+
 ln -sf %{_sbindir}/makemap $RPM_BUILD_ROOT%{_bindir}/makemap
-%{__make} $SMINSTOPT install -C $OBJDIR/smrsh
 
 # install the cf files
 cd cf
@@ -234,7 +243,7 @@ install cf/cf/pld.cf $RPM_BUILD_ROOT%{_sysconfdir}/sendmail.cf
 sed -e 's|@@PATH@@|%{_libdir}/sendmail-cf|' < %{SOURCE6} \
        > $RPM_BUILD_ROOT%{_sysconfdir}/sendmail.mc
 
-%if %{?_with_pgsql:1}%{!?_with_pgsql:0}
+%if %{with pgsql}
 install bluelabs.mc $RPM_BUILD_ROOT%{_sysconfdir}/bluelabs.mc
 %endif
 
@@ -399,7 +408,7 @@ fi
 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/submit.mc
 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/local-host-names
 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/aliases
-%{?_with_pgsql:%{_sysconfdir}/bluelabs.mc}
+%{?with_pgsql:%{_sysconfdir}/bluelabs.mc}
 %attr(644,root,mail) %ghost %{_sysconfdir}/aliases.db
 %attr(770,root,smmsp) %dir /var/spool/clientmqueue
 %attr(750,root,mail) %dir /var/spool/mqueue
This page took 0.123959 seconds and 4 git commands to generate.