]> git.pld-linux.org Git - packages/samba.git/blobdiff - samba.spec
- up to 3.6.6, start preparing to virusfilter support (based form old vscan spec)
[packages/samba.git] / samba.spec
index 8496ea00b5c5407c1a718b831b048a6564107583..a849394236b3f89bfe178c1cbf515810025d6a87 100644 (file)
@@ -14,6 +14,7 @@
 #      libnetapi
 #      libsmbsharemodes
 # - MERGE vfs modules into main package, what was the point of splitting these?
+#
 
 #
 # Conditional build:
 %bcond_without kerberos5       # without Kerberos V support
 %bcond_without ldap            # without LDAP support
 %bcond_without avahi
-%bcond_without merged_build    # without samba3+samba4 merge
+%bcond_with    merged_build    # without samba3+samba4 merge
+%bcond_without system_libtalloc
+%bcond_without system_libtdb
                                                                # http://wiki.samba.org/index.php/Franky
 %bcond_with    mks             # with vfs-mks (mksd dependency not distributale)
-%bcond_with    vscan
 
 # ADS requires kerberos5 and LDAP
-%if !%{with kerberos5} || !%{with ldap}
+%if %{without kerberos5} || %{without ldap}
 %undefine      with_ads
 %endif
-%define                vscan_version 0.3.6c-beta5
+
+%if %{with system_libtalloc}
+%define                libtalloc_ver   2.0.1
+%else
+%define                libtalloc_ver   %{epoch}:%{version}-%{release}
+%endif
+
+%if %{with system_libtdb}
+%define                libtdb_ver              2:1.2.9
+%else
+%define                libtdb_ver              %{epoch}:%{version}-%{release}
+%endif
+
+%define                virusfilter_version 0.1.3
 Summary:       SMB server
 Summary(cs.UTF-8):     Server SMB
 Summary(da.UTF-8):     SMB server
@@ -49,39 +64,39 @@ Summary(tr.UTF-8):  SMB sunucusu
 Summary(uk.UTF-8):     SMB клієнт та сервер
 Summary(zh_CN.UTF-8):  Samba 客户端和服务器
 Name:          samba
-Version:       3.4.5
-Release:       0.1
+Version:       3.6.6
+Release:       1
 Epoch:         1
 License:       GPL v3
 Group:         Networking/Daemons
 Source0:       http://www.samba.org/samba/ftp/stable/%{name}-%{version}.tar.gz
-# Source0-md5: 8e8a484782f2b7716b6c6bd9a7d2bf71
+# Source0-md5: 0bea52842d172231c0c0e23ee570d7af
 Source1:       smb.init
 Source2:       %{name}.pamd
 Source3:       swat.inetd
 Source4:       %{name}.sysconfig
 Source5:       %{name}.logrotate
 Source6:       smb.conf
-Source7:       http://www.openantivirus.org/download/%{name}-vscan-%{vscan_version}.tar.gz
-# Source7-md5: 8f1dd119172e04e6d7c2d05526a4cf8b
-Source8:       winbind.init
-Source9:       winbind.sysconfig
-Source10:      %{name}-rfc3454.txt
+Source7:       winbind.init
+Source8:       winbind.sysconfig
+Source9:       %{name}-rfc3454.txt
+Source10:      https://github.com/downloads/fumiyas/samba-virusfilter/samba-virusfilter-%{virusfilter_version}.tar.bz2
+# Source10-md5:        a3a30d5fbf309d356e8c5833db680c17
 Patch0:                %{name}-smbwrapper.patch
 Patch1:                %{name}-c++-nofail.patch
 Patch2:                %{name}-pthread.patch
 Patch3:                %{name}-nscd.patch
 Patch4:                %{name}-lprng-no-dot-printers.patch
-Patch5:                %{name}-python.patch
-Patch6:                %{name}-disable-unused.patch
+Patch5:                %{name}-passdb-smbpasswd.patch
 URL:           http://www.samba.org/
 BuildRequires: acl-devel
 BuildRequires: autoconf
 BuildRequires: automake
 %{?with_avahi:BuildRequires:   avahi-devel}
+BuildRequires: ctdb-devel
 %{?with_cups:BuildRequires:    cups-devel >= 1:1.2.0}
 BuildRequires: dmapi-devel
-BuildRequires: fam-devel
+BuildRequires: gamin-devel
 BuildRequires: gdbm-devel
 BuildRequires: gettext-devel
 %{?with_kerberos5:BuildRequires:       heimdal-devel}
@@ -103,12 +118,14 @@ BuildRequires:    python-modules
 BuildRequires: readline-devel >= 4.2
 BuildRequires: rpmbuild(macros) >= 1.304
 BuildRequires: sed >= 4.0
+%{?with_system_libtalloc:BuildRequires:        talloc-devel >= %{libtalloc_ver}}
+%{?with_system_libtdb:BuildRequires:   tdb-devel >= %{libtdb_ver}}
 BuildRequires: xfsprogs-devel
 Requires(post,preun):  /sbin/chkconfig
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
 Requires:      logrotate >= 3.7-4
 Requires:      pam >= 0.99.8.1
-Requires:      rc-scripts
+Requires:      rc-scripts >= 0.4.0.12
 Requires:      setup >= 2.4.6-7
 # smbd links with libcups
 %{?with_cups:Requires: cups-lib >= 1:1.2.0}
@@ -328,19 +345,14 @@ Group:            Applications/Networking
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
 %{?with_kerberos5:Requires:    heimdal-libs}
 Requires:      libsmbclient = %{epoch}:%{version}-%{release}
-Obsoletes:     mount-cifs
 Obsoletes:     smbfs
+Suggests:      cifs-utils
 
 %description client
 Samba-client provides some SMB clients, which complement the build-in
 SMB filesystem in Linux. These allow accessing of SMB shares and
 printing to SMB printers.
 
-%description client -l pt_BR.UTF-8
-O pacote samba-clientes prove alguns clientes SMB, que complementam o
-sistema de arquivos SMB do Linux. Eles permitem o acesso a shares SMB,
-e também, à impressoras SMB.
-
 %description client -l es.UTF-8
 Cliente SMB de Samba.
 
@@ -377,8 +389,8 @@ Summary(pt_BR.UTF-8):       Arquivos em comum entre samba e samba-clients
 Summary(ru.UTF-8):     Файлы, используемые как сервером, так и клиентом Samba
 Summary(uk.UTF-8):     Файли, що використовуються як сервером, так і клієнтом Samba
 Group:         Networking/Daemons
-Requires:      libtalloc >= %{epoch}:%{version}-%{release}
-Requires:      tdb >= %{epoch}:%{version}-%{release}
+Requires:      talloc >= %{libtalloc_ver}
+Requires:      tdb >= %{libtdb_ver}
 
 %description common
 Samba-common provides files necessary for both the server and client
@@ -503,8 +515,9 @@ Group:              Development/Libraries
 Requires:      libtalloc = %{epoch}:%{version}-%{release}
 
 %description -n libtalloc-devel
-The libtalloc-devel package contains the header files and libraries needed to
-develop programs that link against the talloc library in the Samba suite.
+The libtalloc-devel package contains the header files and libraries
+needed to develop programs that link against the talloc library in the
+Samba suite.
 
 %package -n tdb
 Summary:       TDB - Trivial Database
@@ -765,198 +778,26 @@ VFS module to make automatic copy of data in samba share.
 %description vfs-shadow_copy -l pl.UTF-8
 Moduł VFS do tworzenia automatycznych kopii danych w zasobach samby.
 
-%package vfs-vscan-antivir
-Summary:       On-access virus scanning for samba using AntiVir
-Summary(pl.UTF-8):     Skaner antywirusowy online wykorzystujący AntiVir
-Group:         Networking/Daemons
-Requires:      %{name} = %{epoch}:%{version}-%{release}
-Provides:      %{name}-vscan = %{epoch}:%{version}-%{release}
-
-%description vfs-vscan-antivir
-A vfs-module for samba to implement on-access scanning using the
-AntiVir antivirus software (which must be installed to use this).
-
-%description vfs-vscan-antivir -l pl.UTF-8
-Moduł vfs do samby implementujący skaning antywirusowy w czasie
-dostępu do plików korzystając z oprogramowania antywirusowego AntiVir
-(które musi być zainstalowane, aby wykorzystać ten moduł).
-
-%package vfs-vscan-clamav
-Summary:       On-access virus scanning for samba using ClamAV
-Summary(pl.UTF-8):     Skaner antywirusowy online wykorzystujący ClamAV
-Group:         Networking/Daemons
-Requires:      %{name} = %{epoch}:%{version}-%{release}
-Requires:      clamav
-Provides:      %{name}-vscan = %{epoch}:%{version}-%{release}
-
-%description vfs-vscan-clamav
-A vfs-module for samba to implement on-access scanning using the
-ClamAV antivirus software (which must be installed to use this).
-
-%description vfs-vscan-clamav -l pl.UTF-8
-Moduł vfs do samby implementujący skaning antywirusowy w czasie
-dostępu do plików korzystając z oprogramowania antywirusowego ClamAV
-(które musi być zainstalowane, aby wykorzystać ten moduł).
-
-%package vfs-vscan-fprot
-Summary:       On-access virus scanning for samba using FPROT
-Summary(pl.UTF-8):     Skaner antywirusowy online wykorzystujący FPROT
-Group:         Networking/Daemons
-Requires:      %{name} = %{epoch}:%{version}-%{release}
-Provides:      %{name}-vscan = %{epoch}:%{version}-%{release}
-Obsoletes:     vscan-fprot
-
-%description vfs-vscan-fprot
-A vfs-module for samba to implement on-access scanning using the FPROT
-antivirus software (which must be installed to use this).
-
-%description vfs-vscan-fprot -l pl.UTF-8
-Moduł vfs do samby implementujący skaning antywirusowy w czasie
-dostępu do plików korzystając z oprogramowania antywirusowego FPROT
-(które musi być zainstalowane, aby wykorzystać ten moduł).
-
-%package vfs-vscan-fsav
-Summary:       On-access virus scanning for samba using F-Secure AntiVirus
-Summary(pl.UTF-8):     Skaner antywirusowy online wykorzystujący F-Secure AntiVirus
-Group:         Networking/Daemons
-Requires:      %{name} = %{epoch}:%{version}-%{release}
-Provides:      %{name}-vscan = %{epoch}:%{version}-%{release}
-Obsoletes:     vscan-fsav
-
-%description vfs-vscan-fsav
-A vfs-module for samba to implement on-access scanning using the
-F-Secure AntiVirus antivirus software (which must be installed to use
-this).
-
-%description vfs-vscan-fsav -l pl.UTF-8
-Moduł vfs do samby implementujący skaning antywirusowy w czasie
-dostępu do plików korzystając z oprogramowania antywirusowego F-Secure
-AntiVirus (które musi być zainstalowane, aby wykorzystać ten moduł).
-
-%package vfs-vscan-kavp
-Summary:       On-access virus scanning for samba using Kaspersky AVP
-Summary(pl.UTF-8):     Skaner antywirusowy online wykorzystujący Kaspersky AVP
-Group:         Networking/Daemons
-Requires:      %{name} = %{epoch}:%{version}-%{release}
-Provides:      %{name}-vscan = %{epoch}:%{version}-%{release}
-Obsoletes:     vscan-kavp
-
-%description vfs-vscan-kavp
-A vfs-module for samba to implement on-access scanning using the
-Kaspersky AVP antivirus software (which must be installed to use
-this).
-
-%description vfs-vscan-kavp -l pl.UTF-8
-Moduł vfs do samby implementujący skaning antywirusowy w czasie
-dostępu do plików korzystając z oprogramowania antywirusowego
-Kaspersky AVP (które musi być zainstalowane, aby wykorzystać ten
-moduł).
-
-%package vfs-vscan-mcafee
-Summary:       On-access virus scanning for samba using mcafee
-Summary(pl.UTF-8):     Skaner antywirusowy online wykorzystujący mcafee
-Group:         Networking/Daemons
-Requires:      %{name} = %{epoch}:%{version}-%{release}
-#Requires:     mcafee
-Provides:      %{name}-vscan = %{epoch}:%{version}-%{release}
-Obsoletes:     vscan-mcafee
-
-%description vfs-vscan-mcafee
-A vfs-module for samba to implement on-access scanning using the
-mcafee antivirus software (which must be installed to use this).
-
-%description vfs-vscan-mcafee -l pl.UTF-8
-Moduł vfs do samby implementujący skaning antywirusowy w czasie
-dostępu do plików korzystając z oprogramowania antywirusowego mcafee
-(które musi być zainstalowane, aby wykorzystać ten moduł).
-
-%package vfs-vscan-mks
-Summary:       On-access virus scanning for samba using mks
-Summary(pl.UTF-8):     Skaner antywirusowy online wykorzystujący mks
-Group:         Networking/Daemons
-Requires:      %{name} = %{epoch}:%{version}-%{release}
-Requires:      mksd
-Provides:      %{name}-vscan = %{epoch}:%{version}-%{release}
-Obsoletes:     vscan-mks
-
-%description vfs-vscan-mks
-A vfs-module for samba to implement on-access scanning using the mks
-antivirus software (which must be installed to use this).
-
-%description vfs-vscan-mks -l pl.UTF-8
-Moduł vfs do samby implementujący skaning antywirusowy w czasie
-dostępu do plików korzystając z oprogramowania antywirusowego mks
-(które musi być zainstalowane, aby wykorzystać ten moduł).
-
-%package vfs-vscan-openantivirus
-Summary:       On-access virus scanning for samba using OpenAntivirus
-Summary(pl.UTF-8):     Skaner antywirusowy online wykorzystujący OpenAntiVirus
-Group:         Networking/Daemons
-Requires:      %{name} = %{epoch}:%{version}-%{release}
-Provides:      %{name}-vscan = %{epoch}:%{version}-%{release}
-Obsoletes:     vscan-openantivirus
-
-%description vfs-vscan-openantivirus
-A vfs-module for samba to implement on-access scanning using the
-OpenAntivirus antivirus software (which must be installed to use
-this).
-
-%description vfs-vscan-openantivirus -l pl.UTF-8
-Moduł vfs do samby implementujący skaning antywirusowy w czasie
-dostępu do plików korzystając z oprogramowania antywirusowego
-OpenAntiVirus.org (które musi być zainstalowane, aby wykorzystać ten
-moduł).
-
-%package vfs-vscan-sophos
-Summary:       On-access virus scanning for samba using Sophos
-Summary(pl.UTF-8):     Skaner antywirusowy online wykorzystujący Sophos
-Group:         Networking/Daemons
-Requires:      %{name} = %{epoch}:%{version}-%{release}
-Provides:      %{name}-vscan = %{epoch}:%{version}-%{release}
-Obsoletes:     vscan-sophos
-
-%description vfs-vscan-sophos
-A vfs-module for samba to implement on-access scanning using the
-Sophos antivirus software (which must be installed to use this).
-
-%description vfs-vscan-sophos -l pl.UTF-8
-Moduł vfs do samby implementujący skaning antywirusowy w czasie
-dostępu do plików korzystając z oprogramowania antywirusowego Sophos
-(które musi być zainstalowane, aby wykorzystać ten moduł).
-
-%package vfs-vscan-symantec
-Summary:       On-access virus scanning for samba using Symantec
-Summary(pl.UTF-8):     Skaner antywirusowy online wykorzystujący Symantec
+%package vfs-catia
+Summary:       VFS module to fix Catia CAD filenames
 Group:         Networking/Daemons
 Requires:      %{name} = %{epoch}:%{version}-%{release}
-Provides:      %{name}-vscan = %{epoch}:%{version}-%{release}
-Obsoletes:     vscan-symantec
 
-%description vfs-vscan-symantec
-A vfs-module for samba to implement on-access scanning using the
-Symantec antivirus software (which must be installed to use this).
+%description vfs-catia
+The Catia CAD package commonly creates filenames that use characters
+that are illegal in CIFS filenames. The vfs_catia VFS module
+implements a fixed character mapping so that these files can be shared
+with CIFS clients.
 
-%description vfs-vscan-symantec -l pl.UTF-8
-Moduł vfs do samby implementujący skaning antywirusowy w czasie
-dostępu do plików korzystając z oprogramowania antywirusowego firmy
-Symantec (które musi być zainstalowane, aby wykorzystać ten moduł).
-
-%package vfs-vscan-trend
-Summary:       On-access virus scanning for samba using Trend
-Summary(pl.UTF-8):     Skaner antywirusowy online wykorzystujący Trend
+%package vfs-scannedonly
+Summary:       Anti-virus solution as VFS module
 Group:         Networking/Daemons
 Requires:      %{name} = %{epoch}:%{version}-%{release}
-Provides:      %{name}-vscan = %{epoch}:%{version}-%{release}
-Obsoletes:     vscan-trend
-
-%description vfs-vscan-trend
-A vfs-module for samba to implement on-access scanning using the Trend
-antivirus software (which must be installed to use this).
 
-%description vfs-vscan-trend -l pl.UTF-8
-Moduł vfs do samby implementujący skaning antywirusowy w czasie
-dostępu do plików korzystając z oprogramowania antywirusowego Trend
-(które musi być zainstalowane, aby wykorzystać ten moduł).
+%description vfs-scannedonly
+The vfs_scannedonly VFS module ensures that only files that have been
+scanned for viruses are visible and accessible to the end user. If
+non-scanned files are found an anti-virus scanning daemon is notified.
 
 %package -n openldap-schema-samba
 Summary:       Samba LDAP schema
@@ -1009,19 +850,29 @@ Samba Module for Python.
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
+%if "%{pld_release}" == "ti"
 %patch5 -p1
-%patch6 -p1
+%endif
 
 %{__sed} -i 's#%SAMBAVERSION%#%{version}#' docs/htmldocs/index.html
 
-cd examples/VFS
-tar xzf %{SOURCE7}
-mv README{,.vfs}
-cd ../..
+# deprecated in gnutls 3.0
+%{__sed} -i -e "s/gnutls_transport_set_lowat(tls->session, 0);//"      source4/lib/tls/tls.c
+%{__sed} -i -e "s/gnutls_transport_set_lowat(tlss->tls_session, 0);//" source4/lib/tls/tls_tstream.c
 
-install %{SOURCE10} source4/heimdal/lib/wind/rfc3454.txt
+#cd examples/VFS
+#mv README{,.vfs}
+#cd ../..
+
+install %{SOURCE9} source4/heimdal/lib/wind/rfc3454.txt
 
 %build
+# use ld.bfd because gold doesn't understand linker script
+install -d our-ld
+ln -s %{_bindir}/ld.bfd our-ld/ld
+export PATH=$(pwd)/our-ld:$PATH
+
+
 cd source3
 %{__libtoolize}
 %{__autoconf} -Im4 -I../m4 -I../lib/replace -Ilib/replace -I../source4
@@ -1044,16 +895,23 @@ cd source3
        --with-syslog \
        --with-utmp \
        --with-fhs \
+%if %{with system_libtalloc}
+       --with-libtalloc=no \
+       --enable-external-libtalloc=yes \
+%endif
+%if %{with system_libtdb}
+       --with-libtdb=no \
+       --enable-external-libtdb=yes \
+%endif
        --without-included-popt \
-       --%{?with_merged_build:en}%{!?with_merged_build:dis}able-merged-build \
-       --enable-automatic-dependencies \
        --enable-dso \
        --%{?with_avahi:en}%{!?with_avahi:dis}able-avahi \
        --disable-dnssd \
        --with%{!?with_ldap:out}-ldap \
        --with%{!?with_kerberos5:out}-krb5
 
-%{__make} -j1 everything pam_smbpass bin/smbget bin/mount.cifs bin/vfstest
+%{__make} -j1 everything pam_smbpass bin/smbget bin/vfstest \
+       LD=ld
 
 cd ../examples
 %{__make} -C libsmbclient/smbwrapper \
@@ -1067,14 +925,6 @@ cd VFS
        CFLAGS="%{rpmcflags} -fPIC"
 %{__make}
 
-%if %{with vscan}
-cd samba-vscan-%{vscan_version}
-cp -f /usr/share/automake/config.sub .
-%configure
-ln -s ../../../source3/lib .
-%{__make} all
-%endif
-
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT/etc/{logrotate.d,rc.d/init.d,pam.d,security,sysconfig/rc-inetd} \
@@ -1086,42 +936,39 @@ install -d $RPM_BUILD_ROOT/etc/{logrotate.d,rc.d/init.d,pam.d,security,sysconfig
        DESTDIR=$RPM_BUILD_ROOT \
        CONFIGDIR=$RPM_BUILD_ROOT%{_sysconfdir}/samba
 
-install source3/script/mksmbpasswd.sh $RPM_BUILD_ROOT%{_sbindir}
+install -p source3/script/mksmbpasswd.sh $RPM_BUILD_ROOT%{_sbindir}
 
-install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/smb
-install %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/samba
-install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/swat
-install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/samba
-install %{SOURCE5} $RPM_BUILD_ROOT/etc/logrotate.d/samba
-install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/samba/smb.conf
-install %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/winbind
-install %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/winbind
+install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/smb
+cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/samba
+install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/swat
+cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/samba
+cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/logrotate.d/samba
+cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/samba/smb.conf
+install -p %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/winbind
+cp -p %{SOURCE8} $RPM_BUILD_ROOT/etc/sysconfig/winbind
 
-install nsswitch/libnss_winbind.so $RPM_BUILD_ROOT/%{_lib}/libnss_winbind.so.2
+install -p nsswitch/libnss_winbind.so $RPM_BUILD_ROOT/%{_lib}/libnss_winbind.so.2
 ln -s libnss_winbind.so.2              $RPM_BUILD_ROOT/%{_lib}/libnss_winbind.so
-install nsswitch/libnss_wins.so        $RPM_BUILD_ROOT/%{_lib}/libnss_wins.so.2
+install -p nsswitch/libnss_wins.so     $RPM_BUILD_ROOT/%{_lib}/libnss_wins.so.2
 ln -s libnss_wins.so.2                 $RPM_BUILD_ROOT/%{_lib}/libnss_wins.so
-install source3/bin/wbinfo             $RPM_BUILD_ROOT%{_bindir}
-install source3/bin/smbget             $RPM_BUILD_ROOT%{_bindir}
-install source3/bin/vfstest            $RPM_BUILD_ROOT%{_bindir}
+install -p source3/bin/wbinfo          $RPM_BUILD_ROOT%{_bindir}
+install -p source3/bin/smbget          $RPM_BUILD_ROOT%{_bindir}
+install -p source3/bin/vfstest         $RPM_BUILD_ROOT%{_bindir}
 
-install source3/bin/libsmbclient.a $RPM_BUILD_ROOT%{_libdir}/libsmbclient.a
+cp -a source3/bin/libsmbclient.a $RPM_BUILD_ROOT%{_libdir}/libsmbclient.a
 
 # smbwrapper
-install examples/libsmbclient/smbwrapper/smbwrapper.so $RPM_BUILD_ROOT%{_libdir}/smbwrapper.so
-install examples/libsmbclient/smbwrapper/smbsh $RPM_BUILD_ROOT%{_bindir}
-install examples/libsmbclient/smbwrapper/smbsh.1 $RPM_BUILD_ROOT%{_mandir}/man1
+install -p examples/libsmbclient/smbwrapper/smbwrapper.so $RPM_BUILD_ROOT%{_libdir}/smbwrapper.so
+install -p examples/libsmbclient/smbwrapper/smbsh $RPM_BUILD_ROOT%{_bindir}
+cp -p examples/libsmbclient/smbwrapper/smbsh.1 $RPM_BUILD_ROOT%{_mandir}/man1
 
 # these are needed to build samba-pdbsql
-install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/{tdb,nsswitch}
+install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/nsswitch
 cp -a source3/include/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}
-cp -a lib/tdb/include/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/tdb
 cp -a nsswitch/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/nsswitch
-
-%if %{with vscan}
-# vscan modules
-install examples/VFS/samba-vscan-%{vscan_version}/*.so $RPM_BUILD_ROOT%{_vfsdir}
-install examples/VFS/samba-vscan-%{vscan_version}/{antivir,clamav,fprot,icap,kaspersky,mks,openantivirus,sophos,trend,f-secure,nai}/*.conf $RPM_BUILD_ROOT%{_sysconfdir}/samba
+%if %{without system_libtdb}
+install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/tdb
+cp -a lib/tdb/include/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/tdb
 %endif
 
 touch $RPM_BUILD_ROOT/var/lib/samba/{wins.dat,browse.dat}
@@ -1137,7 +984,7 @@ ln -s %{_bindir}/smbspool $RPM_BUILD_ROOT%{cups_serverbin}/backend/smb
 > $RPM_BUILD_ROOT/etc/security/blacklist.samba
 
 # unneeded
-rm -r $RPM_BUILD_ROOT%{_datadir}/swat/using_samba
+#rm -r $RPM_BUILD_ROOT%{_datadir}/swat/using_samba
 
 # tests
 %if %{with merged_build}
@@ -1148,6 +995,13 @@ rm -r $RPM_BUILD_ROOT%{_bindir}/{gentest4,locktest4,masktest4,nsstest4}
 install examples/LDAP/samba.schema $RPM_BUILD_ROOT%{schemadir}
 %endif
 
+%if %{with system_libtdb}
+# remove manuals of tdb if system lib used
+%{__rm} $RPM_BUILD_ROOT%{_mandir}/man8/tdbbackup.8*
+%{__rm} $RPM_BUILD_ROOT%{_mandir}/man8/tdbdump.8*
+%{__rm} $RPM_BUILD_ROOT%{_mandir}/man8/tdbtool.8*
+%endif
+
 %find_lang pam_winbind
 
 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
@@ -1212,6 +1066,7 @@ if [ "$1" != "0" ]; then
        /sbin/chkconfig --add smb
 fi
 
+%if "%{pld_release}" != "ti"
 %triggerpostun -- samba < 3.4.0
 %banner %{name} << EOF
 !!! WARNING !!! The default passdb backend has been changed to 'tdbsam'!
@@ -1219,6 +1074,7 @@ That breaks existing setups using the 'smbpasswd' backend without explicit decla
 Please use 'passdb backend = smbpasswd' if you would like to stick to the 'smbpasswd'
 backend or convert your smbpasswd entries using e.g. 'pdbedit -i smbpasswd -e tdbsam'.
 EOF
+%endif
 
 %files
 %defattr(644,root,root,755)
@@ -1226,33 +1082,40 @@ EOF
 %attr(755,root,root) %{_sbindir}/smbd
 %attr(755,root,root) %{_sbindir}/mksmbpasswd.sh
 %if %{with merged_build}
-%attr(755,root,root) %{_bindir}/ad2oLschema4
+#%attr(755,root,root) %{_bindir}/ad2oLschema4
 %attr(755,root,root) %{_bindir}/oLschema2ldif4
 %attr(755,root,root) %{_bindir}/reg*
 # "This utility disabled until rewritten"
 #%attr(755,root,root) %{_bindir}/setnttoken4
 %endif
-%attr(755,root,root) %{_bindir}/ldb*
 %attr(755,root,root) %{_bindir}/smbstatus
 %attr(755,root,root) %{_bindir}/smbpasswd
+%attr(755,root,root) %{_bindir}/smbta-util
 %attr(755,root,root) %{_bindir}/smbcontrol
 
+%dir %{_libdir}/%{name}/idmap
+%attr(755,root,root)  %{_libdir}/%{name}/idmap/autorid.so
+%{_mandir}/man8/idmap_autorid.8*
 %dir %{_libdir}/%{name}/pdb
 %dir %{_vfsdir}
 %attr(755,root,root) %{_vfsdir}/acl_tdb.so
 %attr(755,root,root) %{_vfsdir}/acl_xattr.so
 %attr(755,root,root) %{_vfsdir}/aio_fork.so
+%attr(755,root,root) %{_vfsdir}/crossrename.so
 %attr(755,root,root) %{_vfsdir}/dirsort.so
 %attr(755,root,root) %{_vfsdir}/fileid.so
+%attr(755,root,root) %{_vfsdir}/linux_xfs_sgid.so
 %attr(755,root,root) %{_vfsdir}/preopen.so
 %attr(755,root,root) %{_vfsdir}/shadow_copy2.so
 %attr(755,root,root) %{_vfsdir}/smb_traffic_analyzer.so
 %attr(755,root,root) %{_vfsdir}/streams_depot.so
 %attr(755,root,root) %{_vfsdir}/streams_xattr.so
 %attr(755,root,root) %{_vfsdir}/syncops.so
+%attr(755,root,root) %{_vfsdir}/time_audit.so
 %attr(755,root,root) %{_vfsdir}/xattr_tdb.so
 %{_mandir}/man8/vfs_acl_tdb.8*
 %{_mandir}/man8/vfs_acl_xattr.8*
+%{_mandir}/man8/vfs_crossrename.8*
 %{_mandir}/man8/vfs_dirsort.8*
 %{_mandir}/man8/vfs_fileid.8*
 %{_mandir}/man8/vfs_preopen.8*
@@ -1260,6 +1123,7 @@ EOF
 %{_mandir}/man8/vfs_smb_traffic_analyzer.8*
 %{_mandir}/man8/vfs_streams_xattr.8*
 %{_mandir}/man8/vfs_streams_depot.8*
+%{_mandir}/man8/vfs_time_audit.8*
 %{_mandir}/man8/vfs_xattr_tdb.8*
 
 
@@ -1269,7 +1133,6 @@ EOF
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/samba
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/samba
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.samba
-%{_mandir}/man1/ldb*.1*
 %{_mandir}/man1/log2pcap.1*
 %{_mandir}/man1/smbstatus.1*
 %{_mandir}/man1/smbcontrol.1*
@@ -1298,14 +1161,15 @@ EOF
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_sbindir}/winbindd
 %attr(755,root,root) %{_bindir}/wbinfo
-%if %{with merged_build}
-%attr(755,root,root) %{_bindir}/wbinfo4
-%endif
+#%if %{with merged_build}
+#%attr(755,root,root) %{_bindir}/wbinfo4
+#%endif
 %attr(755,root,root) /%{_lib}/security/pam_winbind*
 %attr(755,root,root) /%{_lib}/libnss_winbind*
 %attr(754,root,root) /etc/rc.d/init.d/winbind
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/winbind
 %{_mandir}/man1/wbinfo*.1*
+%{_mandir}/man5/pam_winbind.conf.5*
 %{_mandir}/man8/pam_winbind.8*
 %{_mandir}/man8/winbindd*.8*
 
@@ -1320,11 +1184,9 @@ EOF
 %attr(755,root,root) %{_bindir}/net4
 %attr(755,root,root) %{_bindir}/nmblookup4
 %attr(755,root,root) %{_bindir}/smbclient4
-%attr(755,root,root) %{_sbindir}/cifs.upcall
-%{_mandir}/man8/cifs.upcall.8*
+%attr(755,root,root) %{_bindir}/setnttoken4
+%attr(755,root,root) %{_bindir}/smbtorture4
 %endif
-%attr(755,root,root) /sbin/mount.cifs
-%attr(755,root,root) /sbin/umount.cifs
 %attr(755,root,root) %{_bindir}/findsmb
 %attr(755,root,root) %{_bindir}/net
 %attr(755,root,root) %{_bindir}/nmblookup
@@ -1346,7 +1208,6 @@ EOF
 %{_mandir}/man1/smbtar.1*
 %{_mandir}/man1/smbtree.1*
 %{_mandir}/man8/net.8*
-%{_mandir}/man8/*mount.cifs.8*
 
 %files common
 %defattr(644,root,root,755)
@@ -1437,6 +1298,7 @@ EOF
 %{_includedir}/libsmbclient.h
 %{_includedir}/wbclient.h
 
+%if %{without system_libtalloc}
 %files -n libtalloc
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libtalloc.so.*
@@ -1445,7 +1307,9 @@ EOF
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libtalloc.so
 %{_includedir}/talloc.h
+%endif
 
+%if %{without system_libtdb}
 %files -n tdb
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/tdbbackup
@@ -1455,6 +1319,7 @@ EOF
 %attr(755,root,root) %{_bindir}/tdbbackup4
 %attr(755,root,root) %{_bindir}/tdbdump4
 %attr(755,root,root) %{_bindir}/tdbtool4
+%attr(755,root,root) %{_bindir}/tdbtorture4
 %endif
 %attr(755,root,root) %{_libdir}/libtdb.so.*
 %{_mandir}/man8/tdbbackup.8*
@@ -1465,6 +1330,7 @@ EOF
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libtdb.so
 %{_includedir}/tdb.h
+%endif
 
 %files devel
 %defattr(644,root,root,755)
@@ -1546,77 +1412,15 @@ EOF
 %attr(755,root,root) %{_vfsdir}/shadow_copy.so
 %{_mandir}/man8/vfs_shadow_copy.8*
 
-%if %{with vscan}
-%files vfs-vscan-antivir
+%files vfs-catia
 %defattr(644,root,root,755)
-#%doc examples/VFS/%{name}-vscan-%{vscan_version}/{INSTALL,FAQ}
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/samba/vscan-antivir.conf
-%attr(755,root,root) %{_vfsdir}/vscan-antivir.so
+%attr(755,root,root) %{_vfsdir}/catia.so
+%{_mandir}/man8/vfs_catia.8*
 
-%files vfs-vscan-clamav
+%files vfs-scannedonly
 %defattr(644,root,root,755)
-#%doc examples/VFS/%{name}-vscan-%{vscan_version}/{INSTALL,FAQ}
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/samba/vscan-clamav.conf
-%attr(755,root,root) %{_vfsdir}/vscan-clamav.so
-
-%files vfs-vscan-fprot
-%defattr(644,root,root,755)
-#%doc examples/VFS/%{name}-vscan-%{vscan_version}/{INSTALL,FAQ}
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/samba/vscan-fprotd.conf
-%attr(755,root,root) %{_vfsdir}/vscan-fprotd.so
-
-%files vfs-vscan-fsav
-%defattr(644,root,root,755)
-#%doc examples/VFS/%{name}-vscan-%{vscan_version}/{INSTALL,FAQ}
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/samba/vscan-fsav.conf
-%attr(755,root,root) %{_vfsdir}/vscan-fsav.so
-
-%files vfs-vscan-kavp
-%defattr(644,root,root,755)
-#%doc examples/VFS/%{name}-vscan-%{vscan_version}/{INSTALL,FAQ}
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/samba/vscan-kavp.conf
-%attr(755,root,root) %{_vfsdir}/vscan-kavp.so
-
-%files vfs-vscan-mcafee
-%defattr(644,root,root,755)
-#%doc examples/VFS/%{name}-vscan-%{vscan_version}/{INSTALL,FAQ}
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/samba/vscan-mcdaemon.conf
-%attr(755,root,root) %{_vfsdir}/vscan-mcdaemon.so
-
-%if %{with mks}
-%ifarch %{ix86} %{x8664}
-%files vfs-vscan-mks
-%defattr(644,root,root,755)
-#%doc examples/VFS/%{name}-vscan-%{vscan_version}/{INSTALL,FAQ}
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/samba/vscan-mks32.conf
-%attr(755,root,root) %{_vfsdir}/vscan-mksd.so
-%endif
-%endif
-
-%files vfs-vscan-openantivirus
-%defattr(644,root,root,755)
-#%doc examples/VFS/%{name}-vscan-%{vscan_version}/{INSTALL,FAQ}
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/samba/vscan-oav.conf
-%attr(755,root,root) %{_vfsdir}/vscan-oav.so
-
-%files vfs-vscan-sophos
-%defattr(644,root,root,755)
-#%doc examples/VFS/%{name}-vscan-%{vscan_version}/{INSTALL,FAQ}
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/samba/vscan-sophos.conf
-%attr(755,root,root) %{_vfsdir}/vscan-sophos.so
-
-%files vfs-vscan-symantec
-%defattr(644,root,root,755)
-#%doc examples/VFS/%{name}-vscan-%{vscan_version}/{INSTALL,FAQ}
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/samba/vscan-icap.conf
-%attr(755,root,root) %{_vfsdir}/vscan-icap.so
-
-%files vfs-vscan-trend
-%defattr(644,root,root,755)
-#%doc examples/VFS/%{name}-vscan-%{vscan_version}/{INSTALL,FAQ}
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/samba/vscan-trend.conf
-%attr(755,root,root) %{_vfsdir}/vscan-trend.so
-%endif
+%attr(755,root,root) %{_vfsdir}/scannedonly.so
+%{_mandir}/man8/vfs_scannedonly.8*
 
 %if %{with ldap}
 %files -n openldap-schema-samba
This page took 0.059071 seconds and 4 git commands to generate.