]> git.pld-linux.org Git - packages/samba.git/blobdiff - samba.spec
- existings patches first
[packages/samba.git] / samba.spec
index eb938197f294a1ba59436f80fe5857407d48cdb8..73944abdf3e2d0e6794638d3c6441beb1952f114 100644 (file)
@@ -1,20 +1,26 @@
 #
 # TODO:
-# - package python tools
+# - fix Summary and Description for python-samba package
 # - look into other distro specs for valid %descriptions for samba 3
 # - review configure options
 # - fix broken --without ldap, test functionality with other bconds
-# - new package with McAfee vscan - I dunno what to do with daemon
+# - check tdbtool (with tdb.spec)
 #
 # Conditional build:
+%bcond_without ads             # without ActiveDirectory support
 %bcond_without cups            # without CUPS support
+%bcond_without krb5            # without Kerberos5/Heimdal support
+%bcond_without ldap            # without LDAP support
 %bcond_without mysql           # without MySQL support
+%bcond_without pgsql           # without PostgreSQL support
+%bcond_without python          # without python libs/utils
 %bcond_with    ldapsam         # with LDAP SAM 2.2 based auth (instead of smbpasswd)
 #%bcond_with   ipv6            # with IPv6 support
-%bcond_without ldap            # without LDAP support
-%bcond_without krb5            # without Kerberos5/Heimdal support
-%bcond_with    python          # with python utils, not builds, not packaged now
 #
+# ADS requires krb5 and LDAP
+%if %{without krb5} || %{without ldap}
+%undefine      with_ads
+%endif
 %define                vscan_version 0.3.5
 Summary:       SMB server
 Summary(cs):   Server SMB
@@ -33,13 +39,13 @@ Summary(tr):        SMB sunucusu
 Summary(uk):   SMB Ë̦¤ÎÔ ÔÁ ÓÅÒ×ÅÒ
 Summary(zh_CN):        Samba ¿Í»§¶ËºÍ·þÎñÆ÷
 Name:          samba
-Version:       3.0.4
+Version:       3.0.10
 Release:       1
 Epoch:         1
 License:       GPL v2
 Group:         Networking/Daemons
-Source0:       http://www.samba.org/samba/ftp/%{name}-%{version}.tar.gz
-# Source0-md5: 0156265c1e95ac662deef386f615504f
+Source0:       http://us1.samba.org/samba/ftp/%{name}-%{version}.tar.gz
+# Source0-md5: b19fd86d3c11a1b43f75a5988cd9ceeb
 Source1:       smb.init
 Source2:       %{name}.pamd
 Source3:       swat.inetd
@@ -52,7 +58,11 @@ Source8:     winbind.init
 Source9:       winbind.sysconfig
 Patch0:                %{name}-statfs-workaround.patch
 Patch1:                %{name}-lib64.patch
-#Patch2:       http://v6web.litech.org/samba/%{name}-2.2.4+IPv6-20020609.diff
+Patch2:                %{name}-setup-python.patch
+Patch3:                %{name}-FHS.patch
+Patch4:                %{name}-case_insensitive_sql_operator.patch
+Patch5:                %{name}-3_0_9-printing.patch
+#Patch6:       http://v6web.litech.org/samba/%{name}-2.2.4+IPv6-20020609.diff
 URL:           http://www.samba.org/
 BuildRequires: acl-devel
 BuildRequires: autoconf
@@ -65,6 +75,9 @@ BuildRequires:        libxml2-devel
 BuildRequires: mysql-devel
 BuildRequires: mysql-extras
 %endif
+%if %{with pgsql}
+BuildRequires: postgresql-devel
+%endif
 BuildRequires: ncurses-devel >= 5.2
 %{?with_ldap:BuildRequires:    openldap-devel}
 BuildRequires: openssl-devel >= 0.9.7d
@@ -74,16 +87,18 @@ BuildRequires:      readline-devel >= 4.2
 BuildRequires: xfsprogs-devel
 %{?with_python:BuildRequires:  python-devel}
 PreReq:                rc-scripts
+PreReq:                setup >= 2.4.6-7
 Requires(post,preun):  /sbin/chkconfig
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
 Requires:      logrotate
 Requires:      pam >= 0.66
+Obsoletes:     samba-vfs-block
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _vfsdir         %{_libdir}/%{name}/vfs
 %define                _sambahome      /home/services/samba
 %if %{with cups}
-%define                cups_serverbin  %(cups-config --serverbin)
+%define                cups_serverbin  %{_libdir}/cups
 %endif
 
 %description
@@ -290,6 +305,18 @@ Samba MySQL password database plugin.
 %description pdb-mysql -l pl
 Wtyczka Samby do przechowywania hase³ w bazie MySQL.
 
+%package pdb-pgsql
+Summary:       Samba PostgreSQL password database plugin
+Summary(pl):   Wtyczka Samby do przechowywania hase³ w bazie PostgreSQL
+Group:         Networking/Daemons
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+
+%description pdb-pgsql
+Samba MySQL password database plugin.
+
+%description pdb-pgsql -l pl
+Wtyczka Samby do przechowywania hase³ w bazie MySQL.
+
 %package pdb-xml
 Summary:       Samba XML password database plugin
 Summary(pl):   Wtyczka Samby do przechowywania hase³ w bazie XML
@@ -311,9 +338,9 @@ Summary(pt_BR):     Cliente SMB do samba
 Summary(ru):   ëÌÉÅÎÔÓËÉÅ ÐÒÏÇÒÁÍÍÙ Samba (SMB)
 Summary(uk):   ë̦¤ÎÔÓØ˦ ÐÒÏÇÒÁÍÉ Samba (SMB)
 Group:         Applications/Networking
-Requires:      samba-common = %{epoch}:%{version}-%{release}
-Obsoletes:     smbfs
+Requires:      %{name}-common = %{epoch}:%{version}-%{release}
 Obsoletes:     mount-cifs
+Obsoletes:     smbfs
 
 %description client
 Samba-client provides some SMB clients, which complement the build-in
@@ -429,7 +456,7 @@ file.
 
 %description -n pam-pam_smbpass -l pl
 Modu³ PAM, który mo¿e byæ u¿ywany do trzymania pliku smbpasswd (has³a
-Samby) zsynchronizowanego z has³ami unixowymi.
+Samby) zsynchronizowanego z has³ami uniksowymi.
 
 %package -n libsmbclient
 Summary:       libsmbclient - samba client library
@@ -498,6 +525,17 @@ CUPS backend for printing to SMB printers.
 %description -n cups-backend-smb -l pl
 Backend CUPS-a drukuj±cy na drukarkach SMB.
 
+%package -n python-samba
+Summary:       Samba python tools and libraries
+Summary(pl):   Narzêdzia i biblioteki pythona do samby
+Group:         Applications/Networking
+
+%description -n python-samba
+Samba python tools and libraries.
+
+%description -n python-samba -l pl
+Narzêdzia i biblioteki pythona do samby.
+
 %package vfs-audit
 Summary:       VFS module to audit file access
 Summary(pl):   Modu³ VFS do monitorowania operacji na plikach
@@ -515,30 +553,6 @@ Monitorowane s
 otwarcie/utworzenie/zmiana nazwy katalogu, otwarcie/zamknêcie/zmiana
 nazwy/skasowania/zmiana praw plików.
 
-%package vfs-recycle
-Summary:       VFS module to add recycle bin facility to a samba share
-Summary(pl):   Modu³ VFS dodaj±cy mo¿liwo¶æ kosza do zasobu samby
-Group:         Networking/Daemons
-Requires:      %{name} = %{epoch}:%{version}-%{release}
-
-%description vfs-recycle
-VFS module to add recycle bin facility to a samba share.
-
-%description vfs-recycle -l pl
-Modu³ VFS dodaj±cy mo¿liwo¶æ kosza do zasobu samby.
-
-%package vfs-shadow_copy
-Summary:       VFS module to make automatic copy of data in samba share
-Summary(pl):   Modu³ VFS do tworzenia automatycznych kopii danych w zasobach samby
-Group:         Networking/Daemons
-Requires:      %{name} = %{epoch}:%{version}-%{release}
-
-%description vfs-shadow_copy
-VFS module to make automatic copy of data in samba share.
-
-%description vfs-shadow_copy -l pl
-Modu³ VFS do tworzenia automatycznych kopii danych w zasobach samby.
-
 %package vfs-cap
 Summary:       VFS module for CAP and samba compatibility
 Summary(pl):   Modu³ VFS zgodno¶ci z CAP (Columbia AppleTalk Program)
@@ -554,25 +568,18 @@ This is used for compatibility between Samba and CAP.
 Zamienia znaki kodowane Shift-JIS do trzybajowej szestnastkowej
 reprezentacji u¿ywanej przez program Columbia AppleTalk Program (CAP).
 
-%package vfs-readonly
-Summary:       VFS module
-Summary(pl):   Modu³ VFS
-Group:         Networking/Daemons
-Requires:      %{name} = %{epoch}:%{version}-%{release}
-
-%description vfs-readonly
-
-%description vfs-readonly -l pl
-
 %package vfs-default_quota
-Summary:       VFS module
-Summary(pl):   Modu³ VFS
+Summary:       VFS module to store default quotas in a specified quota record
+Summary(pl):   Modu³ VFS do zapisywania domy¶lnych limitów w okre¶lonym rekordzie
 Group:         Networking/Daemons
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description vfs-default_quota
+This VFS modules stores default quotas in a specified quota record.
 
-%description vfs-default-quota -l pl
+%description vfs-default_quota -l pl
+Ten modu³ VFS zapisuje domy¶lne limity (quoty) w okre¶lonym rekordzie
+limitów.
 
 %package vfs-expand_msdfs
 Summary:       VFS module for hosting a Microsoft Distributed File System Tree
@@ -634,6 +641,46 @@ and netatalk file sharing services.
 Pakiet zawiera modu³ VFS netatalk umo¿liwiaj±cy wspó³pracê us³ug samba
 i netatalk przy udostêpnianiu zasobów.
 
+%package vfs-recycle
+Summary:       VFS module to add recycle bin facility to a samba share
+Summary(pl):   Modu³ VFS dodaj±cy mo¿liwo¶æ kosza do zasobu samby
+Group:         Networking/Daemons
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+
+%description vfs-recycle
+VFS module to add recycle bin facility to a samba share.
+
+%description vfs-recycle -l pl
+Modu³ VFS dodaj±cy mo¿liwo¶æ kosza do zasobu samby.
+
+%package vfs-readonly
+Summary:       VFS module for read-only limitation for specified share
+Summary(pl):   Modu³ VFS do ograniczania okre¶lonego udzia³u tylko do odczytu
+Group:         Networking/Daemons
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+
+%description vfs-readonly
+This module performs a read-only limitation for specified share (or
+all of them if it is loaded in a [global] section) based on period
+definition in smb.conf.
+
+%description vfs-readonly -l pl
+Ten modu³ wprowadza ograniczenie tylko do odczytu dla okre¶lonego
+udzia³u (lub wszystkich, je¶li jest wczytywany w sekcji [global]) w
+oparciu o definicje okresów w smb.conf.
+
+%package vfs-shadow_copy
+Summary:       VFS module to make automatic copy of data in samba share
+Summary(pl):   Modu³ VFS do tworzenia automatycznych kopii danych w zasobach samby
+Group:         Networking/Daemons
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+
+%description vfs-shadow_copy
+VFS module to make automatic copy of data in samba share.
+
+%description vfs-shadow_copy -l pl
+Modu³ VFS do tworzenia automatycznych kopii danych w zasobach samby.
+
 %package vfs-vscan-clamav
 Summary:       On-access virus scanning for samba using ClamAV
 Summary(pl):   Skaner antywirusowy online wykorzystuj±cy ClamAV
@@ -668,9 +715,82 @@ Modu
 dostêpu do plików korzystaj±c z oprogramowania antywirusowego FPROT
 (które musi byæ zainstalowane, aby wykorzystaæ ten modu³).
 
+%package vfs-vscan-fsav
+Summary:       On-access virus scanning for samba using F-Secure AntiVirus
+Summary(pl):   Skaner antywirusowy online wykorzystuj±cy F-Secure AntiVirus
+Group:         Networking/Daemons
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+Provides:      %{name}-vscan = %{epoch}:%{version}-%{release}
+Obsoletes:     vscan-fsav
+
+%description vfs-vscan-fsav
+A vfs-module for samba to implement on-access scanning using the
+F-Secure AntiVirus antivirus software (which must be installed to use
+this).
+
+%description vfs-vscan-fsav -l pl
+Modu³ vfs do samby implementuj±cy skaning antywirusowy w czasie
+dostêpu do plików korzystaj±c z oprogramowania antywirusowego F-Secure
+AntiVirus (które musi byæ zainstalowane, aby wykorzystaæ ten modu³).
+
+%package vfs-vscan-kavp
+Summary:       On-access virus scanning for samba using Kaspersky AVP
+Summary(pl):   Skaner antywirusowy online wykorzystuj±cy Kaspersky AVP
+Group:         Networking/Daemons
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+Provides:      %{name}-vscan = %{epoch}:%{version}-%{release}
+Obsoletes:     vscan-kavp
+
+%description vfs-vscan-kavp
+A vfs-module for samba to implement on-access scanning using the
+Kaspersky AVP antivirus software (which must be installed to use
+this).
+
+%description vfs-vscan-kavp -l pl
+Modu³ vfs do samby implementuj±cy skaning antywirusowy w czasie
+dostêpu do plików korzystaj±c z oprogramowania antywirusowego
+Kaspersky AVP (które musi byæ zainstalowane, aby wykorzystaæ ten
+modu³).
+
+%package vfs-vscan-mcafee
+Summary:       On-access virus scanning for samba using mcafee
+Summary(pl):   Skaner antywirusowy online wykorzystuj±cy mcafee
+Group:         Networking/Daemons
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+#Requires:     mcafee
+Provides:      %{name}-vscan = %{epoch}:%{version}-%{release}
+Obsoletes:     vscan-mcafee
+
+%description vfs-vscan-mcafee
+A vfs-module for samba to implement on-access scanning using the mcafee
+antivirus software (which must be installed to use this).
+
+%description vfs-vscan-mcafee -l pl
+Modu³ vfs do samby implementuj±cy skaning antywirusowy w czasie
+dostêpu do plików korzystaj±c z oprogramowania antywirusowego mcafee
+(które musi byæ zainstalowane, aby wykorzystaæ ten modu³).
+
+%package vfs-vscan-mks
+Summary:       On-access virus scanning for samba using mks
+Summary(pl):   Skaner antywirusowy online wykorzystuj±cy mks
+Group:         Networking/Daemons
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+Requires:      mksd
+Provides:      %{name}-vscan = %{epoch}:%{version}-%{release}
+Obsoletes:     vscan-mks
+
+%description vfs-vscan-mks
+A vfs-module for samba to implement on-access scanning using the mks
+antivirus software (which must be installed to use this).
+
+%description vfs-vscan-mks -l pl
+Modu³ vfs do samby implementuj±cy skaning antywirusowy w czasie
+dostêpu do plików korzystaj±c z oprogramowania antywirusowego mks
+(które musi byæ zainstalowane, aby wykorzystaæ ten modu³).
+
 %package vfs-vscan-openantivirus
 Summary:       On-access virus scanning for samba using OpenAntivirus
-Summary(pl):   Modu³ VFS dodaj±cy obs³ugê antywirusa OpenAntiVirus
+Summary(pl):   Skaner antywirusowy online wykorzystuj±cy OpenAntiVirus
 Group:         Networking/Daemons
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 Provides:      %{name}-vscan = %{epoch}:%{version}-%{release}
@@ -689,7 +809,7 @@ modu
 
 %package vfs-vscan-sophos
 Summary:       On-access virus scanning for samba using Sophos
-Summary(pl):   Modu³ VFS dodaj±cy obs³ugê antywirusa Sophos
+Summary(pl):   Skaner antywirusowy online wykorzystuj±cy Sophos
 Group:         Networking/Daemons
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 Provides:      %{name}-vscan = %{epoch}:%{version}-%{release}
@@ -723,7 +843,7 @@ Symantec (kt
 
 %package vfs-vscan-trend
 Summary:       On-access virus scanning for samba using Trend
-Summary(pl):   Modu³ VFS dodaj±cy obs³ugê antywirusa Trend
+Summary(pl):   Skaner antywirusowy online wykorzystuj±cy Trend
 Group:         Networking/Daemons
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 Provides:      %{name}-vscan = %{epoch}:%{version}-%{release}
@@ -738,68 +858,17 @@ Modu
 dostêpu do plików korzystaj±c z oprogramowania antywirusowego Trend
 (które musi byæ zainstalowane, aby wykorzystaæ ten modu³).
 
-%package vfs-vscan-mks
-Summary:       On-access virus scanning for samba using mks
-Summary(pl):   Modu³ VFS dodaj±cy obs³ugê antywirusa mks
-Group:         Networking/Daemons
-Requires:      %{name} = %{epoch}:%{version}-%{release}
-Requires:      mksd
-Provides:      %{name}-vscan = %{epoch}:%{version}-%{release}
-Obsoletes:     vscan-mks
-
-%description vfs-vscan-mks
-A vfs-module for samba to implement on-access scanning using the mks
-antivirus software (which must be installed to use this).
-
-%description vfs-vscan-mks -l pl
-Modu³ vfs do samby implementuj±cy skaning antywirusowy w czasie
-dostêpu do plików korzystaj±c z oprogramowania antywirusowego mks
-(które musi byæ zainstalowane, aby wykorzystaæ ten modu³).
-
-%package vfs-vscan-kavp
-Summary:       On-access virus scanning for samba using Kaspersky AVP
-Summary(pl):   Modu³ VFS dodaj±cy obs³ugê antywirusa Kaspersky AVP
-Group:         Networking/Daemons
-Requires:      %{name} = %{epoch}:%{version}-%{release}
-Provides:      %{name}-vscan = %{epoch}:%{version}-%{release}
-Obsoletes:     vscan-kavp
-
-%description vfs-vscan-kavp
-A vfs-module for samba to implement on-access scanning using the
-Kaspersky AVP antivirus software (which must be installed to use
-this).
-
-%description vfs-vscan-kavp -l pl
-Modu³ vfs do samby implementuj±cy skaning antywirusowy w czasie
-dostêpu do plików korzystaj±c z oprogramowania antywirusowego
-Kaspersky AVP (które musi byæ zainstalowane, aby wykorzystaæ ten
-modu³).
-
-%package vfs-vscan-fsav
-Summary:       On-access virus scanning for samba using F-Secure AntiVirus
-Summary(pl):   Modu³ VFS dodaj±cy obs³ugê antywirusa F-Secure AntiVirus
-Group:         Networking/Daemons
-Requires:      %{name} = %{epoch}:%{version}-%{release}
-Provides:      %{name}-vscan = %{epoch}:%{version}-%{release}
-Obsoletes:     vscan-kavp
-
-%description vfs-vscan-fsav
-A vfs-module for samba to implement on-access scanning using the
-F-Secure AntiVirus antivirus software (which must be installed to use
-this).
-
-%description vfs-vscan-fsav -l pl
-Modu³ vfs do samby implementuj±cy skaning antywirusowy w czasie
-dostêpu do plików korzystaj±c z oprogramowania antywirusowego F-Secure
-AntiVirus (które musi byæ zainstalowane, aby wykorzystaæ ten modu³).
-
 %prep
 %setup -q
 %patch0 -p1
 %ifarch amd64
 %patch1 -p1
 %endif
-#%{?with_ipv6:%patch2 -p1}
+%patch2 -p1
+%patch3 -p1
+%patch4 -p1
+%patch5 -p1
+#%{?with_ipv6:%patch6 -p1}
 
 cd examples/VFS
 tar xjf %{SOURCE7}
@@ -824,7 +893,7 @@ cd source
        --with-libsmbclient \
        --with-pam \
        --with-pam_smbpass \
-       --with-ads \
+       --with%{!?with_ads:out}-ads \
        --with-privatedir=%{_sysconfdir}/samba \
        --with-quotas \
        --with-readline \
@@ -833,12 +902,11 @@ cd source
        --with-syslog \
        --with-utmp \
        --with-fhs \
-        %{?with_python:--with-python} \
-       --with-expsam=xml,%{?with_mysql:mysql} \
+       %{?with_python:--with-python} \
+       --with-expsam=xml,%{?with_mysql:mysql}%{?with_pgsql:,pgsql} \
        %{?with_ldapsam:--with-ldapsam} \
-       %{!?with_ldap:--without-ldap} \
-       %{?with_krb5:--with-krb5} \
-       %{!?with_krb5:--without-krb5}
+       --with%{!?with_ldap:out}-ldap \
+       --with%{!?with_krb5:out}-krb5
 
 %{__make} proto
 %{__make} everything pam_smbpass bin/smbget client/mount.cifs
@@ -851,7 +919,7 @@ cd ../examples/VFS
 mv README{,.vfs}
 
 cd samba-vscan-%{vscan_version}
-cp %{_datadir}/automake/config.sub .
+cp -f /usr/share/automake/config.sub .
 %configure
 %{__make} -j1 all
 
@@ -890,14 +958,15 @@ install source/bin/pam_smbpass.so $RPM_BUILD_ROOT/%{_lib}/security
 install source/bin/wbinfo              $RPM_BUILD_ROOT%{_bindir}
 install source/bin/smbget              $RPM_BUILD_ROOT%{_bindir}
 
-mv $RPM_BUILD_ROOT%{_libdir}/libsmbclient.so $RPM_BUILD_ROOT%{_libdir}/libsmbclient.so.0
+mv $RPM_BUILD_ROOT%{_libdir}/samba/libsmbclient.so $RPM_BUILD_ROOT%{_libdir}/libsmbclient.so.0
+mv $RPM_BUILD_ROOT%{_libdir}/samba/libsmbclient.a $RPM_BUILD_ROOT%{_libdir}/libsmbclient.a
 ln -s libsmbclient.so.0 $RPM_BUILD_ROOT%{_libdir}/libsmbclient.so
 
 install source/include/libsmbclient.h $RPM_BUILD_ROOT%{_includedir}
 
 # vscan modules
 install examples/VFS/samba-vscan-%{vscan_version}/*.so $RPM_BUILD_ROOT%{_vfsdir}
-install examples/VFS/samba-vscan-%{vscan_version}/{clamav,fprot,icap,kaspersky,mks,openantivirus,sophos,trend,f-secure}/*.conf $RPM_BUILD_ROOT%{_sysconfdir}/samba
+install examples/VFS/samba-vscan-%{vscan_version}/{clamav,fprot,icap,kaspersky,mks,openantivirus,sophos,trend,f-secure,nai}/*.conf $RPM_BUILD_ROOT%{_sysconfdir}/samba
 
 touch $RPM_BUILD_ROOT/var/lock/samba/{STATUS..LCK,wins.dat,browse.dat}
 
@@ -917,6 +986,14 @@ rm -f docs/htmldocs/*.[0-9].html
 # we have this utility in tdb package
 rm -f $RPM_BUILD_ROOT{%{_bindir}/tdbdump,%{_mandir}/man8/tdbdump.8*}
 
+# python stuff
+%if %{with python}
+install -d $RPM_BUILD_ROOT%{py_sitedir}
+cp -R source/build/lib.*/samba $RPM_BUILD_ROOT%{py_sitedir}
+%endif
+
+mv $RPM_BUILD_ROOT%{_bindir}/tdbtool $RPM_BUILD_ROOT%{_bindir}/tdbtool_samba
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -984,6 +1061,7 @@ fi
 %attr(755,root,root) %{_bindir}/smbpasswd
 %attr(755,root,root) %{_bindir}/smbcontrol
 %attr(755,root,root) %{_bindir}/tdbbackup
+%attr(755,root,root) %{_bindir}/tdbtool_samba
 
 %dir %{_libdir}/%{name}/pdb
 %dir %{_vfsdir}
@@ -991,7 +1069,7 @@ fi
 %attr(600,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/samba/smbusers
 %attr(754,root,root) /etc/rc.d/init.d/smb
 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/samba
-%attr(640,root,root) /etc/logrotate.d/samba
+%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/logrotate.d/samba
 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/pam.d/samba
 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/security/blacklist.samba
 %{_mandir}/man1/smbstatus.1*
@@ -1002,16 +1080,18 @@ fi
 %{_mandir}/man8/smbd.8*
 %{_mandir}/man8/smbpasswd.8*
 %{_mandir}/man8/pdbedit.8*
-%{_mandir}/man8/winbindd.8*
 %{_mandir}/man8/tdbbackup.8*
 
 %dir %{_sambahome}
 %dir /var/lock/samba
 %ghost /var/lock/samba/*
 
-%attr(0750,root,root) %dir /var/log/samba
-%attr(0750,root,root) %dir /var/log/archiv/samba
+%attr(750,root,root) %dir /var/log/samba
+%attr(750,root,root) %dir /var/log/archiv/samba
 %attr(1777,root,root) %dir /var/spool/samba
+%if %{with ldap}
+%doc examples/LDAP
+%endif
 
 %if %{with mysql}
 %files pdb-mysql
@@ -1019,6 +1099,12 @@ fi
 %attr(755,root,root) %{_libdir}/%{name}/pdb/mysql.so
 %endif
 
+%if %{with pgsql}
+%files pdb-pgsql
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/%{name}/pdb/pgsql.so
+%endif
+
 %files pdb-xml
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/%{name}/pdb/xml.so
@@ -1031,7 +1117,6 @@ fi
 %attr(755,root,root) /%{_lib}/libnss_winbind*
 %attr(754,root,root) /etc/rc.d/init.d/winbind
 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/winbind
-#%attr(-,root,root) %config(noreplace) %{_sysconfdir}/pam.d/system-auth-winbind*
 %{_mandir}/man8/winbindd*.8*
 %{_mandir}/man1/wbinfo*.1*
 
@@ -1065,8 +1150,6 @@ fi
 %{_mandir}/man1/smbsh.1*
 %attr(755,root,root) %{_bindir}/rpcclient
 %{_mandir}/man1/rpcclient.1*
-%attr(755,root,root) %{_bindir}/wbinfo
-%{_mandir}/man1/wbinfo.1*
 %attr(755,root,root) %{_bindir}/findsmb
 %{_mandir}/man1/findsmb.1*
 
@@ -1075,23 +1158,19 @@ fi
 %doc README Manifest WHATSNEW.txt
 %doc Roadmap docs/*.pdf docs/registry/*
 %doc docs/htmldocs/*.* docs/{history,THANKS}
-%dir %{_libdir}/%{name}
-%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/samba/smb.conf
+%dir %{_sysconfdir}/samba
+%attr(664,root,fileshare) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/samba/smb.conf
 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/samba/lmhosts
+%dir %{_libdir}/%{name}
 %{_libdir}/%{name}/*.dat
-#%attr(755,root,root) %{_bindir}/make_smbcodepage
-#%attr(755,root,root) %{_bindir}/make_unicodemap
 %attr(755,root,root) %{_bindir}/testparm
 %attr(755,root,root) %{_bindir}/testprns
 %attr(755,root,root) %{_bindir}/ntlm_auth
 %attr(755,root,root) %{_bindir}/smbcquotas
 %attr(755,root,root) %{_bindir}/profiles
 %attr(755,root,root) %{_bindir}/pdbedit
-#%attr(755,root,root) %{_bindir}/make_printerdef
 %dir %{_libdir}/%{name}/charset
 %attr(755,root,root) %{_libdir}/%{name}/charset/*.so
-#%{_mandir}/man1/make_smbcodepage.1*
-#%{_mandir}/man1/make_unicodemap.1*
 %{_mandir}/man1/editreg.1*
 %{_mandir}/man1/testparm.1*
 %{_mandir}/man1/testprns.1*
@@ -1129,6 +1208,16 @@ fi
 %lang(tr) %{_libdir}/%{name}/tr.msg
 %{_mandir}/man8/swat.8*
 
+%if %{with python}
+%files -n python-samba
+%defattr(644,root,root,755)
+%dir %{py_sitedir}/samba
+%attr(755,root,root) %{py_sitedir}/samba/*.so
+%{py_sitedir}/samba/*.py
+%doc source/python/{README,gprinterdata,gtdbtool,gtkdictbrowser.py}
+%doc source/python/examples
+%endif
+
 %files -n pam-pam_smbpass
 %defattr(644,root,root,755)
 %doc source/pam_smbpass/{CHAN*,README,TODO} source/pam_smbpass/samples
@@ -1165,23 +1254,12 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_vfsdir}/audit.so
 %attr(755,root,root) %{_vfsdir}/extd_audit.so
-
-%files vfs-shadow_copy
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_vfsdir}/shadow_copy.so
+%attr(755,root,root) %{_vfsdir}/full_audit.so
 
 %files vfs-cap
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_vfsdir}/cap.so
 
-%files vfs-readonly
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_vfsdir}/readonly.so
-
-%files vfs-recycle
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_vfsdir}/recycle.so
-
 %files vfs-default_quota
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_vfsdir}/default_quota.so
@@ -1198,6 +1276,18 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_vfsdir}/netatalk.so
 
+%files vfs-readonly
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_vfsdir}/readonly.so
+
+%files vfs-recycle
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_vfsdir}/recycle.so
+
+%files vfs-shadow_copy
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_vfsdir}/shadow_copy.so
+
 %files vfs-vscan-clamav
 %defattr(644,root,root,755)
 #%doc examples/VFS/%{name}-vscan-%{vscan_version}/{INSTALL,FAQ}
@@ -1210,6 +1300,32 @@ fi
 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/samba/vscan-fprotd.conf
 %attr(755,root,root) %{_vfsdir}/vscan-fprotd.so
 
+%files vfs-vscan-fsav
+%defattr(644,root,root,755)
+#%doc examples/VFS/%{name}-vscan-%{vscan_version}/{INSTALL,FAQ}
+%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/samba/vscan-fsav.conf
+%attr(755,root,root) %{_vfsdir}/vscan-fsav.so
+
+%files vfs-vscan-kavp
+%defattr(644,root,root,755)
+#%doc examples/VFS/%{name}-vscan-%{vscan_version}/{INSTALL,FAQ}
+%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/samba/vscan-kavp.conf
+%attr(755,root,root) %{_vfsdir}/vscan-kavp.so
+
+%files vfs-vscan-mcafee
+%defattr(644,root,root,755)
+#%doc examples/VFS/%{name}-vscan-%{vscan_version}/{INSTALL,FAQ}
+%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/samba/vscan-mcdaemon.conf
+%attr(755,root,root) %{_vfsdir}/vscan-mcdaemon.so
+
+%ifarch %{ix86}
+%files vfs-vscan-mks
+%defattr(644,root,root,755)
+#%doc examples/VFS/%{name}-vscan-%{vscan_version}/{INSTALL,FAQ}
+%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/samba/vscan-mks32.conf
+%attr(755,root,root) %{_vfsdir}/vscan-mksd.so
+%endif
+
 %files vfs-vscan-openantivirus
 %defattr(644,root,root,755)
 #%doc examples/VFS/%{name}-vscan-%{vscan_version}/{INSTALL,FAQ}
@@ -1233,23 +1349,3 @@ fi
 #%doc examples/VFS/%{name}-vscan-%{vscan_version}/{INSTALL,FAQ}
 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/samba/vscan-trend.conf
 %attr(755,root,root) %{_vfsdir}/vscan-trend.so
-
-%ifarch %{ix86}
-%files vfs-vscan-mks
-%defattr(644,root,root,755)
-#%doc examples/VFS/%{name}-vscan-%{vscan_version}/{INSTALL,FAQ}
-%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/samba/vscan-mks32.conf
-%attr(755,root,root) %{_vfsdir}/vscan-mksd.so
-%endif
-
-%files vfs-vscan-kavp
-%defattr(644,root,root,755)
-#%doc examples/VFS/%{name}-vscan-%{vscan_version}/{INSTALL,FAQ}
-%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/samba/vscan-kavp.conf
-%attr(755,root,root) %{_vfsdir}/vscan-kavp.so
-
-%files vfs-vscan-fsav
-%defattr(644,root,root,755)
-#%doc examples/VFS/%{name}-vscan-%{vscan_version}/{INSTALL,FAQ}
-%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/samba/vscan-fsav.conf
-%attr(755,root,root) %{_vfsdir}/vscan-fsav.so
This page took 0.078845 seconds and 4 git commands to generate.