]> git.pld-linux.org Git - packages/samba.git/blobdiff - samba.spec
- existings patches first
[packages/samba.git] / samba.spec
index c8a468ddbd7c77ee2fe00814598c34f7a59fa071..73944abdf3e2d0e6794638d3c6441beb1952f114 100644 (file)
@@ -9,13 +9,13 @@
 # Conditional build:
 %bcond_without ads             # without ActiveDirectory support
 %bcond_without cups            # without CUPS support
+%bcond_without krb5            # without Kerberos5/Heimdal support
+%bcond_without ldap            # without LDAP support
 %bcond_without mysql           # without MySQL support
 %bcond_without pgsql           # without PostgreSQL support
+%bcond_without python          # without python libs/utils
 %bcond_with    ldapsam         # with LDAP SAM 2.2 based auth (instead of smbpasswd)
 #%bcond_with   ipv6            # with IPv6 support
-%bcond_without ldap            # without LDAP support
-%bcond_without krb5            # without Kerberos5/Heimdal support
-%bcond_without python          # without python libs/utils
 #
 # ADS requires krb5 and LDAP
 %if %{without krb5} || %{without ldap}
@@ -39,13 +39,13 @@ Summary(tr):        SMB sunucusu
 Summary(uk):   SMB Ë̦¤ÎÔ ÔÁ ÓÅÒ×ÅÒ
 Summary(zh_CN):        Samba ¿Í»§¶ËºÍ·þÎñÆ÷
 Name:          samba
-Version:       3.0.8
-Release:       2
+Version:       3.0.10
+Release:       1
 Epoch:         1
 License:       GPL v2
 Group:         Networking/Daemons
 Source0:       http://us1.samba.org/samba/ftp/%{name}-%{version}.tar.gz
-# Source0-md5: 7088483c858ac362d302acc0c2a1d431
+# Source0-md5: b19fd86d3c11a1b43f75a5988cd9ceeb
 Source1:       smb.init
 Source2:       %{name}.pamd
 Source3:       swat.inetd
@@ -58,10 +58,11 @@ Source8:    winbind.init
 Source9:       winbind.sysconfig
 Patch0:                %{name}-statfs-workaround.patch
 Patch1:                %{name}-lib64.patch
-#Patch2:       http://v6web.litech.org/samba/%{name}-2.2.4+IPv6-20020609.diff
-Patch3:                %{name}-setup-python.patch
-Patch4:                %{name}-FHS.patch
-Patch5:                %{name}-case_insensitive_sql_operator.patch
+Patch2:                %{name}-setup-python.patch
+Patch3:                %{name}-FHS.patch
+Patch4:                %{name}-case_insensitive_sql_operator.patch
+Patch5:                %{name}-3_0_9-printing.patch
+#Patch6:       http://v6web.litech.org/samba/%{name}-2.2.4+IPv6-20020609.diff
 URL:           http://www.samba.org/
 BuildRequires: acl-devel
 BuildRequires: autoconf
@@ -91,6 +92,7 @@ Requires(post,preun): /sbin/chkconfig
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
 Requires:      logrotate
 Requires:      pam >= 0.66
+Obsoletes:     samba-vfs-block
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _vfsdir         %{_libdir}/%{name}/vfs
@@ -336,9 +338,9 @@ Summary(pt_BR):     Cliente SMB do samba
 Summary(ru):   ëÌÉÅÎÔÓËÉÅ ÐÒÏÇÒÁÍÍÙ Samba (SMB)
 Summary(uk):   ë̦¤ÎÔÓØ˦ ÐÒÏÇÒÁÍÉ Samba (SMB)
 Group:         Applications/Networking
-Requires:      samba-common = %{epoch}:%{version}-%{release}
-Obsoletes:     smbfs
+Requires:      %{name}-common = %{epoch}:%{version}-%{release}
 Obsoletes:     mount-cifs
+Obsoletes:     smbfs
 
 %description client
 Samba-client provides some SMB clients, which complement the build-in
@@ -862,10 +864,11 @@ dost
 %ifarch amd64
 %patch1 -p1
 %endif
-#%{?with_ipv6:%patch2 -p1}
+%patch2 -p1
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
+#%{?with_ipv6:%patch6 -p1}
 
 cd examples/VFS
 tar xjf %{SOURCE7}
@@ -916,7 +919,7 @@ cd ../examples/VFS
 mv README{,.vfs}
 
 cd samba-vscan-%{vscan_version}
-cp %{_datadir}/automake/config.sub .
+cp -f /usr/share/automake/config.sub .
 %configure
 %{__make} -j1 all
 
@@ -989,7 +992,7 @@ install -d $RPM_BUILD_ROOT%{py_sitedir}
 cp -R source/build/lib.*/samba $RPM_BUILD_ROOT%{py_sitedir}
 %endif
 
-mv $RPM_BUILD_ROOT%{_bindir}/tdbtool $RPM_BUILD_ROOT%{_libdir}/tdbtool_samba
+mv $RPM_BUILD_ROOT%{_bindir}/tdbtool $RPM_BUILD_ROOT%{_bindir}/tdbtool_samba
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -1077,15 +1080,14 @@ fi
 %{_mandir}/man8/smbd.8*
 %{_mandir}/man8/smbpasswd.8*
 %{_mandir}/man8/pdbedit.8*
-%{_mandir}/man8/winbindd.8*
 %{_mandir}/man8/tdbbackup.8*
 
 %dir %{_sambahome}
 %dir /var/lock/samba
 %ghost /var/lock/samba/*
 
-%attr(0750,root,root) %dir /var/log/samba
-%attr(0750,root,root) %dir /var/log/archiv/samba
+%attr(750,root,root) %dir /var/log/samba
+%attr(750,root,root) %dir /var/log/archiv/samba
 %attr(1777,root,root) %dir /var/spool/samba
 %if %{with ldap}
 %doc examples/LDAP
@@ -1115,7 +1117,6 @@ fi
 %attr(755,root,root) /%{_lib}/libnss_winbind*
 %attr(754,root,root) /etc/rc.d/init.d/winbind
 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/winbind
-#%attr(-,root,root) %config(noreplace) %{_sysconfdir}/pam.d/system-auth-winbind*
 %{_mandir}/man8/winbindd*.8*
 %{_mandir}/man1/wbinfo*.1*
 
@@ -1149,8 +1150,6 @@ fi
 %{_mandir}/man1/smbsh.1*
 %attr(755,root,root) %{_bindir}/rpcclient
 %{_mandir}/man1/rpcclient.1*
-%attr(755,root,root) %{_bindir}/wbinfo
-%{_mandir}/man1/wbinfo.1*
 %attr(755,root,root) %{_bindir}/findsmb
 %{_mandir}/man1/findsmb.1*
 
@@ -1159,23 +1158,19 @@ fi
 %doc README Manifest WHATSNEW.txt
 %doc Roadmap docs/*.pdf docs/registry/*
 %doc docs/htmldocs/*.* docs/{history,THANKS}
-%dir %{_libdir}/%{name}
+%dir %{_sysconfdir}/samba
 %attr(664,root,fileshare) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/samba/smb.conf
 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/samba/lmhosts
+%dir %{_libdir}/%{name}
 %{_libdir}/%{name}/*.dat
-#%attr(755,root,root) %{_bindir}/make_smbcodepage
-#%attr(755,root,root) %{_bindir}/make_unicodemap
 %attr(755,root,root) %{_bindir}/testparm
 %attr(755,root,root) %{_bindir}/testprns
 %attr(755,root,root) %{_bindir}/ntlm_auth
 %attr(755,root,root) %{_bindir}/smbcquotas
 %attr(755,root,root) %{_bindir}/profiles
 %attr(755,root,root) %{_bindir}/pdbedit
-#%attr(755,root,root) %{_bindir}/make_printerdef
 %dir %{_libdir}/%{name}/charset
 %attr(755,root,root) %{_libdir}/%{name}/charset/*.so
-#%{_mandir}/man1/make_smbcodepage.1*
-#%{_mandir}/man1/make_unicodemap.1*
 %{_mandir}/man1/editreg.1*
 %{_mandir}/man1/testparm.1*
 %{_mandir}/man1/testprns.1*
This page took 0.073661 seconds and 4 git commands to generate.