]> git.pld-linux.org Git - packages/samba.git/blobdiff - samba.spec
- up to 3.3.2
[packages/samba.git] / samba.spec
index c3ac56f93c14a529ca397e34e7d706960d16b206..41cc5e58deb6bd1c9dea54c56e691980c8290e57 100644 (file)
@@ -1,29 +1,33 @@
 # TODO:
+# - drop tdb.spec and build tdb,tdb-devel,tdb-static package from samba
 # - look into other distro specs for valid %descriptions for samba 3
 # - unpackaged man pages for modules that are not built by default,
 #   maybe we should build them?
-#   /usr/share/man/man8/vfs_cacheprime.8.gz
-#   /usr/share/man/man8/vfs_catia.8.gz
-#   /usr/share/man/man8/vfs_commit.8.gz
-#   /usr/share/man/man8/vfs_extd_audit.8.gz
-#   /usr/share/man/man8/vfs_full_audit.8.gz
-#   /usr/share/man/man8/vfs_gpfs.8.gz
-#   /usr/share/man/man8/vfs_notify_fam.8.gz
-#   /usr/share/man/man8/vfs_prealloc.8.gz
+#   /usr/share/man/man8/vfs_cacheprime.8*
+#   /usr/share/man/man8/vfs_catia.8*
+#   /usr/share/man/man8/vfs_commit.8*
+#   /usr/share/man/man8/vfs_gpfs.8*
+#   /usr/share/man/man8/vfs_notify_fam.8*
+#   /usr/share/man/man8/vfs_prealloc.8*
 # - libmsrpc.so is broken (references smbc_attr_server() which is no longer exported from libsmbclient)
+# - package libs:
+#      libnetapi
+#      libsmbsharemodes
+# - MERGE vfs modules into main package, what was the point of splitting these?
 #
 # Conditional build:
 %bcond_without ads             # without ActiveDirectory support
 %bcond_without cups            # without CUPS support
 %bcond_without kerberos5       # without Kerberos V support
 %bcond_without ldap            # without LDAP support
-%bcond_without python          # without python libs/utils
+%bcond_with    mks             # with vfs-mks (mksd dependency not distributale)
+%bcond_with    vscan
 
 # ADS requires kerberos5 and LDAP
 %if !%{with kerberos5} || !%{with ldap}
 %undefine      with_ads
 %endif
-%define                vscan_version 0.3.6c-beta4
+%define                vscan_version 0.3.6c-beta5
 Summary:       SMB server
 Summary(cs.UTF-8):     Server SMB
 Summary(da.UTF-8):     SMB server
@@ -41,13 +45,13 @@ Summary(tr.UTF-8):  SMB sunucusu
 Summary(uk.UTF-8):     SMB клієнт та сервер
 Summary(zh_CN.UTF-8):  Samba 客户端和服务器
 Name:          samba
-Version:       3.0.25a
-Release:       2
+Version:       3.3.2
+Release:       1
 Epoch:         1
 License:       GPL v2
 Group:         Networking/Daemons
-Source0:       http://us1.samba.org/samba/ftp/%{name}-%{version}.tar.gz
-# Source0-md5: cbd33bb5d904ccd8a294a4019743745d
+Source0:       http://www.samba.org/samba/ftp/%{name}-%{version}.tar.gz
+# Source0-md5: 5c5178ea2c5d9bd5f6569285f2e0e6d7
 Source1:       smb.init
 Source2:       %{name}.pamd
 Source3:       swat.inetd
@@ -55,45 +59,41 @@ Source4:    %{name}.sysconfig
 Source5:       %{name}.logrotate
 Source6:       smb.conf
 Source7:       http://www.openantivirus.org/download/%{name}-vscan-%{vscan_version}.tar.gz
-# Source7-md5: c40acad9691ef5284a164c024124ca78
+# Source7-md5: 8f1dd119172e04e6d7c2d05526a4cf8b
 Source8:       winbind.init
 Source9:       winbind.sysconfig
-Patch0:                %{name}-lib64.patch
-Patch1:                %{name}-smbwrapper.patch
-Patch2:                %{name}-c++-nofail.patch
-Patch3:                %{name}-pthread.patch
-Patch4:                %{name}-libsmbclient-libnscd_link.patch
-Patch5:                %{name}-doc.patch
-Patch6:                %{name}-libs-needed.patch
+Patch0:                %{name}-smbwrapper.patch
+Patch1:                %{name}-c++-nofail.patch
+Patch2:                %{name}-pthread.patch
+Patch3:                %{name}-nscd.patch
+Patch4:                %{name}-lprng-no-dot-printers.patch
+Patch5:                %{name}-link.patch
 URL:           http://www.samba.org/
 BuildRequires: acl-devel
 BuildRequires: autoconf
 BuildRequires: automake
 %{?with_cups:BuildRequires:    cups-devel >= 1:1.2.0}
 BuildRequires: dmapi-devel
-%{?with_kerberos5:BuildRequires:       krb5-devel}
+BuildRequires: fam-devel
 BuildRequires: iconv
+%{?with_kerberos5:BuildRequires:       krb5-devel}
 BuildRequires: libmagic-devel
 BuildRequires: libnscd-devel
 BuildRequires: libtool >= 2:1.4d
 BuildRequires: ncurses-devel >= 5.2
 %{?with_ldap:BuildRequires:    openldap-devel >= 2.3.0}
 BuildRequires: openssl-devel >= 0.9.7d
-BuildRequires: pam-devel > 0.66
+BuildRequires: pam-devel >= 0.99.8.1
 BuildRequires: popt-devel
 %{?with_pgsql:BuildRequires:   postgresql-devel}
-%if %{with python}
-BuildRequires: python-devel
-BuildRequires: rpm-pythonprov
-%endif
 BuildRequires: readline-devel >= 4.2
 BuildRequires: rpmbuild(macros) >= 1.304
 BuildRequires: sed >= 4.0
 BuildRequires: xfsprogs-devel
 Requires(post,preun):  /sbin/chkconfig
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
-Requires:      logrotate
-Requires:      pam >= 0.66
+Requires:      logrotate >= 3.7-4
+Requires:      pam >= 0.99.8.1
 Requires:      rc-scripts
 Requires:      setup >= 2.4.6-7
 # smbd links with libcups
@@ -104,6 +104,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _vfsdir         %{_libdir}/%{name}/vfs
 %define                _sambahome      /home/services/samba
+%define                _sambalibdir    %{_libdir}/%{name}
 %if %{with cups}
 %define                cups_serverbin  %{_prefix}/lib/cups
 %endif
@@ -310,6 +311,7 @@ Summary(ru.UTF-8):  Клиентские программы Samba (SMB)
 Summary(uk.UTF-8):     Клієнтські програми Samba (SMB)
 Group:         Applications/Networking
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
+Requires:      libsmbclient = %{epoch}:%{version}-%{release}
 %{?with_kerberos5:Requires:    krb5-libs}
 Obsoletes:     mount-cifs
 Obsoletes:     smbfs
@@ -360,6 +362,7 @@ Summary(pt_BR.UTF-8):       Arquivos em comum entre samba e samba-clients
 Summary(ru.UTF-8):     Файлы, используемые как сервером, так и клиентом Samba
 Summary(uk.UTF-8):     Файли, що використовуються як сервером, так і клієнтом Samba
 Group:         Networking/Daemons
+Requires:      tdb >= 1.1.3
 
 %description common
 Samba-common provides files necessary for both the server and client
@@ -422,7 +425,7 @@ Obsoletes:  pam_smbpass
 
 %description -n pam-pam_smbpass
 PAM module which can be used on conforming systems to keep the
-smbpasswd (Samba password) database in sync with the unix password
+smbpasswd (Samba password) database in sync with the Unix password
 file.
 
 %description -n pam-pam_smbpass -l pl.UTF-8
@@ -471,6 +474,22 @@ Static libsmbclient library.
 %description -n libsmbclient-static -l pl.UTF-8
 Statyczna biblioteka libsmbclient.
 
+%package -n libtalloc
+Summary:       The talloc library
+Group:         Libraries
+
+%description -n libtalloc
+The talloc library from the Samba suite.
+
+%package -n libtalloc-devel
+Summary:       Developer tools for the talloc library
+Group:         Development/Libraries
+Requires:      libtalloc = %{epoch}:%{version}-%{release}
+
+%description -n libtalloc-devel
+The libtalloc-devel package contains the header files and libraries needed to
+develop programs that link against the talloc library in the Samba suite.
+
 %package devel
 Summary:       Header files for Samba
 Summary(pl.UTF-8):     Pliki nagłówkowe Samby
@@ -507,18 +526,6 @@ CUPS backend for printing to SMB printers.
 %description -n cups-backend-smb -l pl.UTF-8
 Backend CUPS-a drukujący na drukarkach SMB.
 
-%package -n python-samba
-Summary:       Samba python tools and libraries
-Summary(pl.UTF-8):     Narzędzia i biblioteki pythona do samby
-Group:         Applications/Networking
-%pyrequires_eq python-libs
-
-%description -n python-samba
-Samba python tools and libraries.
-
-%description -n python-samba -l pl.UTF-8
-Narzędzia i biblioteki pythona do samby.
-
 %package vfs-audit
 Summary:       VFS module to audit file access
 Summary(pl.UTF-8):     Moduł VFS do monitorowania operacji na plikach
@@ -538,6 +545,7 @@ do sysloga. Monitorowane są następujące operacje:
  - podłączenie do/odłączenie od zasobu,
  - otwarcie/utworzenie/zmiana nazwy katalogu,
  - otwarcie/zamknięcie/zmiana nazwy/skasowanie/zmiana praw plików.
+
 Zawiera moduły audit, extd_audit i full_audit.
 
 %package vfs-cap
@@ -614,6 +622,21 @@ klientom, że pliki i katalogi z profilu są zapisywane. To wystarczy
 klientom pomimo, że pliki nie zostaną nigdy nadpisane przy logowaniu
 lub wylogowywaniu klienta.
 
+%package vfs-notify_fam
+Summary:       VFS module to implement  file  change  notifications
+Summary(pl.UTF-8):     Moduł VFS implementujący informowanie o zmianach w plikach
+Group:         Networking/Daemons
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+
+%description vfs-notify_fam
+The vfs_notify_fam module makes use of the system FAM (File Alteration
+Monitor) daemon to implement file change notifications for Windows
+clients.
+
+%description vfs-notify_fam -l pl.UTF-8
+Ten moduł używa demona FAM (File Alteration Monitor) do implementacji
+informowania o zmianach w plikach dla klientów Windows.
+
 %package vfs-netatalk
 Summary:       VFS module for ease co-existence of samba and netatalk
 Summary(pl.UTF-8):     Moduł VFS ułatwiający współpracę serwisów samba i netatalk
@@ -641,10 +664,10 @@ VFS module to add recycle bin facility to a samba share.
 Moduł VFS dodający możliwość kosza do zasobu samby.
 
 %package vfs-readahead
-Summary:       VFS module for pre-loading the kernel buffer cache
+Summary:       VFS module for pre-loading the kernel buffer cache
 Summary(pl.UTF-8):     Moduł VFS do wczesnego odczytu danych do bufora cache jądra
-Group:         Networking/Daemons
-Requires:      %{name} = %{epoch}:%{version}-%{release}
+Group:         Networking/Daemons
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description vfs-readahead
 This VFS module detects read requests at multiples of a given offset
@@ -907,36 +930,7 @@ Summary(pl.UTF-8): Documentacja samby w formacie HTML
 Group:         Documentation
 
 %description doc-html
-Samba HTML documentation, consists of:
-
-1. SAMBA Developers Guide
-This book is a collection of documents that might be useful for
-people developing samba or those interested in doing so. It's nothing
-more than a collection of documents written by samba developers about
-the internals of various parts of samba and the SMB protocol. It's
-still (and will always be) incomplete.
-
-2. Samba-3 by Example
-Practical Exercises in Successful Samba Deployment.
-
-3. The Official Samba-3 HOWTO and Reference Guide
-This book provides example configurations, it documents key aspects
-of Microsoft Windows networking, provides in-depth insight into the
-important configuration of Samba-3, and helps to put all of these
-into a useful framework.
-
-4. Using Samba, 2nd Edition
-Using Samba, Second Edition is a comprehensive guide to Samba
-administration. It covers all versions of Samba from 2.0 to 2.2,
-including selected features from an alpha version of 3.0, as well as
-the SWAT graphical configuration tool. Updated for Windows 2000, ME,
-and XP, the book also explores Samba's new role as a primary domain
-controller and domain member server, its support for the use of
-Windows NT/2000/XP authentication and filesystem security on the host
-Unix system, and accessing shared files and printers from Unix
-clients.
-
-5. Man pages The Samba man pages in HTML.
+Samba HTML documentation.
 
 %description doc-html -l pl.UTF-8
 Documentacja samby w formacie HTML.
@@ -947,50 +941,33 @@ Summary(pl.UTF-8):        Documentacja samby w formacie PDF
 Group:         Documentation
 
 %description doc-pdf
-Samba PDF documentation, consists of:
-
-1. SAMBA Developers Guide
-This book is a collection of documents that might be useful for
-people developing samba or those interested in doing so. It's nothing
-more than a collection of documents written by samba developers about
-the internals of various parts of samba and the SMB protocol. It's
-still (and will always be) incomplete.
-
-2. Samba-3 by Example
-Practical Exercises in Successful Samba Deployment.
-
-3. The Official Samba-3 HOWTO and Reference Guide
-This book provides example configurations, it documents key aspects
-of Microsoft Windows networking, provides in-depth insight into the
-important configuration of Samba-3, and helps to put all of these
-into a useful framework.
+Samba PDF documentation.
 
 %description doc-pdf -l pl.UTF-8
 Documentacja samby w formacie PDF.
 
 %prep
 %setup -q
-%if "%{_lib}" == "lib64"
 %patch0 -p1
-%endif
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
-%patch6 -p1
+
 %{__sed} -i 's#%SAMBAVERSION%#%{version}#' docs/htmldocs/index.html
 
 cd examples/VFS
 tar xzf %{SOURCE7}
 mv README{,.vfs}
+cd ../..
 
 %build
 cd source
 %{__libtoolize}
-%{__autoconf} -I lib/replace
-
+%{__autoconf} -Im4 -Ilib/replace
 %configure \
+       --with-modulesdir=%{_sambalibdir} \
        --with-rootsbindir=/sbin \
        --with-pammodulesdir=/%{_lib}/security \
        --with-acl-support \
@@ -1003,12 +980,10 @@ cd source
        --with-privatedir=%{_sysconfdir}/samba \
        --with-quotas \
        --with-readline \
-       --with-smbmount \
        --with-swatdir=%{_datadir}/swat \
        --with-syslog \
        --with-utmp \
        --with-fhs \
-       %{?with_python:--with-python} \
        --with%{!?with_ldap:out}-ldap \
        --with%{!?with_kerberos5:out}-krb5
 
@@ -1021,15 +996,19 @@ cd ../examples
        CFLAGS="%{rpmcflags} -fPIC \$(DEFS) \\\$(SMBINCLUDE)"
 
 cd VFS
+%{__autoheader}
 %{__autoconf}
 %configure \
        CFLAGS="%{rpmcflags} -fPIC"
 %{__make}
 
+%if %{with vscan}
 cd samba-vscan-%{vscan_version}
 cp -f /usr/share/automake/config.sub .
 %configure
+ln -s ../../../source/lib .
 %{__make} all
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -1044,8 +1023,6 @@ install -d $RPM_BUILD_ROOT/etc/{logrotate.d,rc.d/init.d,pam.d,security,sysconfig
 
 install source/script/mksmbpasswd.sh $RPM_BUILD_ROOT%{_sbindir}
 
-ln -sf %{_bindir}/smbmount $RPM_BUILD_ROOT/sbin/mount.smbfs
-
 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/smb
 install %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/samba
 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/swat
@@ -1063,29 +1040,24 @@ install source/bin/wbinfo               $RPM_BUILD_ROOT%{_bindir}
 install source/bin/smbget              $RPM_BUILD_ROOT%{_bindir}
 install source/bin/vfstest             $RPM_BUILD_ROOT%{_bindir}
 
-mv $RPM_BUILD_ROOT%{_libdir}/samba/libsmbclient.so $RPM_BUILD_ROOT%{_libdir}/libsmbclient.so.0
-ln -s libsmbclient.so.0 $RPM_BUILD_ROOT%{_libdir}/libsmbclient.so
 install source/bin/libsmbclient.a $RPM_BUILD_ROOT%{_libdir}/libsmbclient.a
-mv $RPM_BUILD_ROOT%{_libdir}/samba/libmsrpc.so $RPM_BUILD_ROOT%{_libdir}/libmsrpc.so.0
-ln -s libmsrpc.so.0 $RPM_BUILD_ROOT%{_libdir}/libmsrpc.so
-install source/bin/libmsrpc.a $RPM_BUILD_ROOT%{_libdir}/libmsrpc.a
-
-install source/include/libsmbclient.h $RPM_BUILD_ROOT%{_includedir}
 
 # smbwrapper
 install examples/libsmbclient/smbwrapper/smbwrapper.so $RPM_BUILD_ROOT%{_libdir}/smbwrapper.so
 install examples/libsmbclient/smbwrapper/smbsh $RPM_BUILD_ROOT%{_bindir}
-install docs/manpages/smbsh.1 $RPM_BUILD_ROOT%{_mandir}/man1
+install examples/libsmbclient/smbwrapper/smbsh.1 $RPM_BUILD_ROOT%{_mandir}/man1
 
 # these are needed to build samba-pdbsql
 install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/{tdb,nsswitch}
 cp -a source/include/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}
-cp -a source/tdb/include/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/tdb
+cp -a source/lib/tdb/include/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/tdb
 cp -a source/nsswitch/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/nsswitch
 
+%if %{with vscan}
 # vscan modules
 install examples/VFS/samba-vscan-%{vscan_version}/*.so $RPM_BUILD_ROOT%{_vfsdir}
 install examples/VFS/samba-vscan-%{vscan_version}/{antivir,clamav,fprot,icap,kaspersky,mks,openantivirus,sophos,trend,f-secure,nai}/*.conf $RPM_BUILD_ROOT%{_sysconfdir}/samba
+%endif
 
 touch $RPM_BUILD_ROOT/var/lib/samba/{wins.dat,browse.dat}
 
@@ -1100,13 +1072,10 @@ ln -s %{_bindir}/smbspool $RPM_BUILD_ROOT%{cups_serverbin}/backend/smb
 > $RPM_BUILD_ROOT/etc/security/blacklist.samba
 
 # we have this utility in tdb package
-rm -f $RPM_BUILD_ROOT{%{_bindir}/tdbdump,%{_mandir}/man8/tdbdump.8*}
+rm -f $RPM_BUILD_ROOT{%{_bindir}/tdb{backup,dump},%{_mandir}/man8/tdb{backup,dump}.8*}
 
-# python stuff
-%if %{with python}
-install -d $RPM_BUILD_ROOT%{py_sitedir}
-cp -R source/build/lib.*/samba $RPM_BUILD_ROOT%{py_sitedir}
-%endif
+# unneeded
+rm -r $RPM_BUILD_ROOT%{_datadir}/swat/using_samba
 
 mv $RPM_BUILD_ROOT%{_bindir}/tdbtool $RPM_BUILD_ROOT%{_bindir}/tdbtool_samba
 
@@ -1114,6 +1083,8 @@ mv $RPM_BUILD_ROOT%{_bindir}/tdbtool $RPM_BUILD_ROOT%{_bindir}/tdbtool_samba
 install examples/LDAP/samba.schema $RPM_BUILD_ROOT%{schemadir}
 %endif
 
+%find_lang pam_winbind
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -1177,14 +1148,34 @@ fi
 %attr(755,root,root) %{_sbindir}/nmbd
 %attr(755,root,root) %{_sbindir}/smbd
 %attr(755,root,root) %{_sbindir}/mksmbpasswd.sh
+%attr(755,root,root) %{_bindir}/ldb*
 %attr(755,root,root) %{_bindir}/smbstatus
 %attr(755,root,root) %{_bindir}/smbpasswd
 %attr(755,root,root) %{_bindir}/smbcontrol
-%attr(755,root,root) %{_bindir}/tdbbackup
 %attr(755,root,root) %{_bindir}/tdbtool_samba
 
 %dir %{_libdir}/%{name}/pdb
 %dir %{_vfsdir}
+%attr(755,root,root) %{_vfsdir}/acl_tdb.so
+%attr(755,root,root) %{_vfsdir}/acl_xattr.so
+%attr(755,root,root) %{_vfsdir}/fileid.so
+%attr(755,root,root) %{_vfsdir}/preopen.so
+%attr(755,root,root) %{_vfsdir}/shadow_copy2.so
+%attr(755,root,root) %{_vfsdir}/smb_traffic_analyzer.so
+%attr(755,root,root) %{_vfsdir}/streams_depot.so
+%attr(755,root,root) %{_vfsdir}/streams_xattr.so
+%attr(755,root,root) %{_vfsdir}/syncops.so
+%attr(755,root,root) %{_vfsdir}/xattr_tdb.so
+%{_mandir}/man8/vfs_acl_tdb.8*
+%{_mandir}/man8/vfs_acl_xattr.8*
+%{_mandir}/man8/vfs_fileid.8*
+%{_mandir}/man8/vfs_preopen.8*
+%{_mandir}/man8/vfs_shadow_copy2.8*
+%{_mandir}/man8/vfs_smb_traffic_analyzer.8*
+%{_mandir}/man8/vfs_streams_xattr.8*
+%{_mandir}/man8/vfs_streams_depot.8*
+%{_mandir}/man8/vfs_xattr_tdb.8*
+
 
 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/samba/smbusers
 %attr(754,root,root) /etc/rc.d/init.d/smb
@@ -1192,6 +1183,7 @@ fi
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/samba
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/samba
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.samba
+%{_mandir}/man1/ldb*.1*
 %{_mandir}/man1/log2pcap.1*
 %{_mandir}/man1/smbstatus.1*
 %{_mandir}/man1/smbcontrol.1*
@@ -1200,7 +1192,6 @@ fi
 %{_mandir}/man8/nmbd.8*
 %{_mandir}/man8/smbd.8*
 %{_mandir}/man8/smbpasswd.8*
-%{_mandir}/man8/tdbbackup.8*
 
 %dir %{_sambahome}
 %dir /var/lib/samba
@@ -1217,7 +1208,7 @@ fi
 %doc examples/LDAP
 %endif
 
-%files winbind
+%files winbind -f pam_winbind.lang
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_sbindir}/winbindd
 %attr(755,root,root) %{_bindir}/wbinfo
@@ -1235,35 +1226,32 @@ fi
 
 %files client
 %defattr(644,root,root,755)
-%attr(755,root,root) /sbin/mount.smbfs
 %attr(755,root,root) /sbin/mount.cifs
 %attr(755,root,root) /sbin/umount.cifs
+%attr(755,root,root) %{_bindir}/findsmb
 %attr(755,root,root) %{_bindir}/net
-%attr(755,root,root) %{_bindir}/smbmnt
-%attr(755,root,root) %{_bindir}/smbmount
-%attr(755,root,root) %{_bindir}/smbsh
-%attr(755,root,root) %{_bindir}/smbtree
-%attr(755,root,root) %{_bindir}/smbumount
-%attr(755,root,root) %{_libdir}/smbwrapper.so
-%{_mandir}/man1/smbtree.1*
-%{_mandir}/man8/net.8*
-%{_mandir}/man8/smbmnt.8*
-%{_mandir}/man8/smbmount.8*
-%{_mandir}/man8/smbumount.8*
-%{_mandir}/man8/*mount.cifs.8*
 %attr(755,root,root) %{_bindir}/nmblookup
+%attr(755,root,root) %{_bindir}/rpcclient
+%attr(755,root,root) %{_bindir}/sharesec
 %attr(755,root,root) %{_bindir}/smbcacls
 %attr(755,root,root) %{_bindir}/smbclient
+%attr(755,root,root) %{_bindir}/smbsh
 %attr(755,root,root) %{_bindir}/smbtar
+%attr(755,root,root) %{_bindir}/smbtree
+%attr(755,root,root) %{_sbindir}/cifs.upcall
+%attr(755,root,root) %{_libdir}/smbwrapper.so
+%{_mandir}/man1/findsmb.1*
 %{_mandir}/man1/nmblookup.1*
+%{_mandir}/man1/rpcclient.1*
+%{_mandir}/man1/sharesec.1*
 %{_mandir}/man1/smbcacls.1*
 %{_mandir}/man1/smbclient.1*
-%{_mandir}/man1/smbtar.1*
 %{_mandir}/man1/smbsh.1*
-%attr(755,root,root) %{_bindir}/rpcclient
-%{_mandir}/man1/rpcclient.1*
-%attr(755,root,root) %{_bindir}/findsmb
-%{_mandir}/man1/findsmb.1*
+%{_mandir}/man1/smbtar.1*
+%{_mandir}/man1/smbtree.1*
+%{_mandir}/man8/cifs.upcall.8*
+%{_mandir}/man8/net.8*
+%{_mandir}/man8/*mount.cifs.8*
 
 %files common
 %defattr(644,root,root,755)
@@ -1281,8 +1269,6 @@ fi
 %attr(755,root,root) %{_bindir}/testparm
 %attr(755,root,root) %{_bindir}/vfstest
 %dir %{_libdir}/%{name}
-# how this one is used? SONAME is libsmbsharemodes.so.0
-%attr(755,root,root) %{_libdir}/%{name}/libsmbsharemodes.so
 %{_libdir}/%{name}/*.dat
 %dir %{_libdir}/%{name}/auth
 %attr(755,root,root) %{_libdir}/%{name}/auth/script.so
@@ -1299,10 +1285,13 @@ fi
 %{_mandir}/man8/pdbedit.8*
 %{_mandir}/man8/eventlogadm.8*
 %{_mandir}/man8/idmap_ad.8*
+%{_mandir}/man8/idmap_adex.8*
+%{_mandir}/man8/idmap_hash.8*
 %{_mandir}/man8/idmap_ldap.8*
 %{_mandir}/man8/idmap_nss.8*
 %{_mandir}/man8/idmap_rid.8*
 %{_mandir}/man8/idmap_tdb.8*
+%{_mandir}/man8/idmap_tdb2.8*
 %{_mandir}/man8/tdbtool.8*
 
 %files swat
@@ -1315,7 +1304,6 @@ fi
 %{_datadir}/swat/help
 %{_datadir}/swat/images
 %{_datadir}/swat/include
-%{_datadir}/swat/using_samba
 %dir %{_datadir}/swat/lang
 %lang(ja) %{_datadir}/swat/lang/ja
 %lang(tr) %{_datadir}/swat/lang/tr
@@ -1330,16 +1318,6 @@ fi
 %lang(tr) %{_libdir}/%{name}/tr.msg
 %{_mandir}/man8/swat.8*
 
-%if %{with python}
-%files -n python-samba
-%defattr(644,root,root,755)
-%dir %{py_sitedir}/samba
-%attr(755,root,root) %{py_sitedir}/samba/*.so
-%{py_sitedir}/samba/*.py
-%doc source/python/{README,gprinterdata,gtdbtool,gtkdictbrowser.py}
-%doc source/python/examples
-%endif
-
 %files -n pam-pam_smbpass
 %defattr(644,root,root,755)
 %doc source/pam_smbpass/{CHAN*,README,TODO} source/pam_smbpass/samples
@@ -1347,16 +1325,25 @@ fi
 
 %files -n libsmbclient
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libmsrpc.so.*
 %attr(755,root,root) %{_libdir}/libsmbclient.so.*
+%attr(755,root,root) %{_libdir}/libwbclient.so.*
 %{_mandir}/man7/libsmbclient.7*
 
 %files -n libsmbclient-devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libmsrpc.so
 %attr(755,root,root) %{_libdir}/libsmbclient.so
-%{_includedir}/libmsrpc.h
+%attr(755,root,root) %{_libdir}/libwbclient.so
 %{_includedir}/libsmbclient.h
+%{_includedir}/wbclient.h
+
+%files -n libtalloc
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libtalloc.so.*
+
+%files -n libtalloc-devel
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libtalloc.so
+%{_includedir}/talloc.h
 
 %files devel
 %defattr(644,root,root,755)
@@ -1364,7 +1351,6 @@ fi
 
 %files -n libsmbclient-static
 %defattr(644,root,root,755)
-%{_libdir}/libmsrpc.a
 %{_libdir}/libsmbclient.a
 
 %files -n smbget
@@ -1387,6 +1373,8 @@ fi
 %attr(755,root,root) %{_vfsdir}/extd_audit.so
 %attr(755,root,root) %{_vfsdir}/full_audit.so
 %{_mandir}/man8/vfs_audit.8*
+%{_mandir}/man8/vfs_extd_audit.8*
+%{_mandir}/man8/vfs_full_audit.8*
 
 %files vfs-cap
 %defattr(644,root,root,755)
@@ -1407,6 +1395,11 @@ fi
 %attr(755,root,root) %{_vfsdir}/fake_perms.so
 %{_mandir}/man8/vfs_fake_perms.8*
 
+%files vfs-notify_fam
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_vfsdir}/notify_fam.so
+%{_mandir}/man8/vfs_notify_fam.8*
+
 %files vfs-netatalk
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_vfsdir}/netatalk.so
@@ -1432,6 +1425,7 @@ fi
 %attr(755,root,root) %{_vfsdir}/shadow_copy.so
 %{_mandir}/man8/vfs_shadow_copy.8*
 
+%if %{with vscan}
 %files vfs-vscan-antivir
 %defattr(644,root,root,755)
 #%doc examples/VFS/%{name}-vscan-%{vscan_version}/{INSTALL,FAQ}
@@ -1468,6 +1462,7 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/samba/vscan-mcdaemon.conf
 %attr(755,root,root) %{_vfsdir}/vscan-mcdaemon.so
 
+%if %{with mks}
 %ifarch %{ix86} %{x8664}
 %files vfs-vscan-mks
 %defattr(644,root,root,755)
@@ -1475,6 +1470,7 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/samba/vscan-mks32.conf
 %attr(755,root,root) %{_vfsdir}/vscan-mksd.so
 %endif
+%endif
 
 %files vfs-vscan-openantivirus
 %defattr(644,root,root,755)
@@ -1499,6 +1495,7 @@ fi
 #%doc examples/VFS/%{name}-vscan-%{vscan_version}/{INSTALL,FAQ}
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/samba/vscan-trend.conf
 %attr(755,root,root) %{_vfsdir}/vscan-trend.so
+%endif
 
 %if %{with ldap}
 %files -n openldap-schema-samba
This page took 0.049567 seconds and 4 git commands to generate.