]> git.pld-linux.org Git - packages/samba.git/blobdiff - samba.spec
- dropped repeated %description
[packages/samba.git] / samba.spec
index 16663a8dcd3c30b7ccacf8cfd128e818da5cf5dd..23dcc97293d431cfae64552dba892527e46cdfa1 100644 (file)
@@ -1,31 +1,42 @@
+#
 # TODO:
+# - review python-samba
 # - look into other distro specs for valid %descriptions for samba 3
 # - unpackaged man pages for modules that are not built by default,
-#   maybe we should build them?
-#   /usr/share/man/man8/vfs_cacheprime.8*
-#   /usr/share/man/man8/vfs_catia.8*
-#   /usr/share/man/man8/vfs_commit.8*
-#   /usr/share/man/man8/vfs_gpfs.8*
-#   /usr/share/man/man8/vfs_notify_fam.8*
-#   /usr/share/man/man8/vfs_prealloc.8*
-# - libmsrpc.so is broken (references smbc_attr_server() which is no longer exported from libsmbclient)
+#  maybe we should build them?
+#  /usr/share/man/man8/vfs_cacheprime.8*
+#  /usr/share/man/man8/vfs_catia.8*
+#  /usr/share/man/man8/vfs_commit.8*
+#  /usr/share/man/man8/vfs_gpfs.8*
+#  /usr/share/man/man8/vfs_notify_fam.8*
+#  /usr/share/man/man8/vfs_prealloc.8*
 # - package libs:
-#      libnetapi
-#      libsmbsharemodes
+#      libnetapi
+#      libsmbsharemodes
 # - MERGE vfs modules into main package, what was the point of splitting these?
+# - remove vscan - project is dead - samba 3.5 will have vfs_scannedonly
+#
+
 #
 # Conditional build:
 %bcond_without ads             # without ActiveDirectory support
 %bcond_without cups            # without CUPS support
 %bcond_without kerberos5       # without Kerberos V support
 %bcond_without ldap            # without LDAP support
+%bcond_without avahi
+%bcond_with    merged_build    # without samba3+samba4 merge
+%bcond_without system_libtalloc
+                                                               # http://wiki.samba.org/index.php/Franky
 %bcond_with    mks             # with vfs-mks (mksd dependency not distributale)
 %bcond_with    vscan
 
 # ADS requires kerberos5 and LDAP
-%if !%{with kerberos5} || !%{with ldap}
+%if %{without kerberos5} || %{without ldap}
 %undefine      with_ads
 %endif
+
+%define        libtalloc_ver   2:2.0.1
+
 %define                vscan_version 0.3.6c-beta5
 Summary:       SMB server
 Summary(cs.UTF-8):     Server SMB
@@ -44,13 +55,13 @@ Summary(tr.UTF-8):  SMB sunucusu
 Summary(uk.UTF-8):     SMB клієнт та сервер
 Summary(zh_CN.UTF-8):  Samba 客户端和服务器
 Name:          samba
-Version:       3.2.7
-Release:       1.1
+Version:       3.5.6
+Release:       1
 Epoch:         1
-License:       GPL v2
+License:       GPL v3
 Group:         Networking/Daemons
-Source0:       http://www.samba.org/samba/ftp/%{name}-%{version}.tar.gz
-# Source0-md5: 528677f261f3ed4a58f9483ca25ba6b2
+Source0:       http://www.samba.org/samba/ftp/stable/%{name}-%{version}.tar.gz
+# Source0-md5: bf6c09ea497a166df8bd672db1d8da8f
 Source1:       smb.init
 Source2:       %{name}.pamd
 Source3:       swat.inetd
@@ -61,31 +72,41 @@ Source7:    http://www.openantivirus.org/download/%{name}-vscan-%{vscan_version}.ta
 # Source7-md5: 8f1dd119172e04e6d7c2d05526a4cf8b
 Source8:       winbind.init
 Source9:       winbind.sysconfig
+Source10:      %{name}-rfc3454.txt
 Patch0:                %{name}-smbwrapper.patch
 Patch1:                %{name}-c++-nofail.patch
 Patch2:                %{name}-pthread.patch
 Patch3:                %{name}-nscd.patch
 Patch4:                %{name}-lprng-no-dot-printers.patch
-Patch5:                %{name}-printerlocation.patch
-Patch6:                %{name}-link.patch
+Patch5:                %{name}-passdb-smbpasswd.patch
 URL:           http://www.samba.org/
 BuildRequires: acl-devel
 BuildRequires: autoconf
 BuildRequires: automake
+%{?with_avahi:BuildRequires:   avahi-devel}
+BuildRequires: ctdb-devel
 %{?with_cups:BuildRequires:    cups-devel >= 1:1.2.0}
 BuildRequires: dmapi-devel
 BuildRequires: fam-devel
+BuildRequires: gdbm-devel
+BuildRequires: gettext-devel
+%{?with_kerberos5:BuildRequires:       heimdal-devel}
 BuildRequires: iconv
-%{?with_kerberos5:BuildRequires:       krb5-devel}
+BuildRequires: keyutils-devel
 BuildRequires: libmagic-devel
 BuildRequires: libnscd-devel
+%{?with_system_libtalloc:BuildRequires:        libtalloc-devel >= %{libtalloc_ver}}
 BuildRequires: libtool >= 2:1.4d
+BuildRequires: make >= 3.81
 BuildRequires: ncurses-devel >= 5.2
 %{?with_ldap:BuildRequires:    openldap-devel >= 2.3.0}
 BuildRequires: openssl-devel >= 0.9.7d
 BuildRequires: pam-devel >= 0.99.8.1
+BuildRequires: pkgconfig
 BuildRequires: popt-devel
 %{?with_pgsql:BuildRequires:   postgresql-devel}
+BuildRequires: python-devel
+BuildRequires: python-modules
 BuildRequires: readline-devel >= 4.2
 BuildRequires: rpmbuild(macros) >= 1.304
 BuildRequires: sed >= 4.0
@@ -98,6 +119,7 @@ Requires:    rc-scripts
 Requires:      setup >= 2.4.6-7
 # smbd links with libcups
 %{?with_cups:Requires: cups-lib >= 1:1.2.0}
+Obsoletes:     python-samba
 Obsoletes:     samba-pdb-xml
 Obsoletes:     samba-vfs-block
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -311,8 +333,8 @@ Summary(ru.UTF-8):  Клиентские программы Samba (SMB)
 Summary(uk.UTF-8):     Клієнтські програми Samba (SMB)
 Group:         Applications/Networking
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
+%{?with_kerberos5:Requires:    heimdal-libs}
 Requires:      libsmbclient = %{epoch}:%{version}-%{release}
-%{?with_kerberos5:Requires:    krb5-libs}
 Obsoletes:     mount-cifs
 Obsoletes:     smbfs
 
@@ -321,11 +343,6 @@ Samba-client provides some SMB clients, which complement the build-in
 SMB filesystem in Linux. These allow accessing of SMB shares and
 printing to SMB printers.
 
-%description client -l pt_BR.UTF-8
-O pacote samba-clientes prove alguns clientes SMB, que complementam o
-sistema de arquivos SMB do Linux. Eles permitem o acesso a shares SMB,
-e também, à impressoras SMB.
-
 %description client -l es.UTF-8
 Cliente SMB de Samba.
 
@@ -362,7 +379,12 @@ Summary(pt_BR.UTF-8):      Arquivos em comum entre samba e samba-clients
 Summary(ru.UTF-8):     Файлы, используемые как сервером, так и клиентом Samba
 Summary(uk.UTF-8):     Файли, що використовуються як сервером, так і клієнтом Samba
 Group:         Networking/Daemons
-Requires:      tdb >= 1.1.0
+%if %{without system_libtalloc}
+Requires:      libtalloc >= %{epoch}:%{version}-%{release}
+%else
+Requires:      libtalloc >= %{libtalloc_ver}
+%endif
+Requires:      tdb >= %{epoch}:%{version}-%{release}
 
 %description common
 Samba-common provides files necessary for both the server and client
@@ -487,8 +509,40 @@ Group:             Development/Libraries
 Requires:      libtalloc = %{epoch}:%{version}-%{release}
 
 %description -n libtalloc-devel
-The libtalloc-devel package contains the header files and libraries needed to
-develop programs that link against the talloc library in the Samba suite.
+The libtalloc-devel package contains the header files and libraries
+needed to develop programs that link against the talloc library in the
+Samba suite.
+
+%package -n tdb
+Summary:       TDB - Trivial Database
+Summary(pl.UTF-8):     TDB - prosta baza danych
+Group:         Libraries
+Obsoletes:     tdb-extras
+
+%description -n tdb
+TDB is a Trivial Database. In concept, it is very much like GDBM, and
+BSD's DB except that it allows multiple simultaneous writers and uses
+locking internally to keep writers from trampling on each other. TDB
+is also extremely small.
+
+%description -n tdb -l pl.UTF-8
+TDB to Trivial Database, czyli prosta baza danych. W założeniach jest
+bardzo podobna do GDBM lub DB z BSD z wyjątkiem tego, że pozwala na
+zapis wielu procesom jednocześnie i używa wewnętrznie blokowania, aby
+nie pozwolić piszącym na zadeptanie się nawzajem. TDB jest ponadto
+ekstremalnie mała.
+
+%package  -n tdb-devel
+Summary:       Header files for TDB library
+Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki TDB
+Group:         Development/Libraries
+Requires:      tdb = %{epoch}:%{version}-%{release}
+
+%description -n tdb-devel
+Header files for TDB library.
+
+%description -n tdb-devel -l pl.UTF-8
+Pliki nagłówkowe biblioteki TDB.
 
 %package devel
 Summary:       Header files for Samba
@@ -623,7 +677,7 @@ klientom pomimo, że pliki nie zostaną nigdy nadpisane przy logowaniu
 lub wylogowywaniu klienta.
 
 %package vfs-notify_fam
-Summary:       VFS module to implement  file  change  notifications
+Summary:       VFS module to implement file change notifications
 Summary(pl.UTF-8):     Moduł VFS implementujący informowanie o zmianach w plikach
 Group:         Networking/Daemons
 Requires:      %{name} = %{epoch}:%{version}-%{release}
@@ -911,6 +965,27 @@ Moduł vfs do samby implementujący skaning antywirusowy w czasie
 dostępu do plików korzystając z oprogramowania antywirusowego Trend
 (które musi być zainstalowane, aby wykorzystać ten moduł).
 
+%package vfs-catia
+Summary:       VFS module to fix Catia CAD filenames
+Group:         Networking/Daemons
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+
+%description vfs-catia
+The Catia CAD package commonly creates filenames that use characters
+that are illegal in CIFS filenames. The vfs_catia VFS module
+implements a fixed character mapping so that these files can be shared
+with CIFS clients.
+
+%package vfs-scannedonly
+Summary:       Anti-virus solution as VFS module
+Group:         Networking/Daemons
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+
+%description vfs-scannedonly
+The vfs_scannedonly VFS module ensures that only files that have been
+scanned for viruses are visible and accessible to the end user. If
+non-scanned files are found an anti-virus scanning daemon is notified.
+
 %package -n openldap-schema-samba
 Summary:       Samba LDAP schema
 Summary(pl.UTF-8):     Schemat LDAP dla samby
@@ -946,6 +1021,15 @@ Samba PDF documentation.
 %description doc-pdf -l pl.UTF-8
 Documentacja samby w formacie PDF.
 
+%package -n python-samba
+Summary:       Samba Module for Python
+Group:         Development/Languages/Python
+%pyrequires_eq         python
+Requires:      %{name}-common = %{epoch}:%{version}-%{release}
+
+%description -n python-samba
+Samba Module for Python.
+
 %prep
 %setup -q
 %patch0 -p1
@@ -953,9 +1037,10 @@ Documentacja samby w formacie PDF.
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
-# why this isn't upstream?
+%if "%{pld_release}" == "ti"
 %patch5 -p1
-%patch6 -p1
+%endif
+
 %{__sed} -i 's#%SAMBAVERSION%#%{version}#' docs/htmldocs/index.html
 
 cd examples/VFS
@@ -963,16 +1048,22 @@ tar xzf %{SOURCE7}
 mv README{,.vfs}
 cd ../..
 
+install %{SOURCE10} source4/heimdal/lib/wind/rfc3454.txt
+
 %build
-cd source
+cd source3
 %{__libtoolize}
-%{__autoconf} -Im4 -Ilib/replace
+%{__autoconf} -Im4 -I../m4 -I../lib/replace -Ilib/replace -I../source4
 %configure \
-       --libdir=%{_sambalibdir} \
+       --with-modulesdir=%{_sambalibdir} \
        --with-rootsbindir=/sbin \
        --with-pammodulesdir=/%{_lib}/security \
        --with-acl-support \
+       --with-aio-support \
        --with-automount \
+       --with-cifsmount \
+       --with-cifsumount \
+       --with-cifsupcall \
        --with-libsmbclient \
        --with-lockdir=/var/lib/samba \
        --with-pam \
@@ -985,11 +1076,21 @@ cd source
        --with-syslog \
        --with-utmp \
        --with-fhs \
+%if %{with system_libtalloc}
+       --with-libtalloc=no \
+       --enable-external-libtalloc=yes \
+%endif
+       --without-included-popt \
+       --%{?with_merged_build:en}%{!?with_merged_build:dis}able-merged-build \
+       --enable-automatic-dependencies \
+       --enable-dso \
+       --%{?with_avahi:en}%{!?with_avahi:dis}able-avahi \
+       --disable-dnssd \
        --with%{!?with_ldap:out}-ldap \
        --with%{!?with_kerberos5:out}-krb5
 
-%{__make} proto
-%{__make} everything pam_smbpass bin/smbget bin/mount.cifs bin/vfstest
+%{__make} -j1 everything pam_smbpass bin/smbget bin/mount.cifs bin/vfstest \
+       LD=ld
 
 cd ../examples
 %{__make} -C libsmbclient/smbwrapper \
@@ -1007,7 +1108,7 @@ cd VFS
 cd samba-vscan-%{vscan_version}
 cp -f /usr/share/automake/config.sub .
 %configure
-ln -s ../../../source/lib .
+ln -s ../../../source3/lib .
 %{__make} all
 %endif
 
@@ -1018,11 +1119,11 @@ install -d $RPM_BUILD_ROOT/etc/{logrotate.d,rc.d/init.d,pam.d,security,sysconfig
        $RPM_BUILD_ROOT/var/log/samba/cores/{smbd,nmbd} \
        $RPM_BUILD_ROOT{/sbin,/%{_lib}/security,%{_libdir},%{_vfsdir},%{_includedir},%{_sambahome},%{schemadir}}
 
-%{__make} -C source install \
+%{__make} -C source3 install \
        DESTDIR=$RPM_BUILD_ROOT \
        CONFIGDIR=$RPM_BUILD_ROOT%{_sysconfdir}/samba
 
-install source/script/mksmbpasswd.sh $RPM_BUILD_ROOT%{_sbindir}
+install source3/script/mksmbpasswd.sh $RPM_BUILD_ROOT%{_sbindir}
 
 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/smb
 install %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/samba
@@ -1033,16 +1134,15 @@ install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/samba/smb.conf
 install %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/winbind
 install %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/winbind
 
-install source/nsswitch/libnss_winbind.so $RPM_BUILD_ROOT/%{_lib}/libnss_winbind.so.2
+install nsswitch/libnss_winbind.so $RPM_BUILD_ROOT/%{_lib}/libnss_winbind.so.2
 ln -s libnss_winbind.so.2              $RPM_BUILD_ROOT/%{_lib}/libnss_winbind.so
-install source/nsswitch/libnss_wins.so $RPM_BUILD_ROOT/%{_lib}/libnss_wins.so.2
+install nsswitch/libnss_wins.so        $RPM_BUILD_ROOT/%{_lib}/libnss_wins.so.2
 ln -s libnss_wins.so.2                 $RPM_BUILD_ROOT/%{_lib}/libnss_wins.so
-install source/bin/wbinfo              $RPM_BUILD_ROOT%{_bindir}
-install source/bin/smbget              $RPM_BUILD_ROOT%{_bindir}
-install source/bin/vfstest             $RPM_BUILD_ROOT%{_bindir}
+install source3/bin/wbinfo             $RPM_BUILD_ROOT%{_bindir}
+install source3/bin/smbget             $RPM_BUILD_ROOT%{_bindir}
+install source3/bin/vfstest            $RPM_BUILD_ROOT%{_bindir}
 
-mv $RPM_BUILD_ROOT%{_libdir}/samba/lib*.so* $RPM_BUILD_ROOT%{_libdir}
-install source/bin/libsmbclient.a $RPM_BUILD_ROOT%{_libdir}/libsmbclient.a
+install source3/bin/libsmbclient.a $RPM_BUILD_ROOT%{_libdir}/libsmbclient.a
 
 # smbwrapper
 install examples/libsmbclient/smbwrapper/smbwrapper.so $RPM_BUILD_ROOT%{_libdir}/smbwrapper.so
@@ -1051,9 +1151,9 @@ install examples/libsmbclient/smbwrapper/smbsh.1 $RPM_BUILD_ROOT%{_mandir}/man1
 
 # these are needed to build samba-pdbsql
 install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/{tdb,nsswitch}
-cp -a source/include/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}
-cp -a source/lib/tdb/include/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/tdb
-cp -a source/nsswitch/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/nsswitch
+cp -a source3/include/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}
+cp -a lib/tdb/include/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/tdb
+cp -a nsswitch/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/nsswitch
 
 %if %{with vscan}
 # vscan modules
@@ -1073,15 +1173,24 @@ ln -s %{_bindir}/smbspool $RPM_BUILD_ROOT%{cups_serverbin}/backend/smb
 > $RPM_BUILD_ROOT%{_sysconfdir}/samba/smbusers
 > $RPM_BUILD_ROOT/etc/security/blacklist.samba
 
-# we have this utility in tdb package
-rm -f $RPM_BUILD_ROOT{%{_bindir}/tdb{backup,dump},%{_mandir}/man8/tdb{backup,dump}.8*}
+# unneeded
+#rm -r $RPM_BUILD_ROOT%{_datadir}/swat/using_samba
 
-mv $RPM_BUILD_ROOT%{_bindir}/tdbtool $RPM_BUILD_ROOT%{_bindir}/tdbtool_samba
+# tests
+%if %{with merged_build}
+rm -r $RPM_BUILD_ROOT%{_bindir}/{gentest4,locktest4,masktest4,nsstest4}
+%endif
 
 %if %{with ldap}
 install examples/LDAP/samba.schema $RPM_BUILD_ROOT%{schemadir}
 %endif
 
+%find_lang pam_winbind
+
+%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
+%py_comp $RPM_BUILD_ROOT%{py_sitedir}
+find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -1140,26 +1249,58 @@ if [ "$1" != "0" ]; then
        /sbin/chkconfig --add smb
 fi
 
+%if "%{pld_release}" != "ti"
+%triggerpostun -- samba < 3.4.0
+%banner %{name} << EOF
+!!! WARNING !!! The default passdb backend has been changed to 'tdbsam'!
+That breaks existing setups using the 'smbpasswd' backend without explicit declaration!
+Please use 'passdb backend = smbpasswd' if you would like to stick to the 'smbpasswd'
+backend or convert your smbpasswd entries using e.g. 'pdbedit -i smbpasswd -e tdbsam'.
+EOF
+%endif
+
 %files
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_sbindir}/nmbd
 %attr(755,root,root) %{_sbindir}/smbd
 %attr(755,root,root) %{_sbindir}/mksmbpasswd.sh
+%if %{with merged_build}
+#%attr(755,root,root) %{_bindir}/ad2oLschema4
+%attr(755,root,root) %{_bindir}/oLschema2ldif4
+%attr(755,root,root) %{_bindir}/reg*
+# "This utility disabled until rewritten"
+#%attr(755,root,root) %{_bindir}/setnttoken4
+%endif
 %attr(755,root,root) %{_bindir}/ldb*
 %attr(755,root,root) %{_bindir}/smbstatus
 %attr(755,root,root) %{_bindir}/smbpasswd
 %attr(755,root,root) %{_bindir}/smbcontrol
-%attr(755,root,root) %{_bindir}/tdbtool_samba
 
 %dir %{_libdir}/%{name}/pdb
 %dir %{_vfsdir}
+%attr(755,root,root) %{_vfsdir}/acl_tdb.so
+%attr(755,root,root) %{_vfsdir}/acl_xattr.so
+%attr(755,root,root) %{_vfsdir}/aio_fork.so
+%attr(755,root,root) %{_vfsdir}/dirsort.so
 %attr(755,root,root) %{_vfsdir}/fileid.so
+%attr(755,root,root) %{_vfsdir}/preopen.so
 %attr(755,root,root) %{_vfsdir}/shadow_copy2.so
 %attr(755,root,root) %{_vfsdir}/smb_traffic_analyzer.so
 %attr(755,root,root) %{_vfsdir}/streams_depot.so
 %attr(755,root,root) %{_vfsdir}/streams_xattr.so
 %attr(755,root,root) %{_vfsdir}/syncops.so
 %attr(755,root,root) %{_vfsdir}/xattr_tdb.so
+%{_mandir}/man8/vfs_acl_tdb.8*
+%{_mandir}/man8/vfs_acl_xattr.8*
+%{_mandir}/man8/vfs_dirsort.8*
+%{_mandir}/man8/vfs_fileid.8*
+%{_mandir}/man8/vfs_preopen.8*
+%{_mandir}/man8/vfs_shadow_copy2.8*
+%{_mandir}/man8/vfs_smb_traffic_analyzer.8*
+%{_mandir}/man8/vfs_streams_xattr.8*
+%{_mandir}/man8/vfs_streams_depot.8*
+%{_mandir}/man8/vfs_xattr_tdb.8*
+
 
 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/samba/smbusers
 %attr(754,root,root) /etc/rc.d/init.d/smb
@@ -1176,10 +1317,6 @@ fi
 %{_mandir}/man8/nmbd.8*
 %{_mandir}/man8/smbd.8*
 %{_mandir}/man8/smbpasswd.8*
-%{_mandir}/man8/vfs_smb_traffic_analyzer.8*
-%{_mandir}/man8/vfs_streams_xattr.8*
-%{_mandir}/man8/vfs_streams_depot.8*
-%{_mandir}/man8/vfs_xattr_tdb.8*
 
 %dir %{_sambahome}
 %dir /var/lib/samba
@@ -1196,16 +1333,20 @@ fi
 %doc examples/LDAP
 %endif
 
-%files winbind
+%files winbind -f pam_winbind.lang
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_sbindir}/winbindd
 %attr(755,root,root) %{_bindir}/wbinfo
+#%if %{with merged_build}
+#%attr(755,root,root) %{_bindir}/wbinfo4
+#%endif
 %attr(755,root,root) /%{_lib}/security/pam_winbind*
 %attr(755,root,root) /%{_lib}/libnss_winbind*
 %attr(754,root,root) /etc/rc.d/init.d/winbind
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/winbind
 %{_mandir}/man1/wbinfo*.1*
-%{_mandir}/man7/pam_winbind.7*
+%{_mandir}/man5/pam_winbind.conf.5*
+%{_mandir}/man8/pam_winbind.8*
 %{_mandir}/man8/winbindd*.8*
 
 %files -n nss_wins
@@ -1214,12 +1355,23 @@ fi
 
 %files client
 %defattr(644,root,root,755)
+%if %{with merged_build}
+%attr(755,root,root) %{_bindir}/cifsdd4
+%attr(755,root,root) %{_bindir}/net4
+%attr(755,root,root) %{_bindir}/nmblookup4
+%attr(755,root,root) %{_bindir}/smbclient4
+%attr(755,root,root) %{_bindir}/mount.cifs4
+%attr(755,root,root) %{_bindir}/umount.cifs4
+%attr(755,root,root) %{_bindir}/setnttoken4
+%attr(755,root,root) %{_bindir}/smbtorture4
+%endif
 %attr(755,root,root) /sbin/mount.cifs
 %attr(755,root,root) /sbin/umount.cifs
 %attr(755,root,root) %{_bindir}/findsmb
 %attr(755,root,root) %{_bindir}/net
 %attr(755,root,root) %{_bindir}/nmblookup
 %attr(755,root,root) %{_bindir}/rpcclient
+%attr(755,root,root) %{_bindir}/sharesec
 %attr(755,root,root) %{_bindir}/smbcacls
 %attr(755,root,root) %{_bindir}/smbclient
 %attr(755,root,root) %{_bindir}/smbsh
@@ -1230,17 +1382,24 @@ fi
 %{_mandir}/man1/findsmb.1*
 %{_mandir}/man1/nmblookup.1*
 %{_mandir}/man1/rpcclient.1*
+%{_mandir}/man1/sharesec.1*
 %{_mandir}/man1/smbcacls.1*
 %{_mandir}/man1/smbclient.1*
 %{_mandir}/man1/smbsh.1*
 %{_mandir}/man1/smbtar.1*
 %{_mandir}/man1/smbtree.1*
-%{_mandir}/man8/cifs.upcall.8*
 %{_mandir}/man8/net.8*
 %{_mandir}/man8/*mount.cifs.8*
+%{_mandir}/man8/cifs.upcall.8*
 
 %files common
 %defattr(644,root,root,755)
+%if %{with merged_build}
+%attr(755,root,root) %{_bindir}/getntacl4
+%attr(755,root,root) %{_bindir}/ndrdump4
+%attr(755,root,root) %{_bindir}/ntlm_auth4
+%attr(755,root,root) %{_bindir}/testparm4
+%endif
 %doc README Manifest WHATSNEW.txt
 %doc Roadmap docs/registry/*
 %doc docs/{history,THANKS}
@@ -1271,11 +1430,13 @@ fi
 %{_mandir}/man8/pdbedit.8*
 %{_mandir}/man8/eventlogadm.8*
 %{_mandir}/man8/idmap_ad.8*
+%{_mandir}/man8/idmap_adex.8*
+%{_mandir}/man8/idmap_hash.8*
 %{_mandir}/man8/idmap_ldap.8*
 %{_mandir}/man8/idmap_nss.8*
 %{_mandir}/man8/idmap_rid.8*
 %{_mandir}/man8/idmap_tdb.8*
-%{_mandir}/man8/tdbtool.8*
+%{_mandir}/man8/idmap_tdb2.8*
 
 %files swat
 %defattr(644,root,root,755)
@@ -1298,12 +1459,13 @@ fi
 %lang(ja) %{_libdir}/%{name}/ja.msg
 %lang(nl) %{_libdir}/%{name}/nl.msg
 %lang(pl) %{_libdir}/%{name}/pl.msg
+%lang(ru) %{_libdir}/%{name}/ru.msg
 %lang(tr) %{_libdir}/%{name}/tr.msg
 %{_mandir}/man8/swat.8*
 
 %files -n pam-pam_smbpass
 %defattr(644,root,root,755)
-%doc source/pam_smbpass/{CHAN*,README,TODO} source/pam_smbpass/samples
+%doc source3/pam_smbpass/{CHAN*,README,TODO} source3/pam_smbpass/samples
 %attr(755,root,root) /%{_lib}/security/pam_smbpass.so
 
 %files -n libsmbclient
@@ -1319,6 +1481,7 @@ fi
 %{_includedir}/libsmbclient.h
 %{_includedir}/wbclient.h
 
+%if %{without system_libtalloc}
 %files -n libtalloc
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libtalloc.so.*
@@ -1327,6 +1490,28 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libtalloc.so
 %{_includedir}/talloc.h
+%endif
+
+%files -n tdb
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/tdbbackup
+%attr(755,root,root) %{_bindir}/tdbdump
+%attr(755,root,root) %{_bindir}/tdbtool
+%if %{with merged_build}
+%attr(755,root,root) %{_bindir}/tdbbackup4
+%attr(755,root,root) %{_bindir}/tdbdump4
+%attr(755,root,root) %{_bindir}/tdbtool4
+%attr(755,root,root) %{_bindir}/tdbtorture4
+%endif
+%attr(755,root,root) %{_libdir}/libtdb.so.*
+%{_mandir}/man8/tdbbackup.8*
+%{_mandir}/man8/tdbdump.8*
+%{_mandir}/man8/tdbtool.8*
+
+%files -n tdb-devel
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libtdb.so
+%{_includedir}/tdb.h
 
 %files devel
 %defattr(644,root,root,755)
@@ -1480,6 +1665,16 @@ fi
 %attr(755,root,root) %{_vfsdir}/vscan-trend.so
 %endif
 
+%files vfs-catia
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_vfsdir}/catia.so
+%{_mandir}/man8/vfs_catia.8*
+
+%files vfs-scannedonly
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_vfsdir}/scannedonly.so
+%{_mandir}/man8/vfs_scannedonly.8*
+
 %if %{with ldap}
 %files -n openldap-schema-samba
 %defattr(644,root,root,755)
@@ -1493,3 +1688,21 @@ fi
 %files doc-pdf
 %defattr(644,root,root,755)
 %doc docs/*.pdf
+
+%if 0
+%files -n python-samba
+%defattr(644,root,root,755)
+%attr(755,root,root) %{py_sitedir}/*.so
+%dir %{py_sitedir}/samba
+%attr(755,root,root) %{py_sitedir}/samba/*.so
+%{py_sitedir}/samba/*.py[co]
+%dir %{py_sitedir}/samba/dcerpc
+%{py_sitedir}/samba/dcerpc/*.py[co]
+%attr(755,root,root) %{py_sitedir}/samba/dcerpc/*.so
+%dir %{py_sitedir}/samba/tests
+%{py_sitedir}/samba/tests/*.py[co]
+%dir %{py_sitedir}/samba/tests/dcerpc
+%{py_sitedir}/samba/tests/dcerpc/*.py[co]
+%dir %{py_sitedir}/samba/torture
+%{py_sitedir}/samba/torture/*.py[co]
+%endif
This page took 0.113968 seconds and 4 git commands to generate.