]> git.pld-linux.org Git - packages/rust.git/blobdiff - rust.spec
up to 1.75.0
[packages/rust.git] / rust.spec
index d78543b56e515fb893e10ef898fb64a932fd8940..26b04d19504ed357c9568ac5e2e1d37ac32dcc8c 100644 (file)
--- a/rust.spec
+++ b/rust.spec
@@ -21,9 +21,9 @@
 # To bootstrap from scratch, set the channel and date from src/stage0.json
 # e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
 # or nightly wants some beta-YYYY-MM-DD
-%define                bootstrap_rust  1.72.0
+%define                bootstrap_rust  1.74.0
 %define                bootstrap_cargo %{bootstrap_rust}
-%define                bootstrap_date  2023-08-24
+%define                bootstrap_date  2023-11-16
 
 %ifarch x32
 %define                with_cross      1
 Summary:       The Rust Programming Language
 Summary(pl.UTF-8):     JÄ™zyk programowania Rust
 Name:          rust
-Version:       1.73.0
+Version:       1.75.0
 Release:       1
 # Licenses: (rust itself) and (bundled libraries)
 License:       (Apache v2.0 or MIT) and (BSD and ISC and MIT)
 Group:         Development/Languages
 Source0:       https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
-# Source0-md5: 2b5fd1623a6591c3e31eaec674ccc81c
+# Source0-md5: 62d794105a8c98923a67e6d9ce032be0
 Source1:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-x86_64-unknown-linux-gnu.tar.xz
-# Source1-md5: 9607a21044d111c5c40b0febdcefec19
+# Source1-md5: d608ce47f4099374ec456a667a87ef38
 Source2:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-i686-unknown-linux-gnu.tar.xz
-# Source2-md5: 7f37eec4326ada8325eae7abfc16d6a9
+# Source2-md5: 14920e66eb12cb24022d5ac3f044c286
 Source3:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-aarch64-unknown-linux-gnu.tar.xz
-# Source3-md5: a0ff7728be371c1a4bed093c5b8641ac
+# Source3-md5: 9a02e2cb332d53886587be184128c206
 Source4:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-arm-unknown-linux-gnueabihf.tar.xz
-# Source4-md5: c767b0183d5d1d78c7ccc41484e64c99
+# Source4-md5: f503139222ec0711cde94fe905133419
 Source5:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-armv7-unknown-linux-gnueabihf.tar.xz
-# Source5-md5: bd6f0fa4eb95c9fef39db034e2817c27
+# Source5-md5: 3a45f0ddab316ea7d41ac48e0f233d9d
 URL:           https://www.rust-lang.org/
 # for src/compiler-rt
 BuildRequires: cmake >= 3.4.3
@@ -68,7 +68,7 @@ BuildRequires:        rpm-build >= 4.6
 BuildRequires: rpmbuild(macros) >= 1.752
 %if %{without cross}
 BuildRequires: curl-devel
-BuildRequires: libgit2-devel >= 1.6.4
+BuildRequires: libgit2-devel >= 1.7.1
 BuildRequires: libstdc++-devel
 %if %{with system_llvm}
 BuildRequires: llvm >= 15.0
@@ -92,7 +92,7 @@ BuildRequires:        glibc-devel(x86-x32)
 # building on x86_64 host with --target x32-pld-linux
 BuildRequires: curl-devel
 BuildRequires: gcc-multilib-x32
-BuildRequires: libgit2-devel >= 1.6.4
+BuildRequires: libgit2-devel >= 1.7.1
 BuildRequires: libstdc++-devel
 %{?with_system_llvm:BuildRequires:     llvm-devel >= 15.0}
 BuildRequires: openssl-devel >= 1.0.1
@@ -103,8 +103,8 @@ BuildRequires:      zlib-devel
 BuildRequires: curl-devel(x86-64)
 BuildRequires: curl-devel(x86-x32)
 BuildRequires: gcc-multilib-64
-BuildRequires: libgit2-devel(x86-64) >= 1.6.4
-BuildRequires: libgit2-devel(x86-x32) >= 1.6.4
+BuildRequires: libgit2-devel(x86-64) >= 1.7.1
+BuildRequires: libgit2-devel(x86-x32) >= 1.7.1
 BuildRequires: libstdc++-multilib-64-devel
 %if %{with system_llvm}
 BuildRequires: llvm-devel(x86-64) >= 15.0
@@ -373,9 +373,7 @@ sed -i -e 's#DIRECTORY=".*"#DIRECTORY="%{_datadir}/%{name}/etc"#' \
 %if "%{_libexecdir}" != "%{_prefix}/libexec"
 suffix="%(echo "%{_libexecdir}" | %{__sed} -e 's,^%{_prefix}/,,')"
 %{__sed} -i -e 's,"libexec","'${suffix}'",' \
-       src/bootstrap/dist.rs \
-       src/tools/cargo/src/cargo/util/auth.rs
-%{__sed} -i -e 's,libexec/,'${suffix}'/,' src/tools/cargo/tests/testsuite/credential_process.rs
+       src/bootstrap/dist.rs
 %endif
 
 # The configure macro will modify some autoconf-related files, which upsets
This page took 0.043253 seconds and 4 git commands to generate.