]> git.pld-linux.org Git - packages/ruby.git/blobdiff - ruby.spec
- up
[packages/ruby.git] / ruby.spec
index a741d47f31e06669a56231f5ab9aba33e22866a4..8c6efed7608e65ebad2878c813fe483884e70f95 100644 (file)
--- a/ruby.spec
+++ b/ruby.spec
@@ -1,5 +1,4 @@
 # TODO
-# - integrate vendordir patch
 # - include ext/ in docs
 # - replace ri with fastri
 # - patch ri to search multiple indexes (one per package), so RPMs can
@@ -9,6 +8,7 @@
 %bcond_without doc     # skip generating docs (which is time-consuming). Intended for speed up test builds
 %bcond_without emacs   # skip building package with ruby-mode for emacs
 %bcond_without tk      # skip building package with Tk bindings
+%bcond_with    onigurma
 #
 %define                ruby_ver        1.8
 %define                ruby_ridir      %{_datadir}/ri/%{ruby_ver}/system
@@ -18,14 +18,14 @@ Summary(pl.UTF-8):  Ruby - interpretowany język skryptowy
 Summary(pt_BR.UTF-8):  Linguagem de script orientada a objeto
 Summary(zh_CN.UTF-8):  ruby - 一种快速高效的面向对象脚本编程语言
 Name:          ruby
-Version:       1.8.6
-Release:       4
+Version:       1.8.7
+Release:       1
 Epoch:         1
 License:       The Ruby License
 Group:         Development/Languages
-%define patchlevel 111
-Source0:       ftp://ftp.ruby-lang.org/pub/ruby/1.8/%{name}-%{version}-p%{patchlevel}.tar.gz
-# Source0-md5: c36e011733a3a3be6f43ba27b7cd7485
+%define patchlevel 22
+Source0:       ftp://ftp.ruby-lang.org/pub/ruby/1.8/%{name}-%{version}-p%{patchlevel}.tar.bz2
+# Source0-md5: 2d57acee0d80531e14ec0f6826a1f9fb
 Source1:       http://www.ibiblio.org/pub/languages/ruby/doc/%{name}-texi-1.4-en.tar.gz
 # Source1-md5: 839fda4af52b5c5c6d21f879f7fc62bf
 Source2:       http://www.math.sci.hokudai.ac.jp/~gotoken/ruby/%{name}-uguide-981227.tar.gz
@@ -46,9 +46,7 @@ Source10:     ri.1
 Source11:      testrb.1
 Source12:      %{name}-mode-init.el
 Patch0:                %{name}-info.patch
-Patch1:                %{name}-LIB_PREFIX.patch
 Patch2:                %{name}-mkmf-shared.patch
-Patch4:                %{name}-vendordir.patch
 Patch5:                %{name}-lib64.patch
 URL:           http://www.ruby-lang.org/
 BuildRequires: autoconf
@@ -221,9 +219,7 @@ Tryb Ruby i debugger dla Emacsa.
 %prep
 %setup -q -n %{name}-%{version}-p%{patchlevel} -a1 -a2 -a3 -a5 -a6 -a7 
 %patch0 -p1
-%patch1 -p1
 %patch2 -p1
-%patch4 -p1
 %patch5 -p1
 
 find . -name '*.rb' -o -name '*.cgi' -o -name '*.test' -o -name 'ruby.1' \
@@ -233,11 +229,13 @@ find . -name '*.rb' -o -name '*.cgi' -o -name '*.test' -o -name 'ruby.1' \
 %build
 cp -f /usr/share/automake/config.sub .
 
+%if %{with onigurma}
 cd oniguruma
 %configure \
        --with-rubydir=..
 %{__make} 18
 cd ..
+%endif
 
 %{__autoconf}
 %configure \
@@ -310,7 +308,7 @@ cp -Rf rubyfaq faq
 # ruby emacs mode - borrowed from FC-4
 %if %{with emacs}
 install misc/*.el $RPM_BUILD_ROOT%{_emacs_lispdir}/%{name}-mode
-rm -f $RPM_BUILD_ROOT%{_emacs_lispdir}/%{name}-mode/rubydb2x.el
+rm -f $RPM_BUILD_ROOT%{_emacs_lispdir}/%{name}-mode/rubydb2x.el*
 install %{SOURCE12} $RPM_BUILD_ROOT%{_emacs_lispdir}/site-start.d
 cat << EOF > path.el
 (setq load-path (cons "." load-path) byte-compile-warnings nil)
This page took 0.029907 seconds and 4 git commands to generate.