]> git.pld-linux.org Git - packages/ruby-ohai.git/blobdiff - ruby-ohai.spec
drop virtualization-vserver.patch
[packages/ruby-ohai.git] / ruby-ohai.spec
index d634e4e994305815e3f5dfaaeb5c7913eb48cbdf..6d86120ee8686d40d6c18049abb8c39a64bd1ada 100644 (file)
@@ -1,41 +1,50 @@
 #
+# Release Notes: https://github.com/opscode/ohai/blob/master/CHANGELOG.md
+#
 # Conditional build:
 %bcond_with    tests           # build without tests
 
 %define pkgname ohai
 Summary:       Profiles your system and emits JSON
 Name:          ruby-%{pkgname}
-Version:       7.4.0
-Release:       0.1
+Version:       7.6.0
+Release:       0.3
 License:       Apache v2.0
 Group:         Development/Languages
 Source0:       https://github.com/opscode/ohai/archive/%{version}/%{pkgname}-%{version}.tar.gz
-# Source0-md5: 5275e5f79b618ce2af85311cd760b977
-Patch0:                virtualization-vserver.patch
+# Source0-md5: b28339ec7f835a2ed4ec0f876178fb14
+Patch1:                platform-pld.patch
+Patch2:                soft-net-dhcp.patch
 URL:           http://docs.getchef.com/ohai.html
 BuildRequires: rpm-rubyprov
 BuildRequires: rpmbuild(macros) >= 1.665
 BuildRequires: ruby-rake
 BuildRequires: sed >= 4.0
+# rake gem uses installed ohai version not version we intend to build!
+BuildConflicts:        ruby-ohai
 %if %{with tests}
 BuildRequires: ruby-ffi >= 1.9
-BuildRequires: ruby-ffi-yajl >= 1.0
+BuildRequires: ruby-ffi-yajl >= 1.1
 BuildRequires: ruby-ipaddress
 BuildRequires: ruby-mixlib-config
 BuildRequires: ruby-mixlib-log
-BuildRequires: ruby-mixlib-shellout >= 1.2
+BuildRequires: ruby-mixlib-shellout >= 2.0.0
 BuildRequires: ruby-rspec
 BuildRequires: ruby-systemu >= 2.6.4
 %endif
+Requires:      iproute2
 Requires:      lsb-release
+Requires:      mount
 Requires:      ruby-ffi >= 1.9
-Requires:      ruby-ffi-yajl >= 1.0
+Requires:      ruby-ffi-yajl >= 1.1
 Requires:      ruby-ipaddress
+Requires:      ruby-mime-types >= 1.16
 Requires:      ruby-mixlib-cli
-Requires:      ruby-mixlib-config
+Requires:      ruby-mixlib-config >= 2.0
 Requires:      ruby-mixlib-log
-Requires:      ruby-mixlib-shellout >= 1.2
+Requires:      ruby-mixlib-shellout >= 2.0.0
 Requires:      ruby-systemu >= 2.6.4
+Suggests:      ruby-net-dhcp
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -54,7 +63,8 @@ This package contains documentation for %{name}.
 
 %prep
 %setup -q -n ohai-%{version}
-%patch0 -p1
+%patch1 -p1
+%patch2 -p1
 %{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
 
 # no plist and not darwin so don't care
@@ -65,7 +75,7 @@ rm spec/unit/plugins/darwin/system_profiler_spec.rb
 rm spec/unit/plugins/ruby_spec.rb
 
 %build
-rake gem
+rake -Ilib gem
 %{__tar} -xmf pkg/ohai-%{version}*.gem
 %__gem_helper spec
 
This page took 0.030234 seconds and 4 git commands to generate.