]> git.pld-linux.org Git - packages/ruby-ohai.git/blobdiff - ruby-ohai.spec
drop virtualization-vserver.patch
[packages/ruby-ohai.git] / ruby-ohai.spec
index c0a83cb05a7b20ae69afb4578b3393bf8307b10e..6d86120ee8686d40d6c18049abb8c39a64bd1ada 100644 (file)
@@ -1,44 +1,50 @@
 #
+# Release Notes: https://github.com/opscode/ohai/blob/master/CHANGELOG.md
+#
 # Conditional build:
-%bcond_without tests           # build without tests
+%bcond_with    tests           # build without tests
 
 %define pkgname ohai
 Summary:       Profiles your system and emits JSON
 Name:          ruby-%{pkgname}
-Version:       6.24.2
-Release:       1
+Version:       7.6.0
+Release:       0.3
 License:       Apache v2.0
 Group:         Development/Languages
 Source0:       https://github.com/opscode/ohai/archive/%{version}/%{pkgname}-%{version}.tar.gz
-# Source0-md5: 3a856987c10aee5ab16ac4f7b73c3a23
-Patch0:                virtualization-vserver.patch
-Patch1:                php-builddate.patch
-Patch2:                https://github.com/glensc/ruby-ohai/compare/OHAI-295.patch
-# Patch2-md5:  7e0f3de1daa40df05a2aa82547d7ca67
-URL:           http://docs.opscode.com/ohai.html
+# Source0-md5: b28339ec7f835a2ed4ec0f876178fb14
+Patch1:                platform-pld.patch
+Patch2:                soft-net-dhcp.patch
+URL:           http://docs.getchef.com/ohai.html
 BuildRequires: rpm-rubyprov
 BuildRequires: rpmbuild(macros) >= 1.665
 BuildRequires: ruby-rake
 BuildRequires: sed >= 4.0
+# rake gem uses installed ohai version not version we intend to build!
+BuildConflicts:        ruby-ohai
 %if %{with tests}
+BuildRequires: ruby-ffi >= 1.9
+BuildRequires: ruby-ffi-yajl >= 1.1
 BuildRequires: ruby-ipaddress
 BuildRequires: ruby-mixlib-config
 BuildRequires: ruby-mixlib-log
-BuildRequires: ruby-mixlib-shellout
+BuildRequires: ruby-mixlib-shellout >= 2.0.0
 BuildRequires: ruby-rspec
-BuildRequires: ruby-systemu >= 2.5.2
-BuildRequires: ruby-yajl
+BuildRequires: ruby-systemu >= 2.6.4
 %endif
 Requires:      iproute2
 Requires:      lsb-release
+Requires:      mount
+Requires:      ruby-ffi >= 1.9
+Requires:      ruby-ffi-yajl >= 1.1
 Requires:      ruby-ipaddress
+Requires:      ruby-mime-types >= 1.16
 Requires:      ruby-mixlib-cli
-Requires:      ruby-mixlib-config
+Requires:      ruby-mixlib-config >= 2.0
 Requires:      ruby-mixlib-log
-Requires:      mount
-Requires:      ruby-mixlib-shellout
-Requires:      ruby-systemu >= 2.5.2
-Requires:      ruby-yajl
+Requires:      ruby-mixlib-shellout >= 2.0.0
+Requires:      ruby-systemu >= 2.6.4
+Suggests:      ruby-net-dhcp
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -57,7 +63,6 @@ This package contains documentation for %{name}.
 
 %prep
 %setup -q -n ohai-%{version}
-%patch0 -p1
 %patch1 -p1
 %patch2 -p1
 %{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
@@ -70,8 +75,8 @@ rm spec/unit/plugins/darwin/system_profiler_spec.rb
 rm spec/unit/plugins/ruby_spec.rb
 
 %build
-rake gem
-%{__tar} -xmf pkg/ohai-%{version}.gem
+rake -Ilib gem
+%{__tar} -xmf pkg/ohai-%{version}*.gem
 %__gem_helper spec
 
 %if %{with tests}
@@ -88,16 +93,16 @@ install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir},%{_bindir},%{_ma
 cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
 cp -p docs/man/man1/ohai.1 $RPM_BUILD_ROOT%{_mandir}/man1
-cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
+cp -p %{pkgname}-%{version}*.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc README.rdoc CHANGELOG.md NOTICE
+%doc README.md CHANGELOG.md RELEASE_NOTES.md OHAI_MVPS.md NOTICE
 %attr(755,root,root) %{_bindir}/ohai
 %{_mandir}/man1/ohai.1*
 %{ruby_vendorlibdir}/%{pkgname}.rb
 %{ruby_vendorlibdir}/%{pkgname}
-%{ruby_specdir}/%{pkgname}-%{version}.gemspec
+%{ruby_specdir}/%{pkgname}-%{version}*.gemspec
This page took 0.07374 seconds and 4 git commands to generate.